Subject: [Moq] The way we talk about latency for Media Over QUIC (and maybe for other things)

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 23 Mar 2022 11:37:25 +0100

Dear MOQ fans,

Stephan said

*Independent of this draft, I think it's time we came up with a draft for
terminology of latency - in video conferencing "ultra-low latency" for me
is sub-milliseconds, when you start sending before you have the whole frame
encoded.  Maybe it would be better to have categories based on explicit
times.*

I would agree, with one caveat - the goal that James and I had (and, I
think, MOPS had for
https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations),
was to have useful categories, that we could say "this will work for use
cases in this latency category, and maybe for others, but not for use cases
with more demanding latency".

James and I carried that forward in
https://www.ietf.org/archive/id/draft-gruessing-moq-requirements-01.html#name-latency-requirement-categor
by adding categories below 1 second.

In the space that's being discussed broadly under MOQ, the stake in the
ground is

   - "already handled in
   https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html"
   - "under 1 second"
   - "under 250 ms"
   - "under 50 ms"

but that stake is actually in a bog, not nailed into a rock, and is
certainly

AND ... further discussion in the BOF makes me think that "latency without
CDNs" may be an important question involving economic, political, and
centralization questions.

I'll hit "send" now ...

Best,

Spencer

---

From: Maxim Sharabayko <[email-masked]>
Date: Wed, 23 Mar 2022 13:17:40 +0000

I would also like to vote for Stephan Wenger’s thesis that the “ultra low glass-to glass latency” defined as “less than 1 second”[1] does not feel like ultra low. The glass-to-glass latency heavily depends on the RTT in the network and encoder/decoder buffering preferences. And such a subjective term as “ultra” really depends on a lot of variables, and is a subject to change in the future with further improvements of networks.

[1] https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html<https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations>
-               ultra low-latency (less than 1 second)
-               low-latency live (less than 10 seconds)
-               non-low-latency live (10 seconds to a few minutes)
-               on-demand (hours or more) [1]

If we talk about content contribution and distribution, then the glass-to-glass latency
For example, here are the round-trip latencies in the Azure network
[2]  https://docs.microsoft.com/en-us/azure/networking/azure-network-latency

We are talking about 150-350 milliseconds of RTT [2] in this kind of networks for content distribution between endpoints.
In SRT, for example, the recommended buffering latency for the sake of ARQ is 3xRTT. It would result in 450-1050 ms end-to-end latency to transport the media content.
A low-latency encoder-decoder pair would add, say, 50 ms, depending on how well it is optimized. Can even be lower if you don’t wait for a whole frame to be encoded. But let’s say we have the order of the number.

Roughly we end up with 500-1100 ms.
Add ingest (contribution) and delivery delays depending on distances to an ingest and to an egress point, and we would be in the lower interval of the “low-latency” live definition. And that feels ok to me. But I have never heard talks combining 10 seconds glass-to-glass delay and low latency in the area of live events.
Ultra-low for me is something that is extremely low. One second is too high for that :)

My gut feeling of a low-latency range is somewhere between 300-1500 ms. And ultra-low for me is somewhere closer to 50-100 ms and below.

From: Moq <[email-masked]> on behalf of Spencer Dawkins at IETF <[email-masked]>
Date: Wednesday, 23. March 2022 at 12:08
To: MOQ Mailing List <[email-masked]>
Subject: [Moq] The way we talk about latency for Media Over QUIC (and maybe for other things)
Dear MOQ fans,

Stephan said

Independent of this draft, I think it's time we came up with a draft for terminology of latency - in video conferencing "ultra-low latency" for me is sub-milliseconds, when you start sending before you have the whole frame encoded.  Maybe it would be better to have categories based on explicit times.

I would agree, with one caveat - the goal that James and I had (and, I think, MOPS had for https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html#name-latency-considerations), was to have useful categories, that we could say "this will work for use cases in this latency category, and maybe for others, but not for use cases with more demanding latency".

James and I carried that forward in https://www.ietf.org/archive/id/draft-gruessing-moq-requirements-01.html#name-latency-requirement-categor by adding categories below 1 second.

In the space that's being discussed broadly under MOQ, the stake in the ground is

  *   "already handled in https://www.ietf.org/archive/id/draft-ietf-mops-streaming-opcons-09.html"
  *   "under 1 second"
  *   "under 250 ms"
  *   "under 50 ms"
but that stake is actually in a bog, not nailed into a rock, and is certainly

AND ... further discussion in the BOF makes me think that "latency without CDNs" may be an important question involving economic, political, and centralization questions.

I'll hit "send" now ...

Best,

Spencer

***[EXTERNAL] This message comes from an external organization. Exercise caution when opening attachments or clicking links, especially from unknown senders.***