Subject: [Mpls-interop] Fwd: Label stack mechanism for TCM

From: David Ward <[email-masked]>
Date: Fri, 4 Apr 2008 15:50:10 -0500

Begin forwarded message:

> From: Maarten Vissers <[email-masked]>
> Date: April 4, 2008 2:47:03 PM CDT
> To: "'Malcolm Betts'" <[email-masked]>, "'David Ward'"  
> <[email-masked]>
> Cc: "'Huub van Helvoort'" <[email-masked]>, "'Italo Busi'"  
> <[email-masked]>
> Subject: Label stack mechanism for TCM
>
> Dave, Malcolm,
>
> I don't know if you have considered the contributions from the  
> April 2006
> meeting addressing the TCM encoding, including multiple label stacking
> mechanisms when you made the decision to use the standard label  
> stacking
> mechanism?
> gevonden mbt tot het gebruik van de label stack voor TCM doeleinden.
> WD61r2
> http://ties.itu.int/u/tsg15/sg15/xchange/ 
> wp3/200604_joint_q9_12_5-13_kobe/wd
> /wd61r2_Breakout_TM_TCM.doc
> WD30r2
> http://ties.itu.int/u/tsg15/sg15/xchange/ 
> wp3/200604_joint_q9_12_5-13_kobe/wd
> /wd30R2_ALCATEL_TCT_MPLS.doc
> WD16r1
> http://ties.itu.int/u/tsg15/sg15/xchange/ 
> wp3/200604_joint_q9_12_5-13_kobe/wd
> /WD16R1_Fujitsu_MPLS%20OAM_MEG%20Levels.doc
>
> The use of the traditional label stack mechanism as a means to  
> encode the
> TCM OAM has some disadvantages in the operation of the network. One  
> of those
> disadvantages is associated with the requirement that you must be  
> able to
> add and remove a TCM level in an active (PW, Tunnel) connection. I  
> wonder if
> this is possible without interrupting the forwarding.
>
> Consider that you set up the E2E A-E LSP without the TCM-LSP (slide  
> 33).
> Then after 2 months of operation it is necessary to add the TCM- 
> LSP. The E2E
> A-E LSP initially was administered with the following labels in nodes
> A,B,C,D,E:
> E(B)/0 - E(C)/0 - E(D)/0 - E(E)/0.
> This must be changed to support the TCM-LSP;
> - first of all the E2E A-E LSP administration in node C must be  
> deleted and
> - the administration of the E2E A-E LSP in node B must be changed from
> E(C)/0 into E(D)/0 and
> - a new TCM-LSP must be set up between nodes B and D via node C.
>
> Similarly, when you have to remove the TCM-LSP from the network you  
> have to
> - take the administration of the TCM-LSP in nodes B, C and D away and
> - change the administration of the E2E A-E LSP in node B from E(C)/ 
> 0 into
> E(D)/0 and
> - add in node C a matrix connection for the E2E A-E LSP.
>
> There are alternative implementations of label stacking possible as
> illustrated in WD61r2 that are more friendly to network management,  
> which
> keep the connection configurations and thus the allocated labels in  
> the
> nodes unchanged.
>
> Regards,
> Maarten
>
>

_______________________________________________
Mpls-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: "Italo Busi" <[email-masked]>
Date: Fri, 11 Apr 2008 15:48:45 +0200

Maarten,

The current approach is similar to the solution analysed by the ITU-T breakout
in section 3.1 (WD61r2).

At that moment in time ITU-T did not identify any open issue: see section 3.1.5
of WD61r2.

Regarding the point of addition and removal of a TCM level in an active (PW,
Tunnel) connection, I think this can be done in an hitless way as described in
the attached slide.

I have also tried to translate the solution in G.805 language and I think this
behavior is aligned with G.805 (see slide 2).

Italo

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Maarten Vissers
> Sent: Tuesday, April 08, 2008 10:27 AM
> To: [email-masked]; [email-masked]
> I don't know if you have considered the contributions from 
> the April 2006
> mechanisms when you made the decision to use the standard 
> label stacking
> mechanism? 
> WD61r2
> http://ties.itu.int/u/tsg15/sg15/xchange/wp3/200604_joint_q9_1
2_5-13_kobe/wd
> http://ties.itu.int/u/tsg15/sg15/xchange/wp3/200604_joint_q9_1
2_5-13_kobe/wd
> http://ties.itu.int/u/tsg15/sg15/xchange/wp3/200604_joint_q9_1
2_5-13_kobe/wd
> The use of the traditional label stack mechanism as a means 
> to encode the
> TCM OAM has some disadvantages in the operation of the 
> network. One of those
> disadvantages is associated with the requirement that you 
> must be able to
> add and remove a TCM level in an active (PW, Tunnel) 
> connection. I wonder if
> Consider that you set up the E2E A-E LSP without the TCM-LSP 
> (slide 37 in
> -v10 slide set). Then after 2 months of operation it is 
> necessary to add the
> TCM-LSP. The E2E A-E LSP initially was administered with the following
> labels in nodes A,B,C,D,E: 
> - first of all the E2E A-E LSP administration in node C must 
> be deleted and
> Similarly, when you have to remove the TCM-LSP from the 
> network you have to
> - change the administration of the E2E A-E LSP in node B from 
> E(C)/0 into
> E(D)/0 and
> illustrated in WD61r2 that are more friendly to network 
> management, which
> keep the connection configurations and thus the allocated 
> labels in the
> nodes unchanged.
> 
> So far, tandem connection monitoring (TCM) has never required 
> a change of
> the connection. TCM required the activation/deactivation of 
> MEP functions in
> port units that are part of the connection. The proposed 
> label stacking
> mechanism for MPLS OAM introduces a major change of the basic 
> TCM operation
> principle. I don't like this at the moment.
> 
> Regards,
> Maarten
> 
> 
>