Subject: Re: [mpls-tp] R: discussion on ring protection in MPLS-TP

From: "D'Alessandro Alessandro" <[email-masked]>
Date: Mon, 1 Sep 2008 12:57:39 +0200

Hi Adrian, hi all,
I would highlight that I expressed interest about ring protection without proposing at this time any particular implementation.

What I said is that metro and metro core networks are mainly based on ring architectures, at least in TI networks, and therefore I have interest in pushing for having network providers resilience requirements discussed.

Next step will be finding the best solutions that match resilience requirements.

Best regards,
Alessandro

PS  just to clarify a little bit the terminology I use: I use the term "ring protection" meaning a generic protection mechanism optimized for ring network. I know that there are people that talk about "ring protection" meaning TM-SPRing.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: venerdì 29 agosto 2008 17.11
To: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] R: discussion on ring protection in MPLS-TP

Hi Diego and Alessandro,

> Ciao Alessandro,
>                      I think you made a good point.
>
> If, as stated in sveral documents, mpls-tp is going to replace sdh we
> have to consider that most of the metro and metro core topology are ring
> based.

I think that what Diego is saying is that we need to be able to deploy
MPLS-TP in topologies that are ring shaped. That is where there is a set of
routers with line-side order of two (and presumably the ability to add and
drop data!) arranged in a ring.

No problem with that as it is just a special case of a mesh of routers.

I think that both Diego and Alessandro are implying that rapid recovery is
needed in any MPLS-TP deployment. We can argue about how rapid, but there is
clearly some desired upper bound for a particular grade of service.

But I am still struggling to understand why "ring protection" is a
requirement. Surely that is one of a set of possible solutions. We can come
on to discuss the benefits and costs of different solutions as a separate
thread. Such a discussion will include the relative complexity of
implementation and operation of various solutions.

So, just for now, can someone explain to me whether "ring protection" is a
real requirement.

Cheers,
Adrian

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp
--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------
                        
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Nitin Bahadur <[email-masked]>
Date: Mon, 01 Sep 2008 20:25:34 -0700

> PS  just to clarify a little bit the terminology I use: I use the term "ring
> protection" meaning a generic protection mechanism optimized for ring network.

Fair enough. It would be great if the MPLS-TP documents also used the same
language and removed ring-protection from the text (to avoid confusion).

---

From: "Italo Busi" <[email-masked]>
Date: Tue, 2 Sep 2008 17:14:11 +0200

Adrian,

I think that "ring protection" means protection switching on a ring topology
that is "optimized" for this kind of deployment taking advantages from the fact
that the topology is a ring.

Italo

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Friday, August 29, 2008 5:11 PM

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Tue, 2 Sep 2008 19:24:06 +0200

And the nodes on the ring have exactly two ports on the ring and it is a
close path....
We can take advantage of this and reduce the number of OAM sessions,
ease the creation of the protection path and the switch over
process,,,,and we can easily support point-to-multipoint connections and
protect them. 
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Italo Busi
Sent: Tuesday, September 02, 2008 18:14
To: 'Adrian Farrel'; [email-masked]; [email-masked]
Subject: Re: [mpls-tp] R: discussion on ring protection in MPLS-TP

Adrian,

I think that "ring protection" means protection switching on a ring
topology
that is "optimized" for this kind of deployment taking advantages from
the fact
that the topology is a ring.

Italo

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 02 Sep 2008 20:44:08 +0100

> process,,,,and we can easily support point-to-multipoint connections and
The implication of this is that the ring is a standalone subnetwork that 
provides a server layer to the rest of the network. Is that what we 
understand the function of a ring to be in an MPLS-TP network? Is that 
how we wish to build MPLS-TP networks?

Stewart

>>> If, as stated in sveral documents, mpls-tp is going to 
>>>       
>> replace sdh we
>>     
>>> have to consider that most of the metro and metro core 
>>>       
>> topology are ring
>>     
>>> based.
>>>

---

From: "Drake, John E" <[email-masked]>
Date: Tue, 2 Sep 2008 13:00:03 -0700

Stewart,

That is the case if the management of the ring occurs at the SDH/SONET
level, underneath MPLS TP.  But in that case, why would we bother doing
ring protection at the MPLS TP level?  I don't think I have asked this
question more than half a doen times.

If we are to do ring protection at the MPLS TP level, I think we have to
deal with P2P links between adjacent MPLS TP nodes that happen to be
arranged in a ring.

Thanks,

John

>From: Stewart Bryant [mailto:[email-masked]] 
>Sent: Tuesday, September 02, 2008 12:44 PM
>To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
>Cc: ext Italo Busi; [email-masked]; [email-masked]
>> And the nodes on the ring have exactly two ports on the ring 
>and it is 
>> a close path....
>> process,,,,and we can easily support point-to-multipoint connections 
>> and protect them.
>>   
>The implication of this is that the ring is a standalone 
>subnetwork that provides a server layer to the rest of the 
>network. Is that what we understand the function of a ring to 
>be in an MPLS-TP network? Is that how we wish to build MPLS-TP 
>networks?
>
>Stewart
>
>>  
>> topology that is "optimized" for this kind of deployment taking 
>> advantages from the fact that the topology is a ring.
>>
>> Italo
>>
>>   
>>> I think that what Diego is saying is that we need to be able to 
>>> deploy MPLS-TP in topologies that are ring shaped. That is where 
>>> there is a set of routers with line-side order of two (and 
>presumably 
>>> the ability to add and drop data!) arranged in a ring.
>>>
>>> I think that both Diego and Alessandro are implying that rapid 
>>> recovery is needed in any MPLS-TP deployment. We can argue 
>about how 
>>> rapid, but there is clearly some desired upper bound for a 
>particular 
>>> grade of service.
>>>
>>> requirement. Surely that is one of a set of possible solutions. We 
>>> can come on to discuss the benefits and costs of different 
>solutions 
>>> as a separate thread. Such a discussion will include the relative 
>>> complexity of implementation and operation of various solutions.
>>>
>>> So, just for now, can someone explain to me whether "ring 
>protection" 
>>> is a real requirement.
>>>
>>> Cheers,
>>> Adrian
>>>

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 02 Sep 2008 22:56:26 +0100

> language and removed ring-protection from the text (to avoid confusion).

Currently draft-jenkins-mpls-mpls-tp-requirements just says

" MPLS-TP MAY support mechanisms that are optimized for specific network
topologies (Ring, Mesh) in order to handle protection switching in an
efficient manner."

Ben

---

From: "Italo Busi" <[email-masked]>
Date: Wed, 3 Sep 2008 09:25:06 +0200

John,

> deal with P2P links between adjacent MPLS TP nodes that happen to be

This was exactly the requirement and use case that was stated by a service
provider and that is in line with the requirements expressed by ITU-T for T-MPLS
ring protection.

Italo

> From: Drake, John E [mailto:[email-masked]] 
> Sent: Tuesday, September 02, 2008 10:00 PM
> To: [email-masked]; Sprecher, Nurit (NSN - IL/Hod HaSharon)
> Subject: RE: [mpls-tp] R: discussion on ring protection in MPLS-TP
> 
> Stewart,
> 
> [mailto:[email-masked]] On 
> >> Behalf Of ext Italo Busi

---

From: "Drake, John E" <[email-masked]>
Date: Wed, 3 Sep 2008 05:42:21 -0700

This is progress. 

>From: Italo Busi [mailto:[email-masked]] 
>Sent: Wednesday, September 03, 2008 12:25 AM
>To: Drake, John E; [email-masked]; 'Sprecher, Nurit (NSN - 
>IL/Hod HaSharon)'
>Cc: [email-masked]
>> If we are to do ring protection at the MPLS TP level, I 
>think we have 
>> to deal with P2P links between adjacent MPLS TP nodes that happen to 
>> be arranged in a ring.
>
>This was exactly the requirement and use case that was stated 
>by a service provider and that is in line with the 
>requirements expressed by ITU-T for T-MPLS ring protection.
>
>Italo
>
>> level, underneath MPLS TP.  But in that case, why would we bother 
>> doing ring protection at the MPLS TP level?  I don't think I have 
>> asked this question more than half a doen times.
>> 
>> If we are to do ring protection at the MPLS TP level, I 
>think we have 
>> to deal with P2P links between adjacent MPLS TP nodes that happen to 
>> be arranged in a ring.
>> 
>> Thanks,
>> 
>> John
>> 
>> >The implication of this is that the ring is a standalone subnetwork 
>> >that provides a server layer to the rest of the network. Is 
>that what 
>> >we understand the function of a ring to be in an MPLS-TP 
>network? Is 
>> >that how we wish to build MPLS-TP networks?
>> >
>> >Stewart
>> >
>> >>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Sep 2008 15:47:55 +0100

Nurit wrote...

> And the nodes on the ring have exactly two ports on the ring and it is a

Stewart wrote...

> understand the function of a ring to be in an MPLS-TP network? Is that how 
> we wish to build MPLS-TP networks?

The implication of this to me is not just a deployment question. It is a 
manufacturing question.

Are people really considering building and buying MPLS-TP boxes that have 
only two line ports (i.e. "exactly two ports on the ring")? I can see that 
if these boxes are manufactured there is value in devising mechanisms 
optimized to these boxes.

However, if ring deployments are built using general multi-port routers that 
just happen to have only two ports populated, then I think we should seek 
out general solutions that are equally functional in ring deployments.

That is: optimize for the general not the specific.

The architetural answer to Stewart's question is that the ring is operated 
as stand-alone, but may be connected (using E-NNI) to more of the core 
network. The architecture would handle this as  end-to-end signaling across 
a subnetwork that is realised as a ring. In this case the subnetwork would 
appear as a "node" in the MPLS-TP network (one might argue that its 
representation as a link is more common in the IETF architecture) and the 
protection domain is hidden from the end-to-end network.

>From a deployment point of view, therefore, the answer to Stewart's question 
is "yes". And that makes MPLS-TP rings rather simple for us to solve, and 
not part of the general MPLS-TP solution space.

Adrian

>>> Behalf Of Adrian Farrel
>>> MPLS-TP in topologies that are ring shaped. That is where there is a set 
>>> of routers with line-side order of two (and presumably the ability to 
>>> add and drop data!) arranged in a ring.
>>>
>>> I think that both Diego and Alessandro are implying that rapid recovery 
>>> is needed in any MPLS-TP deployment. We can argue about how rapid, but 
>>> there is clearly some desired upper bound for a particular grade of 
>>> service.
>>>
>>> requirement. Surely that is one of a set of possible solutions. We can 
>>> come on to discuss the benefits and costs of different solutions as a 
>>> separate thread. Such a discussion will include the relative complexity 
>>> of implementation and operation of various solutions.
>>>
>>> So, just for now, can someone explain to me whether "ring protection" is 
>>> a real requirement.
>>>
>>> Cheers,
>>> Adrian

---

From: Loa Andersson <[email-masked]>
Date: Wed, 03 Sep 2008 16:59:16 +0200

Adrian,

Adrian Farrel wrote:
> only two line ports (i.e. "exactly two ports on the ring")? 

This seems odd since one of the requirements that has been repeated over
and again is compatibility with existing MPLS equipment. Or are people
really saying that we plan to build new (incompatible) boxes for the
ring scenario?

/Loa

> I can see that

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp