Subject: Re: [mpls-tp] [Mpls-sp] Re: discussion on ring protection in MPLS-TP

From: Loa Andersson <[email-masked]>
Date: Tue, 02 Sep 2008 13:07:09 +0200

Huub,

inline please

Huub van Helvoort wrote:
> Hi Cao Wei,
> 
> You wrote:
> 
>> Yes, I also think such clarification is necessary. 
> 
> The most important now is to define the requirements for
> MPLS-TP ring protection, e.g. at which layer, switch time
> ( < 50 ms), number of nodes in the ring, etc.

The paragraph above would have been just fine if it read:

  The most important now is to define the requirements for
  MPLS-TP protection.

Without pushing a solution (rings) to the forefront.

The second part of the paragraph confuses me even more:

" ... requirements for MPLS-TP ring protection, e.g. at which
  layer, ... "

Are you saying that we can do mpls-tp ring protection in another
layer network than the mpls-tp layer network.

/Loa

> 
> Because it is part of the MPLS-TP suite it should also
> comply with the overall TP requirements.
> 
> Then we can look for a solution.
> 
>> IMHO, it is hard to say FRR can not satisfy the protection requirement
>> in metro network.
> 
> If the requirements are agreed, then we can find if existing
> solutions match the requirements, or whether we need to adapt
> existing solutions or define a new solution.
> 
>> It will be helpful if there are clear description why "specific
>> solution" is better than existing solutions.
> 
> That is part of the analisys mentioned above.
> 
> Cheers, Huub.
> -------------------------------------------------
> 
>> On 2008-08-30, at 06:50:20 Nitin Bahadur wrote:
>>
>>> I guess what you specifically want is protection for ring based
>>> networks.
>>>
>>> The solution does not necessarily have to be Sonet like ring protection.
>>> As others have pointed out, MPLS FRR can provide protection.
>>>
>>> So, I guess what we need is a clarification on the problem statement and
>>> not a requirement for a *specific solution*.
>>>
>>> Thanks
>>> Nitin
>>>
>>>
>>> ________________________________
>>>
>>>     From: [email-masked] [mailto:[email-masked]]
>>> On Behalf Of D'Alessandro Alessandro
>>>     Sent: Friday, August 29, 2008 3:07 AM
>>>     To: [email-masked]; [email-masked]
>>>     Subject: [mpls-tp] discussion on ring protection in MPLS-TP
>>>     
>>>     
>>>
>>>     Dear all,
>>>
>>>     I expressed interest in developing ring protection for MPLS-TP
>>> in ITU-T mailing lists.
>>>
>>>     As MPLS-TP is a joint activity between ITU-T and IETF I'd like
>>> renewing my interest about that topic in IETF as well.
>>>
>>>     I'm in favor of developing ring protection for MPLS-TP as it can
>>> be useful deployed in metro and metro-core areas where physical ring
>>> infrastructures are still widely used. My preferred approach is MPLS-TP
>>> over metro rings where networking is assured by MPLS-TP whilst Ethernet
>>> or other server layers are used as point-to-point technologies. MPLS-TP
>>> should keep traditional features/performance (e.g. 50ms switch time,
>>> revertive/non revertive mode) and it should be enhanced with Control
>>> Plane features.
>>>
>>>     As traffic characteristics are fast changing in the networks and
>>> in particular in metro networks (e.g. multicast traffic is getting an
>>> important share of total traffic), ring protection should be designed
>>> taking into account such characteristics.
>>>
>>>     
>>>     Best regards,
>>>
>>>     Alessandro
>>>
>>>     
>>>     
>>> ------------------------------------------------------------------
>>>     Telecom Italia
>>>     Alessandro D'Alessandro
>>>     Transport & OPB Innovation
>>>
>>>     Via Reiss Romoli, 274 - 10148 Torino
>>>     phone:  +39 011 228 5887
>>>
>>>     mobile: +39 335 766 9607
>>>
>>>     fax: +39 06 418 639 07
>>>
>>>     
>>>     
>>> --------------------------------------------------------------------
>>>     CONFIDENTIALITY NOTICE
>>>     This message and its attachments are addressed solely to the
>>> persons
>>>     above and may contain confidential information. If you have
>>> received
>>>     the message in error, be informed that any use of the content
>>> hereof
>>>     is prohibited. Please return it immediately to the sender and
>>> delete
>>>     the message. Should you have any questions, please contact us by
>>>     replying to [email-masked]
>>> <mailto:[email-masked]> .
>>>             Thank you
>>>                                             www.telecomitalia.it
>>> <http://www.telecomitalia.it>     
> 
> 
> 

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: Huub van Helvoort <[email-masked]>
Date: Tue, 02 Sep 2008 14:08:44 +0200

Hi Loa,

> inline please

In-line too [hvh]

>   The most important now is to define the requirements for

[hvh] We have identified two methodologies in the JWT slides:
linear protection and ring protection. The discussion
focussed on the latter. If you need a better desciption,
I would propose "protection in a ring topology" for this case.

> Without pushing a solution (rings) to the forefront.

[hvh] I was not pushing a solution, I was loking for the
requirements for protection in a ring topology.

> layer network than the mpls-tp layer network.

[hvh] in the transport model of a network within a single
technology (e.g. MPLS-TP) several layers can exist (layering
is recursive).
The lowest layer can be a section layer, containing the
sections that connect adjacent nodes, the server signal is
in another technology.
The highest layer is the layer that transports client signals
of another technology (path layer).
If a bundle of the signals that carry client signals is
created because these are transported between the same LSRs
in fact a new layer is created (tunnel layer). This layer can
have its own OAM and protection.
Etc.

Regards, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp