Subject: Re: [mpls-tp] [PWE3] working group last call on draft-ietf-mpls-tp-requirements-04

From: "tom.petch" <[email-masked]>
Date: Fri, 20 Feb 2009 09:44:29 +0100

Editorial

There are several abbreviations that are not expanded on first use.  I suggest
including a list at the start, as draft-ietf-mpls-tp-oam-requirements does.  In
fact, IPR permitting:-(, lift that list and use it as a basis.  It would be good
if all three requirements I-Ds had a common list.

1.1 'that future document' needs nailing down before this progresses, IMO.

1.3 p.3 /the traverse/they traverse/

p.4 /within smaller domain/within ???/

44 /control pane/control plane/

54C /not required/NOT REQUIRED/??

6.1.  Normative References looks a little light.  Looking at the references made
to the RFC and I-Ds listed, I would think that almost all of them are normative.

Tom Petch

----- Original Message -----
From: <[email-masked] [mailto:[email-masked]] On>
To: <[email-masked]>; <[email-masked]>
Sent: Friday, February 20, 2009 9:25 AM
Subject: [PWE3] working group last call on

> All,
>
> this is to initiate a working group last call for
> draft-ietf-mpls-tp-requirements-04.
>
> This document is one of the key documents for the mpls-tp work,
> in particular it is important that the ITU-T mpls-tp ad hoc team
> verifies the completeness of the requirements and that we have a
> good review form all parties.
>
> Please review and send your comments to the mpls-tp list,
> i.e. try to avoid doing a "reply all on this message" !
>
> The working group last call will end on Feb 28, 2009.
>
> /Loa
>
>

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sun, 22 Feb 2009 21:20:12 +0000

Tom,

> if all three requirements I-Ds had a common list.

I will add an abbreviations section.

> 1.1 'that future document' needs nailing down before this progresses, IMO.

Depending what you mean by "nailing down", "that future document" is the
rosetta stone draft that has been proposed but which no one has volunteered
to write. As such a draft is liely to have to be the last draft published
(if it is to contain all the terminology from all MPLS-TP drafts) then
"nailing it down" with a solid reference (assuming there was a document to
reference) would mean it became a gating factor holding up publication of
all MPLS-TP drafts.

> 1.3 p.3 /the traverse/they traverse/

Done.

> p.4 /within smaller domain/within ???/

I changed to " It is sometimes useful to independently control forwarding in
a smaller domain within a layer network"

> 44 /control pane/control plane/

Done.

> 54C /not required/NOT REQUIRED/??

ID nits complains if NOT REQUIRED is capitalised.

> to the RFC and I-Ds listed, I would think that almost all of them are

I will take another look through and adjust as necessary.

Ben

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 23 Feb 2009 00:42:25 +0100

Hello Ben,

> rosetta stone draft that has been proposed but which no one has volunteered

There are currently three editors for this drsft, I am one of them
and working to keep up with the definitions in other drafts.

> reference) would mean it became a gating factor holding up publication of

It is better to leave the definition in each individual draft
until there is a published revision of the rosetta draft.
After publishing a rosetta draft the definition can be replaced
by a reference,

Cheers, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 23 Feb 2009 00:01:31 +0000

Huub,

> and working to keep up with the definitions in other drafts.

My apologies, I assumed as there was no draft in the repository that no one
had volunteered to write it yet.

Ben

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 23 Feb 2009 09:36:24 -0000

Huub,

It is permissible (desirable!) to submit an incomplete draft so that we all 
have something to work with and reference.

A
----- Original Message ----- 
From: "Ben Niven-Jenkins" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, February 23, 2009 12:01 AM
Subject: Re: [mpls-tp] [PWE3] working group last call on 
draft-ietf-mpls-tp-requirements-04

> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>