Subject: [mpls-tp] Definition discrepancy in the MPLS-TP OAM Framework

From: "Wei Zhao C" <[email-masked]>
Date: Wed, 8 Apr 2009 13:49:43 +0200

Hi, Italo and Ben,

There is a definition discrepancy in terms of Maintenance Entity (ME) in the MPLS-TP OAM Framework and Overview draft-ietf-mpls-tp-oam-framework-00.txt. It defines ME as:

"A Maintenance Entity can be viewed as the association of two (or 
   more) Maintenance End Points (MEPs). An example of an ME with more 
   than two MEPs is a point-to-multipoint ME monitoring a point-to-
   multipoint transport path (or point-to-multipoint tandem connection). "

However, the original definition for ME from ITU-T has been defined only for point-to-point connection. I think it may not be the best practice to give the same terminology different definitions.

Best regards,
Wei

Wei Zhao
Research Engineer
Packet Technologies,
Ericsson Research
Färögatan 6
SE-16480
Kista, Sweden
Tel: +46 107178097
email: [email-masked]

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sat, 11 Apr 2009 22:06:25 +0100

Wei,

There are many examples of the same terminology being used to refer to two
(or more) possible definitions. Just take a look in the ITU-T SANCHO
database for countless examples. While it is not ideal it is a fact of life.

Furthermore the definition in the MPLS-TP OAM Framework is simply an
extension of ITU-T definition. If we were to create a new term every time we
expanded the scope of an existing term we would have more words for
basically the same thing than we would be able to sensibly make use of and
the world would IMO be more confusing than having the same term mean
slightly different things in different contexts.

As the functionality of a ME stays the same and all we have done is extended
it to cover both P2P and P2MP transport paths I see no reason to create a
new term just for that purpose.

Regards
Ben

On 08/04/2009 12:49, "Wei Zhao C" <[email-masked]> wrote:

> Hi, Italo and Ben,
> 
> There is a definition discrepancy in terms of Maintenance Entity (ME) in the
> MPLS-TP OAM Framework and Overview draft-ietf-mpls-tp-oam-framework-00.txt. It
> defines ME as:
> 
> However, the original definition for ME from ITU-T has been defined only for
> point-to-point connection. I think it may not be the best practice to give the
> same terminology different definitions.
> 
> Best regards,
> Wei
> 
> Wei Zhao
> Research Engineer
> Packet Technologies,
> Ericsson Research
> Färögatan 6
> SE-16480
> Kista, Sweden
> Tel: +46 107178097