Subject: Re: [mpls-tp] Interworking

From: [email-masked]
Date: Thu, 30 Apr 2009 03:45:07 +0200

Hi Maarten£¬

What's difference between (3) and (4)?  And for (3) and (4), with PW do you 
mean SS-PW or both SS-PW and MS-PW? I think it should include both. 

IMO, I think we should choose (4) with the addition of PDH/SDH/ATM etc. client 
beside EVC.

Best Regards

Jing Ruiquan

--------------------------------------------------------------------------------
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Maarten Vissers
Sent: Wednesday, April 29, 2009 5:05 PM
To: 'Michael T. Wu (mtwu)'; [email-masked]
Subject: Re: [mpls-tp] Interworking

Michael,

I have been discussing interworking with existing Ethernet technologies on this 
mailinglist for some time, but we have not made much progress so far. Before we 
can talk about such "interworking" or "interconnection" we have to agree on the 
layer stack of MPLS-TP based packet transport network domains.

I believe that there are four alternative MPLS-TP based packet transport 
network layer stacks:

    (1)               (2)                (3)             (4)
------------    ---------------     -------------    -------
|   EVC    |    | EVC & MS-PW |     |    EVC    |    | EVC |
------------    ---------------     -------------    ------------
|   LSP    |    |     LSP     |     |    PW     |    |    PW    |
------------    ---------------     -------------    ------------
| T.Media  |    | Trans.Media |     |    LSP    |    |   LSP    |
------------    ---------------     -------------    ------------
                                    |  T.Media  |    |  T.Media |
                                    -------------    ------------

Which of these four stacks do we want to standardize for MPLS-TP based packet 
transport networks?

For Ethernet based packet transport networks the layer stack is:

    (5)
------------
|   EVC    |
------------
|   EVP    |
------------
| T.Media  |
------------

For PBB-TE based packet transport networks the layer stack is:

    (6)
------------
|   EVC    |
------------
|   TESI   |
------------
| T.Media  |
------------

We will also have to talk about the layer stack of the interface connecting the 
two technologies. I expect that those layer stacks to interconnect with 
Ethernet and PBB-TE based packet transport network domains will be:

    (7)             (8) 
------------    -----------
|   EVC    |    |   EVC   |
------------    -----------
| T.Media  |    |   EVP   |
------------    ----------- 
                | T.Media |
                ----------- 

Interconnection/Interworking Ethernet and MPLS-TP packet transport network 
domains may then be one of the following cases (note: numbers refer to the 
layer stacks above):

A)    (1) - (7) - (5)
B)    (1) - (8) - (5)
C)    (2) - (7) - (5)
D)    (2) - (8) - (5)
E)    (3) - (7) - (5)
F)    (3) - (8) - (5)
G)    (4) - (7) - (5)
H)    (4) - (8) - (5)

In the above cases A to H I have assumed that the two domains that 
interconnect/interwork have each their own equipment, and interconnection is 
via an 802.3 interface. In many cases both domains will be sharing an edge node 
and interconnection is via the switch matrix; i.e. one line port connects to 
the ethernet domain and the other line port connects to the MPLS-TP domain. 
This adds another four cases:

I)    (1) - (5)
J)    (2) - (5)
K)    (3) - (5)
L)    (4) - (5)

Regards,
Maarten

--------------------------------------------------------------------------------
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Michael T. Wu (mtwu)
Sent: woensdag 29 april 2009 8:25
To: [email-masked]
Subject: [mpls-tp] Interworking

Hi,

Is there a draft or discussion on the interworking with existing technologies 
(L2 or L3) and standards (ITU/MEF)?

Thanks,
Michael

---

From: Maarten Vissers <[email-masked]>
Date: Thu, 30 Apr 2009 06:54:57 +0200

Hi Jing,

The difference between (3) and (4) is the following:

(3) all services are supported via the EVC layer; i.e. the EVC layer is the
service/channel layer and starts/ends at the UNI-N ports. The PW is a SS-PW
layer and monitors p2p EVC link connections.

PE nodes switch/bridge only EVC signals (as all customer service signals are
supported via EVCs).

------

(4) the p2p and p2mp services are supported via the PW layer (MS-PW) and the
rmp and mp2mp services are supported via the EVC layer; i.e. the PW layer is
the service/channel layer for p2p/p2mp services and for those services
start/end at the UNI-N ports, while the EVC layer is the service/channel
layer for rmp/mp2mp services and for those services start/end at the UNI-N
ports.

Rmp/mp2mp customer services (Ethernet) are either clients of the EVC layer,
or peer with the EVC layer.

P2p/p2mp customer services (PDH, SDH, ATM, Ethernet, ..) are clients fo the
PW layer (and may in future also peer with the PW layer).

PE nodes will be able to switch/bridge both PW and EVC signals. Switch
fabrics must support as such PW switching and Ethernet bridging/switching.

PW connections terminate on the UNI-N ports for the case of p2p/p2mp
services. 
PW connections terminate on the NNI ports for the case of rmp/mp2mp
services. 

------

Interconnecting a MPLS-TP domain according to layer stack (4) with an
Ethernet domain with layer stack (5) via an 802.3 interface results in the
following for rmp/mp2mp services (Ethernet E-Tree, E-LAN):

    (5)                         (4)
-----------------------------------
|   EVC           EVC       EVC   |
----------------------------------------
|   EVP    |   | 802.3 |    |    PW    |
------------   ---------    ------------
| T.Media  |                |   LSP    |
------------                ------------
                            |  T.Media |
                            ------------

And for p2p/p2mp services (Ethernet E-Line, PDH CES, ATM, SDH CES, ..) it
will be:

    (5)                         (4)
                                 -------
                                 | EVC |
----------------------------------------
|   EVC           EVC       X    PW    |
----------------------------------------
|   EVP    |   | 802.3 |    |   LSP    |
------------   ---------    ------------
| T.Media  |                | T.Media  |
------------                ------------

Regards,
Maarten

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: donderdag 30 april 2009 3:45
To: [email-masked]; [email-masked]
Subject: RE: [mpls-tp] Interworking

Hi Maarten£¬

IMO, I think we should choose (4) with the addition of PDH/SDH/ATM etc.
client beside EVC.

Best Regards

Jing Ruiquan

----------------------------------------------------------------------------
----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Maarten Vissers
Sent: Wednesday, April 29, 2009 5:05 PM
To: 'Michael T. Wu (mtwu)'; [email-masked]
Subject: Re: [mpls-tp] Interworking

Michael,

I have been discussing interworking with existing Ethernet technologies on
this 
mailinglist for some time, but we have not made much progress so far. Before
we 
can talk about such "interworking" or "interconnection" we have to agree on
the 
layer stack of MPLS-TP based packet transport network domains.

    (1)               (2)                (3)             (4)

Which of these four stacks do we want to standardize for MPLS-TP based
packet 
transport networks?

    (5)
------------
|   EVC    |
------------
|   EVP    |
------------
| T.Media  |
------------

    (6)
------------
|   EVC    |
------------
|   TESI   |
------------
| T.Media  |
------------

We will also have to talk about the layer stack of the interface connecting
the 
two technologies. I expect that those layer stacks to interconnect with 
Ethernet and PBB-TE based packet transport network domains will be:

    (7)             (8) 
------------    -----------
|   EVC    |    |   EVC   |
------------    -----------
| T.Media  |    |   EVP   |
------------    ----------- 
                | T.Media |
                ----------- 

A)    (1) - (7) - (5)
B)    (1) - (8) - (5)
C)    (2) - (7) - (5)
D)    (2) - (8) - (5)
E)    (3) - (7) - (5)
F)    (3) - (8) - (5)
G)    (4) - (7) - (5)
H)    (4) - (8) - (5)

via an 802.3 interface. In many cases both domains will be sharing an edge
node 
and interconnection is via the switch matrix; i.e. one line port connects to

I)    (1) - (5)
J)    (2) - (5)
K)    (3) - (5)
L)    (4) - (5)

Regards,
Maarten

----------------------------------------------------------------------------
----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of 
Michael T. Wu (mtwu)
Sent: woensdag 29 april 2009 8:25
To: [email-masked]
Subject: [mpls-tp] Interworking

Hi,

Is there a draft or discussion on the interworking with existing
technologies 
(L2 or L3) and standards (ITU/MEF)?

Thanks,
Michael