Subject: Re: [mpls-tp] [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?

From: [email-masked]
Date: Tue, 14 Apr 2009 17:19:15 +0800

stewart:
  it is not clear expression here to use service header . IMO, adding flow 
ID following CW field to identify which flow the service data will belong 
to? then the service data may be carried by ECMP to another sink points, 
the sink points will identify the service data by flow ID . and the packet 
formats will the following:
 
          LSP Label
          PW Label
           CW 
          Flow ID 
          Service data 

   in addtions. if using a flow label, I think the draft will be MPLS or 
MPLS-TP draft and shouldn't be disscussed in pwe3 work group. 
thank you.
liu

Stewart Bryant <[email-masked]> 
2009-04-14 15:54
请答复 给
[email-masked]

收件人
[email-masked]
抄送
[email-masked]
主题
Re: [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?

[email-masked] wrote:
>
> Stewart:
> I understand your meaning , but I think it unnecessary to use and
> apply another flow label. we may add 2 bytes flow ID in services header,

What do you mean by the services header?

> so at sink point, it identify and re-encapsulate the services context
> by flow id and SN in services header.
> do you think so.

Please can you sketch out your label stack and describe the operations
you have in mind?

Thanks

Stewart
> regards
> liu
>
>
> *Stewart Bryant <[email-masked]>*
>
> 2009-04-02 19:24
> 请答复 给
> [email-masked]
>
>
> 
> 收件人
>                [email-masked]
> 抄送
>                [email-masked]
> 主题
>                Re: [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?
>
>
>
> 
>
>
>
>
>
> [email-masked] wrote:
> >
> > Stewart:
> > my problem is : if there is a multimedia data flow, the flow must be
> > transported in order. or else it will not become a multimedia flow.
> > how to process the data flow by ECMP?
> > IMO, there are two solutions:
> > 1 at sink points, there are enough buffers to store the data flow.
> > 2 during transporting the data flow, it must transport in order.
> >
> > do you think so?
> > regards
> > liu
> >
> Yes
>
> Remember this draft is simply a tool that is used to spread out already
> identified flows over the ECMP set.
>
> The processing into and out of a fat pw is outside it's scope.
>
> Clearly you can enable s/n - apply the LB label - and put the flow back
> together at the egress if that suits you application otherwise as you
> say you have to have large enough end to end b/w.
>
> Remember what it says in the PWE3 charter - if the best effort emulation
> provided by PWE3 is not good enough, then either propose a better
> emulation, or use a real wire.
>
> Stewart
>
>
>
>
> --------------------------------------------------------
> ZTE Information Security Notice: The information contained in this mail 
is solely property of the sender's organization. This mail communication 
is confidential. Recipients named above are obligated to maintain secrecy 
and are not permitted to disclose the contents of this communication to 
others.
> This email and any files transmitted with it are confidential and 
intended solely for the use of the individual or entity to whom they are 
addressed. If you have received this email in error please notify the 
originator of the message. Any views expressed in this message are those 
of the individual sender.
> This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 14 Apr 2009 12:18:03 +0100

Liu

You cannot use information in the payload (i.e. after BoS) to load
balance, because in MPLS the payload is opaque.

[email-masked] wrote:
>
> stewart:
> it is not clear expression here to use service header . IMO, adding
> flow ID following CW field to identify which flow the service data
> will belong to? then the service data may be carried by ECMP to
> another sink points, the sink points will identify the service data by
> flow ID . and the packet formats will the following:
> LSP Label
> PW Label
> CW
> Flow ID
> Service data
>
>
>
This is a PWE3 problem because:

1) PWE3 needs a method of addressing the ECMP case
2) PWE3 will signal this in a different way from MPLS
3) MPLS-TP does not have ECMP.

Stewart

> > ZTE Information Security Notice: The information contained in this
> mail is solely property of the sender's organization. This mail
> communication is confidential. Recipients named above are obligated to
> maintain secrecy and are not permitted to disclose the contents of
> this communication to others.
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please notify
> the originator of the message. Any views expressed in this message are
> those of the individual sender.
> ------------------------------------------------------------------------
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>