Subject: Re: [mpls-tp] Tandem Connections in MPLS-TP (wasRE:Associatedbidirectional transport path requirements)

From: "Xueqin WEI (Shuetsing WEI)" <[email-masked]>
Date: Wed, 22 Apr 2009 15:18:29 +0800

Maarten:
Sorry reply you later because I have a trip on Monday and Tuesday.
IMO, nested LSP is a already exist  mechanism but TCM is a new added one. Addtion of TCM will make the thing more complicate.
Second, TCM need to provision the TCM label along the monitored segmant too, I didn't see any provision  difference between nested LSP and TCM.

Sincerely Yours
Xueqin Wei (Shuetsing Wei)
2009-04-22  15:12:35

==================== Following is your email=====================
Subject:RE: [mpls-tp] Tandem Connections in MPLS-TP (wasRE:Associatedbidirectional transport path requirements)
Sent：2009-04-19 01:16:02
From:Maarten Vissers
To:xqwei
CC to:'MPLS-TP'

>Xueqin,
>
>The nested LSP is a more complex solution then TCM. TCM just requires the
>activation of some MEPs in the LSP. Nested LSP requires to set up the same
>MEP functions plus set up an additional LSP and change the existing LSP.
>
>Regards,
>Maarten
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Xueqin WEI (Shuetsing WEI)
>Sent: zaterdag 18 april 2009 8:52
>To: Ben Niven-Jenkins
>Cc: MPLS-TP
>Subject: Re: [mpls-tp] Tandem Connections in MPLS-TP (was
>RE:Associatedbidirectional transport path requirements)
>
>Support, I think the nested LSP will be great! Until now, I didn't see any
>difference between the nested LSP and TCM on performance monitoring. But the
>nested LSP will make the things more easy. I would like select a simple way
>to resolve the problem.
>
>Sincerely Yours
>Xueqin Wei (Shuetsing Wei)
>
>Fiberhome Telecommunication Technologies Co.,Ltd.,
>2009-04-18  14:48:51
>
>==================== Following is your email=====================
>Subject:Re: [mpls-tp] Tandem Connections in MPLS-TP (was RE:
>Associatedbidirectional transport path requirements)
>Sent：2009-04-17 17:17:31
>From:Ben Niven-Jenkins
>To:BUSI ITALO; Adrian Farrel; Alexander Vainshtein CC to:mpls-tp
>
>>Italo,
>>
>>On 17/04/2009 09:34, "BUSI ITALO" <[email-masked]> wrote:
>>> The JWT agreement is to bring the ITU-T transport requirements in 
>>> IETF to extend the MPLS architecture to meet them in a way that is 
>>> compatible, consistent and coherent with existing IETF architecture.
>>
>>So I took a look at the JWT report. It says (slide 16)
>>
>>" Service Providers want LSPs/PWEs to be able to be managed at the 
>>different nested levels seamlessly (path, segment, multiple segments)
>>    aka Tandem Connection Monitoring (TCM), this is used for example 
>>when a LSP/PWE crosses multiple administrations"
>>
>>IMO the requirement is to be able to monitor parts of a path as well as 
>>the end to end path. There are many ways to solve that requirement, one 
>>of which is the creation of nested LSPs, one per level of monitoring 
>>required (my understanding of how TCM works).
>>
>>I think the real discussion is therefore is the requirement to monitor 
>>different components of an end to end path or is the requirement that 
>>such monitoring MUST be achieved using nested LSPs?
>>
>>As an example PW technology today allows end to end and per segment 
>>monitoring but it does not achieve it using nested PWs or PW levels.
>>
>>Ben
>>
>>_______________________________________________
>>mpls-tp mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/mpls-tp
>>
>
>=================================================================
>_______________________________________________
>mpls-tp mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mpls-tp
>
>

=================================================================

---

From: "Maarten Vissers" <[email-masked]>
Date: Wed, 22 Apr 2009 23:02:21 +0200

Xueqin,

TCM as designed in Ethernet, ATM and T-MPLS does not require the
provisioning of a TCM label along the monitored segment. The T-MPLS TCM
design just required the activation of some MEPs, one at each end of the
segment to monitor. I..e. no changes to the existing LSP. MPLS-TP segment
monitoring on the basis of a nested LSP requires much more provisioning, as
you need to set up the new LSP and modify the existing LSP.

Regards,
Maarten

-----Original Message-----
From: Xueqin WEI (Shuetsing WEI) [mailto:[email-masked]] 
Sent: woensdag 22 april 2009 9:18
To: Maarten Vissers
Cc: MPLS-TP
Subject: Re: RE: [mpls-tp] Tandem Connections in MPLS-TP
(wasRE:Associatedbidirectional transport path requirements)

Maarten:
Sorry reply you later because I have a trip on Monday and Tuesday.
IMO, nested LSP is a already exist  mechanism but TCM is a new added one.
Addtion of TCM will make the thing more complicate.
Second, TCM need to provision the TCM label along the monitored segmant too,
I didn't see any provision  difference between nested LSP and TCM.

Sincerely Yours

==================== Following is your email=====================
Subject:RE: [mpls-tp] Tandem Connections in MPLS-TP
(wasRE:Associatedbidirectional transport path requirements)
Sent：2009-04-19 01:16:02
From:Maarten Vissers
To:xqwei
CC to:'MPLS-TP'

>Xueqin,
>
>The nested LSP is a more complex solution then TCM. TCM just requires 
>the activation of some MEPs in the LSP. Nested LSP requires to set up 
>the same MEP functions plus set up an additional LSP and change the
existing LSP.
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Xueqin WEI (Shuetsing WEI)
>Support, I think the nested LSP will be great! Until now, I didn't see 
>any difference between the nested LSP and TCM on performance 
>monitoring. But the nested LSP will make the things more easy. I would 
>like select a simple way to resolve the problem.
>
>Sincerely Yours
>>IMO the requirement is to be able to monitor parts of a path as well 
>>as the end to end path. There are many ways to solve that requirement, 
>>one of which is the creation of nested LSPs, one per level of 
>>monitoring required (my understanding of how TCM works).
>>