Subject: [mpls-tp] Interworking

From: "Michael T. Wu (mtwu)" <[email-masked]>
Date: Tue, 28 Apr 2009 23:25:03 -0700

Hi,
 
Is there a draft or discussion on the interworking with existing
technologies (L2 or L3) and standards (ITU/MEF)?
 
Thanks,
Michael

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 29 Apr 2009 09:37:46 +0200

There is a draft discussing the interworking scenarios with IP/MPLS

http://tools.ietf.org/id/draft-martinotti-mpls-tp-interworking-01.txt

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Michael T. Wu (mtwu)
Sent: Wednesday, April 29, 2009 9:25 AM
To: [email-masked]
Subject: [mpls-tp] Interworking

Hi,

Thanks,

Michael

---

From: "Diego Caviglia" <[email-masked]>
Date: Wed, 29 Apr 2009 09:55:07 +0200

As one of the authors I can say comments are welcome.

BR

Diego

From: [email-masked] [mailto:[email-masked]] On Behalf Of Sprecher, Nurit (NSN - IL/Hod HaSharon)
Sent: mercoledì 29 aprile 2009 9.38
To: ext Michael T. Wu (mtwu); [email-masked]
Subject: Re: [mpls-tp] Interworking

 

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Michael T. Wu (mtwu)
Sent: Wednesday, April 29, 2009 9:25 AM
To: [email-masked]
Subject: [mpls-tp] Interworking

Hi,

Is there a draft or discussion on the interworking with existing technologies (L2 or L3) and standards (ITU/MEF)?

Thanks,

Michael

---

From: Maarten Vissers <[email-masked]>
Date: Wed, 29 Apr 2009 11:05:02 +0200

Michael,
 
I have been discussing interworking with existing Ethernet technologies on
this mailinglist for some time, but we have not made much progress so far.
Before we can talk about such "interworking" or "interconnection" we have to
agree on the layer stack of MPLS-TP based packet transport network domains.
 
I believe that there are four alternative MPLS-TP based packet transport
network layer stacks:
 
    (1)               (2)                (3)             (4)
------------    ---------------     -------------    -------
|   EVC    |    | EVC & MS-PW |     |    EVC    |    | EVC |
------------    ---------------     -------------    ------------
|   LSP    |    |     LSP     |     |    PW     |    |    PW    |
------------    ---------------     -------------    ------------
| T.Media  |    | Trans.Media |     |    LSP    |    |   LSP    |
------------    ---------------     -------------    ------------
                                    |  T.Media  |    |  T.Media |
                                    -------------    ------------
 
Which of these four stacks do we want to standardize for MPLS-TP based
packet transport networks?
 
For Ethernet based packet transport networks the layer stack is:
 
    (5)
------------
|   EVC    |
------------
|   EVP    |
------------
| T.Media  |
------------
 
For PBB-TE based packet transport networks the layer stack is:
 
    (6)
------------
|   EVC    |
------------
|   TESI   |
------------
| T.Media  |
------------
 
We will also have to talk about the layer stack of the interface connecting
the two technologies. I expect that those layer stacks to interconnect with
Ethernet and PBB-TE based packet transport network domains will be:
 
    (7)             (8) 
------------    -----------
|   EVC    |    |   EVC   |
------------    -----------
| T.Media  |    |   EVP   |
------------    ----------- 
                | T.Media |
                ----------- 
 
Interconnection/Interworking Ethernet and MPLS-TP packet transport network
domains may then be one of the following cases (note: numbers refer to the
layer stacks above):
 
A)    (1) - (7) - (5)
B)    (1) - (8) - (5)
C)    (2) - (7) - (5)
D)    (2) - (8) - (5)
E)    (3) - (7) - (5)
F)    (3) - (8) - (5)
G)    (4) - (7) - (5)
H)    (4) - (8) - (5)
 
In the above cases A to H I have assumed that the two domains that
interconnect/interwork have each their own equipment, and interconnection is
via an 802.3 interface. In many cases both domains will be sharing an edge
node and interconnection is via the switch matrix; i.e. one line port
connects to the ethernet domain and the other line port connects to the
MPLS-TP domain. This adds another four cases:
 
I)    (1) - (5)
J)    (2) - (5)
K)    (3) - (5)
L)    (4) - (5)
 
Regards,
Maarten

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Michael T. Wu (mtwu)
Sent: woensdag 29 april 2009 8:25
To: [email-masked]
Subject: [mpls-tp] Interworking

Hi,

Thanks,
Michael