Subject: [mpls-tp] working group last call on draft-ietf-mpls-tp-requirements-08.txt

From: Loa Andersson <[email-masked]>
Date: Mon, 18 May 2009 17:31:16 +0200

Working Group(s),

this is to start a two week working group last call on
http://tools.ietf.org/id/draft-ietf-mpls-tp-requirements-08.txt

The document has been updated to address all comments received in the
earlier working group last call and comments received from the
ITU-T ad hoc team on MPLS-TP.

Please send your comments to the mpls-tp mailing list.

The working group last call ends on June 1st.

/Loa
-- 

Loa Andersson

Sr Strategy and Standards Manager    phone:  +46 10 717 52 13
Ericsson ///                                 +46 767 72 92 13 

                                       email:  [email-masked]
                                               [email-masked]
                                               [email-masked]

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 20 May 2009 14:56:06 +0200

Hi

I have some comments on this document that can be seen more as questions
for clarification:

1. Req 27-C: MPLS-TP MUST support rings of at least 16 nodes...MPLS-TP
SHOULD support rings with more than 16 nodes.

So is it a MUST or a SHOULD?  Isn't "at least 16" and "more than 16"
almost equivalent (except for exactly 16)?

2. In Req 100 & 102 - What is the difference between "Recovery
mechanisms" and "Recovery techniques"? Why is the first a MUST and the
second a SHOULD?

Finally, just a little spelling note: in Req 32-A: change "bellow" to
"below".

Looks like good work to me,
Yaacov Weingarten

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Loa Andersson
Sent: Monday, May 18, 2009 18:31
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [PWE3] working group last call
ondraft-ietf-mpls-tp-requirements-08.txt

Working Group(s),

/Loa
-- 

Loa Andersson

                                       email:
[email-masked]
                                               [email-masked]
                                               [email-masked]

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 20 May 2009 14:57:07 +0100

Yaacov,

> I have some comments on this document that can be seen more
> as questions for clarification:
> 
> 1. Req 27-C: MPLS-TP MUST support rings of at least 16
> nodes...MPLS-TP SHOULD support rings with more than
> 16 nodes.
> 
> So is it a MUST or a SHOULD?  Isn't "at least 16" and "more
> than 16" almost equivalent (except for exactly 16)?

Right 
MUST support 0-16 
SHOULD support 17...

That is what the text says.

> mechanisms" and "Recovery techniques"? Why is the first a MUST
> and the second a SHOULD?

Good catch.
Only one of the two requirements should remain.
But which?

> Finally, just a little spelling note: in Req 32-A: change "bellow" to

Cheers,
Adrian

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 20 May 2009 16:02:48 +0200

Adrian, hi

1. If the intent was a MUST for 0..16 then the text should state:
"MUST support rings of up to 16 nodes"!  "at least 16" (at least in US
English) means 16, 17, ...

Thnx for quick reply
yaacov
-----Original Message-----
From: ext Adrian Farrel [mailto:[email-masked]] 
Sent: Wednesday, May 20, 2009 16:57
To: Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Cc: [email-masked]
Subject: Re: [mpls-tp] working group last
callondraft-ietf-mpls-tp-requirements-08.txt

Yaacov,

Right 
MUST support 0-16 
SHOULD support 17...

Good catch.

Cheers,
Adrian

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 21 May 2009 00:37:22 +0100

Yaacov,

> almost equivalent (except for exactly 16)?

These requirements came from ITU-T.

The semantics may appear incompatible but I don't think they are.

Really it's saying at a minimum have to support up to 16. SHOULD is really
the same as MUST but allows one to not have to do it if one can provide a
good justification as to why it is not possible.

So my interpretation is the same as Adrian's. Guess we can play with the
language if you feel it is ambiguous.

> mechanisms" and "Recovery techniques"? Why is the first a MUST and the

My personal feeling is 102 should stay and we remove 100.

> Finally, just a little spelling note: in Req 32-A: change "bellow" to

Thanks, will correct.

Ben

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 21 May 2009 10:37:21 +0300

Adrian, Yaakov and all,
On top of highly problematic English:
The original limit on up to 16 NEs in a SONET/SDH ring is a side effect of having just 4 bits for NE ID in the BLSR/MS-SPRing protocol
that used K1/K2 octets in the Line/MS overhead.

Unless we plan to reuse the same protocol in MPLS-TP or consider an upgrade of SONET/SDH muxes into MPLS-TP switches,
the limit of 16 MPLS-TP nodes in a ring looks artificial to me. 

My 2c,
     Sasha

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Wednesday, May 20, 2009 4:57 PM
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 21 May 2009 11:17:39 +0200

Sasha, hi

I understand the limitation of up-to 16 nodes is also related to the
famous 50ms switching time requirement - where the base ring size is
up-to 16 nodes and up-to 1200km.

But I know that in G.8032 (Ethernet Ring Protection) the language that
is used to describe this behavior is: "... with less than 1200 km of
ring fibre circumference, and fewer than 16 nodes, the switch completion
time ... shall be less than 50 ms."

Therefore, I suggest that the language be changed to: "MUST ... up to 16
nodes..."

Thanx and BR
yaacov

-----Original Message-----
From: ext Alexander Vainshtein [mailto:[email-masked]]

Sent: Thursday, May 21, 2009 10:37
To: Adrian Farrel; Weingarten, Yaacov (NSN - IL/Hod HaSharon)
Cc: [email-masked]
Subject: RE: [mpls-tp] working group
lastcallondraft-ietf-mpls-tp-requirements-08.txt

Adrian, Yaakov and all,
On top of highly problematic English:
The original limit on up to 16 NEs in a SONET/SDH ring is a side effect
of having just 4 bits for NE ID in the BLSR/MS-SPRing protocol
that used K1/K2 octets in the Line/MS overhead.

Unless we plan to reuse the same protocol in MPLS-TP or consider an
upgrade of SONET/SDH muxes into MPLS-TP switches,
the limit of 16 MPLS-TP nodes in a ring looks artificial to me. 

My 2c,
     Sasha

---

From: [email-masked]
Date: Thu, 21 May 2009 18:09:49 +0800

hi,all
 I think everyone's explaining maybe be  true and have a few good reasons. 
but IMO.there are not two different describles : 
   1 MPLS-TP MUST support rings of at least 16 nodes. IMO . there should 
be 16 and more than 16 nodes in the ring.
   2 MPLS-TP should support rings of more than 16 nodes. IMO, there should 
be more than 16 nodes in the ring.
so I advise there should be the same describles.
 
  in additions, according to yaacov and sasha's email. I think the 
requirement should be revise to "no more than 16 nodes", it may be easy 
for other people to understand the requirements.
 
 regards
 liu

"Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]> 
发件人:  [email-masked]
2009-05-21 17:17

收件人
"ext Alexander Vainshtein" <[email-masked]>, "Adrian 
Farrel" <[email-masked]>
抄送
[email-masked]
主题
Re: [mpls-tp] working group 
lastcallondraft-ietf-mpls-tp-requirements-08.txt

Sasha, hi

Thanx and BR
yaacov

-----Original Message-----

Adrian, Yaakov and all,

My 2c,
     Sasha

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 21 May 2009 18:05:50 +0100

I think this is good material for discussion in Sophia Antipolis.
AFAIK, the precise wording came from the ITU-T meeting in Geneva.
We should, therefore, get signoff from ITU-T folk when we change it.

A
----- Original Message ----- 
From: <[email-masked]>
To: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, May 21, 2009 11:09 AM
Subject: Re: [mpls-tp] working 
grouplastcallondraft-ietf-mpls-tp-requirements-08.txt

> ZTE Information Security Notice: The information contained in this mail is 
> solely property of the sender's organization. This mail communication is 
> confidential. Recipients named above are obligated to maintain secrecy and 
> are not permitted to disclose the contents of this communication to 
> others.
> This email and any files transmitted with it are confidential and intended 
> solely for the use of the individual or entity to whom they are addressed. 
> If you have received this email in error please notify the originator of 
> the message. Any views expressed in this message are those of the 
> individual sender.

--------------------------------------------------------------------------------

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 21 May 2009 18:07:51 +0100

Sure, and agreed.

It is simply that we asked the ITU-T "What size rings do you want to 
support" and this is the response we got.

A
----- Original Message ----- 
From: "Alexander Vainshtein" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; "Weingarten, Yaacov (NSN - IL/Hod 
HaSharon)" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, May 21, 2009 8:37 AM
Subject: RE: [mpls-tp] working group 
lastcallondraft-ietf-mpls-tp-requirements-08.txt

Adrian, Yaakov and all,
On top of highly problematic English:
The original limit on up to 16 NEs in a SONET/SDH ring is a side effect of 
having just 4 bits for NE ID in the BLSR/MS-SPRing protocol
that used K1/K2 octets in the Line/MS overhead.

Unless we plan to reuse the same protocol in MPLS-TP or consider an upgrade 
of SONET/SDH muxes into MPLS-TP switches,
the limit of 16 MPLS-TP nodes in a ring looks artificial to me.

My 2c,
     Sasha