Subject: [mpls-tp] Fw: I-D Action:draft-ietf-mpls-tp-process-02.txt

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 20 Sep 2009 00:11:39 +0100

Hi,

This revision folds in a definition of "contribution" in the IETF context as 
suggested by Tom Petch.

Adrian
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, September 19, 2009 11:30 PM
Subject: [mpls] I-D Action:draft-ietf-mpls-tp-process-02.txt

>A New Internet-Draft is available from the on-line Internet-Drafts 
>directories.
> This draft is a work item of the Multiprotocol Label Switching Working 
> Group of the IETF.
>
>
> Title           : IETF Multi-Protocol Label Switching (MPLS) Transport 
> Profile (MPLS-TP) Document Process
> Author(s)       : L. Andersson, et al.
> Filename        : draft-ietf-mpls-tp-process-02.txt
> Pages           : 22
> Date            : 2009-09-19
>
> The decision to develop a Multiprotocol Label Switching (MPLS)
> Transport Profile (MPLS-TP) in cooperation between the IETF and the
> ITU-T is document in RFC 5317 as the decision of the Joint Working
> Team on MPLS-TP.
>
> This document provides additional detail of the processes for the
> development of IETF RFCs on MPLS-TP. It provides an adaptation of the
> IETF working group process; identifies the expected participation in
> the process by the ITU-T; and clarifies the rules and conventions
> regarding MPLS-TP documents.
>
> This document doe not specify any ITU-T process; ITU-T activities
> will be done according to ITU-T process/rules.
>
> This document does not specify or modify the normal IETF working
> group process. It is limited to the specific adaptations of that
> process to facilitate the cooperation agreement between the IETF and
> the ITU-T on MPLS-TP, and to ensure a good and consistent document
> review across the two organizations.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mpls-tp-process-02.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: "tom.petch" <[email-masked]>
Date: Fri, 25 Sep 2009 16:15:06 +0200

I find this much clearer than the initial versions for which, thank you.

Some potential points of clarification.

1.1.1. IETF Terms and Abbreviations

" The MEAD team is chartered to ..."

chartered by whom? not, I think, the IESG, which is what I would read
into this.  Is there a charter as such, publicly available?  If not, I would
suggest a less technical word, such as 'established'.

" Documents that originate from the IRTF RFC stream are NOT
      considered as MPLS-TP documents."

I suggest excluding the other streams as well, Independent Submissions and
Individual Submissions, lest they be tried as an end around to this process.

 2.1. IETF Consensus and Mailing Lists

                  "            the MPLS-TP responsible
   working group chair MAY direct discussions to the MPLS-TP list and
   MAY direct that consensus will be judged on that list"

Earlier, it says

"The MPLS-TP list is the mailing list that is used
      decide consensus on MPLS-TP issues"

so which mailing list is it?

2.3.1. Flow Chart

3)
    "      as independent submissions as described in step 2."
Suggest independent documents, as used elsewhere, to avoid confusion
with the Independent Submission Stream.

4) Should the mpls-tp mailing list also be told of the MEAD team's
decisions?  Well, I think it should:-)

3.3
Again, is consensus always declared on the mpls-tp list?

"A message will also be sent to the MPLS-TP ad hoc team"

suggest 'Ad Hoc Team on MPLS-TP mailing list ' as used
elsewhere.

I also have a number of grammatical comments, most of which would
be fixed by
/addresses/address/ * *

Tom Petch

----- Original Message -----
From: "Adrian Farrel" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, September 20, 2009 1:11 AM
Subject: [mpls-tp] Fw: I-D Action:draft-ietf-mpls-tp-process-02.txt

> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Sep 2009 17:47:33 +0100

Hi Tom,

>I find this much clearer than the initial versions for which, thank you.

Thank you for your input to date which has helped a lot.

> suggest a less technical word, such as 'established'.

It is a design team so it is chartered by one or more WG chairs. In this 
case (rather unusually), the chairs of MPLS, PWE3, and CCAMP reviewed the 
charter along with their ADs.

The charter is on the wiki at 
http://www.tla-group.com/~loa/mead-team-charter.pdf

> Individual Submissions, lest they be tried as an end around to this 

Hmmm. Yes, probably.

I do worry about Independent Stream work in this area. I would hope that if 
anything was submitted, the RFC Editor and the IESG would agree that the 
work is in direct conflict with the IETF work and would redirect the I-D to 
the IETF.

> so which mailing list is it?

OK. Clarifying...
SHOULD be MPLS-TP
MAY use a specific WG list.

> with the Independent Submission Stream.

OK

> decisions?  Well, I think it should:-)

Yup

> Again, is consensus always declared on the mpls-tp list?

Now consistent with SHOULD and MAY above.

> suggest 'Ad Hoc Team on MPLS-TP mailing list ' as used

Yes. Found two cases.

> I also have a number of grammatical comments, most of which would

Yes (except for one case).

Thanks,
Adrian

---

From: "tom.petch" <[email-masked]>
Date: Mon, 28 Sep 2009 16:25:09 +0200

Adrian

Just to add my remaining grammatical suggestions.

1
     It /Provides/provides an adaptation

     respect to the how the IETF 
remove first 'the'

2.3.2
     given as options, it is always possible a particular MPLS-TP
insert 'for' before'a particular'

2.3.2 5)
      in the communications received ITU-T, and SHOULD attempt to make
insert 'from the' before 'ITU-T'

2.3.2 9)
     informational notification MUST be sent to the ITU-T as a liaison
insert 'an' at start

2.3.2. 11)
   11. Editors working group documents SHOULD solicit comments on the
insert 'of' after 'Editors'

3.4
   In extreme cases, the JWT is empowered to convene to resolve issues
   of failed communications.
unsure quite what this is; 'the JWT will be convened' or is the JWT going
to convene something else?
 
Tom Petch

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 28 Sep 2009 16:51:20 +0100

Excellent, Tom.

All nits, collected for next revision.

> to convene something else?

Yes: "convene itself"

Cheers,
Adrian