Subject: Re: [mpls-tp] Choice of BFD mechanism/mode for proactive CV/CC

From: Greg Mirsky <[email-masked]>
Date: Thu, 25 Mar 2010 14:55:35 -0700

Dear Authors and All,
I would like to ask several questions related to the subject I've asked at
the meeting today:

   - what are reasons considered to select only unidirectional BFD (based on
   BFD for multipoint networks work) for proactive CV/CC
   - what capabilities of BFD for multipoint networks required for use as
   CV/CC in MPLS-TP
   - what of capabilities are optional (can and may)
   - are there any capabilities that would not be supported (should not and
   must not)

As was demonstrated in presentation of David's analysis by Rahul today,
within BFD for MPLS one can create unidirectional BFD session already,
assuming that the DCN exists in some form. Thus it leave p2mp LSP that can
benefit from use of BFD for multipoint networks mechanism. Or a root can
"pretend" that p2mp LSP is p2p and send after first exchange of
Discriminator, and ignore Discrminators from other, late-joiner leaves.

Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 31 Mar 2010 09:15:37 -0700

I haven't seen any response from authors thus assuming that it didn't make
to the list the first time.

On Thu, Mar 25, 2010 at 2:55 PM, Greg Mirsky <[email-masked]> wrote:

>    - what are reasons considered to select only unidirectional BFD (based
>    on BFD for multipoint networks work) for proactive CV/CC
>    - are there any capabilities that would not be supported (should not
>    and must not)
>

---

From: David Ward <[email-masked]>
Date: Wed, 31 Mar 2010 09:32:33 -0700

Greg -

On Mar 31, 2010, at 11:15 AM, Greg Mirsky wrote:

I haven't seen any response from authors thus assuming that it didn't make to the list the first time.

On Thu, Mar 25, 2010 at 2:55 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Dear Authors and All,
I would like to ask several questions related to the subject I've asked at the meeting today:

 *   what are reasons considered to select only unidirectional BFD (based on BFD for multipoint networks work) for proactive CV/CC

DW: This requirement has been bantered back and forth by the group. Although not completely explained, it's been deemed critical to support by those well versed in transport network architectures.

 *   what capabilities of BFD for multipoint networks required for use as CV/CC in MPLS-TP

DW: Certainly in the MP scenario. As discussed in the preso by Rahul at the meeting it can also be used if there is no return path (odd network design).

 *   what of capabilities are optional (can and may)

DW: As you saw in the preso, many capabilities and scenarios were presented.The point of the preso was they there were all optional and that if any of the options were *ever* desired then pure unidirectional MP BFD was not a good choice.

 *   are there any capabilities that would not be supported (should not and must not)

As was demonstrated in presentation of David's analysis by Rahul today, within BFD for MPLS one can create unidirectional BFD session already, assuming that the DCN exists in some form.

DW: And really only useful if there is never, ever a return path.

Thus it leave p2mp LSP that can benefit from use of BFD for multipoint networks mechanism. Or a root can "pretend" that p2mp LSP is p2p and send after first exchange of Discriminator, and ignore Discrminators from other, late-joiner leaves.

Regards,
Greg

HIH

-DWard