Subject: [mpls-tp] About applicability of draft-boutros-mpls-tp-loopback-03

From: Greg Mirsky <[email-masked]>
Date: Fri, 19 Mar 2010 16:29:08 -0700

Dear Authors and All,
in the Introduction its stated that the document is applicable to
"associated bidirectional paths as defined" in
draft-ietf-mpls-tp-framework-00. I cannot find definition of the associated
bidirectional paths in the referred document. The MPLS-TP Framework
document, as I understand it, only requires that it must be possible to
provision congruent, i.e. co-routed, bidirectional LSP. Term "associated
bi-directional LSP" usually refers to more generic case of bidirectional
LSP, that might have no LSRs that host both forward and backward directions
of the LSP. If the applicability of the document is broader than just
co-routed bidirectional LSPs and includes some cases of associated
bidirectional LSPs may I suggest to add a reference topology that will
illustrate mentioned in the document MPLS-TP LSP [A,B,C,D].
And may I suggest to split Introduction section into several sections as
currently it has problem statement, reference model and proposed solutions.

Regards,
Greg

---

From: Huub van Helvoort <[email-masked]>
Date: Sat, 20 Mar 2010 06:52:43 +0100

Hello Greg,

You wrote:
> draft-ietf-mpls-tp-framework-00. I cannot find definition of the 
> associated bidirectional paths in the referred document.

Probalby it was removed when it was added to
draft-ietf-mpls-tp-rosetta-stone.

Regards, Huub.

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 19 Mar 2010 23:44:46 -0700

Hello Huub,
very well could be. But the definition in Rosetta's Section 3.1 is generic
(as definition should be) to require certain additional explanation for the
loopback applicability, particularly for placing MIP into loopback.I think
that while any LSR on a associated bidirectional LSP can be MIP (if there's
OOB) but not any, in general case, MIP can be put into Loopback mode.

Regards,
Greg

On Fri, Mar 19, 2010 at 10:52 PM, Huub van Helvoort <[email-masked]>wrote:

>> bidirectional paths in the referred document.
>>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Huub van Helvoort <[email-masked]>
Date: Sat, 20 Mar 2010 08:42:33 +0100

Hi Greg,

You replied:

 > very well could be. But the definition in Rosetta's Section 3.1 is
 > generic (as definition should be) to require certain additional
 > explanation for the loopback applicability, particularly for placing MIP
 > into loopback.

OK, I see what you mean, in fact MIPs that should reply to
an incoming OAM message can be placed only on congruent/co-routed
paths (and not on associated bi-directional paths).

 > I think that while any LSR on a associated bidirectional
 > LSP can be MIP (if there's OOB) but not any, in general case,
 > MIP can be put into Loopback mode.

If the (A-Z) MIP is put into loopback (for traffic) the return
path has to go through the same LSR with an associated (Z-A) MIP.
This can only be guaranteed when the path is set-up co-routed.

Best regards, Huub.

 > On Fri, Mar 19, 2010 at 10:52 PM, Huub van Helvoort <[email-masked]
 > <mailto:[email-masked]>> wrote:
 >
 >     Hello Greg,
 >
 >
 >     You wrote:
 >
 >         in the Introduction its stated that the document is applicable
 >         to "associated bidirectional paths as defined" in

---

From: "George Swallow (swallow)" <[email-masked]>
Date: Sun, 28 Mar 2010 19:20:24 -0500

Greg -
 
You are quite correct.  Thanks for pointing it out.  Further we are
restricting this draft to just hard loopback.  The "soft loopback" is
now in Nitin's draft.
 
...George
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Greg Mirsky
Sent: Saturday, March 20, 2010 1:45 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] [mpls] About applicability
ofdraft-boutros-mpls-tp-loopback-03

	Hello Huub,
	very well could be. But the definition in Rosetta's Section 3.1
is generic (as definition should be) to require certain additional
explanation for the loopback applicability, particularly for placing MIP
into loopback.I think that while any LSR on a associated bidirectional
LSP can be MIP (if there's OOB) but not any, in general case, MIP can be
put into Loopback mode.
	
	Regards,
	Greg

	On Fri, Mar 19, 2010 at 10:52 PM, Huub van Helvoort
<[email-masked]> wrote:

		Hello Greg, 

		You wrote:

			in the Introduction its stated that the document
is applicable to "associated bidirectional paths as defined" in
draft-ietf-mpls-tp-framework-00. I cannot find definition of the
associated bidirectional paths in the referred document.

		Regards, Huub.

		-- 
	
================================================================
		Always remember that you are unique...just like everyone
else...
		_______________________________________________
		mpls mailing list
		[email-masked]
		https://www.ietf.org/mailman/listinfo/mpls