Subject: Re: [mpls-tp] A new ID draft-zulr-mpls-tp-linear-protection-switching

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Thu, 25 Mar 2010 07:53:02 +0900

Loa, amir and all,

The aim of our draft is to support the WG activity and to provide a solution to the current open issues in draft-ietf-mpls-tp-linear-protection-00.

Our proposal is based on the abstract APS protocol behavior described in G.808.1. It has been already implemented in other transport technologies (including packet based technologies) and it is proven by deployment for more than the last ten years.

We are willing to work with the authors of draft-ietf-mpls-tp-linear-protection-00 to resolve these issues and move forward.

Best regards,

Jeong-dong

==============================================
Jeong-dong Ryoo, Ph.D.
Principal Member of Research Staff
Network Research Department
Electronics and Telecommunications Research Institute (ETRI)
Phone: +82-42-860-5384, Fax: +82-42-860-6342
Email: [email-masked]
==============================================

-----원본 메시지-----
From: "Loa Andersson" <[email-masked]>
From Date: 2010-03-25 오전 2:24:19
To: "Amir Halperin" <[email-masked]>
Cc: "Ryoo, Jeong-dong" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls-tp] A new ID draft-zulr-mpls-tp-linear-protection-switching

Amir and all,

I know of no plans to replace the working group draft.

I've not yet had time to read draft-zulr, so I can't just make up
my mind if this is just a friendly amendment or different solution.

If it is the first, the authors of draft-zulr should talk to the
authors of the wg draft and make sure that whatever is needed
is added to the wg draft.

If we have a different solution, we will return to a discussion of
this new draft when we cleared the current backlog.

/Loa

On 2010-03-24 00:06, Amir Halperin wrote:
> Is this draft intends to replace
> http://tools.ietf.org/html/draft-ietf-mpls-tp-linear-protection-01?
>
> **Amir Halperin***
> *mailto:[email-masked]
>
> ------------------------------------------------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Ryoo, Jeong-dong
> *Sent:* Wednesday, March 24, 2010 1:35 AM
> *To:* [email-masked]
> *Subject:* [mpls-tp] A new ID draft-zulr-mpls-tp-linear-protection-switching
>
> Dear all in MPLS-TP,
>
>
> Please be aware that we submitted a new document:
>
>
> Linear Protection Switching in MPLS-TP
> draft-zulr-mpls-tp-linear-protection-switching-00
> http://www.ietf.org/id/draft-zulr-mpls-tp-linear-protection-switching-00.txt
>
>
> This document specifies a linear protection switching mechanism for
> MPLS-TP. This mechanism supports 1+1 unidirectional/bidirectional
> protection switching and 1:1 bidirectional protection switching. It
> is purely supported by MPLS-TP data plane, and can work without any
> control plane.
>
>
> We would appreciate review and comments for our document.
>
>
> Thank you,
>
>
> Jeong-dong
>
> ==============================================
> Jeong-dong Ryoo, Ph.D.
> Principal Member of Research Staff
> Network Research Department
> Electronics and Telecommunications Research Institute (ETRI)
> Phone: +82-42-860-5384, Fax: +82-42-860-6342
> Email: [email-masked] <mailto:[email-masked]>
> ==============================================
>
>
>
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

--

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
+46 767 72 92 13

---

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Wed, 24 Mar 2010 23:59:04 +0100

In addition to considerations expressed below, I was not able to identify any significant improvement wrt the APS protocol that is in operation in Telecom Italia networks and it has been proven to work.

I would like to avoid having a new protocol if it does not add significant functionalities and requires extensive testing before it can be deployed in a real network.

Best regards,
Alessandro
------------------------------------------------------------------
Telecom Italia
Alessandro D'Alessandro
Transport & OPB Innovation
Via Reiss Romoli, 274 - 10148 Torino
phone:  +39 011 228 5887
mobile: +39 335 766 9607
fax: +39 06 418 639 07
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ryoo, Jeong-dong
Sent: mercoledì 24 marzo 2010 23.53
To: Loa Andersson; Amir Halperin
Cc: [email-masked]
Subject: Re: [mpls-tp] A new ID draft-zulr-mpls-tp-linear-protection-switching

Loa, amir and all,

Best regards,

Jeong-dong

Email: [email-masked]<mailto:[email-masked]>

-----원본 메시지-----
From: "Loa Andersson" <[email-masked]>
From Date: 2010-03-25 오전 2:24:19
To: "Amir Halperin" <[email-masked]>
Cc: "Ryoo, Jeong-dong" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls-tp] A new ID draft-zulr-mpls-tp-linear-protection-switching

Amir and all,

/Loa

--

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13
[http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name=mpls-tp%40ietf.org&fromemail=[email-masked]&messageid=[email-masked]%3E]
Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "Amir Halperin" <[email-masked]>
Date: Thu, 25 Mar 2010 08:33:50 +0200

I agree with Alessandro, and therefore suggest to use the same protocol i.e. state machine, that is defined in G.8031.

Amir Halperin
mailto:[email-masked]

From: D'Alessandro Alessandro Gerardo [mailto:[email-masked]] 
Sent: Thursday, March 25, 2010 12:59 AM
To: Loa Andersson; Amir Halperin
Cc: [email-masked]; Ryoo, Jeong-dong
Subject: RE: Re: [mpls-tp] A new IDdraft-zulr-mpls-tp-linear-protection-switching

Best regards,

Alessandro

Loa, amir and all,

Best regards,

Jeong-dong

-----원본 메시지-----
From: "Loa Andersson" <[email-masked]>
From Date: 2010-03-25 오전 2:24:19
To: "Amir Halperin" <[email-masked]>
Cc: "Ryoo, Jeong-dong" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls-tp] A new ID draft-zulr-mpls-tp-linear-protection-switching

Amir and all,

/Loa

--

 <http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name=mpls-tp%40ietf.org&fromemail=[email-masked]&messageid=[email-masked]%3E>

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 25 Mar 2010 03:31:53 -0400

In message <[email-masked]>
"D'Alessandro Alessandro Gerardo" writes:
>  
> In addition to considerations expressed below, I was not able to
> identify any significant improvement wrt the APS protocol that is in
> operation in Telecom Italia networks and it has been proven to work.
>  
> I would like to avoid having a new protocol if it does not add
> significant functionalities and requires extensive testing before it
> can be deployed in a real network.
>  
> Best regards,
> Alessandro

Does APS have the ability to share protection capacity among many
working paths in a mesh network that do not share a common SRLG?  If
not, then there is a significant improvement in what MPLS protection
can do (with packet services at least) relative to APS.

Curtis

---

From: "Amir Halperin" <[email-masked]>
Date: Thu, 25 Mar 2010 10:36:21 +0200

Isn't the all point with MPLS-TP is to provide MPLS for transport
networks?
Assuming transport operators require simplicity + hard 50ms protection,
it seems logical supporting SONET/SDH APS like for MPLS-TP transport
networks.

Amir Halperin
mailto:[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 25, 2010 9:32 AM
To: D'Alessandro Alessandro Gerardo
Cc: Loa Andersson; Amir Halperin; [email-masked]
Subject: Re: [mpls-tp] A new ID
draft-zulr-mpls-tp-linear-protection-switching 

In message
<[email-masked]

Curtis

---

From: Maarten Vissers <[email-masked]>
Date: Thu, 25 Mar 2010 14:10:48 +0100

Curtis,

The APS OAM defined in SONET/SDH, OTN, Ethernet supports 1:n protection;
i.e. n working paths, 1 protection path.

Regards,
Maarten
PS. Experience however is that this capability is hardly used in transport
networks as it is difficult to find more then two paths in a mesh network
that do not share a common SRLG. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Curtis Villamizar
Sent: donderdag 25 maart 2010 8:32
To: D'Alessandro Alessandro Gerardo
Cc: [email-masked]
Subject: Re: [mpls-tp] A new ID
draft-zulr-mpls-tp-linear-protection-switching

In message
<[email-masked]>
> can be deployed in a real network.

Does APS have the ability to share protection capacity among many working
paths in a mesh network that do not share a common SRLG?  If not, then there
is a significant improvement in what MPLS protection can do (with packet
services at least) relative to APS.

Curtis

---

From: Zhi-Wei Lin <[email-masked]>
Date: Thu, 25 Mar 2010 09:40:31 -0400

Hi Maarten,

In one of my earlier emails regarding similar topic, I was thinking more of
the (1:1)^n protection. I think in a packet network, 1:n may make less sense
than (1:1)^n.

In our network, we do have the case of paths that satisfy the SRLG
constraint.

Thanks
Zhi

On Thu, Mar 25, 2010 at 9:10 AM, Maarten Vissers <[email-masked]
> wrote:

---

From: Maarten Vissers <[email-masked]>
Date: Thu, 25 Mar 2010 14:48:48 +0100

Hi Zhi,
 
I agree with you that (1:1)^n protection makes more sense in a packet
network.
Good to know that it is possible to have n+1 diverse paths in a packet
network.
What value of n is possible: 3, 5, 10, ..?
 
Regards,
Maarten

  _____  

From: Zhi-Wei Lin [mailto:[email-masked]] 
Sent: donderdag 25 maart 2010 14:41
To: Maarten Vissers
Cc: [email-masked]; D'Alessandro Alessandro Gerardo; [email-masked]
Subject: Re: [mpls-tp] A new ID
draft-zulr-mpls-tp-linear-protection-switching

Hi Maarten,

Thanks
Zhi

On Thu, Mar 25, 2010 at 9:10 AM, Maarten Vissers
<[email-masked]> wrote:

Curtis,

Regards,
Maarten

-----Original Message-----

Of Curtis Villamizar

Cc: [email-masked]

In message

Curtis

---

From: Zhi-Wei Lin <[email-masked]>
Date: Thu, 25 Mar 2010 09:57:29 -0400

Hi Maarten,

Not too many. Physically disjoint paths: around 3.

However, for tunnel environment, since many of the northbound and southbound
tracks are separated by a pretty thick concrete wall, they can be considered
disjoint as well. So it could go up to 5 (discounting some tunnels that
don't have this separation).

Thanks
Zhi

On Thu, Mar 25, 2010 at 9:48 AM, Maarten Vissers <[email-masked]

>  ------------------------------
> *From:* Zhi-Wei Lin [mailto:[email-masked]]
> *Sent:* donderdag 25 maart 2010 14:41
> *To:* Maarten Vissers
> *Cc:* [email-masked]; D'Alessandro Alessandro Gerardo; [email-masked]
>
> *Subject:* Re: [mpls-tp] A new ID
> On Thu, Mar 25, 2010 at 9:10 AM, Maarten Vissers <
> [email-masked]> wrote:
>
>> Curtis,
>>

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 25 Mar 2010 12:18:46 -0400

In message <44F4E579A764584EA9BDFD07D0CA0813059E11E6@tlvmail1>
> it seems logical supporting SONET/SDH APS like for MPLS-TP transport

MPLS-TP is the superset of GMPLS as used for traditional transport
technologies such as OTN, Ethernet as commonly used as a metro
transport technology, and packet based MPLS/GMPLS networks which are
to be made more transport like.  If we want to call the superset
capability GMPLS-APS, that is fine with me as long as existing
capabilities are not forbidden by the reuse of the term APS.

Curtis

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Fri, 26 Mar 2010 14:44:47 +0100

Hi Curtis,
I am bit lost.
MPLS-TP is a superset of GMPLS?
GMPLS is the control plane of choice of MPLS-TP, but the control plane
is only one of the components of MPLS-TP. 
MPLS-TP data-plane can fully operate also in the absence of a control
plane. 
And, the whole intention of the Protection State Coordination protocol
is to provide the endpoints of protection domain the capability to
coordinate the protection state even fast even in the absence of a
control plane. 
So how we get to GMPLS-APS?
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Curtis Villamizar
Sent: Thursday, March 25, 2010 9:19 AM
To: Amir Halperin
Cc: [email-masked]
Subject: Re: [mpls-tp] A new
IDdraft-zulr-mpls-tp-linear-protection-switching

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Sat, 27 Mar 2010 21:15:33 -0400

In message <[email-masked]>
> So how we get to GMPLS-APS?

Yes you are correct.  In MPLS-TP the control plane is optional.

OK - so call it MPLS-TP APS.

Curtis