Subject: [mpls-tp] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

From: "Loa Andersson" <[email-masked]>
Date: Fri, 12 Mar 2010 00:32:45 +0100

All,

this is to start an MPLS working group last call on
draft-ietf-mpls-tp-identifiers-01

There is a discussion on the OAM model for MS-PWs where we haven't been
able to come to conclusion. Once we reach agreement the document will
be updated. Comments in this area are welcome during the working group
last call.

Please send your comments to the [email-masked] mailing list.

The working group last ends eob April 2nd.

/Loa

--

Loa Andersson

Sr Strategy and Standards Manager
Ericsson ///
   phone:  +46 10 717 52 13
           +46 767 72 92 13

   email:  [email-masked]
           [email-masked]

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 11 Mar 2010 16:27:32 -0800

Hi,

Couple of comments:

1) Why the Interface_ID is 32-bit while the Tunnel_ID is 16-bit? Do we need to support more interfaces than tunnels? 
2) The draft defines the Global_Tunnel_ID as:
      Src-Global_ID::Src-Node_ID::Src-Tunnel_Num:: Dst-Global_ID::Dst-Node_ID::Dst-Tunnel_Num

This seems to define a bidirectional tunnel. Is that the intent? If so please clarify. If not then why Dst-Global_ID::Dst-Node_ID::Dst-Tunnel_Num is needed?

3) Is section 5.2 talking about unidirectional LSP or bidirectional LSP?
4) Section 7.1.2.1 says:
	Since a MEG pertains to a single MPLS-TP Tunnel, IP compatible MEG_IDs for MPLS-TP Tunnels are simply the corresponding Tunnel_IDs

Assuming the Tunnel_ID is a unidirectional ID, then this statement implies that for the reverse direction a different MEG_ID is required. Is that the intent? If so why?

5) Why are drafts part of the normative references?

6) Will section 8 (open issues) be removed before publishing? This section implies that the MEP and MIP definition is not yet aligned with framework?

Regards,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Thursday, March 11, 2010 3:33 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

All,

/Loa

--

Loa Andersson

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 24 Mar 2010 09:20:44 -0700

Hi

In addition to the previous comments that I have raised I like to also raise the following comments:

7) I think it is too early for this draft (just with 1 version) to become RFC. This draft affects many IETF WGs and drafts and is really putting stakes on the ground before the requirements are finalized for other drafts. 

8) I am concerned about not having a commonly agreed identifier for objects in this draft and in most cases defining an IETF identifier and an ITU identifier. That would make the interoperability a nightmare.

Thanks,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Thursday, March 11, 2010 4:28 PM
To: Loa Andersson; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

Hi,

Couple of comments:

Regards,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Thursday, March 11, 2010 3:33 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

All,

/Loa

--

Loa Andersson

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 24 Mar 2010 18:57:22 +0200

Shahram,
I fully agree with you that defining two incompatible identifiers without defining the mandatory default results in a clear breach of interoperability. 

Aside ==> Could somebody remind me when did the IESG revoke its once-in-force requirement to explicitly define
          mandatory default every time multiple incompatible modes are specified in a protocol?

On the other hand, neither of the two looks like a good candidate for the mandatory default:

- IETF identifiers effectively assume usage of IP addressing which cannot be presumed in MPLS-TP. 
  The notes stating that IP addresses, AS numbers etc. used in these identifiers do not necessarily have
  to behave as "real" IP addresses/AS numbers do not really help IMO.

- AFAIK, ITU identifiers have hardly ever been used before for any meaningful purpose.
  Hence mandating them would be at best premature.

I must admit that I do not see any clear way out of this situation.

Regards,
     Sasha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Wednesday, March 24, 2010 6:21 PM
To: Loa Andersson; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [PWE3] [mpls] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

Hi

Thanks,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Thursday, March 11, 2010 4:28 PM
To: Loa Andersson; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

Hi,

Couple of comments:

Regards,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Thursday, March 11, 2010 3:33 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] mpls wg last call on draft-ietf-mpls-tp-identifiers-01

All,

/Loa

--

Loa Andersson

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3