Subject: [mpls-tp] Protection Object extension in draft-takacs-ccamp-revertive-ps

From: Attila Takacs <[email-masked]>
Date: Tue, 23 Mar 2010 19:01:16 +0100

Hi all,

We have a document in CCAMP that suggest to extend the Protection Object to carry sub-TLVs: ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-takacs-ccamp-revertive-ps-04.txt

This would allow to configure protection timers and revertive operation for protection mechanisms that run independently from the control plane. This has been identified in MPLS-TP Control Plane Framework as needed extension to fulfill TP requirements.

Please check, your comments are welcome!
Thanks,
Attila

---

From: hejia <[email-masked]>
Date: Wed, 24 Mar 2010 02:36:33 +0800

Hi Attila,

Is the draft specific for MPLS-TP or a generalized configuration framework 
for ps just like what we do for OAM configuration currently?

B.R.
Jia

----- Original Message ----- 
From: "Attila Takacs" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, March 24, 2010 2:01 AM
Subject: [mpls-tp] Protection Object extension 
indraft-takacs-ccamp-revertive-ps

> Hi all,
>
> We have a document in CCAMP that suggest to extend the Protection Object 
> to carry sub-TLVs: 
> ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-takacs-ccamp-revertive-ps-04.txt
>
> This would allow to configure protection timers and revertive operation 
> for protection mechanisms that run independently from the control plane. 
> This has been identified in MPLS-TP Control Plane Framework as needed 
> extension to fulfill TP requirements.
>
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: Attila Takacs <[email-masked]>
Date: Tue, 23 Mar 2010 20:04:47 +0100

Hi Jia,
It is a general extension of the Protection Object which will be useful to meet TP requirements too.
Attila 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of hejia
> Sent: Tuesday, March 23, 2010 7:37 PM
> To: Attila Takacs; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [CCAMP] [mpls-tp] Protection Object extension 
> Is the draft specific for MPLS-TP or a generalized 
> configuration framework for ps just like what we do for OAM 
> configuration currently?
> 
> B.R.
> Jia
> 
> 
> > We have a document in CCAMP that suggest to extend the Protection 
> > Object to carry sub-TLVs:
> > 
> > This would allow to configure protection timers and revertive 
> > operation for protection mechanisms that run independently 
> from the control plane.
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>