Subject: [mpls-tp] MPLS-TP OAM framework technical comments/questions

From: "Rolf Winter" <[email-masked]>
Date: Wed, 28 Apr 2010 17:33:35 +0200

Hi,

Some technical comments/questions on the document:

Section 2.2, page 7: I don't quite get the significance of the 'intermediate' in the DBN definition. Does it have to be an intermediate node?

Section 2.2., The definition of OAM information element rules out the information send between MEPs and MIPs, is this intentional?

PM: Why is on-demand LM to be done in the class with the lowest loss but proactive LM with the PHB class of the to be monitored class?

Route tracing up to a MIP alone is not intended, right? Just a clarification question.

Some observations on lock instruct and lock report. The way I read the document right now is that in case a lock is being issued, the client layer is informed which in turn will send a lock report towards the MEPs in its layer (I guess Lock report messages are exempt from the lock itself, otherwise one direction will be locked, is that understanding correct? Now assume the layer above the client layer an MPLS-TP LSP which is CC-V:ed, then there will be alarms despite of the fact that the client-layer MEPs are suppressing alarm messages. I suggest to have those MEPs issue AIS in order to avoid this.

Best,

	Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: David Allan I <[email-masked]>
Date: Wed, 28 Apr 2010 15:09:29 -0400

Hi Rolf:

A few notes in line, prefaced DA)

DA) the intent of the definition was (common case) an inter carrier peering point, we'll fix the text.

DA) No, I agree the definition is too restrictive and needs broadening

DA) Good catch, they should be the same, lowest loss probability within the Ordered Aggregate was the intent

DA) is there text that gave you that impression?

DA) Lock report should hierarchically escalate upwards, just like AIS, we have one correction to make to the next version to make that clearer....

Cheers
D