Subject: Re: [mpls-tp] [mpls] [CCAMP] Term "PSC"indraft-ietf-mpls-tp-linear-protection-01

From: <[email-masked]>
Date: Fri, 2 Apr 2010 16:30:52 +0100

Zhi,

I suspect your requirement is to keep the operational procedures (MOP) for
MPLS-TP as closely aligned to those of your existing transport network as
possible. In other words if scenario A occurs, operations need to follow
steps B, C and D etc. where the functions of A, B, C and D are as similar as
possible for MPLS-TP and your existing transport network.

Whether the protection switching mechanism is called APS or FOO is a very
minor point in the overall operations procedure, otherwise I suspect your
operations personnel are going to really struggle with MPLS-TP with its
introduction of other new acronyms Vs transport networks like LSP, PW, BFD
etc ;-)

Ben

On 02/04/2010 15:26, "Lin, Zhi-Wei" <[email-masked]> wrote:

> Hi Ben,
> 
> Yes, definitely there are other operators with different operational
> considerations. I was offering my perspective and what my company plans to do.
> 
> However, in terms of the acronyms, even if in your company you plan to have
> your data group handle MPLS-TP, whether the term is "MPLS-TP APS" or "PSC",
> from their perspective it will be a new term and therefore no difference which
> it should be.
> 
> However, for other operators (such as us) who plans to have the transport
> personnel handle MPLS-TP, then "MPLS-TP APS" would make more sense. Again,
> functionally, our transport staff will need to be trained on specific
> procedures associated with MPLS-TP, but anything that keeps things "similar"
> is better than nothing.
> 
> As such, MPLS-TP APS would be a better term that would make more operators'
> life easier, yes?
> 
> Thanks
> Zhi
> 
> 
> ________________________________
> From: [email-masked] on behalf of [email-masked]
> Sent: Fri 4/2/2010 7:46 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [mpls] [CCAMP] [mpls-tp] Term
> "PSC"indraft-ietf-mpls-tp-linear-protection-01
> 
> 
> Zhi,
> 
> Thanks, I understand you perspective.
> 
> However I suspect other operators may target their existing data network
> operations staff to maintain and operate an MPLS-TP network!
> 
> The functionality needs to be as aligned to existing practices (MPLS and
> Transport) as possible. Re-learning/Re-definition of existing operations
> processes should be minimised but given that MPLS-TP is bridging a gap
> between data and transport networks some relearning on both sides is
> inevitable.
> 
> HTH
> Ben
> 
> 
> 
> On 25/03/2010 14:38, "Zhi-Wei Lin" <[email-masked]> wrote:
> 
>> Hi,
>> 
>> I like to give my perspective. As a small network company (but one of the
>> largest transit agencies), we have a small operating staff split into two
>> groups: one that handles traditional data network (Ethernet, IP), and one
>> that
>> handles transport network (SONET, WDM).
>> 
>> We are targeting the transport network operating staff to maintain and
>> operate
>> the MPLS-TP network. As such, anything that will help to reduce the learning
>> curve (less training), simplify operating, and make the MOP as consistent as
>> possible between SONET and MPLS-TP would be hugely beneficial.
>> 
>> Obviously there will be some differences since MPLS-TP is a packet-based
>> transport network, but the standards groups (I don't really care for politics
>> of IETF and ITU) should strive to make these differences easy to learn.
>> 
>> Thanks
>> Zhi
>> 
>> 
>> On Thu, Mar 25, 2010 at 2:09 AM, Curtis Villamizar
>> <[email-masked]<mailto:[email-masked]>> wrote:
>> 
>> In message
>> 
<[email-masked]<mailto:4B2E951>>
0
>> [email-masked]>>
>> "Cecil Byles" writes:
>>> 
>>> 
>>> Hi,
>>> Can I therefore also asked how PSC "Protection State Coordination" in
>>> the MPLS-TP parlance align with ITU-T 808.1 recommendation that "defines
>>> the generic functional models, characteristics and processes associated
>>> with various linear protection schemes for connection-oriented layer
>>> networks; e.g., Optical Transport Networks (OTN), Synchronous Digital
>>> Hierarchy (SDH) networks and Asynchronous Transfer Mode (ATM) networks"
>>> and the sections covering  Terms and Definitions as well as
>>> Abbreviations.  IMO all transport engineers and the general telecom
>>> community understand that 1+1 or 1:1 are either SNCP or APS. Hence why
>>> introduce a new TLA (three letter abbreviation) cover the same function
>>> and feature for MPLS-TP.  I can only agree that this will only cause
>>> confusion.
>>> 
>>> Cecil Byles
>> 
>> 
>> Though this is joint work, this is the IETF not the ITU.  We should
>> use ITU terms where appropriate but where there is a conflict such as
>> this we need to pick another term and another TLA.  If the ITU wants
>> to update 808.1 at some later date that is up to the ITU.  In the mean
>> time we can use another term and point out the mapping.
>> 
>> Curtis
>> _______________________________________________
>> mpls mailing list
>> [email-masked]<mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/mpls
>> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Zhi-Wei Lin <[email-masked]>
Date: Fri, 2 Apr 2010 17:26:27 -0400

Hi Ben,

Yes, exactly! As a small network operator, we don't have the luxury that you
may have in terms of a larger workforce and better funding for training. So
anything that keeps things similar would be helpful, and would alleviate us
struggling with terminology and fundamental technology differences.

Of course there would be lots of new terms, but if we keep part of the
terminology as closely coupled to transport network as possible (e.g.,
protection switching, manual switch, force switch, lockout, wait to
restore), these would be concepts they are already familiar with and can
identify.

Thanks
Zhi

---

From: "Ryoo, Jeong-dong" <[email-masked]>
Date: Mon, 5 Apr 2010 18:38:15 +0900

Hi, all.

I don't have any big issues with the word for a protection switching, APS, PSC, xSC, or whatever. But, just FYI, RFC5586-MPLS Generic Associated Channel document already uses the term APS (Automatic Protection Switching).

Best regards,

Jeong-dong

==============================================
Jeong-dong Ryoo, Ph.D.
Principal Member of Research Staff
Network Research Department
Electronics and Telecommunications Research Institute (ETRI)
Phone: +82-42-860-5384, Fax: +82-42-860-6342
Email: [email-masked]
==============================================

-----Original Message-----
From: "Zhi-Wei Lin" <[email-masked]>
From Date: 2010-04-03 AM 6:26:27
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] [CCAMP] [mpls-tp] Term"PSC"indraft-ietf-mpls-tp-linear-protection-01

Hi Ben,

Yes, exactly! As a small network operator, we don't have the luxury that you may have in terms of a larger workforce and better funding for training. So anything that keeps things similar would be helpful, and would alleviate us struggling with terminology and fundamental technology differences.

Of course there would be lots of new terms, but if we keep part of the terminology as closely coupled to transport network as possible (e.g., protection switching, manual switch, force switch, lockout, wait to restore), these would be concepts they are already familiar with and can identify.

Thanks
Zhi

Zhi,

Ben

>>> and the sections covering ?Terms and Definitions as well as
>>> Abbreviations. ?IMO all transport engineers and the general telecom
>>> and feature for MPLS-TP. ?I can only agree that this will only cause
>>> confusion.
>>>
>>> Cecil Byles
>>
>>
>> Though this is joint work, this is the IETF not the ITU. ?We should
>> this we need to pick another term and another TLA. ?If the ITU wants
>> to update 808.1 at some later date that is up to the ITU. ?In the mean