Subject: [mpls-tp] Service LSP label swap at MPLS-TP NNI

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Fri, 30 Apr 2010 14:07:28 +0200

Hi,

I'm planning on adding the following figure to Section 3.4.5 (Network Layer Adaptation) of draft-ietf-mpls-tp-framework, in response to comments we have received about whether a service LSP label could be swapped at an MPLS-TP NNI. This figure is basically very similar to the current figure 6 for MS-PW.

     |<--------------------- Client Layer ------------------------>|
     |                                                             |
     |                                                             |
     |    |<---------- Packet Transport Service ------------->|    |
     |    |                                                   |    |
     |    |              Transport               Transport    |    |
     | AC |     |<-------- LSP1 --------->|    |<--LSP2-->|   | AC |
     | |  V     V                         V    V          V   V |  |
     V |  +----+              +-----+    +----+          +----+ |  V
 +---+ |  | PE1|===============\   /=====| PE2|==========| PE3| |  +---+
 |   |----|......svc-lsp1.... | \ / | .....X....svc-lsp1......|----|   |
 |CE1| |  |    |              |  X  |    |    |          |    | |  |CE2|
 |   |----|......svc-lsp2.... | / \ | .....X....svc-lsp2......|----|   |
 +---+  ^ |    |===============/   \=====|    |==========|    | | ^+---+
        | +----+     ^        +-----+    +----+     ^    +----+   |
        |            |           ^         ^        |             |
        |          TE LSP        |         |      TE LSP          |
        |                      P-router    |                      |
   Native Service            (  LSR for    |                 Native Service
                             T'port LSP1)  |
                                           |
                                   LSR for Service LSPs
                                   LER for Transport LSPs 

One question we, as editors, have is whether this is a realistic scenario? 

Please let me know if you have any comments.

Best regards,

Matthew

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 30 Apr 2010 16:54:44 -0400

Matthew,

While this case probably wouldn't be part of our initial deployment,
it's certainly a case that we would want to be able to use going
forward.

Thanks,
Andy

On Fri, Apr 30, 2010 at 8:07 AM, Bocci, Matthew (Matthew)
<[email-masked]> wrote:
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>