Subject: [mpls-tp] Global_ID or ICC for operator identification - Why not just Global_ID?

From: venkatesan mahalingam <[email-masked]>
Date: Fri, 9 Apr 2010 02:10:05 +0530

HI,

In the draft draft-ietf-mpls-tp-identifiers-01,
Is there any dependency to use either Global Id or ICC for operator
identification? Can't we just use Global_ID to uniquely identify an
operator?

Best Regards,
Venkatesan Mahalingam.

---

From: "BUSI ITALO" <[email-masked]>
Date: Fri, 9 Apr 2010 09:05:04 +0200

Venkatesan,
 
in all the other ITU-T transport technologies the ICC is used for operator identification.
 
When MPLS-TP is deployed with other ITU-T transport networks, the ICC will be used for operator identification.
 
Italo 

P.S. Please note my new email address, [email-masked], effective since 1 November 2009.

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of venkatesan mahalingam
	Sent: giovedì 8 aprile 2010 22.40
	To: mpls; [email-masked]
	Subject: [mpls-tp] Global_ID or ICC for operator identification - Why notjust Global_ID?

	HI,
	
	In the draft draft-ietf-mpls-tp-identifiers-01, 
	Is there any dependency to use either Global Id or ICC for operator identification? Can't we just use Global_ID to uniquely identify an operator?

	Best Regards,
	Venkatesan Mahalingam.

---

From: venkatesan mahalingam <[email-masked]>
Date: Fri, 9 Apr 2010 12:46:17 +0530

BUSI ITALO,

Thanks for your reply.

>>When MPLS-TP is deployed with other ITU-T transport networks, the ICC will
be used for operator identification.
You mean to say MPLS-TP enabled swich should be identified by Global_ID and
ICC if the switch needs to be deployed with other ITU-T networks and MPLS-TP
networks.

Is this understanding correct?

BR,
Venkatesan Mahalingam.
On Fri, Apr 9, 2010 at 12:35 PM, BUSI ITALO
<[email-masked]>wrote:

>  ------------------------------
>  *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *venkatesan mahalingam
> *Sent:* giovedì 8 aprile 2010 22.40
>
> *To:* mpls; [email-masked]
> *Subject:* [mpls-tp] Global_ID or ICC for operator identification - Why
> notjust Global_ID?
>
>   HI,
>

-- 
Best Regards,
Venkatesan Mahalingam.

---

From: "BUSI ITALO" <[email-masked]>
Date: Fri, 9 Apr 2010 09:34:28 +0200

I am not sure I understand your question.
 
An MPLS-TP enabled switch may be deployed either by a transport operator, who manages his network according to ITU-T operations, or by an IP operator, who manages his network according to IP operations.
 
In the latter case, I understand that the Global_ID is likely to be used to identify the operator while the ICC will be used in the former case.
 
If you are building an MPLS-TP switch addressing both types of operators you need to support both types of operators' identification.
 
Italo

 

	From: venkatesan mahalingam [mailto:[email-masked]] 
	Sent: venerdì 9 aprile 2010 9.16
	To: BUSI ITALO
	Cc: mpls; [email-masked]
	Subject: Re: [mpls-tp] Global_ID or ICC for operator identification - Why notjust Global_ID?

	BUSI ITALO,
	 
	Thanks for your reply.
	 
	>>When MPLS-TP is deployed with other ITU-T transport networks, the ICC will be used for operator identification.
	You mean to say MPLS-TP enabled swich should be identified by Global_ID and ICC if the switch needs to be deployed with other ITU-T networks and MPLS-TP networks.

	BR,
	Venkatesan Mahalingam.
	
	On Fri, Apr 9, 2010 at 12:35 PM, BUSI ITALO <[email-masked]> wrote:

		Venkatesan,

		 
		Italo 

		 

			

			HI,

			

			Best Regards,
			Venkatesan Mahalingam.

	-- 
	Best Regards,
	Venkatesan Mahalingam.