Subject: [mpls-tp] Comments of draft-ietf-mpls-tp-survive-fwk-04

From: Elisa Bellagamba <[email-masked]>
Date: Thu, 8 Apr 2010 11:15:17 +0200

Dear Adrian and Nurit,

I've been reading the survivability framework and I have some comments and questions.

In my opinion, the "Introduction" section is a bit too long. Maybe you could ease the readability dividing this section in several subsections with a corresponding title. Something like:

Paragraph 1 to 3 --> General Introduction

Paragraph 4 to 6 --> Background: RFC 4427 and 4428

Paragraph 7 to 14 --> MPLS-TP and survivability

Paragraph 15 to 24 --> Scope of the document

Please find below some other minor comments.

Introduction - Paragraph 2

"The function provided is intended to be similar or better to that found in established transport networks which set a high benchmark for reliability."

I am not entirely sure here, but I think that "similar or better than" is the correct form.

Introduction - Paragraph 9

   "The protection switching operation is basically a data-plane capability and in the context of MPLS-TP it needs to be ensured that
   it is possible to switch over independent of the way the network is configured and managed."

I think it should be "independently" instead of "independent".

Introduction - Paragraph 8

It is talking about protection but restoration is not mentioned anymore. Was it done on purpose?

Introduction - Paragraph 22

"Generally, network operators aim to provide the fastest, most stable, and the best protection mechanism..."

I think the comma before "and best protection" should be deleted.

Thanks,
Elisa

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 14 Apr 2010 14:59:18 +0100

Hi Elisa,

Thanks so much for reading and commenting.

> In my opinion, the "Introduction" section is a bit too long.
> Maybe you could ease the readability dividing this section
> in several subsections with a corresponding title. Something like:
>

Possibly you were looking at the 03 revision?
The 04 was broken up as:

1.  Introduction (4 paragraphs)
1.1.  Recovery Schemes (2 paragraphs)
1.2.  Recovery Action Initiation (5 paragraphs)
1.3.  Recovery Context (4 paragraphs)
1.4.  Scope of this Framework (7 paragraphs)

Is this OK?

> "The function provided is intended to be similar or better to that found 
> in
> established transport networks which set a high benchmark for 
> reliability."
>

Yes. -04 has "similar to or better than"

>   "The protection switching operation is basically a data-plane capability
>   and in the context of MPLS-TP it needs to be ensured that

No, sorry :-)
Although our American cousins have some probelms on this point arising from 
their German ancestary.

However, we have changed to "regardless" to be slicker.

> anymore. Was it done on purpose?

Everything has a purpose. In this case, the purpose was to allow you to 
point out that we were wrong.

> "Generally, network operators aim to provide the fastest, most stable, and 
> the best
> protection mechanism..."
>

This is called a "serial comma" and is used before the last item of a 
compound list in some house styles. Typically, US house styles use serial 
commas whereas UK ones are about 50-50. At school I was taught to not use 
them, but leaving them out in technical documents can often lead to 
ambiguity. The RFC Editor likes them :-)

Many thanks,
Adrian and Nurit

Thanks,
Elisa