Subject: Re: [mpls-tp] [PWE3] Proposal of using GAL for PW

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 30 Jun 2010 12:35:45 -0400

Larry and Feng,

This issue has previously been discussed at length by the working
group, both at the Anaheim meeting and by email, for example in emails
with the subject line "Possible Contradiction re use of GAL in
pwe3-static-pw-status". There was rough consensus that for MPLS-TP
applications and/or when PW OAM is desired, PW implementations are
mature enough (it has been 10 years now, after all) that the time has
come to require the implementation of the CW for all PWs, including
Ethernet.

Cheers,
Andy

On Wed, Jun 30, 2010 at 6:34 AM, HUANG Feng F
<[email-masked]> wrote:
>
> it is reasonable to support GAL in MPLS-TP PW OAM, it is more generic, because CW is an option RFC4448 for Ethernet over MPLS.
>
> 4.6.  The Control Word
>
> xxxx
>
>
> The features that the control word provides may not be needed for a
>   given Ethernet PW.  For example, ECMP may not be present or active on
>   a given MPLS network, strict frame sequencing may not be required,
>   etc.  If this is the case, the control word provides little value and
>   is therefore optional.  Early Ethernet PW implementations have been
>   deployed that do not include a control word or the ability to process
>   one if present.  To aid in backwards compatibility, future
>   implementations MUST be able to send and receive frames without the
>   control word present.
> xxxx
>
>
>
> B.R.
> Feng Huang
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Larry
> Sent: 2010年6月30日 17:38
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [PWE3] Proposal of using GAL for PW
>
> Dear all:
>
>     In section 4.2 in RFC5586, it is defined that GAL MUST NOT be used with PWs in MPLS-TP. The PWE3 control word [RFC4385] MUST be present when the ACH is used to realize the associated control channel.
>     In real application, a lot of MPLS and MPLS-TP equipments do not support control word. It is proposed to use the GAL to identify associated control channel in PW layer.
>
> Best regards,
>
>                 Han Li
>
> ********************************************************************
> Han Li, Ph.D
> China Mobile Research Institute
> Unit 2, 28 Xuanwumenxi Ave, Xuanwu District, Beijing 100053, China
> Fax: +86 10 63601087
> MOBILE: 13501093385
> ********************************************************************
>

---

From: [email-masked]
Date: Thu, 1 Jul 2010 10:56:56 +0800

I think CW should be an option as RFC4448,
don't change it because of other draft's contradiction.
it will affect to compabile with old equipments;

Best regards
liu

"Andrew G. Malis" <[email-masked]> 
发件人:  [email-masked]
2010-07-01 00:35

收件人
[email-masked]
抄送

主题
Re: [mpls-tp] [PWE3] Proposal of using GAL for PW

Larry and Feng,

Cheers,
Andy

On Wed, Jun 30, 2010 at 6:34 AM, HUANG Feng F
<[email-masked]> wrote:
>
> it is reasonable to support GAL in MPLS-TP PW OAM, it is more generic, 
because CW is an option RFC4448 for Ethernet over MPLS.
>     In section 4.2 in RFC5586, it is defined that GAL MUST NOT be used 
with PWs in MPLS-TP. The PWE3 control word [RFC4385] MUST be present when 
the ACH is used to realize the associated control channel.
>     In real application, a lot of MPLS and MPLS-TP equipments do not 
support control word. It is proposed to use the GAL to identify associated 
control channel in PW layer.
>                 Han Li
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.