Subject: Re: [mpls-tp] [PWE3] Pseudo-wires: uni-directional o bi-directional?

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 28 Jun 2010 15:56:25 +0300

Stewart,
Lots of thanks for a prompt and unambiguous response..
This issues looks like one more fine point of MPLS-TP-ese to me: Does "co-routed" mean "co-routed in the immediate lower layer" or "co-routed in all the underlying layers down to the duct"?
FWIW, I tend to agree with your interpretation: "co-routed" means "co-routed in the immediate lower layer", and hence PWs (both single-segment and multi-segment) are co-routed bi-directional LSPs.

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Monday, June 28, 2010 3:46 PM
To: [email-masked]
Subject: Re: [PWE3] Pseudo-wires: uni-directional o bi-directional?

It seems to me that PWs are associated bi-directional LSPs...

PWs are co-routed bi-directional since it is required that they go through the same xPEs in each direction, and the xPEs knows about the association of the two directional components.

Whether they run over co-routed bi-directional, or associated bi-directional LSP is a deployment/applicability issue.

- Stewart

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 28 Jun 2010 10:01:15 -0400

Dear Sasha,
I too find Stewart's explanation very useful for overall MPLS-TP. And in
this perspective perhaps the SS PW might be also referred as PW section.

Regards,
Greg

On Mon, Jun 28, 2010 at 8:56 AM, Alexander Vainshtein <
[email-masked]> wrote:

> This issues looks like one more fine point of MPLS-TP-ese to me: Does
> “co-routed” mean “co-routed in the immediate lower layer” or “co-routed in
> all the underlying layers down to the duct”?
>
> FWIW, I tend to agree with your interpretation: “co-routed” means
> “co-routed in the immediate lower layer”, and hence PWs (both single-segment
> and multi-segment) are co-routed bi-directional LSPs.
>
>
>
> Regards,
>
>      Sasha
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Stewart Bryant
> *Sent:* Monday, June 28, 2010 3:46 PM
> *To:* [email-masked]
>
> *Subject:* Re: [PWE3] Pseudo-wires: uni-directional o bi-directional?
>
>
>
>
>
> PWs are co-routed bi-directional since it is required that they go through
> the same xPEs in each direction, and the xPEs knows about the association of
> the two directional components.
>
> Whether they run over co-routed bi-directional, or associated
> bi-directional LSP is a deployment/applicability issue.
>
> - Stewart
>
>
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 28 Jun 2010 17:26:03 +0100

Greg

I do not understand your point.

MS-PW S-PEs serve a purpose in breaking the PW into segments. If you do 
not need that decomposition in a network, there is nothing requiring 
their use. However we should not prohibit their use either, as there are 
scenarios whether this decomposition is of benefit.

If you need an existence proof of this point, remember that we initially 
designed SS-PW and needed to create MS-PW to address requirements of 
network operators that has deployed SS-PW.

Stewart

On 28/06/2010 15:01, Greg Mirsky wrote:
> Dear Sasha,
> I too find Stewart's explanation very useful for overall MPLS-TP. And 
> in this perspective perhaps the SS PW might be also referred as PW 
> section.
>
> Regards,
> Greg
>
> On Mon, Jun 28, 2010 at 8:56 AM, Alexander Vainshtein 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Stewart,
>
>     This issues looks like one more fine point of MPLS-TP-ese to me:
>     Does “co-routed” mean “co-routed in the immediate lower layer” or
>     “co-routed in all the underlying layers down to the duct”?
>
>     “co-routed in the immediate lower layer”, and hence PWs (both
>     single-segment and multi-segment) are co-routed bi-directional LSPs.
>
>     Regards,
>
>          Sasha
>
>     *From:* [email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>] *On
>     Behalf Of *Stewart Bryant
>     *To:* [email-masked] <mailto:[email-masked]>
>
>     PWs are co-routed bi-directional since it is required that they go
>     through the same xPEs in each direction, and the xPEs knows about
>     the association of the two directional components.
>
>     [email-masked] <mailto:[email-masked]>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 28 Jun 2010 12:50:56 -0400

Dear Stewart,
perhaps I'm applying section/segment terminology to PW without sufficient
explanation of my view. After reading comments by you and Sasha I've looked
at SS-PW as a bi-directional link or section. If such presentation of SS-PW
is valid then it's co-routedness, as you've noted, is obvious. I agree that
SS-PW can be referred as segment as well but then its co-routedness is not
self-evident. Interestingly, from the view of SS-PW as a bi-directional
link/section directly follows bi-directional co-routed essence of MS-PW.

Regards,
Greg

On Mon, Jun 28, 2010 at 12:26 PM, Stewart Bryant <[email-masked]> wrote:

> MS-PW S-PEs serve a purpose in breaking the PW into segments. If you do not
> need that decomposition in a network, there is nothing requiring their use.
> However we should not prohibit their use either, as there are scenarios
> whether this decomposition is of benefit.
>
> designed SS-PW and needed to create MS-PW to address requirements of network
> operators that has deployed SS-PW.
>
> Stewart
>
>
>
>
>
>
>> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
>> Of *Stewart Bryant