Subject: [mpls-tp] Query regarding MPLS P2MP ID usage

From: venkatesan mahalingam <[email-masked]>
Date: Tue, 27 Jul 2010 18:16:05 +0530

Hi,

As per draft-ietf-mpls-p2mp-te-mib-09.txt<http://tools.ietf.org/html/draft-ietf-mpls-p2mp-te-mib-09.txt>
draft,
P2MP MPLS-TE MIB is extended from MPLS-TE-STD-MIB.

So, mplsTunnelTable table can contain the informations for both normal MPLS
tunnels and MPLS P2MP tunnels.
How the two entries can be differentiated, do we need to check the entry
existence in the P2MP tunnel to
confirm the entry in the mplsTunnelTable is for P2MP tunnel?

 P2MP tunnel information in mplsTunnelTable is as follows:
     {
       mplsTunnelIndex              = 4,
       mplsTunnelInstance           = 0,
       mplsTunnelIngressLSRId       = "192.0.2.1",
       -- The tunnel egress LSR ID is used to
       -- hold the P2MP ID for the P2MP LSP tunnel
 *      mplsTunnelEgressLSRId        = 328,*
*       .........................*
*       .........................*
   }

What if the mplsTunnelEgressLSRId unsigned 32 bit integer matches with the
normal MPLS-TE tunnel's egress-id (Egress node IP address)?
Are we assuming that P2MP Id (mplsTunnelEgressLSRId) will not overlap the
valid IP address range?

-- 
Best Regards,
Venkatesan Mahalingam.

---

From: Apratim Mukherjee <[email-masked]>
Date: Tue, 27 Jul 2010 07:34:16 -0700

My comments inline.

Regards,
Apratim
From: [email-masked] [mailto:[email-masked]] On Behalf Of venkatesan mahalingam
Sent: Tuesday, July 27, 2010 6:16 PM
To: [email-masked]; mpls
Subject: [mpls-tp] Query regarding MPLS P2MP ID usage

Hi,

As per draft-ietf-mpls-p2mp-te-mib-09.txt<http://tools.ietf.org/html/draft-ietf-mpls-p2mp-te-mib-09.txt> draft, P2MP MPLS-TE MIB is extended from MPLS-TE-STD-MIB.

So, mplsTunnelTable table can contain the informations for both normal MPLS tunnels and MPLS P2MP tunnels.
How the two entries can be differentiated, do we need to check the entry existence in the P2MP tunnel to
confirm the entry in the mplsTunnelTable is for P2MP tunnel?
[Apratim Mukherjee] Section 4.2 "As indicated in the next section, the presence of a conceptual row in the mplsTeP2mpTunnelTable of the MIB module defined in this document shows that a tunnel defined in the corresponding conceptual row of the mplsTunnelTable of MPLS-TE-STD-MIB

is a P2MP tunnel"

Hence , answer is yes.

 P2MP tunnel information in mplsTunnelTable is as follows:
     {
       mplsTunnelIndex              = 4,
       mplsTunnelInstance           = 0,
       mplsTunnelIngressLSRId       = "192.0.2.1",
       -- The tunnel egress LSR ID is used to
       -- hold the P2MP ID for the P2MP LSP tunnel
       mplsTunnelEgressLSRId        = 328,
       .........................
       .........................
   }

What if the mplsTunnelEgressLSRId unsigned 32 bit integer matches with the normal MPLS-TE tunnel's egress-id (Egress node IP address)?
Are we assuming that P2MP Id (mplsTunnelEgressLSRId) will not overlap the valid IP address range?
[Apratim Mukherjee] Since the key is TunnelIndex + IngressLSRId + EgressLSRId  normally this entire set would be unique.
e.g. p2p tunnel : Ingress LSR Id = 1.1.1.1 , Egress LSR Id = 2.2.2.2 , TunnelIndex = 1 .
If p2mp tunnel from same source , I expect tunnel id would be different even if by some chance Egress LSR Id were to match for p2p Egress IP and p2mp id ( I don't think this is the realistic case , in some cases this is same as Tunnel Index , in others same as Ingress LSR Id , so no chance of clash in those scenarios )
However , this is not made mandatory by the specifications (i.e tunnel id could be same for p2p and p2mp tunnel originating from same Ingress )

So probably the safe way to interpret this might be that the key is assumed to be TunnelIndex+ IngressLSRId + EgressLSRId + rsvpTunnelType(derived from the fact whether entry exists in the derived mplsTeP2mpTunnelTable to be of type p2p or p2mp )

--
Best Regards,
Venkatesan Mahalingam.