Subject: Re: [mpls-tp] Demultiplexing to BFD sessions

From: Mukund Mani <[email-masked]>
Date: Thu, 1 Jul 2010 13:28:35 +0530

Hi Apratim

For your first point I agree with you and had raised this some time back. I
was under the impressions that things would be clear with the next version
of the CC/CV draft.
But I would like to mention here w.r.t the scenario of independent sessions.
As per CC/CV draft, Your Discriminator will be zero when not known else it
can reflect the
My Discriminator vlaue.
So the fast packets for BFD1 from Node A to Node B, can have both both the
Your and My discriminators present. So when I say that label alone
is not enough to demultiplex, that is because (as you mention) both the fast
and slow packets would arrive with the same label. Thus we
anyway need to refer to the Your discriminator value also to find the
correct session context . So in case of independent sessions label and
discriminator might both be required
to find the session context.

For the MEP id, IMHO even for the independent session case, considering
associated bi-directional LSP,
we would have a Source and a Sink MEP for each direction. The BFD session
initiator of each independent session (at either end) will be identified IMO
as mentioned below in
my previous mail..

With Regards
Mukund

On Thu, Jul 1, 2010 at 12:52 PM, Apratim Mukherjee
<[email-masked]>wrote:

>  Hi Mukund /Shahram
>
>
>
> I think single BFD bidirectional session and unique MEP Ids are all correct
> arguments for the normal use-case.
>
>
>
> I have attempted to raise the point only in context  of *‘independent’*BFD sessions over a bidirectional LSP ( for 1+1 uni-directional switchover
> case).
>
> In this case , my understanding is that there are 2 BFD sessions running independent of
>
>

>  each other with each BFD session protecting one direction of the LSP. ( Section 3.5 of draft-ietf-mpls-tp-cc-cv-rdi-00 : “A single bi-directional BFD session is used for fate sharing operation. Two independent BFD sessions are used for independent operation.”
>
>
>
> Node A
>                               Node B
>
> OutLabel = L11 à BFD1 fast packets   + BFD2 packets during state change à
> InLabel = L11
>
> InLabel  = L12 ß BFD1 packets during state change + BFD2 fast packets   à     OutLabel
> = L12
>
>
>
> So if L11 side is down , in steady state BFD1 is in Down State on Node B
> but BFD2 is in Up State on Node B .
>
>
>
> In steady state my assumption is that Discriminators will be different from
> same node for the two sessions.
>
>
>
> My assumption here is that when Node B is sending BFD1 and BFD2 packets
> both using OutLabel = L12 AND if Your Discriminator is 0 in the packet,
>
> Node A has no way to distinguish between packets for BFD1 or BFD2 . The
> only difference is really the Min Rx Interval in the packets .
>
> I assumed here that  even if MEP Id is included , the MEP Id as defined
> today would be Global Id + Node B Id + TunnelId + Lsp id in both the packets
> I.e for Node B Rx and Tx links have the same Lsp Id  unless I have got the
> definition for MEP Id wrong.
>
>
>
> P.S : I think I am missing something here regarding the MEP IDs from Greg’s
> mail snippet
>
> Per Greg “I think "independent" OAM uni-directional OAM session requires
> separate MEG and, consequently, MEP ID will be unique for each session,
> direction of the bi-directional LSP in your scenario. That is why I think
> that MEP ID TLV would not be the same as you've suggested.”
>
>
>
> Per Mukund “IMHO the MEP id will be different.  Eg as far as the
> identification goes say the forward direction is from node A to node B, MEP
> for the forward path can be identified as A::Tnl X::LSP1 and the reverse
> path MEP can be identified as B::Tnl Y::LSP2.” à I think this is for
> bi-directional sessions but not true for the independent mode we are
> discussing here .
>
>
>
>
>
>
>
> Regards,
>
> Apratim
>
>

---

From: Apratim Mukherjee <[email-masked]>
Date: Thu, 1 Jul 2010 02:11:51 -0700

Hi Mukund

Comments inline.

Regards,
Apratim
From: Mukund Mani [mailto:[email-masked]]
Sent: Thursday, July 01, 2010 1:29 PM
To: Apratim Mukherjee
Cc: Shahram Davari; Greg Mirsky; David Allan I; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls-tp] Demultiplexing to BFD sessions

Hi Apratim

For your first point I agree with you and had raised this some time back. I was under the impressions that things would be clear with the next version of the CC/CV draft.
But I would like to mention here w.r.t the scenario of independent sessions. As per CC/CV draft, Your Discriminator will be zero when not known else it can reflect the
My Discriminator vlaue.
So the fast packets for BFD1 from Node A to Node B, can have both both the Your and My discriminators present. So when I say that label alone is not enough to demultiplex, that is because (as you mention) both the fast and slow packets would arrive with the same label.

Thus we anyway need to refer to the Your discriminator value also to find the correct session context .

[Apratim Mukherjee] This is where my concern was . If we choose to do it this way , discriminators need to be known ( via configuration/lsp ping extension exchange of discriminators) before starting the BFD sessions.

So in case of independent sessions label and discriminator might both be required
to find the session context.

For the MEP id, IMHO even for the independent session case, considering associated bi-directional LSP,
we would have a Source and a Sink MEP for each direction. The BFD session initiator of each independent session (at either end) will be identified IMO as mentioned below in
my previous mail..

[Apratim Mukherjee] Probably you are correct i.e. "Unique MEP-ID of source of the BFD packet" is indeed different for each of the two packets coming from same node using same label stack. Greg also seems to be indicating the same thing. In that case for BFD-CC-CV in independent mode ( and also for the fate sharing mode)  ,this is indeed a correct solution on how to locate BFD session correctly from the two packets received for different BFD sessions with same label and not using the Discriminator ( esp. if that is 0 ) . However , this was not clear to me from my understanding of draft-swallow-mpls-tp-identifiers-02 . I was under the impression that it is designed for bidirectional GRSVP-TE session ( which could instead be statically configured ) which would make Node ID / Tunnel ID and Lsp Id same for the MEP-ID in both the BFD packets from the same node  unless Rx and Tx directions have different LSP IDs or an additional identifier is added to MEP Id to indicate Tx/Rx direction.

With Regards

Mukund
On Thu, Jul 1, 2010 at 12:52 PM, Apratim Mukherjee <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mukund /Shahram

I think single BFD bidirectional session and unique MEP Ids are all correct arguments for the normal use-case.

I have attempted to raise the point only in context  of 'independent' BFD sessions over a bidirectional LSP ( for 1+1 uni-directional switchover case).

each other with each BFD session protecting one direction of the LSP. ( Section 3.5 of draft-ietf-mpls-tp-cc-cv-rdi-00 : "A single bi-directional BFD session is used for fate sharing operation. Two independent BFD sessions are used for independent operation."

Node A                                                                         Node B
OutLabel = L11 --> BFD1 fast packets   + BFD2 packets during state change -->      InLabel = L11
InLabel  = L12 <-- BFD1 packets during state change + BFD2 fast packets   -->      OutLabel = L12

So if L11 side is down , in steady state BFD1 is in Down State on Node B  but BFD2 is in Up State on Node B .

In steady state my assumption is that Discriminators will be different from same node for the two sessions.

My assumption here is that when Node B is sending BFD1 and BFD2 packets both using OutLabel = L12 AND if Your Discriminator is 0 in the packet,
Node A has no way to distinguish between packets for BFD1 or BFD2 . The only difference is really the Min Rx Interval in the packets .
I assumed here that  even if MEP Id is included , the MEP Id as defined today would be Global Id + Node B Id + TunnelId + Lsp id in both the packets I.e for Node B Rx and Tx links have the same Lsp Id  unless I have got the definition for MEP Id wrong.

P.S : I think I am missing something here regarding the MEP IDs from Greg's mail snippet
Per Greg "I think "independent" OAM uni-directional OAM session requires separate MEG and, consequently, MEP ID will be unique for each session, direction of the bi-directional LSP in your scenario. That is why I think that MEP ID TLV would not be the same as you've suggested."

Per Mukund "IMHO the MEP id will be different.  Eg as far as the identification goes say the forward direction is from node A to node B, MEP for the forward path can be identified as A::Tnl X::LSP1 and the reverse path MEP can be identified as B::Tnl Y::LSP2." --> I think this is for bi-directional sessions but not true for the independent mode we are discussing here .

Regards,
Apratim

---

From: Apratim Mukherjee <[email-masked]>
Date: Thu, 1 Jul 2010 02:17:47 -0700

Hi Mukund 

Comments inline.

Regards,
Apratim
=====================================================================================================

Hi Apratim

[Apratim Mukherjee] Probably you are correct i.e. “Unique MEP-ID of source of the BFD packet” is indeed different for each of the two packets coming from same node using same label stack. Greg also seems to be indicating the same thing. In that case for BFD-CC-CV in independent mode ( and also for the fate sharing mode)  ,this is indeed a correct solution on how to locate BFD session correctly from the two packets received for different BFD sessions with same label and not using the Discriminator ( esp. if that is 0 ) . However , this was not clear to me from my understanding of draft-swallow-mpls-tp-identifiers-02 . I was under the impression that it is designed for bidirectional GRSVP-TE session ( which could instead also be statically configured ) which would make Node ID / Tunnel ID and Lsp Id same for the MEP-ID in both the BFD packets from the same node  unless Rx and Tx directions have different LSP IDs or an additional identifier is added to MEP Id to indicate Tx/Rx direction.

With Regards

Mukund
On Thu, Jul 1, 2010 at 12:52 PM, Apratim Mukherjee <[email-masked]> wrote:
Hi Mukund /Shahram 

I have attempted to raise the point only in context  of ‘independent’ BFD sessions over a bidirectional LSP ( for 1+1 uni-directional switchover case).
In this case , my understanding is that there are 2 BFD sessions running independent of 

Node A                                                                         Node B 
OutLabel = L11 → BFD1 fast packets   + BFD2 packets during state change →      InLabel = L11
InLabel  = L12 ← BFD1 packets during state change + BFD2 fast packets   →      OutLabel = L12

 
 
P.S : I think I am missing something here regarding the MEP IDs from Greg’s mail snippet
Per Greg “I think "independent" OAM uni-directional OAM session requires separate MEG and, consequently, MEP ID will be unique for each session, direction of the bi-directional LSP in your scenario. That is why I think that MEP ID TLV would not be the same as you've suggested.”
 
Per Mukund “IMHO the MEP id will be different.  Eg as far as the identification goes say the forward direction is from node A to node B, MEP for the forward path can be identified as A::Tnl X::LSP1 and the reverse path MEP can be identified as B::Tnl Y::LSP2.” → I think this is for bi-directional sessions but not true for the independent mode we are discussing here .

Regards,
Apratim