Subject: [mpls-tp] Comment on draft-ietf-mpls-tp-lsp-ping-bfd-procedures-00

From: Lavanya Srivatsa <[email-masked]>
Date: Fri, 2 Jul 2010 13:48:53 +0530

Hello authors of the draft,

In section 3 "Running BFD over MPLS-TP LSPs", it is stated that while sending BFD packets, there may be a need to identify the MEP/MIP.

Identification of MEP, I agree.
However, IMO, BFD control packet being sent to a MIP is not correct.

A MIP does not generate/initiate packets by itself but only responds to packets being sent to it such as ping requests and traceroute requests. Since BFD is intended only for end points of an LSP/PW, I don't think the need to identify MIPs while sending BFD control packets is necessary. So IMHO, this statement needs a rephrase.
Please let me know if you agree.

- Lavanya

---

From: Nitin Bahadur <[email-masked]>
Date: Thu, 8 Jul 2010 13:07:30 -0700

That is correct. Fixed in next revision.

Thanks
Nitin

On 7/2/10 1:18 AM, "Lavanya Srivatsa" <[email-masked]> wrote:

In section 3 “Running BFD over MPLS-TP LSPs”, it is stated that while sending BFD packets, there may be a need to identify the MEP/MIP.

A MIP does not generate/initiate packets by itself but only responds to packets being sent to it such as ping requests and traceroute requests. Since BFD is intended only for end points of an LSP/PW, I don’t think the need to identify MIPs while sending BFD control packets is necessary. So IMHO, this statement needs a rephrase.
Please let me know if you agree.

- Lavanya

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 14 Jul 2010 09:38:53 -0400

In message <[email-masked]>
> That is correct. Fixed in next revision.

Did I misread.  The MEP and MIP IDs apply to BFD, ping, and traceroute
and the ID is described independently of which one uses it.  Only
traceroute needs a MIP ID, but I didn't see that it implied BFD or
ping would address a MIP.

   When sending BFD packets using ACH, there MAY be a need to identify
   the maintenance end point (MEP) and/or the maintenance intermediate
   point (MIP) being monitored.

The key word here is MAY.  There MAY in the future be a need to
identify a MIP and therefore having a construct which allows it
doesn't hurt in the present where we don't yet know of such a need.

We are splitting hairs but don't hack the statement to the point where
it implies that ping or BFD would never need to address a MIP.

IMO the word MAY was sufficient but go ahead and clarify.

Curtis

> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp