Subject: Re: [mpls-tp] Query regarding ICC based identification: draft-ietf-mpls-tp-identifiers

From: George Swallow <[email-masked]>
Date: Mon, 12 Jul 2010 16:25:44 -0400

In Stockholm I was convinced that for ICC based identifiers, only the MEG-ID
and/or ME-ID would need to be configured at various points along an LSP.
Much has changed on this project since then.  Is what we have not
sufficient?

...George

On 5/28/10 2:36 AM, "Mukund Mani" <[email-masked]> wrote:

> Hi
>  
> The "draft-ietf-mpls-tp-identifiers" mention two forms of operator
> identification - Global_ID (for IP operational practice) and ICC (compatible
> with ITU).
> 
> All the sections on identifiers further in the draft, mention the globally
> unique format of the identifiers by pre-pending the Global_ID. i.e they
> mention only the IP based identifiers.
>  
> Eg; For LSP Identiffication:
>  
> "Src-Global_ID::Src-Node_ID::Src-Tunnel_Num::
> Dst-Global_ID::Dst-Node_ID::Dst-Tunnel_Num::LSP_Num"
> Shouldnt the draft be mentioning the ICC based identification also
> (substituting Global_ID by ICC for ICC based LSP Identifiers) or mentioning
> explicitly in the draft as follows:
> 
> "Src-Operator_ID::Src-Node_ID::Src-Tunnel_Num::Dst-Operator_ID::Dst-Node_ID::D
> st-Tunnel_Num::LSP_Num"
> 
> Where Operator_ID can be Global_ID or ICC_ID
> 
> Or is it expected that for ICC based identification, different set
> of identifiers will be defined similar to the MEG & MEP Identifiers??
> 
> Could the draft authors please clarify the same...
> 
> With Regards
> 
> Mukund
> 
>  
> 
>  
> 
> 
> 
> 
> 
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "BUSI, ITALO (ITALO)" <[email-masked]>
Date: Tue, 20 Jul 2010 14:45:52 +0200

George,

I think the issue is related to the facts that:

1) node, interface identifiers are unique within an operator;

2) tunnel, LSP and PW identifiers are composed by combining a set of identifiers that are uninque within the operators at the two ends of the tunnel/LSP/PW.

In order to make these identifiers globally unique, they need to be concatenated with a globally unique operator's identifier.

The draft covers the case where both operators are identified by their  Global_ID.

But, what about the cases where operator(s) are identified by their ICC?

Italo

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of George Swallow
Sent: lunedì 12 luglio 2010 22.26
To: Mukund Mani; [email-masked]
Subject: Re: [mpls-tp] Query regarding ICC based identification: draft-ietf-mpls-tp-identifiers
In Stockholm I was convinced that for ICC based identifiers, only the MEG-ID and/or ME-ID would need to be configured at various points along an LSP.  Much has changed on this project since then.  Is what we have not sufficient?

...George

The "draft-ietf-mpls-tp-identifiers" mention two forms of operator identification - Global_ID (for IP operational practice) and ICC (compatible with ITU).

All the sections on identifiers further in the draft, mention the globally unique format of the identifiers by pre-pending the Global_ID. i.e they mention only the IP based identifiers.

"Src-Global_ID::Src-Node_ID::Src-Tunnel_Num:: Dst-Global_ID::Dst-Node_ID::Dst-Tunnel_Num::LSP_Num"
Shouldnt the draft be mentioning the ICC based identification also (substituting Global_ID by ICC for ICC based LSP Identifiers) or mentioning explicitly in the draft as follows:

"Src-Operator_ID::Src-Node_ID::Src-Tunnel_Num::Dst-Operator_ID::Dst-Node_ID::Dst-Tunnel_Num::LSP_Num"

Or is it expected that for ICC based identification, different set of identifiers will be defined similar to the MEG & MEP Identifiers??

With Regards

Mukund

________________________________
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp