Subject: [mpls-tp] Query regarding usage of MPLS-TP SPME

From: venkatesan mahalingam <[email-masked]>
Date: Tue, 27 Jul 2010 17:42:19 +0530

Hi,

As per draft-ietf-mpls-tp-oam-framework-07 draft section *4.1**. MPLS-TP
Section Monitoring (SME),*
There is a requirement to monitor the link between topologically adjacent
(next hop in this layer network) MPLS-TP LSRs rather than
monitoring the individual LSP or PW path segments traversing the
MPLS-TP Section and the server layer technology does not provide
adequate OAM capabilities.

<VM> For this link level monitoring (Section OAM), there seems to be no
maintanence identifiers defined in the draft-ietf-mpls-tp-identifiers-2
draft,
Is there any plan to define maintanence identifiers for MPLS-TP section
monitoring in the next version of the TP-identifiers draft?

Can SPME for LSP/PW always be achieved in the form of label stacking on top
of E2E LSP/PW?

Can SPME (portion of an LSP) be a server layer for E2E LSP?

Is there any requirement to perform protection switching for SPME?

 --
Best Regards,
Venkatesan Mahalingam.

---

From: David Allan I <[email-masked]>
Date: Tue, 27 Jul 2010 09:55:22 -0400

Hi Venkatesan:

Some answers in line....

As per draft-ietf-mpls-tp-oam-framework-07 draft section 4.1. MPLS-TP Section Monitoring (SME),

Not sure it is adequate OAM capabilities. Motivations are a transport path spans multiple administrative domains, and the goal is to monitor the portion of the path that exists in a single domain. You may also want to offer sub-network protection, to get around speed of light issues in loooooong paths.

<VM> For this link level monitoring (Section OAM), there seems to be no maintanence identifiers defined in the draft-ietf-mpls-tp-identifiers-2 draft,
Is there any plan to define maintanence identifiers for MPLS-TP section monitoring in the next version of the TP-identifiers draft?

I'll leave that one to others to answer.

Can SPME for LSP/PW always be achieved in the form of label stacking on top of E2E LSP/PW?

With the understanding that SPMEs cannot overlap.....

e.g. for path A-B-C-D you could not instantiate an SPME that spanned A-B-C and one that spanned B-C-D. You could do A-B-C and B-C as they properly nest.

Yes. An SPME is never anything other than a server layer for an E2E LSP or another SPME...

Yes, SNC protection is a potential application of SPMEs in addition to domain specific monitoring. The possibility is mentioned in the OAM Framework, but not in detail...

hope this helps
D

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 27 Jul 2010 17:10:06 +0300

Dave, and all,
I’d like to reiterate my position on SPME with label stacking (and I am not aware of any other usage of the name).
• If SPME for a specific segment of a given is set up permanently, it is not an SPME.  It is a new MPLS-TP section crossed by the LSP in question.
• If SPME is set up on demand, it results in monitoring a new LSP different from one that you originally tried to monitor.
The bottom line is that it is either not relevant or unusable.

My 2c,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Tuesday, July 27, 2010 3:55 PM
To: venkatesan mahalingam; [email-masked]
Subject: Re: [mpls-tp] Query regarding usage of MPLS-TP SPME

Hi Venkatesan:
 
Some answers in line....

 
<VM> For this link level monitoring (Section OAM), there seems to be no maintenance identifiers defined in the draft-ietf-mpls-tp-identifiers-2 draft,
Is there any plan to define maintenance identifiers for MPLS-TP section monitoring in the next version of the TP-identifiers draft? 

 

 

 
hope this helps
D