Subject: [mpls-tp] clock sync

From: "Rolando Zappacosta" <[email-masked]>
Date: Fri, 17 Sep 2010 13:01:06 +0200

Hi all,

AFAIK, the clock sync is out of scope of MPLS-TP itself and it's to be done
by other means, i.e. Eth sync if there are Eth links.

However, is there any work on using OAM to carry syncing info? If yes, one
should put NTP info into the MCC or the SCC channel?

TIA,

Rolando

---

From: Rolando Zappacosta <[email-masked]>
Date: Sun, 19 Sep 2010 16:34:59 +0200

Anybody?

My biggest concern is what's the recommended method to sync (if any) when
syncing is not supported/wanted to be done by the phy layer and IP is not
implemented.

Rolando.

On Fri, Sep 17, 2010 at 1:01 PM, Rolando Zappacosta <
[email-masked]> wrote:

>  Hi all,
>
>
>
> AFAIK, the clock sync is out of scope of MPLS-TP itself and it’s to be done

---

From: Ron Cohen <[email-masked]>
Date: Sun, 19 Sep 2010 16:44:33 +0200

Hi Rolando,

I believe that the right place to discuss this is in the TICTOC working
group. Timing over MPLS, mostly in the form of IEEE1588 over MPLS, was
discussed at the last IETF and is on the current agenda.

I also suggest that you provide as much details as possible on the scenario
of concern; this would help people address your question.

Best,
Ron

On Sun, Sep 19, 2010 at 4:34 PM, Rolando Zappacosta <
[email-masked]> wrote:

>> AFAIK, the clock sync is out of scope of MPLS-TP itself and it’s to be
>> done by other means, i.e. Eth sync if there are Eth links.
>>
>>
>>
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>
>

---

From: "Rolando Zappacosta" <[email-masked]>
Date: Sun, 19 Sep 2010 17:13:10 +0200

Ok, that's pretty much what I was asking for. So, there is no any plan to
include sync into MPLS-TP itself by means of OAM packets reuse or something
MPLS-TP specific, correct?

Rolando

De: Ron Cohen [mailto:[email-masked]] 
Enviado el: 19 September 2010 16:45
Para: Rolando Zappacosta
CC: [email-masked]
Asunto: Re: [mpls-tp] clock sync

Hi Rolando,

Best,

Ron

On Sun, Sep 19, 2010 at 4:34 PM, Rolando Zappacosta
<[email-masked]> wrote:

Anybody?

Rolando.

On Fri, Sep 17, 2010 at 1:01 PM, Rolando Zappacosta
<[email-masked]> wrote:

Hi all,

TIA,

Rolando

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 20 Sep 2010 12:29:25 +0100

I pretty much agree with Ron, although it's a lot more complicated 
than that.

For example would you regard sync transfer via SATOP in or out of scope 
of MPLS-TP dataplane?

In the case of NTP over SCC/MCC  it depends on what you want the time 
sync for. If it's simply to provide time for the even logging service, 
that be exactly the way it should probably be done.

If you mean precision time to say a mobile wireless system, then that 
needs specialist design consideration and is in the scope of TICTOC and 
Q13/15, though if either group find that they need to change MPLS 
itself, that component of the work will need to be done in MPLS WG.

Note BTW that the application space is split between those apps that 
prefer NTP and those that need IEEE1588.

- Stewart

On 19/09/2010 16:13, Rolando Zappacosta wrote:
>
> Ok, that's pretty much what I was asking for. So, there is no any plan 
> to include sync into MPLS-TP itself by means of OAM packets reuse or 
> something MPLS-TP specific, correct?
>
> Rolando
>
> *De:* Ron Cohen [mailto:[email-masked]]
> *Enviado el:* 19 September 2010 16:45
> *Para:* Rolando Zappacosta
> *CC:* [email-masked]
> *Asunto:* Re: [mpls-tp] clock sync
>
> Hi Rolando,
>
> I believe that the right place to discuss this is in the TICTOC 
> working group. Timing over MPLS, mostly in the form of IEEE1588 over 
> MPLS, was discussed at the last IETF and is on the current agenda.
>
> I also suggest that you provide as much details as possible on the 
> scenario of concern; this would help people address your question.
>
> Best,
>
> Ron
>
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
> Anybody?
>
> My biggest concern is what's the recommended method to sync (if any) 
> when syncing is not supported/wanted to be done by the phy layer and 
> IP is not implemented.
>
> Rolando.
>
>
>
>
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
> Hi all,
>
> AFAIK, the clock sync is out of scope of MPLS-TP itself and it's to be 
> However, is there any work on using OAM to carry syncing info? If yes, 
> one should put NTP info into the MCC or the SCC channel?
>
> TIA,
>
> Rolando
>
>
> [email-masked] <mailto:[email-masked]>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Rolando Zappacosta" <[email-masked]>
Date: Mon, 20 Sep 2010 14:41:35 +0200

1st of all, thank you guys!!!!

Now, Regarding the clock sync (not time sync), AFAIR TICTOC needs IP,
correct? Then, if somebody out there (just theorizing, not a real need I'm
facing) wants to deploy MPLS-TP and at the same time keep clocks synced
(say, for a RAN), they should be forced to implement IP, correct?

And even if time sync would be enough, NTPoSCC/MCC would require IP too,
correct?

So, my point is I cannot find a way to have time/clock sync without running
IP.

Please note I'm not telling this is a must, I just want to know if
there-are/there-are-going-to-be ways to sync time and/or clock without
having to run IP.

Rolando.

De: [email-masked] [mailto:[email-masked]] En nombre de
Stewart Bryant
Enviado el: 20 September 2010 13:29
Para: [email-masked]
Asunto: Re: [mpls-tp] clock sync

I pretty much agree with Ron, although it's a lot more complicated than
that.

For example would you regard sync transfer via SATOP in or out of scope of
MPLS-TP dataplane?

In the case of NTP over SCC/MCC  it depends on what you want the time sync
for. If it's simply to provide time for the even logging service, that be
exactly the way it should probably be done.

If you mean precision time to say a mobile wireless system, then that needs
specialist design consideration and is in the scope of TICTOC and Q13/15,
though if either group find that they need to change MPLS itself, that
component of the work will need to be done in MPLS WG.

Note BTW that the application space is split between those apps that prefer
NTP and those that need IEEE1588.

- Stewart

Rolando

Hi Rolando,

Best,

Ron

Anybody?

Rolando.

Hi all,

TIA,

Rolando

---

From: Ron Cohen <[email-masked]>
Date: Mon, 20 Sep 2010 15:06:08 +0200

Rolando,

I went back and read the TICTOC charter and it is indeed somewhat IP
centric, both in the name (Timing over IP Connections and Transfer Of Clock)
and in the charter: "WG is concerned with highly accurate time and frequency
distribution over native IP and MPLS-enabled IP Packet Switched Networks
(PSNs)."

That said, proposals for running IEEE1588 directly over MPLS and running
IEEE1588 over Ethernet PW (both not necessarily requiring IP) have been and
are discussed in the WG. The charter may need to be revised to reflect that
(Yaakov?).

Anyhow, what the TICTOC WG lacks most is participants and contributors. So
if you want that either of these proposals will come forward and answer the
specific requirements of your application, you are encouraged to join and
share your concerns there.

Best,
Ron

On Mon, Sep 20, 2010 at 2:41 PM, Rolando Zappacosta <
[email-masked]> wrote:

> correct? Then, if somebody out there (just theorizing, not a real need I’m
> Please note I’m not telling this is a must, I just want to know if
> *De:* [email-masked] [mailto:[email-masked]] *En
> nombre de *Stewart Bryant
> *Enviado el:* 20 September 2010 13:29
> *Para:* [email-masked]
>
> Ok, that’s pretty much what I was asking for. So, there is no any plan to
> *De:* Ron Cohen [mailto:[email-masked] <[email-masked]>]

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 20 Sep 2010 14:11:39 +0100

On 20/09/2010 13:41, Rolando Zappacosta wrote:
>
> 1^st of all, thank you guys!!!!
>
That depends on your interpretation of the expression "MPLS-enabled IP 
Packet Switched Networks (PSNs)" which was written back Nov 2008, before 
we added MPLS-TP to the MPLS charter
>
> Then, if somebody out there (just theorizing, not a real need I'm 
> facing) wants to deploy MPLS-TP and at the same time keep clocks 
> synced (say, for a RAN), they should be forced to implement IP, correct?
>
Not necessarily, though you might want to take a look at the 
specifications being written by ITU-T Q13/15, which use the IP 
encapsulated version of IEEE1588.
>
> And even if time sync would be enough, NTPoSCC/MCC would require IP 
> too, correct?
>
Sure.
>
> So, my point is I cannot find a way to have time/clock sync without 
> running IP.
>
Not true. You can have IP in the SCC/MCC without having IP in the dataplane.
> there-are/there-are-going-to-be ways to sync time and/or clock without 
There could be if that is what we needed/wanted.

Stewart
> For example would you regard sync transfer via SATOP in or out of 
> scope of MPLS-TP dataplane?
>
> needs specialist design consideration and is in the scope of TICTOC 
> and Q13/15, though if either group find that they need to change MPLS 
> *CC:* [email-masked] <mailto:[email-masked]>

---

From: "Rolando Zappacosta" <[email-masked]>
Date: Mon, 20 Sep 2010 15:56:52 +0200

running IP.

>There could be if that is what we needed/wanted.

Interesting. May be it would be great (again, this isn't a need I'm facing)
to have a mean to get sync while at the same time meet both the MPLS lower
layers independence and the MPLS-TP's IP independence.

Jjust thinking out loud, what would the recommendation for that case be:

1)      a new G-ACh channel type that indicates whatever non-IP-based sync
protocol (which?) over the G-ACh itself or

2)      a MCC/SCC ch type reuse where one would put whatever non-IP-based
sync protocol (which?) inside the MCC/SCC over the G-ACh?

Rolando

De: Stewart Bryant [mailto:[email-masked]] 
Enviado el: 20 September 2010 15:12
Para: Rolando Zappacosta
CC: [email-masked]
Asunto: Re: [mpls-tp] clock sync

That depends on your interpretation of the expression "MPLS-enabled IP
Packet Switched Networks (PSNs)" which was written back Nov 2008, before we
added MPLS-TP to the MPLS charter

Then, if somebody out there (just theorizing, not a real need I'm facing)
wants to deploy MPLS-TP and at the same time keep clocks synced (say, for a
RAN), they should be forced to implement IP, correct?

Not necessarily, though you might want to take a look at the specifications
being written by ITU-T Q13/15, which use the IP encapsulated version of
IEEE1588.

Sure.

 

Stewart

Rolando.

- Stewart

Rolando

Hi Rolando,

Best,

Ron

Anybody?

Rolando.

Hi all,

TIA,

Rolando

---

From: "Shahram Davari" <[email-masked]>
Date: Mon, 20 Sep 2010 11:14:38 -0700

Hi Rolando,

The simplest method is to run an Ethernet PW for the 1588. There is no need to define any new protocol.

Thx
Shahram

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rolando Zappacosta
Sent: Monday, September 20, 2010 6:57 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [mpls-tp] clock sync

>>So, my point is I cannot find a way to have time/clock sync without running IP.
>>Please note I'm not telling this is a must, I just want to know if there-are/there-are-going-to-be ways to sync time and/or clock without having to run IP.

Interesting. May be it would be great (again, this isn't a need I'm facing) to have a mean to get sync while at the same time meet both the MPLS lower layers independence and the MPLS-TP's IP independence.

1)      a new G-ACh channel type that indicates whatever non-IP-based sync protocol (which?) over the G-ACh itself or

2)      a MCC/SCC ch type reuse where one would put whatever non-IP-based sync protocol (which?) inside the MCC/SCC over the G-ACh?

Rolando

Now, Regarding the clock sync (not time sync), AFAIR TICTOC needs IP, correct?
That depends on your interpretation of the expression "MPLS-enabled IP Packet Switched Networks (PSNs)" which was written back Nov 2008, before we added MPLS-TP to the MPLS charter
Then, if somebody out there (just theorizing, not a real need I'm facing) wants to deploy MPLS-TP and at the same time keep clocks synced (say, for a RAN), they should be forced to implement IP, correct?
Not necessarily, though you might want to take a look at the specifications being written by ITU-T Q13/15, which use the IP encapsulated version of IEEE1588.

And even if time sync would be enough, NTPoSCC/MCC would require IP too, correct?
Sure.

So, my point is I cannot find a way to have time/clock sync without running IP.
Not true. You can have IP in the SCC/MCC without having IP in the dataplane.

Please note I'm not telling this is a must, I just want to know if there-are/there-are-going-to-be ways to sync time and/or clock without having to run IP.
There could be if that is what we needed/wanted.

Stewart

Rolando.

De: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] En nombre de Stewart Bryant
Enviado el: 20 September 2010 13:29
Para: [email-masked]<mailto:[email-masked]>
Asunto: Re: [mpls-tp] clock sync

I pretty much agree with Ron, although it's a lot more complicated than that.

For example would you regard sync transfer via SATOP in or out of scope of MPLS-TP dataplane?

In the case of NTP over SCC/MCC  it depends on what you want the time sync for. If it's simply to provide time for the even logging service, that be exactly the way it should probably be done.

If you mean precision time to say a mobile wireless system, then that needs specialist design consideration and is in the scope of TICTOC and Q13/15, though if either group find that they need to change MPLS itself, that component of the work will need to be done in MPLS WG.

Note BTW that the application space is split between those apps that prefer NTP and those that need IEEE1588.

- Stewart

On 19/09/2010 16:13, Rolando Zappacosta wrote:
Ok, that's pretty much what I was asking for. So, there is no any plan to include sync into MPLS-TP itself by means of OAM packets reuse or something MPLS-TP specific, correct?

Rolando

De: Ron Cohen [mailto:[email-masked]]
Enviado el: 19 September 2010 16:45
Para: Rolando Zappacosta
CC: [email-masked]<mailto:[email-masked]>
Asunto: Re: [mpls-tp] clock sync

Hi Rolando,

I believe that the right place to discuss this is in the TICTOC working group. Timing over MPLS, mostly in the form of IEEE1588 over MPLS, was discussed at the last IETF and is on the current agenda.

I also suggest that you provide as much details as possible on the scenario of concern; this would help people address your question.

Best,
Ron
On Sun, Sep 19, 2010 at 4:34 PM, Rolando Zappacosta <[email-masked]<mailto:[email-masked]>> wrote:
Anybody?

My biggest concern is what's the recommended method to sync (if any) when syncing is not supported/wanted to be done by the phy layer and IP is not implemented.

Rolando.

On Fri, Sep 17, 2010 at 1:01 PM, Rolando Zappacosta <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

AFAIK, the clock sync is out of scope of MPLS-TP itself and it's to be done by other means, i.e. Eth sync if there are Eth links.

However, is there any work on using OAM to carry syncing info? If yes, one should put NTP info into the MCC or the SCC channel?

TIA,
Rolando

_______________________________________________
mpls-tp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls-tp

mpls-tp mailing list

[email-masked]<mailto:[email-masked]>

--

--

---

From: "Rolando Zappacosta" <[email-masked]>
Date: Mon, 20 Sep 2010 20:41:22 +0200

That's clear, when the lower layer is Eth....

De: Shahram Davari [mailto:[email-masked]] 
Enviado el: 20 September 2010 20:15
Para: Rolando Zappacosta; [email-masked]
CC: [email-masked]
Asunto: RE: [mpls-tp] clock sync

Hi Rolando,

The simplest method is to run an Ethernet PW for the 1588. There is no need
to define any new protocol.

Thx

Shahram

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rolando Zappacosta
Sent: Monday, September 20, 2010 6:57 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [mpls-tp] clock sync

running IP.

Rolando

Sure.

Stewart

Rolando.

- Stewart

Rolando

Hi Rolando,

Best,

Ron

Anybody?

Rolando.

Hi all,

TIA,

Rolando

---

From: "Rolando Zappacosta" <[email-masked]>
Date: Tue, 21 Sep 2010 16:31:00 +0200

OK, I think I see your point. You mean if both ACs of the PW are Eth, one
can run 1588 through the PW to have both ends synced, correct?

De: Sperber, Rolf (Rolf) [mailto:[email-masked]] 
Enviado el: 21 September 2010 07:18
Para: Rolando Zappacosta; 'Shahram Davari'; [email-masked]
CC: [email-masked]
Asunto: RE: [mpls-tp] clock sync

Hi Rolando,

the PHY does not necessarily have to be Ethernet, however, the 1588
grandmaster is generating Ethernet packets with a time stamp and the 1588
client unit is interpreting these packets, regardless of what is happening
in-between. The biggest advantage of 1588v2 is its capability to synchronize
both phase and frequency, necessary for LTE backhaul. As opposed to
Synchronous Ethernet 1588 accuracy depends on both the number and the
specifications of the intermediate nodes between grandmaster and client.

Cheers

Rolf Sperber 
End to End Network Architect
Lorenzstrasse 10 
D-70435 Stuttgart 
Home Office Phone : + 49 7255 724 720 
Mobile : +49 171 8625912 
Mobile Russia : +7 985 152 5106 
Mail: [email-masked] 

Alcatel-Lucent Deutschland AG
Sitz der Gesellschaft: Stuttgart - Amtsgericht Stuttgart HRB 4026
Vorsitzender des Aufsichtsrats: Michael Oppenhoff
Vorstand: Alf Henryk Wulf (Vors.), Hans-Jörg Daub, Dr. Rainer Fechner, Peter
Kury

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rolando Zappacosta
Sent: Montag, 20. September 2010 20:41
To: 'Shahram Davari'; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls-tp] clock sync

That’s clear, when the lower layer is Eth....

Hi Rolando,

Thx

Shahram

running IP.

>There could be if that is what we needed/wanted.

Interesting. May be it would be great (again, this isn’t a need I’m facing)
to have a mean to get sync while at the same time meet both the MPLS lower
layers independence and the MPLS-TP’s IP independence.

Rolando

Then, if somebody out there (just theorizing, not a real need I’m facing)
wants to deploy MPLS-TP and at the same time keep clocks synced (say, for a
RAN), they should be forced to implement IP, correct?

Sure.

Stewart

Rolando.

- Stewart

Rolando

Hi Rolando,

Best,

Ron

Anybody?

Rolando.

Hi all,

TIA,

Rolando

---

From: George Swallow <[email-masked]>
Date: Fri, 24 Sep 2010 14:38:12 -0400

I¹m happy to have most of this work occur in TIC-TOC.   Assuming that OAM
messages are defined and a ACH codepoint is needed, then this would need to
be review by and jointly last called with MPLS (and likely PWE3 as well).

...George

On 9/20/10 9:11 AM, "Stewart Bryant" <[email-masked]> wrote:

>  That depends on your interpretation of the expression "MPLS-enabled IP Packet
> Switched Networks (PSNs)" which was written back Nov 2008, before we added
> MPLS-TP to the MPLS charter
>  
>>  
>>  
>> 
>> Then, if somebody out there (just theorizing, not a real need I¹m facing)
>> Please note I¹m not telling this is a must, I just want to know if
>> there-are/there-are-going-to-be ways to sync time and/or clock without having
>> to run IP.
>>  
>>  
>> Ok, that¹s pretty much what I was asking for. So, there is no any plan to
>> AFAIK, the clock sync is out of scope of MPLS-TP itself and it¹s to be done