Subject: [mpls-tp] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 16 Sep 2010 14:06:47 +0200

The authors of draft-lm-pwe3-mpls-tp-gal-in-pw-00 have requested that this draft be made a PWE3 working group draft.

This email starts a two week poll, closing 30th September, to help judge the consensus for this.

Please rely with yes or no to the PWE3 list.

Regards,

Matthew and Andy

---

From: zhanghaiyan 40693 <[email-masked]>
Date: Thu, 16 Sep 2010 21:12:25 +0800

Yes/Support.

B.R.
Haiyan

----- 原邮件 -----
发件人: "Bocci, Matthew (Matthew)" <[email-masked]>
日期: 星期四, 九月 16日, 2010 下午8:07
主题: [PWE3] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00
收件人: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

> The authors of draft-lm-pwe3-mpls-tp-gal-in-pw-00 have requested 
> that this draft be made a PWE3 working group draft.
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 17 Sep 2010 12:01:52 -0700

No/do not support

Regards,
Greg

On Thu, Sep 16, 2010 at 5:06 AM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

> The authors of draft-lm-pwe3-mpls-tp-gal-in-pw-00 have requested that this
> draft be made a PWE3 working group draft.
>

---

From: "HUANG Feng F" <[email-masked]>
Date: Sun, 19 Sep 2010 12:48:36 +0800

yes/support 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of BOCCI Matthew
Sent: 2010年9月16日 20:07
To: [email-masked]; [email-masked]
Subject: [PWE3] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

Regards,

Matthew and Andy

---

From: [email-masked]
Date: Sun, 19 Sep 2010 16:52:36 +0800

Yes/Support

Fei Zhang

"Bocci, Matthew (Matthew)" <[email-masked]> 
发件人:  [email-masked]
2010-09-16 20:06
请答复 给
"[email-masked]" <[email-masked]>

收件人
"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
抄送

主题
[PWE3] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

This email starts a two week poll, closing 30th September, to help judge 
the consensus for this.

Regards,

Matthew and Andy

---

From: Yaakov Stein <[email-masked]>
Date: Sun, 19 Sep 2010 19:19:51 +0200

Strongly do NOT support.

Reasoning somewhat similar to Sasha's.

At very least this violates the MPLS PW architecture requirement that the PW label 
MUST be the bottom-of-stack ("inner" label). This complicates packet inspection mechanisms.
(Yes I know that the FAT label also messes this up, but I am against that too,
and in any case hope that it will not be widely employed.)

I understand the problem with existing implementations that do not employ the CW.
I believe that this practice should be obsoleted 
(yes, even at the expense of the overhead for small frames).
Existing implementations in any case will break when the PW label is above a 13,
so the proposal does not solve their problem.

I think the best way of identifying the associated channel is
1) for PW - CW with 0001
2) for obsolete PW with no CW (and ONLY for this case) - TTL expiry
3) for non-PW - GAL.

Note that 3) can be considered as a sub-case of 1),
where the GAL is a default PW label signifying "no PW".
So the only special case is for "old" PWs.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, September 16, 2010 14:07
To: [email-masked]; [email-masked]
Subject: [PWE3] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

Regards,

Matthew and Andy

---

From: [email-masked]
Date: Mon, 20 Sep 2010 10:50:00 -0400

Yes/support

Provides consistent means to detect MPLS-TP and PW OAM.

Regards,

Malcolm

"Bocci, Matthew (Matthew)" <[email-masked]> 
Sent by: [email-masked]
16/09/2010 08:06 AM
Please respond to
"[email-masked]" <[email-masked]>

To
cc

Subject
[mpls-tp] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

Regards,

Matthew and Andy
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: [email-masked]
Date: Tue, 21 Sep 2010 09:02:22 +0800

Yes/support 

Regards, 

Liang 

> Please rely with yes or no to the PWE3 list.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Thu, 23 Sep 2010 11:37:59 +0200

Yes, support

Best regards,
Alessandro

------------------------------------------------------------------
Telecom Italia
Alessandro D'Alessandro
Transport & OPB Innovation
Via Reiss Romoli, 274 - 10148 Torino
phone:  +39 011 228 5887
mobile: +39 335 766 9607
fax: +39 06 418 639 07

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: giovedì 16 settembre 2010 14.07
To: [email-masked]; [email-masked]
Subject: [mpls-tp] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

Regards,

Matthew and Andy

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Di Giglio Andrea <[email-masked]>
Date: Fri, 24 Sep 2010 09:43:13 +0200

Yes, support

Andrea

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Bocci, Matthew (Matthew)
Inviato: giovedì 16 settembre 2010 14.07
A: [email-masked]; [email-masked]
Oggetto: [mpls-tp] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00

Regards,

Matthew and Andy

---

From: Thomas Nadeau <[email-masked]>
Date: Fri, 24 Sep 2010 08:02:54 -0400

Support.

	--Tom

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 24 Sep 2010 08:14:42 -0700

support.

-sam

---

From: George Swallow <[email-masked]>
Date: Fri, 24 Sep 2010 13:28:16 -0400

Yes, support

...George

On 9/23/10 5:37 AM, "D'Alessandro Alessandro Gerardo"
<[email-masked]> wrote:

> Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
> persone indicate. La diffusione, copia o qualsiasi altra azione derivante
> dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora
> abbiate ricevuto questo documento per errore siete cortesemente pregati di
> darne immediata comunicazione al mittente e di provvedere alla sua
> distruzione, Grazie.
> 
> This e-mail and any attachments is confidential and may contain privileged
> information intended for the addressee(s) only. Dissemination, copying,
> printing or use by anybody else is unauthorised. If you are not the intended
> recipient, please delete this message and any attachments and advise the
> sender by return e-mail, Thanks.
>

---

From: Yong Lucy <[email-masked]>
Date: Fri, 24 Sep 2010 18:01:10 -0500

Support!
Lucy

> 
> > The authors of draft-lm-pwe3-mpls-tp-gal-in-pw-00 have requested that
> this draft be made a PWE3 working group draft.
> >

---

From: Jia HE <[email-masked]>
Date: Sat, 25 Sep 2010 09:31:12 +0800

Yes, support

B.R.
Jia

---

From: Mach Chen <[email-masked]>
Date: Sat, 25 Sep 2010 10:07:47 +0800

Yes/support!

Best regrads,
Mach

--------------------------------------------------

---

From: Jie Dong <[email-masked]>
Date: Sat, 25 Sep 2010 11:39:22 +0800

Yes/Support

Best regards,
Jie

> Sent: Thursday, September 16, 2010 8:07 PM
the
> consensus for this.

---

From: Luca Martini <[email-masked]>
Date: Tue, 28 Sep 2010 21:11:55 -0600

> and in any case hope that it will not be widely employed.)
Yaakov, as you know we already have the "fat Pw" document which dictates
another label at the bottom of the stack. So I'm not sure that it makes
any difference of we have another label at the bottom of the stack of
OAM packets only.

This document actually greatly simplifies the packet inspection
mechanisms as the GAl is an exception label , and a clear indication
that the packet is an exception packet. In fact it is so easy that I
could should how even 12 year old hardware can support this new
mechanism easily , while it cannot support the CW method.
 
> so the proposal does not solve their problem.
Since this document does not even specify how the GAL will be used with
PWs in MPLS-TP ( note that it is already used in this way in MPLS )
Can you please explain how you come to this conclusion ? Maybe you have
read some document I did not ?

> So the only special case is for "old" PWs.
How can you call "obsolete " the most common deployment of PWs ?
Back in 1998 I would have easily picket the GAL method if I thought it
had a chance to get a reserved label allocated to it. Clearly indicating
that the payload is not IP in a packet is a big advantage if a packet
end up in a random location due to mis-forwarding.

Luca

---

From: <[email-masked]>
Date: Wed, 29 Sep 2010 15:08:19 +0100

Luca/Yaakov,  A general architectural observation.  In a layer network we should have consistent characteristic information (CI).  Wrt traffic units this means they should have semantically well-defined/understood fields...for the reason Luca points out near the end, ie traffic units can get misdirected under defects.

The MPLS traffic unit is woefully poor wrt functional field structure.....this is why the label field has been functionally overloaded....so it already breaks the architectural rules wrt consistent CI.

Aside=> It is OK to have non-forwarding label semantics providing the label comes from the globally reserved 0-15 set.  This does not violate the rules for consistent CI because, by definition, each of the reserved labels should have a well defined meaning that is always understood consistently wherever it turns up.  However, the GAL is stretching the rules here because it should only be used to identify a logically OOB CP/MP channel.  If it used for other purposes, such as to identify a *DP* OAM packet then it too is breaking the rules of consistent CI within the reserved label-set.  BTW - The OAM indicate function should be part of the normal DP header of traffic units.

regards, Neil 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Luca Martini
> Sent: 29 September 2010 04:12
> To: Yaakov Stein
> Cc: [email-masked]; [email-masked]
> Subject: Re: [mpls-tp] WG Poll for draft-lm-pwe3-mpls-tp-gal-in-pw-00
> 
> 
> > At very least this violates the MPLS PW architecture 
> requirement that 
> > the PW label MUST be the bottom-of-stack ("inner" label). 
> This complicates packet inspection mechanisms.
> > (Yes I know that the FAT label also messes this up, but I 
> am against 
> > that too, and in any case hope that it will not be widely employed.)
> >
> Yaakov, as you know we already have the "fat Pw" document 
> which dictates another label at the bottom of the stack. So 
> I'm not sure that it makes any difference of we have another 
> label at the bottom of the stack of OAM packets only.
> 
> This document actually greatly simplifies the packet 
> inspection mechanisms as the GAl is an exception label , and 
> a clear indication that the packet is an exception packet. In 
> fact it is so easy that I could should how even 12 year old 
> hardware can support this new mechanism easily , while it 
> cannot support the CW method.
>  
> > I believe that this practice should be obsoleted (yes, even at the 
> > expense of the overhead for small frames).
> > Existing implementations in any case will break when the PW 
> label is 
> > above a 13, so the proposal does not solve their problem.
> Since this document does not even specify how the GAL will be 
> used with PWs in MPLS-TP ( note that it is already used in 
> this way in MPLS ) Can you please explain how you come to 
> this conclusion ? Maybe you have read some document I did not ?
> 
> > Note that 3) can be considered as a sub-case of 1), where 
> the GAL is a 
> > default PW label signifying "no PW".
> Back in 1998 I would have easily picket the GAL method if I 
> thought it had a chance to get a reserved label allocated to 
> it. Clearly indicating that the payload is not IP in a packet 
> is a big advantage if a packet end up in a random location 
> due to mis-forwarding.
> 
> Luca
>  
> > Y(J)S
> >
> >
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of Bocci, Matthew (Matthew)
> > The authors of draft-lm-pwe3-mpls-tp-gal-in-pw-00 have 
> requested that this draft be made a PWE3 working group draft.
> >