Subject: Re: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an mpls wgdraft

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Wed, 1 Sep 2010 16:26:20 +0200

Judging the maturity of normative proposals is not easy and is often questionable.
When those proposals are supported by multiple implementations and tests, field trials and deployments from a plurality of carriers it is easier and less questionable.

I believe this is the case for draft-bhh-mpls-tp-oam-y1731-05 and I don't see many other normative proposals that can claim the same.

Best regards,
Alessandro

------------------------------------------------------------------
Telecom Italia
Alessandro D'Alessandro
Transport & OPB Innovation
Via Reiss Romoli, 274 - 10148 Torino
phone:  +39 011 228 5887
mobile: +39 335 766 9607
fax: +39 06 418 639 07

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sprecher, Nurit (NSN - IL/Hod HaSharon)
Sent: martedì 31 agosto 2010 19.43
To: ext Greg Mirsky
Cc: [email-masked]
Subject: Re: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an mpls wgdraft

Hi Greg,
This is an interesting reference! - although the argument is not backed up in any IETF process document (even though said by Luca :)).
As I recall, Luca's comment was offered in a discussion where it was claimed that the solution in draft-bhh is fully baked and

ready for publication, which is obviously not the case.

As I have indicated, this draft proposes a solution to functions that are required in MPLS-TP and I believe the group wants to work on it, that is why it should become an WG document with the control of the group. It is a starting point.

Best regards,

Nurit

From: ext Greg Mirsky [mailto:[email-masked]]
Sent: Sunday, August 29, 2010 8:33 PM
To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an mpls wgdraft

Dear Nurit,
though I agree with your point I'd like to quote the following argument made by Luca Martini as reflected in IETF-78 minutes:
"... the following unix command:
cat draft-bhh-mpls-tp-oam-y1731-05.txt | grep future | wc -l
returns a value of 7. That means there there are at least 7 things that are undefined, and left to a future version.
So I have to say once again this document is badly under-defined, as was stated today in the MPLS WG meeting."
Kind regards,
Greg
On Sun, Aug 29, 2010 at 9:33 AM, Sprecher, Nurit (NSN - IL/Hod HaSharon) <[email-masked]<mailto:[email-masked]>> wrote:
Huub,
I think it was mentioned many times in the past that the document does
not need to be complete or even in a specific situation to be adopted as
an IETF document.
A yes/support just indicates that the group is interested to work on
this topic.
Do not you want the group to work on loopback? It is specified of the
requirements!
Your concerns can be discussed and addressed in the IETF document.
Best regards,
Nurit

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On
Behalf Of ext [email-masked]<mailto:[email-masked]>
Sent: Sunday, August 29, 2010 7:28 PM
To: [email-masked]<mailto:[email-masked]>; MPLS-TP ad hoc team; Loa Andersson
Subject: Re: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an
mpls wgdraft

No/do not support.

This draft is not complete, it is not trechnically sound enough.
It misses the response of the MEP_A when neither ACK nor NACK is
received.
on the lock and on the loopback messages.
It misses the requirements for other (pro-active) OAM tools that
MUST/MUST-NOT
run at the same time.
An example is the CC OAM tool (which normally always is activated), any
CC
message sent by MEP-A is looped back to itself when loopback is enabled.
For MEP-A this is an unexpected CC, so it will take appropriate action.
Also MEP-D does not receive the MEP-A CC (because the loopback is full)
and raises an alarm.

These issues need to be addressed before making it WG draft.

Regards, Huub.

---- Loa Andersson <[email-masked]<mailto:[email-masked]>> schreef:
> Working Group,
>
> this email is to start a poll to adopt
> draft-boutros-mpls-tp-li-lb-01.txt
> as an MPLS working group draft.
>
> After recent experience, the chairs would like to remind you all
> what it means to conduct a poll to adopt a draft as a working group
> draft.
>
> - Please recall that the IETF does not "vote." Polls of a working
>     group are to gather information to help the chairs make their
>     decisions. Voting is not part of the normal working methods of
>     an IETF working group.
>
> - The "rough consensus" process used in the working group assumes
>     that people expressing opinions are also participating in the
>     development of standards documents.
>
> - Subscription to the list specifically to express an opinion is
>     noticed by the chairs who has access to information on the new
list
>     members. Such behavior is not part of the normal working methods.
>
> - The purpose of a poll for adoption is to help the chairs understand
>     the level of support for a document (i.e. who has read it, who
>     believes it is a good starting point for working group work, who
>     will contribute to the work) and whether there are any significant
>     technical issues. Statements of objection must be backed up by
>     proper technical reasons.
>
> So please respond to this poll indicating whether you support the
> adoption of this draft or stating your technical issues.
>
> This poll ends eob August 29.
>
>
> Loa and George
> mpls wg co-chairs
>
>
> --
>
>
> Loa Andersson                         email:
[email-masked]<mailto:[email-masked]>
> Sr Strategy and Standards Manager            [email-masked]<mailto:[email-masked]>
> Ericsson Inc                          phone: +46 10 717 52 13
>                                               +46 767 72 92 13
> _______________________________________________
> mpls-tp mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mpls-tp

_______________________________________________
mpls-tp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls-tp
_______________________________________________
mpls-tp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls-tp

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 1 Sep 2010 16:35:42 +0200

Hi Alessandro,

Talking about maturity, I referred to the draft as appears in the web site. 

I think that what is tested and deployed is Ethernet Y.1731, and not draft-bhh. Isn't it? (or G.8114???)

As far as I understand what was tested in the EATNC events from draft-bhh is just the proactive CC function...the PM functions and other FM functions were not tested...and we do not have enough information on the tests, scenarios, scaling information, etc. to evaluate the tests and their results (as it is under NDA).

There are other OAM mechanisms that were tested and widely deployed. 

Best regards,

Nurit

From: ext D'Alessandro Alessandro Gerardo [mailto:[email-masked]] 
Sent: Wednesday, September 01, 2010 5:26 PM
To: Sprecher, Nurit (NSN - IL/Hod HaSharon); ext Greg Mirsky
Cc: [email-masked]
Subject: RE: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an mplswgdraft

Best regards,

Alessandro

Hi Greg,

This is an interesting reference! - although the argument is not backed up in any IETF process document (even though said by Luca J). 

Best regards,

Nurit

Dear Nurit,

Kind regards,

Greg

On Sun, Aug 29, 2010 at 9:33 AM, Sprecher, Nurit (NSN - IL/Hod HaSharon) <[email-masked]> wrote:

Huub,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext [email-masked]
Sent: Sunday, August 29, 2010 7:28 PM
To: [email-masked]; MPLS-TP ad hoc team; Loa Andersson
Subject: Re: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an
mpls wgdraft

No/do not support.

Regards, Huub.

list
> This poll ends eob August 29.
[email-masked]
> Sr Strategy and Standards Manager            [email-masked]
> [email-masked]

[email-masked]
[email-masked]

---

From: D'Alessandro Alessandro Gerardo <[email-masked]>
Date: Wed, 1 Sep 2010 17:55:03 +0200

Hi Nurit,
My previous email didn’t add anything new to the presentation “draft-fang-mpls-tp-oam-considerations” I presented at the last IETF meeting (attached for your convenience slide 6 that couldn’t be read properly from the IETF website http://www.ietf.org/proceedings/78/slides/mpls-26/mpls-26.htm ).

As I told at that time, the OAM toolset I refer to is based on draft-bhh (and therefore it addresses MPLS-TP).

The presentation recalls EANTC interoperability tests only as official tests but it also highlights some of the activities and plans based on draft-bhh of a number of carriers (slide 4 and slides 9-12) that I think that is very valuable.

If there were tests and wide deployments of other OAM tools for MPLS-TP, I would encourage you to share them.

Best regards,
Alessandro

From: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Hi Alessandro,
Talking about maturity, I referred to the draft as appears in the web site.
I think that what is tested and deployed is Ethernet Y.1731, and not draft-bhh. Isn’t it? (or G.8114???)
As far as I understand what was tested in the EATNC events from draft-bhh is just the proactive CC function…the PM functions and other FM functions were not tested…and we do not have enough information on the tests, scenarios, scaling information, etc. to evaluate the tests and their results (as it is under NDA).
There are other OAM mechanisms that were tested and widely deployed.
Best regards,
Nurit

From: D'Alessandro Alessandro Gerardo
Judging the maturity of normative proposals is not easy and is often questionable.
When those proposals are supported by multiple implementations and tests, field trials and deployments from a plurality of carriers it is easier and less questionable.

I believe this is the case for draft-bhh-mpls-tp-oam-y1731-05 and I don’t see many other normative proposals that can claim the same.

Best regards,
Alessandro

From: Sprecher, Nurit
Hi Greg,
This is an interesting reference! - although the argument is not backed up in any IETF process document (even though said by Luca ☺).
From: ext Greg Mirsky
..snipped…

---

From: "BUSI, ITALO (ITALO)" <[email-masked]>
Date: Mon, 13 Sep 2010 14:01:07 +0200

Nurit,

the discussion was about accepting the draft as a WG document. We were not requesting a WG last call.

Italo

________________________________
Da: [email-masked] [mailto:[email-masked]] Per conto di Sprecher, Nurit (NSN - IL/Hod HaSharon)
Inviato: martedì 31 agosto 2010 19.43
A: ext Greg Mirsky
Cc: [email-masked]
Oggetto: Re: [mpls-tp] poll on making draft-boutros-mpls-tp-li-lb an mpls wgdraft

Hi Greg,

Best regards,

Nurit

Dear Nurit,

-----Original Message-----

No/do not support.

Regards, Huub.

list