Subject: [mpls-tp] Questions about the draft-ceccarelli-mpls-tp-p2mp-ring-01

From: Najat Nassit <[email-masked]>
Date: Thu, 21 Oct 2010 11:21:44 +0000

hello every body,

I have some questions about this draft
(draft-ceccarelli-mpls-tp-p2mp-ring-01) :

   1. Do the protected LSPs are set up at the same time as the working LSPs?
   2. For the example of the figure 4, the traffic is sent from the A to the
   all the nodes or juste to the nodes which are connected to the DSLAMs?
   3. My last question is about the differnce between the FRR-TP and the
   ROM-FRR. I don't understand it, can you please tell me what are the ROM-TP
   's enhancements to the FRR-TP?

Thank u a lot.

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 22 Oct 2010 10:58:42 +0200

Hi Najat,

PLEASE NOTE: This draft has been merged with: http://tools.ietf.org/html/draft-weingarten-mpls-tp-ring-protection-03.
The ROM-FRR is now called ROM-WRAPPING and is described is section 3.1

>1. Do the protected LSPs are set up at the same time as the working LSPs?
Yes

>2. For the example of the figure 4, the traffic is sent from the A to the all the nodes or juste to the nodes which are connected to the DSLAMs
The traffic is sent to the leaf nodes of the P2MP LSP (i.e. the nodes connected to the DSLAMs)

>3. My last question is about the differnce between the FRR-TP and the ROM-FRR. I don't understand it, can you please tell me what are the ROM-TP 's enhancements to the FRR-TP?
When traffic is restored using FRR-TP, a P2p bypass tunnel is created from the node detecting the failure towards the merge node and then the "second half" of the working LSP is used (traffic is not delivered to leaf nodes while crossing them).
On the other side, using ROM-FRR, when a node detects a failure, a P2MP backup path is activated having as leaf nodes the leaf nodes of the working LSP located downstream with respect to the failure (traffic is delivered to the leaf nodes while crossing them).

You can have a look at slide 6 of the slide set presented at the IETF 76th meeting: http://tools.ietf.org/agenda/76/slides/mpls-24.ppt

Also, see section 7 for a comparison between the two mechanisms:
- Bandwidth saving
- Lower number of nodes crossed by the traffic
- No distinction between node and link failure
- Possibility of recovery from multiple failures

BR
Daniele
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Najat Nassit
Sent: giovedì 21 ottobre 2010 13.22
To: [email-masked]
Subject: [mpls-tp] Questions about the draft-ceccarelli-mpls-tp-p2mp-ring-01

hello every body,

I have some questions about this draft (draft-ceccarelli-mpls-tp-p2mp-ring-01) :

 1.  Do the protected LSPs are set up at the same time as the working LSPs?
 2.  For the example of the figure 4, the traffic is sent from the A to the all the nodes or juste to the nodes which are connected to the DSLAMs?
 3.  My last question is about the differnce between the FRR-TP and the ROM-FRR. I don't understand it, can you please tell me what are the ROM-TP 's enhancements to the FRR-TP?

Thank u a lot.