Subject: [mpls-tp] PW over bidir lsp

From: "Vijayanand C - ERS, HCL Tech" <[email-masked]>
Date: Thu, 21 Oct 2010 12:55:40 +0530

Hello all,
When a pseudo wire is transported over bidirectional mpls-tp LSPs, should
both directions of the PW use the same bidirectional LSP  or is it
acceptable for the forward and reverse directions of the PW to use
different mpls-tp LSPs ?

Regards
Vijay

---

From: Mach Chen <[email-masked]>
Date: Thu, 21 Oct 2010 16:00:48 +0800

Hi Vijay,

IMO, when bidirectional MPLS-TP LSPs are used as PSN tunnels, both 
directions should use the same bidirectional LSP, and in case of 
unidirectional LSP, it's better to make sure both directions to use the LSPs 
with congruent paths. And this is one of the requirements of MPLS-TP.

We have a draft that is intended to resolve these questions, this draft was 
presented at last IETF meeting. Here is the link: 
http://tools.ietf.org/html/draft-cao-pwe3-mpls-tp-pw-over-bidir-lsp-00, 
please check, any comments are very welcomed!

Best regards,
Mach

--------------------------------------------------
From: "Vijayanand C - ERS, HCL Tech" <[email-masked]>
Sent: Thursday, October 21, 2010 3:25 PM
To: <[email-masked]>
Subject: [mpls-tp] PW over bidir lsp

> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Vijayanand C - ERS, HCL Tech" <[email-masked]>
Date: Thu, 21 Oct 2010 13:41:45 +0530

Hi mach,
Is this an explicit requirement in mpls-tp or is it derived from something else ? I could nt find it in the mpls-tp-requirements draft.

Regards
Vijay

> -----Original Message-----
> From: Mach Chen [mailto:[email-masked]]
> Sent: Thursday, October 21, 2010 1:31 PM
> To: Vijayanand C - ERS, HCL Tech
> Cc: [email-masked]; PWE3 IETF
> Subject: Re: [mpls-tp] PW over bidir lsp
>
> Hi Vijay,
>

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. 
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates. 
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

---

From: Mach Chen <[email-masked]>
Date: Thu, 21 Oct 2010 16:31:05 +0800

Hi Vijay,

This is not an explicit requirement defined in the requirement draft, but it 
is explicitly mentined in draft-ietf-ccamp-mpls-tp-cp-framework (Section 
5.3.2. Support for Explicit Control of PW-to-LSP Binding).

Best regards,
Mach

--------------------------------------------------
From: "Vijayanand C - ERS, HCL Tech" <[email-masked]>
Sent: Thursday, October 21, 2010 4:11 PM
To: "Mach Chen" <[email-masked]>
Cc: <[email-masked]>; "PWE3 IETF" <[email-masked]>
Subject: RE: [mpls-tp] PW over bidir lsp

> Hi mach,
> Is this an explicit requirement in mpls-tp or is it derived from something 
> else ? I could nt find it in the mpls-tp-requirements draft.
>
> Regards
> Vijay
>
> The contents of this e-mail and any attachment(s) are confidential and 
> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its 
> affiliates. Any views or opinions presented in
> Any form of reproduction, dissemination, copying, disclosure, 
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this 
> e-mail is strictly prohibited. If you have

---

From: "Amir Halperin" <[email-masked]>
Date: Thu, 21 Oct 2010 11:47:50 +0200

Hi Mach.

Maybe I'm missing something, but it seems to me that this is exactly the
responsibility/capability of the MPLS bi-directional tunnel/LSP layer.
If the operator requires bi-directional and symmetric LSP he should use
bi-directional tunnel and not a pair of unidirectional.

Amir Halperin
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mach Chen
Sent: Thursday, October 21, 2010 10:31 AM
To: Vijayanand C - ERS, HCL Tech
Cc: PWE3 IETF; [email-masked]
Subject: Re: [mpls-tp] PW over bidir lsp

Hi Vijay,

This is not an explicit requirement defined in the requirement draft,
but it 
is explicitly mentined in draft-ietf-ccamp-mpls-tp-cp-framework (Section

Best regards,
Mach

>> unidirectional LSP, it's better to make sure both directions to use
the
>> LSPs
>> We have a draft that is intended to resolve these questions, this
draft
>> was
>> > https://www.ietf.org/mailman/listinfo/mpls-tp
------------------------------------------------------------------------
-----------------------------------------------

> this email are solely those of the author and may not necessarily
reflect 
> the opinions of HCL or its affiliates.
------------------------------------------------------------------------
-----------------------------------------------

---

From: Mach Chen <[email-masked]>
Date: Fri, 22 Oct 2010 09:35:33 +0800

Hi Amir,

Yes, you are right, if the operators require bi-directional and symmetric 
transport connectivity, bi-directional LSP is mostly the direct choice. But, 
for whatever reason, when there is no bi-directional LSP, and the 
unidirectional LSPs can satisfy the requirement in question, I see there is 
no reason to not use it.

As for the explicit PW to LSP binding, the issue is that there can be 
multiple bi-directional LSPs and/or pairs of unidirectional LSPs between two 
PEs, if you want the both directions of a PW to follow congruent paths, the 
selected LSPs for PSN tunnel should also have the congruent path: same 
bi-directional LSP or a pair unidirectional LSPs with congurent paths.

Best regards,
Mach

--------------------------------------------------
From: "Amir Halperin" <[email-masked]>
Sent: Thursday, October 21, 2010 5:47 PM
To: "Mach Chen" <[email-masked]>; "Vijayanand C - ERS, HCL Tech" 
<[email-masked]>
Cc: "PWE3 IETF" <[email-masked]>; <[email-masked]>
Subject: RE: [mpls-tp] PW over bidir lsp