Subject: [mpls-tp] Need your opinion on MPLS-TP CFI function. Thanks in advance!

From: Jia HE <[email-masked]>
Date: Wed, 03 Nov 2010 19:47:45 +0800

Hi Folks,

We would like to hear your opinion about the CFI function, one of the MPLS-TP OAM functions as required. 

An MPLS-TP OAM tool as Client Signal Fail indication (CSF) is defined to propagate client failures and their clearance across a MPLS-TP domain in case the client service carried by MPLS-TP networks does not provide mechanisms to propagate its failure information through MPLS-TP networks.
   
The URL for the relevant draft is:
http://www.ietf.org/id/draft-he-mpls-tp-csf-02.txt

Looking forward to your comments!

Thanks a lot!

B.R.
Jia

---

From: binny jeshan <[email-masked]>
Date: Wed, 3 Nov 2010 18:15:01 +0530

Hi Jia,

How is the use case mentioned in this draft different from
http://tools.ietf.org/html/draft-ietf-pwe3-mpls-eth-oam-iwk-03 and
http://tools.ietf.org/html/draft-ietf-pwe3-oam-msg-map-14 ?

I feel that the last statement in the CFI requirements of
http://tools.ietf.org/html/draft-ietf-mpls-tp-oam-framework-09 , and current
gaps could be met by your idea  through your draft, when compared to the
existing mechanisms i have mentioned above. In that aspect i think, more
effort may need to be added to your draft.
" multiple clients are multiplexed over a transport path, the CFI message
requires additional information to permit the client instance to be
identified. "

Thanks a lot,
Binny.

2010/11/3 Jia HE <[email-masked]>

> An MPLS-TP OAM tool as Client Signal Fail indication (CSF) is defined to
> propagate client failures and their clearance across a MPLS-TP domain in
> case the client service carried by MPLS-TP networks does not provide
> mechanisms to propagate its failure information through MPLS-TP networks.
>
> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>
>

---

From: <[email-masked]>
Date: Wed, 3 Nov 2010 16:06:41 +0000

Jia,

It is very bad architectural practice to functionally couple different layer networks.  If layer network X is functionally deficient in some DP or CP aspect one should not try and address this by adding functionally to a different layer network Y.

Aside=> You mention AIS/FDI in the draft.  This only has real value in the co-cs mode.  It should not be used in co-ps mode layer networks, and it is (more) obviously wrong for cl-ps mode layer networks.

regards Neil

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jia HE
Sent: 03 November 2010 11:48
To: [email-masked]; [email-masked]
Cc: 李 晗
Subject: [mpls-tp] Need your opinion on MPLS-TP CFI function. Thanks in advance!

Hi Folks,

Thanks a lot!

B.R.
Jia