Subject: [mpls-tp] Comments to draft-ietf-mpls-tp-cp-framework-03

From: Greg Mirsky <[email-masked]>
Date: Wed, 3 Nov 2010 22:49:19 -0700

Dear Editors and All,
please kindly accept my comments to the document:

   - Section 1.1 Scope, p.3

s/These document/These documents/

   - Requirements 44 and 45 list capability of MPLS-TP Control Plane to
   dynamically define protection and OAM functions of MPLS-TP paths. At the
   same time, all this functions can be provisioned via management plane.
   Requirement 47 refers to ability to dynamically transfer control of "MPLS-TP
   transport paths" between control plane and management plane. I think that
   two additional requirements that refer to ability dynamically transfer
   control of protection functions and OAM functions and relationships between
   control plane and management plane are needed.

Regards,
Greg

---

From: Eric Gray <[email-masked]>
Date: Thu, 4 Nov 2010 10:09:01 -0400

Greg,

I don't believe it is within the purview of this document to create requirements
that do not exist elsewhere - i.e. - this is a framework, not a requirements, draft.

That said, I am unsure what requirement(s) it is that you are asking us to add.
It sounds to me like what you are saying is:

o    we have a requirement to allow transfer of path "ownership" between the
      management and control planes
o    we have requirements to allow dynamic control of protection and OAM
o    therefore we need to have explicit requirements to allow ownership transfer
      of OAM and protection between the management and control planes.

I do not see that this follows.  Implicitly, if a path is owned by management, then
there must at least be a management mechanism to control protection/OAM for
that path.  This does not preclude implementation of control-plane mechanisms
to also control protection/OAM for the same path - though I imagine any such
mechanism must be capable of being disabled (and probably would be disabled
by default).

The analogous relationship should also be true if a path is owned by the control
plane.

Also (again implicitly) since we require mechanisms to allow transfer of ownership
between the control and management planes, it is clear that ownership of a path
is possible for either plane.  Hence there is an obvious (though possibly implicit)
requirement to define mechanisms to allow control of protection and OAM by both
planes.

So, it seems that what you are asking for is an explicit requirement to add a knob
(almost certainly as a management/configuration capability) to control ownership
of the protection.OAM for a path - apparently independently of path ownership.  I
think that is a bit of a detailed requirement to be adding in a framework document,
don't you?  Also, thsi strikes me as most likely a detailed management requirement
as opposed to a control plane requirement.

Ordinarily, however dynamic we might like control of a network to be, we do not
typically want it to be making management decisions in the control plane.  How
annoying it might be if the system consistently disagrees with the operator on
how it should be configured...

So, what are you really asking for?

--
Eric
________________________________
From: Greg Mirsky [mailto:[email-masked]]
Sent: Thursday, November 04, 2010 1:49 AM
To: Loa Andersson; Lou Berger; [email-masked]; Bitar, Nabil N; Eric Gray; Attila Takacs; [email-masked]; Elisa Bellagamba; [email-masked]; [email-masked]
Subject: Comments to draft-ietf-mpls-tp-cp-framework-03
Importance: High

Dear Editors and All,

 *   Section 1.1 Scope, p.3

 *   Requirements 44 and 45 list capability of MPLS-TP Control Plane to dynamically define protection and OAM functions of MPLS-TP paths. At the same time, all this functions can be provisioned via management plane. Requirement 47 refers to ability to dynamically transfer control of "MPLS-TP transport paths" between control plane and management plane. I think that two additional requirements that refer to ability dynamically transfer control of protection functions and OAM functions and relationships between control plane and management plane are needed.

Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 4 Nov 2010 18:05:12 -0700

Dear Eric,
thank you for the explanation.
The Requirement 47 can be interpreted as implicitly addressing transfer of
protection and OAM states between control and management planes. You
expressed my intention better:

   - Consider explicitly list protection and OAM state in Requirement 47 as
   integral part control information of MPLS-TP transport path.

Regards,
Greg

On Thu, Nov 4, 2010 at 7:09 AM, Eric Gray <[email-masked]> wrote:

> there must *at least* be a management mechanism to control protection/OAM
> for
> ------------------------------
> *From:* Greg Mirsky [mailto:[email-masked]]
> *Sent:* Thursday, November 04, 2010 1:49 AM
> *To:* Loa Andersson; Lou Berger; [email-masked]; Bitar, Nabil N; Eric
> Gray; Attila Takacs; [email-masked]; Elisa
> Bellagamba; [email-masked]; [email-masked]
> *Subject:* Comments to draft-ietf-mpls-tp-cp-framework-03
> *Importance:* High
>
> Dear Editors and All,

---

From: Lou Berger <[email-masked]>
Date: Thu, 18 Nov 2010 10:04:46 -0500

Greg,
	I'm not sure we ever closed this point.  I agree with Eric 100% about 
not being able to add new requirements.  That said, assuming no 
objections, I think it's fair to add something like:

   "Note, such transfers cover all transport path control functions
    including control of recovery and OAM."

Any objections?

Thanks,
Lou

On 11/4/2010 9:05 PM, Greg Mirsky wrote:
> The Requirement 47 can be interpreted as implicitly addressing transfer
> of protection and OAM states between control and management planes. You
>     * Consider explicitly list protection and OAM state in Requirement
>       47 as integral part control information of MPLS-TP transport path.
>
>
> Regards,
> Greg
>
> On Thu, Nov 4, 2010 at 7:09 AM, Eric Gray <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Greg,
>     there must */at least/* be a management mechanism to control
>     protection/OAM for
>     ------------------------------------------------------------------------
>     *From:* Greg Mirsky [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     *To:* Loa Andersson; Lou Berger; [email-masked]
>     <mailto:[email-masked]>; Bitar, Nabil N; Eric Gray; Attila Takacs;
>     [email-masked]
>     <mailto:[email-masked]>; Elisa Bellagamba;
>     [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>         * Requirements 44 and 45 list capability of MPLS-TP Control
>           Plane to dynamically define protection and OAM functions of
>           MPLS-TP paths. At the same time, all this functions can be
>           provisioned via management plane. Requirement 47 refers to
>           ability to dynamically transfer control of "MPLS-TP transport
>           paths" between control plane and management plane. I think
>           that two additional requirements that refer to ability
>           dynamically transfer control of protection functions and OAM
>           functions and relationships between control plane and
>           management plane are needed.
>
>     Regards,
>     Greg
>
>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 18 Nov 2010 07:14:51 -0800

Dear Lou,
I agree with the proposed wording..

Regards,
Greg

On Thu, Nov 18, 2010 at 7:04 AM, Lou Berger <[email-masked]> wrote:

> Greg,
>        I'm not sure we ever closed this point.  I agree with Eric 100%
> about not being able to add new requirements.  That said, assuming no