Subject: Re: [mpls-tp] Regarding BFD Code Points for ACH header and MEP TLV for PW

From: binny jeshan <[email-masked]>
Date: Mon, 1 Nov 2010 23:19:03 +0530

Hello,

I am not able to find standard IANA allocations for the BFD ACH code points
for differentiating CC and CV messages. Draft authors / Group members if any
are aware of these standard values, kindly share. Are we expecting these to
be defined in any new draft versions?

Thanks a lot,
Binny.

On 5 October 2010 19:09, Mukund Mani <[email-masked]> wrote:

> Hello draft authors
>
> Could somebody please respond to this query.
>
> With Regards
> Mukund
>
>
>
>
> On Thu, Sep 30, 2010 at 1:02 PM, Mukund Mani <[email-masked]>wrote:
>
>> Hello group
>>
>>
>>
>>
>>
>>    1. For BFD CC/CV, “draft-ietf-mpls-tp-bfd-cc-cv-01” mentions about
>>    separate code points for CC and CV in the ACH header.
>>
>>           Considering the same how will the code points be defined for
>> using BFD (CC/CV) on PW?
>>           Currently Channel Type (0x07) is the code point for BFD payload
>> and 0x21 that for IPv4
>>
>>           Thus for MPLS-TP PW we will need further code points to
>> differentiate CC and CV for the VCCV payload types.
>>
>>
>>
>>
>>
>>    1. MEP TLV for PW will contain the AGI field which is of variable
>>    length. Will there be a separate sub-tlv for source MEP id in case of PW.
>>
>>
>> Will the above be defined in the next version of the draft?
>>
>>
>>
>>
>>
>> With Regards
>>
>> Mukund
>>
>
>

---

From: "t.petch" <[email-masked]>
Date: Thu, 11 Nov 2010 15:37:02 +0100

----- Original Message -----
From: "binny jeshan" <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>
Cc: "Mukund Mani" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Monday, November 01, 2010 6:49 PM

Hello,

<tp>
I did not see a reply on the list and do not know if you got one off list, but
...

IANA make standard allocations when the technical work on an I-D is complete,
after:
WG Last Call
AD Review
IETF Last Call
IESG Review
and all that is left is for the RFC Editor to get the format and grammar
correct.  Hence you should expect NOT to see standard values in an I-D:-)  And
which is why many namespaces define a range of experimental values for use
during development.

Of course, there are times when it is desirable to nail down a value earlier in
the process, eg to allow extensive interoperability testing, but this should be
the exception, not the rule.  You will find that RFC4020 covers this
eventuality.  As this RFC says,
" This memo proposes that, under strictly controlled circumstances,
   IANA make an early allocation of code points.  "

Tom Petch
</tp>
Thanks a lot,
Binny.

>> Will the above be defined in the next version of the draft?

--------------------------------------------------------------------------------

> _______________________________________________
> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>