Subject: Re: [mpls-tp] [mpls] [PWE3] [AHMPLS-TP] Re: pollondraft-he-mpls-tp-csf-03.txt

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Thu, 2 Dec 2010 08:38:18 -0600

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> LEVRAU, LIEVEN (LIEVEN)
> Sent: Thursday, December 02, 2010 8:17 AM
> To: Rajiv Asati (rajiva); Yuanlong Jiang
> Cc: [email-masked]; Sprecher,Nurit (NSN - IL/Hod HaSharon); MPLS-TP ad
hoc
> team; [email-masked]; [email-masked]
> Subject: Re: [mpls] [PWE3] [AHMPLS-TP] Re:[mpls-tp]
pollondraft-he-mpls-
> tp-csf-03.txt
> 
> provocative statement alert- We should as we are talking about MPLS-TP
and
> not about IP network layer.
> 

OK, so maybe this is where I'm confused.  Aren't we talking about a
mechanism to indicate to a *client* of TP that there's a problem (thus,
Client Signal Fail)?

eric

> ./
> Lieven
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Rajiv Asati (rajiva)
> Sent: 02 December 2010 14:14
> To: Yuanlong Jiang
> Cc: Sprecher, Nurit (NSN - IL/Hod HaSharon); MPLS-TP ad hoc team;
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [mpls] [PWE3] [AHMPLS-TP] Re: [mpls-tp]
pollondraft-he-mpls-
> tp-csf-03.txt
> 
> Are we ignoring the existence of BFD altogether?
> 
> Cheers,
> Rajiv
> 
> Sent from my Phone
> 
> On Dec 1, 2010, at 8:19 PM, Yuanlong Jiang <[email-masked]> wrote:
> 
> > John,
> >
> > Typically, IP will only detect a failure in a time scale of minutes.
> > That is one reason why MPLS-TP OAM and Protection & Switching is
needed.
> > I am not sure which mechanism in MPLS provides the CSF-like
capability,
> could you give more hints?
> >
> > Thanks
> > Yuanlong
> >
> > ----- Original Message ----- From: "John E Drake"
<[email-masked]>
> > To: "Sprecher, Nurit (NSN - IL/Hod HaSharon)"
> > <[email-masked]>; "Yuanlong Jiang" <[email-masked]>;
"Loa
> > Andersson" <[email-masked]>; <[email-masked]>; <[email-masked]>;
> > <[email-masked]>; "MPLS-TP ad hoc team" <[email-masked]>
> > Sent: Wednesday, December 01, 2010 9:29 PM
> > Subject: RE: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll
> > ondraft-he-mpls-tp-csf-03.txt
> >
> >
> >> Nurit,
> >>
> >> As I understand the original requirement from Malcolm Betts, this
> capability is required for those cases in which a client is unable to
> detect the failure of its peer.  In MPLS-TP, we have three clients,
PW,
> IP, and MPLS, and I am quite sure that IP and MPLS clients can take
care
> of themselves wrt detecting peer failure.
> >>
> >> Thanks,
> >>
> >> John
> >>
> >> Sent from my iPhone
> >>
> >>> -----Original Message-----
> >>> From: Sprecher, Nurit (NSN - IL/Hod HaSharon)
> >>> [mailto:[email-masked]]
> >>> Sent: Wednesday, December 01, 2010 4:47 AM
> >>> To: John E Drake; Yuanlong Jiang; Loa Andersson; [email-masked];
> >>> mpls- [email-masked]; [email-masked]; MPLS-TP ad hoc team
> >>> Subject: RE: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll
> >>> ondraft-he-mpls-tp- csf-03.txt
> >>>
> >>> But what about other client services... e.g. adapted by
service-LSP
> >>> and not by PWE3?
> >>>
> >>> -----Original Message-----
> >>> From: [email-masked] [mailto:[email-masked]] On
Behalf
> >>> Of ext John E Drake
> >>> Sent: Wednesday, December 01, 2010 2:35 PM
> >>> To: Yuanlong Jiang; Loa Andersson; [email-masked];
[email-masked];
> >>> [email-masked]; MPLS-TP ad hoc team
> >>> Subject: Re: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll
> >>> ondraft-he-mpls-tp-csf-03.txt
> >>>
> >>> I am not convinced.  It seems like it belongs in the Pseudo Wire
> >>> application, which already has this capability.
> >>>
> >>> Sent from my iPhone
> >>>
> >>>
> >>> > -----Original Message-----
> >>> > From: Yuanlong Jiang [mailto:[email-masked]]
> >>> > Sent: Wednesday, December 01, 2010 1:07 AM
> >>> > To: Loa Andersson; [email-masked]; [email-masked];
[email-masked];
> >>> > MPLS-TP ad hoc team
> >>> > Subject: [AHMPLS-TP] Re: [mpls-tp] poll on draft-he-mpls-tp-csf-
> >>> 03.txt
> >>> >
> >>> > Support.
> >>> >
> >>> > I believe this mechanism is needed in MPLS-TP.
> >>> >
> >>> > Thanks
> >>> > Yuanlong
> >>> >
> >>> > ----- Original Message -----
> >>> > From: "Loa Andersson" <[email-masked]>
> >>> > To: <[email-masked]>; <[email-masked]>; <[email-masked]>;
"MPLS-TP
> >>> > ad hoc team" <[email-masked]>
> >>> > Sent: Thursday, November 18, 2010 7:56 PM
> >>> > Subject: [mpls-tp] poll on draft-he-mpls-tp-csf-03.txt
> >>> >
> >>> >
> >>> > > all,
> >>> > >
> >>> > > this is to start a two week poll on making
> >>> > >
> >>> > >
http://www.ietf.org/internet-drafts/draft-he-mpls-tp-csf-03.txt
> >>> > >
> >>> > > a mpls working group document.
> >>> > >
> >>> > > Please send comments support/not support to the mpls-tp
maililng
> >>> > list.
> >>> > >
> >>> > > The poll ends Thursday Dec 2, 2010.
> >>> > >
> >>> > > /Loa
> >>> > > --
> >>> > >
> >>> > >
> >>> > > Loa Andersson                         email:
> >>> > [email-masked]
> >>> > > Sr Strategy and Standards Manager            [email-masked]
> >>> > > Ericsson Inc                          phone: +46 10 717 52 13
> >>> > >                                              +46 767 72 92 13
> >>> > > _______________________________________________
> >>> > > mpls-tp mailing list
> >>> > > [email-masked]
> >>> > > https://www.ietf.org/mailman/listinfo/mpls-tp
> >>>
> >>> _______________________________________________
> >>> pwe3 mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/pwe3
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/pwe3
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: John E Drake <[email-masked]>
Date: Thu, 2 Dec 2010 06:53:28 -0800

As I understand it, the server at one end of an LSP detects that its client has failed and it uses CSF to tell the server at the other end of the LSP.  Presumably that server then tells its client.

Sent from my iPhone

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Eric Osborne (eosborne)
> Sent: Thursday, December 02, 2010 6:38 AM
> To: LEVRAU, LIEVEN (LIEVEN); Rajiv Asati (rajiva); Yuanlong Jiang
> Cc: [email-masked]; MPLS-TP ad hoc team; [email-masked]; [email-masked]
> Subject: Re: [mpls-tp] [mpls] [PWE3] [AHMPLS-TP] Re: pollondraft-he-
> mpls-tp-csf-03.txt
> 
> 
>

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Thu, 2 Dec 2010 08:57:48 -0600

> From: John E Drake [mailto:[email-masked]]
> Sent: Thursday, December 02, 2010 9:53 AM
> To: Eric Osborne (eosborne); LEVRAU, LIEVEN (LIEVEN); Rajiv Asati
> (rajiva); Yuanlong Jiang
> Subject: RE: [mpls-tp] [mpls] [PWE3] [AHMPLS-TP]
Re:pollondraft-he-mpls-
> tp-csf-03.txt
> 
> As I understand it, the server at one end of an LSP detects that its
> client has failed and it uses CSF to tell the server at the other end
of
> the LSP.  Presumably that server then tells its client.
> 

Yup.  And I go back to my earlier point - there are three things we know
how to transport over MPLS: MPLS, IP, and pseudowires.  Pseudowires
solve this problem on their own.  IP and MPLS have client-side tools
that would be used anyways.

To Manuel's point about ".. terminal nodes connected by attachment
circuits" - wouldn't those be handled by the existing pseudowire
mechanisms?

eric

> > > provocative statement alert- We should as we are talking about
MPLS-
> > TP
> > mechanism to indicate to a *client* of TP that there's a problem
> > (thus, Client Signal Fail)?
> >
> >
> >
> > eric
> >
> >
> > > ./
> > > Lieven
> > > capability is required for those cases in which a client is unable
> > > to detect the failure of its peer.  In MPLS-TP, we have three
> > > clients,
> > PW,
> > > >>> > >                                              +46 767 72 92
> > > >>> > > 13 _______________________________________________
> > > >>> > > mpls-tp mailing list
> > > >>> > > [email-masked]

---

From: John E Drake <[email-masked]>
Date: Thu, 2 Dec 2010 07:01:07 -0800

Exactly

Sent from my iPhone

> From: Eric Osborne (eosborne) [mailto:[email-masked]]
> Sent: Thursday, December 02, 2010 6:58 AM
> To: John E Drake; LEVRAU, LIEVEN (LIEVEN); Rajiv Asati (rajiva);
> Yuanlong Jiang
> Subject: RE: [mpls-tp] [mpls] [PWE3] [AHMPLS-TP] Re:pollondraft-he-
> mpls-tp-csf-03.txt
> 
> 
> 
> > > > Cc: [email-masked]; Sprecher,Nurit (NSN - IL/Hod HaSharon); MPLS-
> TP
> > > > ad
> > > hoc
> > > > >>> > Subject: [AHMPLS-TP] Re: [mpls-tp] poll on draft-he-mpls-
> tp-
> > > csf-
> > > > >>> 03.txt
> > > > >>> >
> > > > >>> > Support.
> > > > >>> >
> > > > >>> > > Ericsson Inc                          phone: +46 10 717
> 52
> 13
> > > > >>> > >                                              +46 767 72
> 92

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 2 Dec 2010 10:10:33 -0500

> circuits" - wouldn't those be handled by the existing pseudowire

	Spot on.  There is no need to re-invent everything from optical within
the context of MPLS/IP. People need to stop loosing sight of the original goals 
of MPLS-TP: adding just enough to make it solve the requirements, and then
(hopefully) fold (most of) that back into the base. There is no need to shoe-horn every 
last concept and technology from optical transport technology into MPLS-TP just because 
it exists, or because you do not like the names used for the technology.  When the 
requirement can be solved sufficiently using existing mechanisms, leave it at that. 
If you want a 1:1 replication of optical transport technology, frankly, I'd say just 
go use that as it is already built and works as-designed today.

	--Tom

---

From: "LEVRAU, LIEVEN (LIEVEN)" <[email-masked]>
Date: Thu, 2 Dec 2010 17:29:02 +0100

With you on that one!
./
Lieven

-----Original Message-----
From: Eric Osborne (eosborne) [mailto:[email-masked]] 
Sent: 02 December 2010 15:38
To: LEVRAU, LIEVEN (LIEVEN); Rajiv Asati (rajiva); Yuanlong Jiang
Cc: [email-masked]; Sprecher,Nurit (NSN - IL/Hod HaSharon); MPLS-TP ad hoc team; [email-masked]; [email-masked]
Subject: RE: [mpls] [PWE3] [AHMPLS-TP] Re:[mpls-tp] pollondraft-he-mpls-tp-csf-03.txt

Of
hoc
pollondraft-he-mpls-
and

eric

Of
pollondraft-he-mpls-
needed.
capability,
<[email-masked]>
"Loa
PW,
care
service-LSP
Behalf
[email-masked];
[email-masked];
"MPLS-TP
maililng