Subject: some questions about mpls

From: "aaa" <[email-masked]>
Date: Fri, 17 Sep 1999 07:58:22 +0800

Dear  sir(or lady):
    Glad to ask your some questions about MPLS online. I think it is
significant.
    This time, I have three questions to ask you. I think you should answer
me immediately, shouldn't you?
1.Could you tell me the format of the shim? (if you can tell me with the  
  diagrammative, it is very good)   
2.How to combine the control component and the forwarding component?
3.How to create a forwarding table from the IP routing tabel?
               Sorry for my broken-English.
                   Expect to your answer!!!
                                         yours  qjqin       
       please <mailto:[email-masked]> ,thinks.

---

From: Shahram Davari <[email-masked]>
Date: Thu, 16 Sep 1999 17:19:13 -0700

Hi,
 
1) Here is the format of shim header:
_______________________________________________________
|                                     |                      |
|                    |
|       Label   (20 bits)       |    EXP(3 bits)   | S (1 bit) |  TTL (8
bits) |
|_____________________|_____________|________|___________|

EXP is experimental bits
S is end of stack
TTL is Time To Live
 
2) Control component is implemented completely independent of forwarding
component.
 
3) You have to map IP routing table's entries to FECs and then each FEC is
mapped to a label.

Shahram

-----Original Message-----
From: aaa [mailto:[email-masked]]
Sent: Thursday, September 16, 1999 4:58 PM
To: [email-masked]
Subject: some questions about mpls

Dear  sir(or lady):
    Glad to ask your some questions about MPLS online. I think it is
significant.
    This time, I have three questions to ask you. I think you should answer
me immediately, shouldn't you?
1.Could you tell me the format of the shim? (if you can tell me with 
  diagrammative, it is very good)   
2.How to combine the control component and the forwarding component?
3.How to create a forwarding table from the IP routing tabel?
               Sorry for my broken-English.
                   Expect to your answer!!!
                                         yours  qjqin       
       please < mailto:[email-masked] <mailto:[email-masked]> > ,thinks.

---

From: Shahram Davari <[email-masked]>
Date: Thu, 16 Sep 1999 17:24:36 -0700

Sorry if the figure was corrupted. Here is a better version.

Hi,

Label   (20 bits) ,   EXP(3 bits) ,   S (1 bit)  ,   TTL (8 bits) 
 
EXP is experimental bits
S is end of stack
TTL is Time To Live

Shahram

-----Original Message-----
From: aaa [mailto:[email-masked]]
Sent: Thursday, September 16, 1999 4:58 PM
To: [email-masked]
Subject: some questions about mpls

Dear  sir(or lady):