Subject: ATM and POS interfaces on a router and MPLS operation

From: "Badarinath Devalla" <[email-masked]>
Date: Thu, 2 Sep 1999 16:43:47 -0500

Howdy !
Question on encapsulation/transformation:

Consider the following config:
ATM Switch ---- Router ------ Router - ATM Switch

All packets in this network are IP (AAL5 encapsulation)
ATM switch is connected to the router via an ATM interface (say OC12-ATM).
The Routers are connected via Packet-over-SONET backbone ie Router trunks
are OC48-POS -
I am trying to understand the encapsulation/transformation an IP packet that
goes through in a non-MPLS and a MPLS context -

AAL5 + IP -----> PPP + IP ----> AAL5+IP (i.e. transformation)

OR
AAL5 + IP -------> PPP + AAL5+IP ----------> AAL5+IP (i.e. encapsulation)

Now, what happens if the ATM switch is configured as an MPLS Label Edge
Device ?- will the transformation still work or are we forced to use
encapsulation ?

Any drafts relevant to this question ?

Thanks in advance

badari

-----
Badari Devalla
IP & ATM Network Planning
Nortel Networks Systems Engineering, Richardson
[email-masked]
Tel: (972) 685 5174 (W), (972) 414 6453 (H)

---

From: Shahram Davari <[email-masked]>
Date: Thu, 2 Sep 1999 16:02:27 -0700

Hi,

In the absence of MPLS, the "transformation" is the only accepted method,
because a router needs to access the IP header after terminating PPP, and
there is no PPP protocol-ID for AAL5.

In MPLS context, also  "transformation" is the correct way to go. Because
suppose your second router wants to send the packet to another
non-ATM-router but without an MPLS Label. In this case using encapsulation
PPP+Label+AAL5+IP, creates a problem because again the router can't access
the IP header for routing.

Shahram Davari
PMC-Sierra Inc.

-----Original Message-----
From: Badarinath Devalla [mailto:[email-masked]]
Sent: Thursday, September 02, 1999 2:44 PM
To: [email-masked]'
Cc: Badarinath Devalla
Subject: ATM and POS interfaces on a router and MPLS operation

Howdy !

OR

Thanks in advance

badari

-----
Badari Devalla

---

From: Abhishek Singh <[email-masked]>
Date: Thu, 2 Sep 1999 18:59:11 -0700 (PDT)

> Now, what happens if the ATM switch is configured as
 
I thought only routers could act as MPLS edge devices,
switches would act as forwading engines(sitting in the
core).

So a configuration of
Router---Switch--------Switch------Router
would be more relevant.

And MPLS is all about that.

Abhishek

===
Go to 
http://abhishekrs.eCode.com 
to pick up my online Business Card.
__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

---

From: [email-masked]
Date: Fri, 3 Sep 1999 08:15:31 -0400

It is my understanding that you could also have the following protocol trail:
(not an exhaustive list)

1) AAL5 + IP -----> SONET/SDH + Byte HDLC + FR + IP ----> AAL5+IP
2) AAL5 + IP -----> SONET/SDH + Byte HDLC + "Shim Header" + IP ----> AAL5+IP

The PPP layer is not essential to running IP over SONET/SDH links.
(depends on many factors)

Regards.

---
Jean-Lou Dupont
Marconi Communications

"Badarinath Devalla" <[email-masked]> on 09/02/99 05:43:47 PM

To:   "[email-masked]'" <[email-masked]>
cc:   "Badarinath Devalla" <[email-masked]> (bcc: Jeanlou
      Dupont/RMQ/RELTECCORP)

Howdy !

OR

Thanks in advance

badari

-----
Badari Devalla