Subject: RE: Notification message: "session rejected, no Hello"

From: Bora Akyol <[email-masked]>
Date: Mon, 27 Sep 1999 12:59:19 -0700

I think that when a LDP session is rejected the LDP ID should be set to a
well-known invalid value. All zeros comes to mind.

Bora

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Vasanthi
Thirumalai
Sent: Thursday, September 23, 1999 8:36 PM
To: Vrishab Sikand
Cc: MPLS
Subject: Re: Notification message: "session rejected, no Hello"

Vrishab,
   Since the spec. is not so clear as to what LDP ID should
be sent in this case, what seems to be the safest in the
situation is to copy the "Receiver LDP ID" from the
Initialization message into the notification message.
    In any case the TCP connection would be torn
down following transmission of the notification
message by the passive LSR.

Vrishab Sikand wrote:

> This section in LDP-05 states that The Ldp identifier "Six octet field
that
> uniquely identifies the label space of the
>      sending LSR for which this PDU applies."
>
> Now think of the scenario i am describing, the passive LSR accepts a TCP
> connection from the
> peer, it has to wait for the Init message before it can know which Label
> Space (or adjacency the peer is talking about)
> on receiving the first Ldp Pdu on this connection it determines that it
has
> No Matching Hello adjacency.
>
> Now it has to build and send a notification message with status = 10
> (session rejected , no hello)
> But since it has no adjacency with this peer, what would be the LDP
> Identifier in this notification message
>
> 3.1. LDP PDUs
>
>    Each LDP PDU is an LDP header followed by one or more LDP messages.
>    The LDP header is:
>
>     0                   1                   2                   3
>     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |  Version                      |         PDU Length            |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |                         LDP Identifier                        |
>    +                               +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |                               |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>    Version
>      Two octet unsigned integer containing the version number of the
>      protocol.  This version of the specification specifies LDP protocol
>      version 1.
>
>    PDU Length
>      Two octet integer specifying the total length of this PDU in
>      octets, excluding the Version and PDU Length fields.
>
>      The maximum allowable PDU Length is negotiable when an LDP session
>      is initialized.  Prior to completion of the negotiation the maximum
>      allowable length is 4096 bytes.
>
>    LDP Identifier
>
> Andersson, et al.                                              [Page 29]
>
> Internet Draft         draft-ietf-mpls-ldp-05.txt              June 1999
>
>      Six octet field that uniquely identifies the label space of the
>      sending LSR for which this PDU applies.  The first four octets
>      encode an IP address assigned to the LSR.  This address should be
>      the router-id, also used to identify the LSR in loop detection Path
>      Vectors.  The last two octets identify a label space within the
>      LSR.  For a platform-wide label space, these should both be zero.
>
> Srinivasan Balaji wrote:
>
> > Vrishab,
> >    I guess you wanted to say that the "Receiver LDP Identifier"
> > in the Initialization message should be the LDP ID in the Notification.
> >
> > Right ?
> >
> > Vrishab Sikand wrote:
> >
> > > LDP-05 calls for passive LSR to send a notification message during
> > > session initialization, when
> > > no matching hello adjacency is found.
> > >
> > > My Q is what LDP ID, will you put in the Header of this  notification
> > > message?? you have established
> > > no adjacency with this potential peer hence there is no valid Label
> > > space ID to insert.
> > >
> > > I suggest that the
> > >
> > > --
> > > tx
> > > Vrishab Sikand
> >
> > --
> >   -----------------------------------------------------------------
> >   Srinivasan Balaji
> >   Ficon Technology
> >   Voice : (732) 283-2770 xtn.303
> >   Fax   : (732) 283-2848
> >   mailto:[email-masked]
> >   Web   : http://www.ficon-tech.com
> >   -----------------------------------------------------------------
>
> --
> tx
> Vrishab Sikand
>
> Quarry Technologies
> 8 New England Office Park
> Burlington Ma 01803
>
> Off : 781 505 8300 ext. 332
> Fax : 781 505 8316
> Res.: 781 395 7280

Vasanthi Thirumalai
Lucent Technologies

---

From: Bob Thomas <[email-masked]>
Date: Mon, 27 Sep 1999 16:35:53 -0400

> well-known invalid value. All zeros comes to mind.

My understanding of the scenario being discussed is:

1.  LSR A and LSR B establish a session TCP connection.

2.  LSR A plays the active role; LSR B plays the passive role.

3.  LSR A sends LSR B an Initialization message.

    - The LDP Id in the PDU header of the PDU carrying the Initialization
       message is a.b.c.d:i.

    - The Initialization message carries a Common Session Parameters TLV
      with Recevier LDP Identifier field specifying LDP ID  w.x.y.z:j

4.  LSR B has no Hello adjacency corresponding to the LDP Id a.b.c.d:i.

And, the question is:

  What LDP Id should appear in the PDU header for the PDU from LSR B to
  LSR A that carries the Notification mesasage with the Status Code
  Session Rejected/No Hello?

My opinion on this is that the LPD Id should be w.x.y.z:j, since:

1.  That is the LDP Id (identifying a label space of LSR B) that LSR A
    specified in its Initialization message, and 

2.  That is the LDP Id LSR A expects to see in the PDU header for messages
    from LSR B carried by the (about to be closed) session TCP connection.

Bob