Subject: RE: LDP MIB-03: Can FEC have only one LSP.

From: Shahram Davari <[email-masked]>
Date: Fri, 29 Oct 1999 09:14:42 -0700

Hi,

It is correct. Assigning one FEC to multiple LSPs are also required for
Diffserv operation over MPLS, which may require different Classes be
transported via different LSPs.

Regards,
Shahram Davari
PMC-Sierra Inc.

> -----Original Message-----
> From: Barry Hass [mailto:[email-masked]]
> Sent: Friday, October 29, 1999 8:00 AM
> To: Joan Cucchiara
> Cc: Anup Anil Cheruvathoor; [email-masked]
> Subject: Re: LDP MIB-03: Can FEC have only one LSP.
> 
> 
> Hi Joan,
> 
> I think Anup is asking the opposite question to the one you answered -
> can a FEC be associated with more than one LSP? This might be
> useful for load sharing.
> 
> Thanks,
> Barry
> 
> Joan Cucchiara wrote:
> 
> > Anup Anil Cheruvathoor wrote:
> > >
> > > Hi,
> >
> > Hi Anup,
> >
> > >     It seems from the MIB that a single FEC can have only
> > > one LSP associated with it.
> > >     FEC can have multiple LSPs associated with it.
> > >     Shouldn't  the mapping be such that FEC can have
> > > multiple LSPs.
> > >
> > >     mplsLdpFecEntry OBJECT-TYPE
> > >          SYNTAX      MplsLdpFecEntry
> > >          MAX-ACCESS  not-accessible
> > >          STATUS      current
> > >          DESCRIPTION
> > >              "Each row represents a single FEC Element."
> > >          INDEX       { mplsLdpFecType,
> > >                        mplsLdpFecAddressFamily,
> > >                        mplsLdpFecAddressLength,
> > >                        mplsLdpFecAddress }
> > >          ::= { mplsLdpFecTable 1 }
> > >
> > >      MplsLdpFecEntry ::= SEQUENCE {
> > >          mplsLdpFecType           INTEGER,
> > >          mplsLdpFecAddressFamily  AddressFamilyNumbers,
> > >          mplsLdpFecAddressLength  Integer32(0..255),
> > >          mplsLdpFecAddress        MplsLdpGenAddr,
> > >          mplsLdpFecLspId          Unsigned32
> > >      }
> > >
> > >     This seems to show that FEC can have only one LSP
> > > associated with it.
> >
> > There can be multiple FEC's associated with the same LSP.  Please
> > note that the LspId is NOT part of the index, this could be the
> > same value for one or more entries in the table.  In other words,
> > the same LSP-ID could have multiple FEC's associated with it.
> >
> > I should also point out that this table is NOT sorted on LSP-ID,
> > and that if a manager wanted to display the FECs with a specific
> > LSP-ID it would need to read through the entire table, checking
> > the specific mplsLdpFecLspId object.
> >
> > >     This can be enhanced by providing a index for
> > > MplsLdpFecEntry also.So that multiple such entries are
> > >     present in the FEC.
> >
> > We could change indexing here by including the LspId as
> > part of the index, that's true.  It would be good to
> > get more feedback on this from the working group.
> >
> >         Thanks, Joan
> >
> > >
> > > Ragards,
> > >     -Anup
> > >
> > > --
> > >
> > > Name : Anup Anil Chervathoor
> > > E-mail : mailto:[email-masked]
> > > Web : www.ficon-tech.com
>

---

From: Barry Hass <[email-masked]>
Date: Fri, 29 Oct 1999 12:32:22 -0400

In this case, wouldn't traffic requiring different classes of service be
assigned
to different FECs?

---

From: Mohammed Hendaz <[email-masked]>
Date: Fri, 29 Oct 1999 16:10:43 -0400

if the FEC is, for example, the BGP next hop then different CoS having the
same
BGP next hop would share the same FEC and not different ones.

Mohammed.