Subject: Looking for a solution for vc merge in FR mpls network

From: Chen Liang <[email-masked]>
Date: Sat, 16 Oct 1999 08:12:23 -0700 (PDT)

I'm looking for ways to support vc merge in FR MPLS
network.Can somebody tell me some suggestion about
that?If I use a buffer to store the arrived frame,how
can I know the end frame of the network layer data>
package?
Please give some idea to me. Thank you.

Chen Liang
1999.10.16

=====

__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Mon, 18 Oct 1999 09:57:22 -0400

> Please give some idea to me. Thank you.

  Hi Chen,

  Good news, VC merge is only a problem on ATM where
the frame is split into cells by AAL5. The VC merge problem
is really a problem with AAL5 . This is because AAL5 does not have
any way to know if a cell belongs to this frame or some
other frame, it simply assumes all cells between certain
markers are part of the same frame so it gets confused if
cells get misordered or mixed up.

  With Frame relay, or any other frame based protocol 
there is no merge problem. The frames arrive ingress and
are transmitted to the outgoing port as a complete frame.
The frames will then arrive intact at the egress LSR which 
will strip the DLCI header and deliver the frame to IP for
routing. 

  Hope this helps,

  Peter Ashwood-Smith

---

From: Jeremy Lawrence <[email-masked]>
Date: Tue, 19 Oct 1999 11:19:09 +1000

Peter,

At 09:57 10/18/1999 -0400, Peter Ashwood-Smith wrote:
[...]
>will strip the DLCI header and deliver the frame to IP for

On the other hand, there may be FR switches which cannot do
VC merge because their hardware may have minor limitations
based on the assumption that all FR connections are
point-to-point. As far as I know, none of the ITU-T or FR
Forum specs define multipoint-to-point FR connections, so
it cannot automatically be assumed that any old FR switch
supports VC Merge.

The modifications would typically be minor for the reasons
you mention, but they might involve new cards or more
substantial replacement of the switches concerned.

Regards,

Jeremy Lawrence

---

From: Eric Gray <[email-masked]>
Date: Tue, 19 Oct 1999 08:14:07 -0400

Jeremy,

	What you say is true, but in all fairness to Peter,
I believe he correctly answered the question being asked -
which was about the queuing of frames and not the merging
of DLCIs...