Subject: Re: egress LSR

From: [email-masked]
Date: Fri, 15 Oct 1999 18:09:46 +0800

>   An LSR R1 is considered to be an "LSP Proxy Egress" LSR for address
>   prefix X if and only if:

>      1. R1's next hop for X is R2, and R1 and R2 are not label
>       distribution peers with respect to X (perhaps because R2 does
>         not support MPLS), or

>[ For me this case is a little unclear.  Consider the following cases.
>  - My downstream for this FEC does not support MPLS. 
Proxy egress can be used.

>  - My downstream for this FEC is an LSR but my LDP session to that peer is
>not up.
Can't the LSR act as a Proxy egress before the LDP session has been established.
Once, the session has been established, the LSR can become a transit LSR.

>  - I have a session to my downstream peer, however when I requested 
>  a label for the FEC he responded with either "no route" or "no resource" 
>  notification. 
LSR should not be Egress

>  It seems pretty certain that in first case we would consider ourselves
>the egress
>  but how about the second two cases ? 
>  My inclination is that we would not want to be the egress in the last two
cases. 
> ]
There may be a need to have "Proxy Egress" as configurable option.

cheers,
chetan

---

From: Vrishab Sikand <[email-masked]>
Date: Fri, 15 Oct 1999 15:07:33 -0400

> Once, the session has been established, the LSR can become a transit LSR.

How about the special case of this situation (downstream on demand, ordered control
mode):
if LSR1 determines by some means that LSR5 is a egress for FEC's X,Y,Z. It then it
decides to ask for
a label for address prefix FEC 128.89.0.1/32 which is LSR 5's host address. It
intends to do egress targeted
LSP's fec's X,Y,Z.

In this case LSR3 cannot become proxy egress. If it does become proxy egress, it MAY
not know how to forward the packets via IP
for some of packets coming in on this LSP.

I assume in order for Egress targeted to work, we have  to make a rule that only the
LSR whose local address matches the 32 prefix can assign a label
for a 32 bit mask, Address prefix type FEC.
                  ______________________________________________________________
                 |                       MPLS
Domain
|          Non Mpls Domain fec X, Y, Z
 ----->---  |       LSR 1
---------LSR2-----------LSR3+++++LSR4--------------LSR5         |----->--------

|
(LSR 5 Host address |

|
128.89.0.1).            |

|
egress for FEC X,Y,Z  |
                 | ______________________________________________________________|

--
tx
Vrishab Sikand