Subject: clarification on "LSR ingress for FEC"

From: [email-masked] (Mukul Katiyar)
Date: Tue, 5 Oct 1999 12:26:48 -0700

Hi all,
 
I need some clarification on the terminology "Is LSR ingress for FEC"
in the context of hop-by-hop routed LSPs.

How does a LSR decide it is to behave as an Ingress for a FEC.
FECs are reachability information obtained from the a router's
routing database. 

As it appears from the term "Ingress for the FEC", for a LSR to
know if it is to behave as an ingress for a given FEC, it must
be able to conclude that it shall not be used as a next hop for 
that FEC by any other LSR/LER. 
 
If one were to assume the above interpretation, the LSR would need
to be aware of the complete topology of the network; not only from it's
own point of view but from the pespective of every other node in that
domain!, which sounds quite impractical. 

Another offshoot in that case may be that the LSR behaving as
an ingress for a FEC may not distribute any label mappings
to any of the peers irrespective of the distribution mode. 

Please correct me if I am wrong or missing some thing.
Any clarification regarding this issue will be greatly appreciated.

Regards
-mukul

---

From: Vasanthi Thirumalai <[email-masked]>
Date: Tue, 05 Oct 1999 16:35:21 -0400

Mukul,
   Ingress (in the FEC case) only means that IP packets with some
destination constraint would be mapped to the LSP at the node. It
does not eliminate the possibility of the node being the transit for the same
FEC.
   The behaviour is entirely dependent on the configuration on that node
which would be done depending on the position of the LSR in the
network and other policies.

-Vasanthi

-- 
------------------------------------------------
Vasanthi Thirumalai         Phone: 732-949-3787
Lucent Technologies         Room : 2J-643
101 Crawfords Corner
Holmdel, NJ-07733
------------------------------------------------

---

From: Anup Anil Cheruvathoor <[email-masked]>
Date: Wed, 06 Oct 1999 09:22:41 +0530

Hi mukul,
   A example for vasanthi's point .
A LSR can act like the ingress as well as the transit for the
same FEC. There is no restriction on this. For eg:

              A
                   \__
                        B---C----D----- ...... X

consider A and B LSRs as the edge nodes of the MPLS domain. For some destination
say X , the path from A to X includes B in the path.

B also gets unlabeled packets coming to it from non-mpls domain
destined for X.
So B would be acting as the Ingress for unlabeled packets for X. and transit for
traffic
from A to X.

-Cheru

--

Name : Anup Anil Chervathoor
E-mail : mailto:[email-masked]
Web : www.ficon-tech.com