Subject: Questions about LDP MIB

From: James Cheng <[email-masked]>
Date: Mon, 25 Oct 1999 21:12:00 -0500

Hi:
        I have questions about LDP MIB defined under
"draft-ietf-mpls-ldp-mib-03.txt"

Q1: In the "draft-ietf-mpls-ldp-06.txt", it mention the label
         distribution control mode at 2.6.1.1, either Ordered or
Independent.
         How come no associated object identifier get defined?

Q2:  Both in LDP Spec section 2.5.5  and LDP MIB LDP Hello Adjacency
Table
          mention "An LDP session with a peer has one or more Hello
adjacencies."

          I can not figure out relationship between session table and
          hello adjacencies table based on the index field of
mplsLdpHelloAdjacencyEntry.

           Do it mean
           INDEX       { mplsLdpEntityLdpId,
                       mplsLdpEntityIndex,
                       mplsLdpPeerLdpId,
                       mplsLdpPeerIndex,
                       mplsLdpHelloAdjacencyIndex }
           or
          INDEX       { mplsLdpEntityLdpId,
                       mplsLdpEntityIndex,
                       mplsLdpPeerLdpId,
                       mplsLdpPeerIndex,
                       mplsLdpSessionIndex,
                       mplsLdpHelloAdjacencyIndex }

Thanks

---

From: Joan Cucchiara <[email-masked]>
Date: Tue, 26 Oct 1999 11:25:33 -0400

James Cheng wrote:

Hi James,

>          How come no associated object identifier get defined?

Yes, we could add an object, mplsLdpEntityControlMethod, to
the mplsLdpEntityTable to represent this:

mplsLdpEntityControlMethod OBJECT-TYPE
    SYNTAX      INTEGER {
                   independent(1),
                   ordered(2)
                }
    MAX-ACCESS  read-create
    STATUS      current
    DESCRIPTION
        "This object indicates whether the LSR is operating
        with independent or odered LSP control."
    ::= { mplsLdpEntityEntry 11 }

>                        mplsLdpHelloAdjacencyIndex }

Yes, this was pointed out previously and should have been fixed
but wasn't.  Another index needs to be added here also.

    INDEX       { mplsLdpEntityLdpId,
                  mplsLdpEntityIndex,
                  mplsLdpPeerLdpId,
                  mplsLdpPeerIndex,
                  mplsLdpSessionIndexOrZero,  <--- additional index
                  mplsLdpHelloAdjacencyIndex }
    ::= { mplsLdpHelloAdjacencyTable 1 }

....

mplsLdpSessionIndexOrZero OBJECT-TYPE
    SYNTAX      Unsigned32 (0..4294967295)
    MAX-ACCESS  not-accessible
    STATUS      current
    DESCRIPTION
        "This index should have the same value of the
mplsLdpSessionIndex
        if it is known, otherwise, it will have the special value of
zero,
        which means that there is no session currently associated with
the
        Hello Adjacency represented by this entry."
    ::= { mplsLdpHelloAdjacencyEntry 1 }

Thanks for your comments.

	-Joan