Subject: Question on Label Stack Table on LSR MIB

From: James Cheng <[email-masked]>
Date: Tue, 19 Oct 1999 13:55:25 -0500

I have question about Label Stack Table on LSR MIB defined under
"draft-ietf-mpls-lsr-mib-00.txt".

mplsLabelStackEntry OBJECT-TYPE
   SYNTAX                  MplsLabelStackEntry
   MAX-ACCESS    not-accessible
   STATUS                   current
   DESCRIPTION
       "An  entry in this table represents one label  to  be
        pushed  onto  an  outgoing packets beneath  the  top
        label.   An  entry  can  be  created  by  a  network
        administrator  or by an SNMP agent as instructed  by
        LDP or RSVP."
   INDEX         { mplsLabelStackIndex }
      ::= { mplsLabelStackTable 1 }

My question is on the INDEX.  It should be changed  to
   INDEX         { mplsLabelStackIndex , mplsLabelStackLabelIndex}

Thanks

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 19 Oct 1999 19:25:19 -0400

>    INDEX         { mplsLabelStackIndex , mplsLabelStackLabelIndex}

         Hi,

         That is a good point. The table should be doubly-indexed. After
looking at this for several minutes and scratching my head, allow me to
make a suggestion regarding the alteration of the descriptive text for the
mplsLableStackLabelIndex which may make it a bit easier to understand:

mplsLabelStackLabelIndex OBJECT-TYPE
    SYNTAX        Integer32
    MAX-ACCESS    not-accessible
    STATUS        current
    DESCRIPTION
        "This secondary index is used to identify one of the labels
         within a specific label stack, denoted by mplsLabelStackIndex.
         Note that in the case that there is only a single label in any
         particular stack, this secondary index will only take on the
         value 1."
    ::= { mplsLabelStackEntry 2 }