Subject: Questions for "Extensions to RSVP for LSP tunnels"

From: Marco Tana <[email-masked]>
Date: Thu, 28 Oct 1999 13:30:10 +0200 (CEST)

Thank you for reading this e-mail!
Can a SESSION consist of more than one tunnel or more than one LSP? (Which is the difference between LSP ID
and TUNNEL ID?)
If so, there will be more than one TUNNEL ID for a specific SESSION?
Is it possible to have more than one ingress node inside a SESSION?
Is IPv4 TUNNEL SENDER ADDRESS field in SENDER_TEMPLATE or FILTER_SPEC objects the address of a
sender host or an ingress node?
Hoping for a reply, I wish you all the best!

_________________________________________________________________________
la tua email gratuita e per sempre su http://www.freemail.it (anche POP3)

---

From: "Navin kumar Agrawal" <[email-masked]>
Date: Thu, 28 Oct 1999 19:27:46 +0530

> Can a SESSION consist of more than one tunnel or more than one LSP? (Which is the difference between LSP ID

A 'tunnel' can have more than one LSP, where the different LSPs may
have different starting points.

I would say that Tunnel id is one more level of abstraction of lsp id.

I guess the idea behind introducing virtual term like tunnel id, 
lsp id instead of source and destination port number is that it removes
the restriction in which the data flow has to start and terminate in 
a RSVP compliant network only. so the introduction of these virtual 
terms like tunnelid and lspid allows an MPLS/RSVP compliant network 
to be used as a pure transit network.

> If so, there will be more than one TUNNEL ID for a specific SESSION?

...oops, i am confused.
still let me try to answer...If you say there is one unique 
session...it should be different from others in some way...and it 
is possible that 'different' sessions may have 'same'  tunnel id. :-)

> Is it possible to have more than one ingress node inside a SESSION?

yep!
No doubt about it.
Session is something which is destination node oriented.

> Is IPv4 TUNNEL SENDER ADDRESS field in SENDER_TEMPLATE or FILTER_SPEC objects the address of a sender host or
> an ingress node?

yes it is the address of the sender node.

Hope this helps,

Regards,
Navin

---

From: Rohit Chhapolia <[email-masked]>
Date: Thu, 28 Oct 1999 09:57:04 -0400

Hello Marco,

> Can a SESSION consist of more than one tunnel or more than one LSP? (Which is the difference between LSP ID

In general, yes. A LSP is unique per combination of Session and Sender Template.
However, these set of LSPs for a session should share resources (bandwidth) on the
common nodes.

> If so, there will be more than one TUNNEL ID for a specific SESSION?

No, changing the TUNNEL ID changes the session. This can be achieved by changing
the LSP ID.

> Is it possible to have more than one ingress node inside a SESSION?

Yes, this can be achieved by setting the Extended Tunnel Id to all zeros.
Different ingress nodes can use this session value (possibly by configuring
these nodes to use same TUNNEL ID) and having different sender templates.

> sender host or an ingress node?

In general, it should be address of the sender host. But, it may be set to that of
ingress node depending on which node handles the PATH ERROR messages and possibly
other policies.

Rohit
-- 
Rohit Chhapolia
Ficon Technology, Inc.
mailto:[email-masked]
http://www.ficon-tech.com