Subject: RE: Last call for draft-ietf-mpls-icmp-00.txt

From: Rahul Kasralikar <[email-masked]>
Date: Thu, 28 Oct 1999 15:33:17 -0700

This is a question related to mpls-icmp. (It refers to sections 2.3.2
of mpls-label-encaps.)

In section 2.3.2 of mpls-label-encaps-07: Suppose you are tunneling
private addresses (AS1-src, AS2-transit, AS3-dest). LSR R1 in AS2 wants
to send ICMP error.

Suppose you have an LSP loop exclusively within AS2 and the loop starts
after LSR R1. (But there was a TTL error at R1.) When the ICMP error is
sent to the destination, it will loop too. At then end of the loop -
1. either the original ICMP error is discarded
2. it ends up in a rtr which does not know how to get to the source of
original pkt.

In either case, you can't get to the source of the original pkt.

Is this correct? Your answers will be appreciated..

Rahul Kasralikar

> -----Original Message-----
> From: Vijay Srinivasan [mailto:[email-masked]]
> Sent: Thursday, October 28, 1999 10:21 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Last call for draft-ietf-mpls-icmp-00.txt
> 
> 
> 
> We have received a request to evaluate whether
> draft-ietf-mpls-icmp-00.txt (ICMP Extensions for MPLS) is ready for
> publication as an RFC.
> 
> This note serves to commence the WG last call for this document.  The
> last call will end on Friday, Nov 5, 1999.
>

---

From: Ron Bonica <[email-masked]>
Date: Thu, 28 Oct 1999 23:21:17 -0400

Rahul,

In this matter, draft-ietf-mpls-icmp-00.txt defers to
draft-ietf-mpls-label-encapse-07.txt. Please see the
disclaimer in Section 5 of draft-ietf-mpls-icmp-00.txt.

Rather than offering my interpretation of the encapsulation draft, I will
let the authors of that document speak for themselves.

                         Thanks,
                           Ron

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Rahul
> Kasralikar
> Sent: Thursday, October 28, 1999 6:33 PM
> To: 'Vijay Srinivasan'; [email-masked]'
> Subject: RE: Last call for draft-ietf-mpls-icmp-00.txt
>
>