Subject: RE: VC "unmerging" - MPLS using ATM VC switching related

From: "Lin, Si-Jian" <[email-masked]>
Date: Wed, 20 Oct 1999 14:50:58 -0500

Yes S2 has to process IP layer. In your case S2 advertise one 
route for two destinations. Whenever you do route aggregate
you do have to go higher layer; it's not ATM specific.

The same applies to OSPF backbone routers and BGP routers who arregate
area/AS routes.

Sijian 

-----Original Message-----
From: alper altinordu ee stnt [mailto:[email-masked]]
Sent: Wednesday, October 20, 1999 2:35 PM
To: [email-masked]
Subject: VC "unmerging" - MPLS using ATM VC switching related

Hi All,

I have a question regarding to MPLS using ATM VC switching. I would like
to know how AAL5 frames are separated once they are VC merged. It seems
that there's no way to separate the frames without processing the upper
level (i.e. IP) header.

Let me specify my question more precisely:
 
(Payload, VPI/VCI)  <- Let this represent an ATM cell
 
[Payload, VPI/VCI)  <- and this be an AAL5 EoP cell
 
SW-1 is a VC Merge capable switch
It merges the VCs a/b and c/d to the VC x/y
 
A is the destination of the cells of the VC a/b
C is the destination of the cells of the VC c/d
 
[5,a/b)_(2,a/b)_(1,a/b)  _____                         _____ 
                       \_|_ _|_         [4,x/y)(3,x/y)_|_ _|_____ Dest A
                        _|_/ | [5,x/y)(2,x,y)(1,x/y)   |  \|
___[4,c/d)___(3,c/d)___/ |S-1|                         |S-2|----- Dest C
                         |___|                         |___|
 
Switch 1 (S-1) receives packets P-1 consisting of cells with payloads 1,2
and 5 and P-2 with payloads 3 and 4. S-1 reassembles (or just buffers
until the EoP cells are received) the packets and VC merges them on the
VC x/y and transmits P-2 first followed by P-1 to S-2.
 
Now the question is how does S-2 know it should send the first incoming
packet (P2) to "Dest C" output port and the second incoming one (P1) to
the "Dest A" output port? Is there a way to know this without reassembling
the packets and processing the IP (or other upper level) header?
 
Thank you
 
Alper Altinordu

---

From: Shahram Davari <[email-masked]>
Date: Wed, 20 Oct 1999 15:09:41 -0700

Correct. May I also add that if you require no IP lookup at S2, then you
shouldn't do VC-merge at S1. VC-merge, is usually done to deliver the
packets to an egress ATM LSR, in which it goes up to the IP layer.

-Shahram 

> From: Lin, Si-Jian [mailto:[email-masked]]
> Sent: Wednesday, October 20, 1999 12:51 PM
> To: 'alper altinordu ee stnt'; [email-masked]
> Subject: RE: VC "unmerging" - MPLS using ATM VC switching related
> 
>