Subject: egress LSR

From: "Santosh Gupta" <[email-masked]>
Date: Tue, 12 Oct 1999 17:39:22 +0530

Hello All,
    I am implementing ietf-draft-05.txt for LDP. My doubt is :
How does an LSR decide that it is the egress router for the particular LSP? 
Thanx in advance.
Santosh Gupta

---

From: Vasanthi Thirumalai <[email-masked]>
Date: Tue, 12 Oct 1999 10:08:14 -0400

Santosh,

    At the LSR in question, it would determine the next hop for the LSP
with the help of routing tables. If the next hop so found is not a
downstream neighboring LSR, then the LSR concludes that it is the egress
LSR for the given LSP.

Ofcourse if the LSP terminates at the LSR in question, it is the egress
LSR.

-Vasanthi
Santosh Gupta wrote:

>  Hello All,    I am implementing ietf-draft-05.txt for LDP. My doubt
> is :How does an LSR decide that it is the egress router for the
> particular LSP?Thanx in advance.Santosh Gupta

---

From: Eric Gray <[email-masked]>
Date: Tue, 12 Oct 1999 10:32:53 -0400

Santosh,

> How does an LSR decide that it is the egress router for the particular LSP?

An LSR could be implemented, or configured, to egress packets 
for any of a number of reasons, but it would 'decide' it is
the egress for a particular LSP when the FEC (or perhaps other
criteria used) in setting up the LSP is associated with a next
hop that is not a labeling peer or is not associated with any
next hop (other than 'self').

-- 
Eric Gray		Email: mailto:[email-masked]
Voice: (978)960-6162