Subject: draft-ietf-mpls-ldp-mib-03.txt - clarification

From: manikantan <[email-masked]>
Date: Tue, 26 Oct 1999 16:06:47 +0530

Hello

The mplsLdpLibTable has been added in the  <draft-ietf-mpls-ldp-mib-02.txt> and in <draft-ietf-mpls-ldp-mib-03.txt> .

The table has the fields "mplsLdpLibInLabel" and "mplsLdpLibOutLabel". The syntax for these two fields have been indicated as "MplsLdpGenAddr".

The description for the Textual-Convention "MplsLdpGenAddr" indicates it to be "the value of an network layer or data link layer address."

With the above description, the syntax does not holds good for the mib objects "mplsLdpLibInLabel" and "mplsLdpLibOutLabel".

The Textual convention "MplsLabel" as given below  and defined in <draft-ietf-mpls-lsr-mib-00.txt> appears to be applicable.

Any Suggestions? - Sorry if this has been pointed out earlier itself.

MplsLabel ::= TEXTUAL-CONVENTION
   STATUS        current
   DESCRIPTION
       "Represents an MPLS label.  Note that the contents of
        a  label  field are interpreted in an interface-type
        specific fashion.  For example, the label carried in
        the MPLS shim header is 20 bits wide and the top  12
        bits  must  be zero.  The frame relay label  can  be
        either 10, 17 or 23 bits wide depending on the  size
        of the DLCI field size and the top 22, 15, or 9 bits
        must  be  zero, respectively.  For an ATM interface,
        the  lowermost 16 bits are interpreted as  the  VCI,
        the  next  8 bits as the VPI and the remaining  bits
        must  be  zero.   Also  note the  permissible  label
        values  are  also a function of the interface  type.
        For  example,  the value 3 has special semantics  in
        the  control plane for an MPLS shim header label and
        is not a valid label value in the datapath."
   REFERENCE
       "1.  MPLS  Label Stack Encoding, Rosen et al,  draft-
        ietf-mpls-label-encaps-04.txt, April 1999.
       2.  Use  of  Label Switching on Frame Relay Networks,
        Conta et al, draft-ietf-mpls-fr-03.txt, Nov. 1998."
   SYNTAX Integer32

thanks in advance
with best regards
mani

/*-------------------------------------------------------------------*/
S.Manikantan
Project Manager
Future Software Private Limited
480-481, Anna salai, Nandanam,
Chennai, Tamil Nadu, 600 035,
India.
Phone	: +91-44-4330550
Fax	: +91-44-4344157.
Email	: [email-masked]
http://www.futsoft.com
/*--------------------------------------------------------------------*/

---

From: Joan Cucchiara <[email-masked]>
Date: Tue, 26 Oct 1999 11:57:15 -0400

Hi Mani,

> Any Suggestions? - Sorry if this has been pointed out earlier itself.

The TC below is certainly more specific.  We will look into the
possibility of using this one for the next rev.

Thank you for your suggestion.

	-Joan