Subject: Reserved label value 0.

From: "Eunah Kim" <[email-masked]>
Date: Wed, 17 Nov 1999 04:38:39 +0900

Hi, all.

In "draft-ietf-mpls-label-encaps-07.txt", there are several reserved label values.
The first, reserved value 0 is written like this, 

    ... A value of 0 represents the "IPv4 Explicit NULL Label".
        This label value is only legal when it is the sole label stack entry.
        It indicates that the label stack must be popped, and the forwarding 
        of the packet must then be based on the IPv4 header..... (p.5)
        
I have questions about this value, 0.

1. In the label value '3' case, it's said like this in this document, 
   
   ... A value of 3 represents the "Implicit NULL Label". This is label that 
       an LSR may assign and distribute, but which never actually appears 
       in the encapsulation..... (p.6)
       
   It means the value 3 is never used for input label on an LSR.
   Then how about label value 0? Is it possible for using the label value 0
   as an input label?

2. When is the value used? Is there any case for usage?

Best regards,
Eunah

----------------------------------------------------------------
Kim, EunAh
Protocol Eng. Lab,  Dept. of Computer Eng., ChungNam Nat'l Univ.
220 Goong-dong,Yusong-Gu, Taejeon, 305-764, Korea (R.O.K)
TEL   : +82-42-821-6280      FAX : +82-42-822-4997
mailto:[email-masked]
http://rose.ce.cnu.ac.kr/~eakim
----------------------------------------------------------------

---

From: Shahram Davari <[email-masked]>
Date: Tue, 16 Nov 1999 13:11:07 -0800

---[Shahram Davari] Hi,
 
See comments below.
 
 -Original Message-----
From: Eunah Kim [mailto:[email-masked]]
Sent: Tuesday, November 16, 1999 11:39 AM
To: [email-masked]
Subject: Reserved label value 0.

Hi, all.
 
In "draft-ietf-mpls-label-encaps-07.txt", there are several reserved label
values.
The first, reserved value 0 is written like this, 
 
    ... A value of 0 represents the "IPv4 Explicit NULL Label".
        This label value is only legal when it is the sole label stack
entry.
        It indicates that the label stack must be popped, and the
forwarding 
        of the packet must then be based on the IPv4 header..... (p.5)

   
   ... A value of 3 represents the "Implicit NULL Label". This is label
that 
       an LSR may assign and distribute, but which never actually appears 
       in the encapsulation..... (p.6)

[Shahram Davari]  Yes, it is possible to receive a packet with label=0.    

[Shahram Davari]  Label=0 is used when downstream node does not support
MPLS. Label=3 is used for pen-ultimate hop popping (PHP).

Best regards,
Eunah
 
----------------------------------------------------------------
Kim, 
Protocol Eng. Lab,  Dept. of Computer Eng., ChungNam Nat'l Univ.
220 Goong-dong,Yusong-Gu, Taejeon, 305-764, Korea (R.O.K)
TEL   : +82-42-821-6280      FAX : +82-42-822-4997
mailto:[email-masked] <mailto:[email-masked]> 
http://rose.ce.cnu.ac.kr/~eakim <http://rose.ce.cnu.ac.kr/~eakim> 
----------------------------------------------------------------