Subject: Question about "local repair" and "global repair"

From: "Masaharu Tomioka" <[email-masked]>
Date: Mon, 29 Nov 1999 18:00:18 +0900

Hi,All

I read "draft-ietf-mpls-ldp-06.txt" and "draft-ietf-mpls-ldp-state-02.txt".
But I was not  able to find about difference of "local repair" and
"global repair".
Please tell me about difference of "local repair" and "global repair".

Thanks.

---

From: Eric Gray <[email-masked]>
Date: Mon, 29 Nov 1999 08:21:30 -0500

Masaharu,

	We will review the draft to determine
if this issue can be made clearer.

	In brief - however - the difference is
in how a segment on an LSP that has changed is
dealt with.  I would expect no details of this
in [LDP] because it is a peculiarity of end-to-
end LSP setup (there is only local repair in 
hop-by-hop routed LSPs).

	If - for example - a CR-LSP is setup
using a loose explicit route, then there are
three things that an LSR at the edge of a loose
segment can do in the case where a better route
has been discovered for the loose segment:

  1) ignore the change - this would be what is
     done when the loose segment is 'pinned';
  2) attempt to establish a replacement segment
     using the new route - this is local repair;
  3) withdraw associated label mapping(s) to up-
     stream peer(s) - this is global repair.

There was discussion among the team about what
were appropriate actions when the loose segment
actually goes down - should a replacement be
signaled or should the ingress be notified via
a withdraw or global repair?  Could the 'pin'
bit be over-loaded to indicate what to do in
this case?  Ultimately, the global repair
approach seemed less questionable in this case, 
so that is what we tried to specify.  This 
does not preclude anyone bold enough to try a
different approach from doing so.