Subject: Question about Hello message

From: [email-masked]
Date: Wed, 10 Nov 1999 16:33:12 +0800

Hi,
 I'm trying to understand deeply about LDP. I have
a question about Hello message:

 Two LSR must negotiate their Hello hold time,
and Hello message must be sent through UDP multicast,
When LSR A send Hello message , and LSR B, LSR C receive
this message, LSR A and LSR B negotiate a hello hold time
of  10s, LSR A and LSR C negotiate a hello hold time of
20s.

Then what hello hold time should use when LSR A send
Hello message the next time? Because this Hello message
may be received by LSR B and LSR C.

---

From: "Prakash C. Jain" <[email-masked]>
Date: Wed, 10 Nov 1999 14:43:27 +0530

Hi,
I think you mean LSR B and LSR C are connected to LSR A on the same
interface.
In such case, LSR A should always send its own (configured) Hello Hold
time in all hello messages it sends over the interface. But, LSR A
should always use (eg. for calculating retransmission time for hellos it
sends) lowest of all negotiated Hello hold times with different peers
(eg. B & C) over the interface .
Regards,
Prakash

--
___________________________
Prakash C. Jain
Ficon Technology
mailto:[email-masked]
http://www.ficon-tech.com/