Subject: RE: Question related to shim header...

From: CATANZARITI Sergio FTR&D/TI <[email-masked]>
Date: Fri, 5 Nov 1999 13:18:07 -0800

From the document MPLS Label Stack Encoding:
>LSRs that are implemented on certain switching devices (such as ATM
switches) may use different encoding techniques for encoding the top one or
two entries of the label stack. When the label stack has additional entries,
however, the encoding technique described in this document MUST be used for
the additional label stack entries>
So, that means that if I choose to use VPI/VCI as the only label encoding
schema, I do NOT have to have additional fields, and a related shim header,
such as TTL, S, and EXP, for being MPLS-compliance (assuming that the
compliance category applies to MPLS...)
So, why MUST? Is it your interpretation of different encoding techniques? I
know that it would be good to have it for loop-related actions, but that it
is different from a MUST.
Please, answer me as much simple and short as possible.
Thanks,
Sergio

> --------------------------------------------------------------------
> Sergio Catanzariti
> Senior Project Manager, Technology Integration
> France Telecom R&D 
> 1000 Marina Boulevard Suite 300 
> Brisbane CA 94005
> Tel. 650-875-1526
> Fax. 650-875-1505
> email:[email-masked] 
> --------------------------------------------------------------------
> 
> 
> -----Original Message-----
> From:	Peter Ashwood-Smith [SMTP:[email-masked]]
> Sent:	Friday, November 05, 1999 6:47 AM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	Re: Question related to shim header...
> 
> > When L2 media is ATM & Frame relay, is shim header must or optional?
> 
>   Must, it carries the TTL.
> 
> > 
> > If L2 media is ethernet, what will be the case? Shim header is a must or
> > not?
> 
> > If it is optional, how we will find out whether shim header is present
> or
> > not?
> 
>   The Ethertype tells you if it is MPLS or not. If the Ethertype says its
> MPLS then there follows a shim header otherwise its whatever the Ethertype
> says.
> Two Ethertypes 0x8847 and 0x8848 indicate MPLS unicast and MPLS multicast.
> 
>   Cheers,
>  
>   Peter

---

From: [email-masked] (Test Civetta asic)
Date: Mon, 8 Nov 1999 12:03:47 +0100 (MET)

I think that there could be different situations:

One can be the following; two LSR are connected via an ATM PVC as in the example;

LSR ---> ATM switch ------> ATM switch -------> ATM switch --------LSR2

                              ATM PVC
   <-------------------------------------------------------------->

- the two LSR have ATM interfaces
- LSR1 sees LSR2 as "next-hop" where to perform MPLS lable swap (switch); ATM
  is seen as pure transport.

In this sceneario I think that:
- the whole label stack is included in the shim header, the ATM VPI/VCI fields are NOT considered
   as "label".
- the encapsulation can be one of the following:

   a) ATM/AAL-5 + LLC/SNAP + MPLS (shim) IPv4    (RFC1483: LLC encaps.)
   b) ATM/AAL-5 + MPLS (shim) + IPv4                       (RFC1483: VC-Mux encaps.)

I wonder if a PPP layer can add any benefit to this encapsulation. For example can encapsulations
a' and b' have a sense?

   a') ATM/AAL-5 + LLC/SNAP + PPP + MPLS (shim) IPv4    (RFC1483: LLC encaps.)
   b') ATM/AAL-5 + PPP + MPLS (shim) + IPv4                       (RFC1483: VC-Mux encaps.)

Regards

Civett