Subject: Questions on draft-swallow-rsvp-bypass-label-00.txt

From: Vishal Sharma <[email-masked]>
Date: Tue, 23 Nov 1999 11:04:54 -0500

George,

As discussed in the MPLS WG meeting on 11/11 (Thursday) at the DC
IETF, we are in the process of reconciling the terminology across the
various drafts addressing protection and LSP recovery, and have some
questions in this context.

(i) The term "local repair" is defined as referring to techniques which 
accomplish
reroute in 10s of milliseconds. By this definition it seems that "local repair" 
is related to time
and not to space (that is, the point at which the repair action is actually 
executed)?
It appears that this is not consistent with the notion of "local" repair being 
repair
that is "locally" executed, namely by the LSR closest to the point of failure.
Would you please define what you mean by local repair?

(ii) Is the bypass tunnel pre-established or dynamic? And if it is dynamic, how
would you propose accomplishing this.

(iii) In either one of the  examples considered in the draft, what happens if 
link R3-R4 fails?
How does R2 execute the local repair in this case? Is there an assumption
that R3-R4 is protected by say SONET APS?

Thanks,

-Vishal
*******************************************************
Vishal Sharma, Ph.D.  A small group of determined spirits with an
Research Engineer      unquenchable thirst for their mission can 
                                  alter the course of history. --- Gandhi
Tellabs Research Center
One Kendall Square      Phone: (617).577.8760
Bldg. 100, Suite 121         Fax: (617).494.0118
Cambridge, MA 02139   e-mail: [email-masked]
                                              [email-masked]
*******************************************************

---

From: George Swallow <[email-masked]>
Date: Tue, 23 Nov 1999 11:47:06 -0500

>Would you please define what you mean by local repair?

I mean the upstream router which is closest to the point of failure
(be that failure the next link or the next router).  

>would you propose accomplishing this.

Pre-established

>(iii) In either one of the  examples considered in the draft, what happens if 

As far as local repair goes that's up to R3.  R3 *may* endup routing
back through R2, but R2 would have no special role to play in such an
event.  

>How does R2 execute the local repair in this case? 

It doesn't.  Nor would that be local repair.

>Is there an assumption

The only assumption is that R2 doesn't have to worry about the link
R3-R4.

>-Vishal

...George

==================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 0182