Subject: RE: Why MPLS is called so

From: John Hopkins <[email-masked]>
Date: Thu, 4 Nov 1999 17:36:26 -0000

Hi Antti,

	I would think that providing the Voice/MPLS stack is the same as the IP/MPLS stack up to the shim layer, then an existing LSR would be able to switch it. One could include the labelled voice sample directly after the shim header (i.e. instead of the labelled IP packet), or possibly (e.g. in  trunking applications) concatenate them in order to improve efficiency further and reduce packet numbers going thru the lsr. Anyway, having had a look at your web site (following Yakov's hint) i'm sure you've put a lot more thought into it than i!

	cheers,
	john

> Yakov Rekhter wrote:
> 
> > John,
> >
> > > > But, for now, who cares about multiprotocol apart from IP.
> > >
> > > Well I'd like to send small voice packets over this kind of network
> > > without h aving to load them up with IP headers, SHIM headers and so
> > > on. 12 to 16 (say) b ytes of packetized voice sample doesn't get
> > > transported very efficiently if you add 20 bytes of IP header, plus 20
> > > bytes of UDP header ... plus 4 bytes of SHIM etc, etc.  In other words
> > > an LSP for packetised voice traffic that uses a compressed VoIP/MPLS
> > > stack that can still be switched by LSRs.
> >
> > You may talk to Antti Kankkunen (Integral Access Inc).
> >
> > Yakov.
> 
> We do indeed see an important class of applications where it makes sense to
> carry voice directly over MPLS. I would be very interested in sharing ideas
> with other parties who have recognized this fact. Please send me an e-mail
> and lets see if we can get some common effort going around VoMPLS.
> 
> Best regards,
> 
> Antti K.
> 
> --
> Antti Kankkunen
> Integral Access Inc.
> 321 Billerica Rd.
> Chelmsford, MA 01824
> Phone: +1 978 256 8833 x 232
> Mobile: +1 617 513 2172
> Fax: +1 978 256 8077
> e-mail: [email-masked]
>

---

From: Antti Kankkunen <[email-masked]>
Date: Thu, 04 Nov 1999 13:50:51 -0500

>         Hi Antti,
>
>         I would think that providing the Voice/MPLS stack is the same as the
> IP/MPLS stack up to the shim layer, then an existing LSR would be able to switch
> it. One could include the labelled voice sample directly after the shim header
> (i.e. instead of the labelled IP packet), or possibly (e.g. in  trunking
> applications) concatenate them in order to improve efficiency further and reduce
> packet numbers going thru the lsr. Anyway, having had a look at your web site
> (following Yakov's hint) i'm sure you've put a lot more thought into it than i!
>
>         cheers,
>         john
>

Hi John,

the approach you describe above is exactly what we are doing.

Best regards,

Antti K.