Subject: Recv Label Mapping procedure

From: "Siddharth Gahlaut" <[email-masked]>
Date: Mon, 29 Nov 1999 12:13:55 -0500

Hi,
I have a question regarding section A.1.2(Recv Label Mapping procedure).

The very 1st line (LMp.1) says:

LMp.1   Does the received label mapping match an outstanding label
           request for FEC previously sent to MsgSource.
           If not, goto LMp.9.

Loop Detection actions are performed between LMp.3 and LMp.8.
Should I assume that Loop Detection is configured ONLY for the case when
the Mapping
corresponds to a Request.Cause LMp.3 to Lmp.8 are only used when Lmp.1 holds
true.

If Loop Detection is  considered as an option then shouldnt  it  be:

LMp.1   Does the received label mapping match an outstanding label
           request for FEC previously sent to MsgSource.
           If not, goto LMp.3.
                (INSTEAD OF)
LMp.1   Does the received label mapping match an outstanding label
           request for FEC previously sent to MsgSource.
           If not, goto LMp.9.

I might be missing something  in understanding this procedure .Could someone
give me some pointers to it.

Thanx in advance.
Siddharth

---

From: "James R. Leu" <[email-masked]>
Date: Mon, 29 Nov 1999 12:59:58 -0500

> give me some pointers to it.

Basically what is being determined by LMp.1 is if this is a solicited mapping
or an unsolicited mapping.  If it is unsolicited, you need only decide if
it is valide according to your forwarding table (ie the next hop matches the
source of this mapping, LMp.10)

Provisions for loop detection for unsoliceted mappings are needed, but I think 
the procedures in "Recognize New FEC" and "Receive Label Mapping" (LMp.23) 
handle this.

Jim

-- 
James R. Leu         | Ericsson Datacom, Inc
Software Engineer    | IP Infrastructure
[email-masked]  | Morrisville, NC USA

---

From: Bob Thomas <[email-masked]>
Date: Mon, 29 Nov 1999 13:27:59 -0500

Siddharth,

> give me some pointers to it.

The loop detection mechanism is intended for use with the Label Mapping
and Label Request messages when operating in Downstream on Demand mode.

When operating in Downstream on Demand mode it is possible
to receive a Label Mapping message for which there is no outstanding
Label Request.

In this circumstance, (if loop detection is configured on) the loop detection
procedures should be executed.

Therefore, I agree with you.  LMp.1 should read:

Note that procedure Check_Received_Attributes (A.2.6) should probably have
a check to determine whether loop detection is configured on.

Thanks,
Bob