Subject: RE: Session Negotiation.

From: T M Kishore <[email-masked]>
Date: Wed, 17 Nov 1999 21:49:29 +0530

Hi Bob,
        I will ask my question in another way.

             Initially, session s2 between B and C  is established with DU 
mode due to B sent initailization message with DU to C .  Later Hello 
Messages are received from LSR A.  B supports both DU and DoD . Then 
session s1 is also established  with DoD since B can switch to DoD for 
session s1.
               That means session s1 sholud implement State Event Machine 
of DoD and Session s2 implement State Event Machine of DU .
                   In the above sitaution, if A sends Label Request Message 
to B , B will handle as in state Event Machine of DoD and finds that its 
next hop is C . Then B  will forward the Label Request Message  to LSR C 
using session s2.
If B receives Label Mapping Messages in session s2, it will go to State 
Event Machine( SEM)  of DU.
               Is it possible to have different SEMs for different sessions 
?
            How SEM of DU and DoD will communicate ?
             Then there should be some Internal events between  SEM of DoD 
and SEM of DU. Otherwise, Control Block which implements DoD will be in 
Response Awaited State.  LSP may not be established.
     If I am wrong anywhere, Please correct me.

Thanks,
Kishore.

-----Original Message-----
From:	Bob Thomas [SMTP:[email-masked]]
Sent:	Wednesday, November 17, 1999 7:48 PM
To:	T M Kishore
Cc:	T M Kishore; [email-masked]'; 
[email-masked]'; [email-masked]'
Subject:	Re: Session Negotiation.

Kishore,

>          Please see the following situation .
>               s1            s2
>          A --------> B---------> C  .
>
>             LSR A supports DoD, LSR B supports Both Dod and unsolicited 
and LSR C supports only Unsolicited and all liks are ATM .
> In above situation, session  s1 uses DoD and session s2 uses Unsolicited 
.
> Is It?
> Or session can not established?

Correct.

>               Suppose, we want to establish LSP between A to C, How will 
be established  ?

Not sure what the question is here.  Is it about DU / DoD or
about the fact that A and C are not directly connected?

Bob

> Please Clarify My doubt .

---

From: Bob Thomas <[email-masked]>
Date: Wed, 17 Nov 1999 11:46:54 -0500

Kishore,

>         I will ask my question in another way.

Sorry, for some reason I misread "we want to establish an LSP" as
"we want to establish an LDP (session)" ...

> next hop is C . Then B  will forward the Label Request Message  to LSR C 

I think there are several possibilities at this point:

1.  B has already learned a label from C for the FEC in question.

    In this case B responds to the label request from A by sending
    a label mapping to A.

2.  B has not yet learned the label from C; and B is using ordered control.

    In this case B sends a label request to C.

3.  B has not yet learned the label from C; and B is using independent
    control.

    In this case B responds to the label request from A by sending
    a label mapping to A.  In addition B sends a label request to C.

> Response Awaited State.  LSP may not be established.

These are important implementation issues.  However, I think that
different implementations may deal with them differently and that they
are outside of the scope of the protocol specification.

Bob