Subject: RE: About mpls forwarding

From: Shelon <[email-masked]>
Date: Tue, 16 Nov 1999 19:47:50 +0530

Hi Adrian,
You suggest that IP frames should continue to be forwarded in the old
way until the LSP has been set up. But if IP frames is discarded, is there 
some serious problem?

Thanks
Shelon

-----Original Message-----
From:	Adrian Farrel [SMTP:[email-masked]]
Sent:	Tuesday, November 16, 1999 7:32 PM
To:	Shelon; 'Peter Ashwood-Smith'
Cc:	'MPLS Mailing List'
Subject:	RE: About mpls forwarding

Shelon,

That's right.  Flow-driven LSP set up is not a requirement.
It is, however, something that individual switch manufacturers may opt to
include to distinguish them from the competition.

I would suggest that IP frames should continue to be forwarded in the old
way until the LSP has been set up (buffering them sounds disastrous!)

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

> -----Original Message-----
> From: Shelon [mailto:[email-masked]]
> Sent: Tuesday, November 16, 1999 1:50 PM
> To: 'Peter Ashwood-Smith'
> Cc: 'MPLS Mailing List'
> Subject: RE: About mpls forwarding
> 
> 
> Peter, thanks for your help.
> So, as you say, LER is only recommended to adopt topology 
> driven by mpls protocol
> and flow driven is not required! 
> Am I correct?
> 
> Shelon
> 
> -----Original Message-----
> From:	Peter Ashwood-Smith [SMTP:[email-masked]]
> Sent:	Tuesday, November 16, 1999 9:45 AM
> To:	Shelon
> Cc:	'MPLS Mailing List'
> Subject:	Re: About mpls forwarding
> 
> Shelon wrote:
> > 
> > Hi, All
> > I have a question about mpls forwarding.
> > When a unlabeled packet arrived (it need be forwarded), LSR 
> should request to establish a lsp for this packet.
> > But it will take some time to establish the lsp. So, how to 
> process the packet? Discard it or forward as normal
> > unlabeled packet?
> > 
> > Regards
> > Shelon
> 
>   Sheldon,
> 
>   An MPLS LER (it's the label edge router that encapsulates 
> the packet) probably
> will not establish an LSP in response to traffic flow, at 
> least it is not required
> to. Initially you will see LER's that will pre-establish LSPs 
> either through 
> provisioning (CR-LDP/RSVP-TE) or as IP routes come and go 
> (LDP). If no LSP is
> available the packet is forwarded normally.
> 
> 
>   That's not to say that some vendors will not offer the 
> ability to locally 
> measure flows and establish LSPs, it's just that this is not 
> mandated by any
> of the MPLS protocols so far.
> 
>   Hope this helps,
> 
>   Peter Ashwood-Smith
>

---

From: Dirk Ooms <[email-masked]>
Date: Tue, 16 Nov 1999 15:28:21 +0100

If it is a new RTP/UDP flow I wouldn't mind losing some packets.

-- 
Dirk Ooms (DN9)                           Alcatel Research
mailto:[email-masked]          Francis Wellesplein 1
Phone: +32 3 240 4732                       B-2018 Antwerp
Fax:   +32 3 240 9932                              Belgium

---

From: [email-masked] (David Wilder)
Date: Tue, 16 Nov 1999 10:34:20 -0500 (EST)

Or there could be a default route TE LSP for MPLS similar to what IP has to deal
with new unknown routes.

Dave

---

From: Geetha Brown <[email-masked]>
Date: Tue, 16 Nov 1999 11:07:39 -0500

Shelon,

Handling of IP packets, in the absence of an LSP on which it can be
forwarded, should be handled the way it is done in the classical IP 
forwarding.  Discarding the packet or buffering the packet is  
implementation specific.  MPLS architecture does not define this
behaviour.

In MPLS architecture LSPs are preestablished, but that does not preclude
you from setting up a data driven LSP.  Until the data can be sent on
the
LSP, it can be forwarded in the classical ip forwarding way.

Geetha

-- 
Geetha M Brown

---

From: "Nava Zvaig" <[email-masked]>
Date: Tue, 16 Nov 1999 10:12:51 -1000

Given that the LSPs are preestablished:

Are LSPs to be determined mostly manually or automatically (in practice)?

When LSPs are determined manually, how is it done? (i.e. is there a table
that is modified by the system administrator and the LERs look at it to
establish LSPs accordingly?)  How is done when LSPs are determined
automatically?

Also, what layer two technology is mostly used with MPLS today (and in the
near future)?

Thanks,
Nava

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Geetha
Brown
Sent: Tuesday, November 16, 1999 6:08 AM
To: Shelon; [email-masked]
Subject: Re: About mpls forwarding

Shelon,

Geetha

--
Geetha M Brown

---

From: GeeVarghese John <[email-masked]>
Date: Wed, 17 Nov 1999 10:18:19 -0500

Hi Nava Zvaig,

Regrading your question 1

>>>> Are LSPs to be determined mostly manually or automatically (in practice)?

Automatic determination is preferred though manual is not ruled out ..

question 2

>>establish LSPs accordingly?)  How is done when LSPs are determined

I think,
for automatic determination, routing information is used for label binding
and then gets disseminated to the other  LSRs. When packets arrives from a flow
that gets mapped to a label and gets forwarded based on the label attached.
When the next LSR receive the packet it look at the incoming label and determine
the
outgoing interface and its label.

For manual determination,
I think  you can have a table where flow to label binding is specified manually.

GVJ

--
Geevarghese John,
Motorola India Electronics Ltd, Bangalore. India