Subject: RE: bridging over mpls

From: Adrian Farrel <[email-masked]>
Date: Tue, 23 Nov 1999 12:53:16 -0000

PMFJI,

> > In the case of bridging, I would assume that the entire packet that
> > needs to be bridged (including its Layer 2 header) would 
> > constitute the payload of the MPLS packet.
> 
> The point is not to restrict
> the contents of the packet beyond the last label to a network
> layer, or a fully-formed layer 2 packet, or anything.
> 
> ...
> > This requires that the egress
> > LSP know that what is coming off the LSP is bridged 
> > Ethernet traffic.
> 
> That's the key: if the ingress and egress LSRs are agreed on the
> contents of the packet past the last label, everything is hunky dory.
 
Isn't this "agreement" something we need to look at?

Of course it's fine to say that it is a configuration issue or an
implementation issue, but that doesn't seem to solve the interoperation
issues that will arise.

If my ingress sets up two tunnel LSPs one for IP traffic and one for (say)
tunneled Ethernet (or IPX, or Voice) how will the egress know which tunnel
is which?  How will it know how to handle the payload?

It seems to me that this is an important part of the signaling protocol for
MPLS.

In RSVP it is possible to supply the protocol identifier of the encapsulated
layer 3 traffic.  This is a start, but does it provide enough information
for all cases?

In CR-LDP the protocol identifier cannot be passed.

We could introduce a SNAP header to the signaling flow (which, I think is
what Juha was suggesting) or to the data packets or both.

Thoughts anyone?

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
ATM, MPLS and Telecoms Development Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 23 Nov 1999 01:44:38 +0200 (EET)

> is which?  How will it know how to handle the payload?

the contents (either a single protocol or an encapsulation mechanism) of
the lsp needs to be told when the lsp is setup via signaling.

 > It seems to me that this is an important part of the signaling protocol for

exactly.

 > In CR-LDP the protocol identifier cannot be passed.

indicating the contents of lsp should be part of ldp itself, not rsvp or
cr-ldp, since it has nothing to do with constraints, explicit routing, or
traffic engineering.

 > what Juha was suggesting) or to the data packets or both.

see how it is done in atm signaling using the low layer protocol
information element.

-- juha

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 23 Nov 1999 01:44:38 +0200 (EET)

exactly.

-- juha