Subject: RE: About mpls forwarding

From: Shelon <[email-masked]>
Date: Tue, 16 Nov 1999 19:20:01 +0530

Peter, thanks for your help.
So, as you say, LER is only recommended to adopt topology driven by mpls protocol
and flow driven is not required! 
Am I correct?

Shelon

-----Original Message-----
From:	Peter Ashwood-Smith [SMTP:[email-masked]]
Sent:	Tuesday, November 16, 1999 9:45 AM
To:	Shelon
Cc:	'MPLS Mailing List'
Subject:	Re: About mpls forwarding

Shelon wrote:
> 
> Hi, All
> I have a question about mpls forwarding.
> When a unlabeled packet arrived (it need be forwarded), LSR should request to establish a lsp for this packet.
> But it will take some time to establish the lsp. So, how to process the packet? Discard it or forward as normal
> unlabeled packet?
> 
> Regards
> Shelon

  Sheldon,

  An MPLS LER (it's the label edge router that encapsulates the packet) probably
will not establish an LSP in response to traffic flow, at least it is not required
to. Initially you will see LER's that will pre-establish LSPs either through 
provisioning (CR-LDP/RSVP-TE) or as IP routes come and go (LDP). If no LSP is
available the packet is forwarded normally.

  That's not to say that some vendors will not offer the ability to locally 
measure flows and establish LSPs, it's just that this is not mandated by any
of the MPLS protocols so far.

  Hope this helps,

  Peter Ashwood-Smith

---

From: Adrian Farrel <[email-masked]>
Date: Tue, 16 Nov 1999 14:01:57 -0000

Shelon,

That's right.  Flow-driven LSP set up is not a requirement.
It is, however, something that individual switch manufacturers may opt to
include to distinguish them from the competition.

I would suggest that IP frames should continue to be forwarded in the old
way until the LSP has been set up (buffering them sounds disastrous!)

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

> From: Shelon [mailto:[email-masked]]
> Sent: Tuesday, November 16, 1999 1:50 PM
> To: 'Peter Ashwood-Smith'
> Cc: 'MPLS Mailing List'
> Subject: RE: About mpls forwarding
> 
> 
> > When a unlabeled packet arrived (it need be forwarded), LSR 
> should request to establish a lsp for this packet.
> > But it will take some time to establish the lsp. So, how to 
> process the packet? Discard it or forward as normal
> > unlabeled packet?
> > 
> > Regards
> > Shelon
> 
>   Sheldon,
>

---

From: Adrian Farrel <[email-masked]>
Date: Tue, 16 Nov 1999 14:26:08 -0000

Shelon,
You are always free to discard IP frames.  It is entirely your choice on the
amount of disruption to service you want to expose to your IP applications. 
Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

> Sent: Tuesday, November 16, 1999 2:18 PM
> To: Adrian Farrel; 'Peter Ashwood-Smith'
> Cc: 'MPLS Mailing List'
> Hi Adrian,
> You suggest that IP frames should continue to be forwarded in the old
> way until the LSP has been set up. But if IP frames is 
> discarded, is there 
> some serious problem?
> 
> Thanks
> Shelon
> 
> From:	Adrian Farrel [SMTP:[email-masked]]
> Sent:	Tuesday, November 16, 1999 7:32 PM
> To:	Shelon; 'Peter Ashwood-Smith'
> Cc:	'MPLS Mailing List'

---

From: Rajesh Kumar <[email-masked]>
Date: Tue, 16 Nov 1999 18:24:33 -0800

Automatic LSP establishment is preferable, although manual configuration is 
not entirely ruled out. The problem with any manual configurations is as 
always one of scalability and flexibility.

As for layer 2 technology, today most of the implementations seem to be 
focussing on ATM and some on PPP (Packet Over Sonet) - at least In My 
Humble Awareness.

-----Original Message-----
From:	Nava Zvaig [SMTP:[email-masked]]
Sent:	Tuesday, November 16, 1999 12:13 PM
To:	[email-masked]
Subject:	RE: About mpls forwarding

Given that the LSPs are preestablished:

Are LSPs to be determined mostly manually or automatically (in practice)?

When LSPs are determined manually, how is it done? (i.e. is there a table
that is modified by the system administrator and the LERs look at it to
establish LSPs accordingly?)  How is done when LSPs are determined
automatically?

Also, what layer two technology is mostly used with MPLS today (and in the
near future)?

Thanks,
Nava

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Geetha
Brown
Sent: Tuesday, November 16, 1999 6:08 AM
To: Shelon; [email-masked]
Subject: Re: About mpls forwarding

Shelon,

Handling of IP packets, in the absence of an LSP on which it can be
forwarded, should be handled the way it is done in the classical IP
forwarding.  Discarding the packet or buffering the packet is
implementation specific.  MPLS architecture does not define this
behaviour.

In MPLS architecture LSPs are preestablished, but that does not preclude
you from setting up a data driven LSP.  Until the data can be sent on
the
LSP, it can be forwarded in the classical ip forwarding way.

Geetha

> way until the LSP has been set up. But if IP frames is discarded, is 
there

--
Geetha M Brown

---

From: Rahul Kasralikar <[email-masked]>
Date: Tue, 16 Nov 1999 19:12:18 -0800

> From: Nava Zvaig [mailto:[email-masked]]

IMHO,

What you say will work for manual establishment of LSPs. This
table/database can be populated using CLI etc.

You could apply a set of policies to the route table to
automatically establish LSPs. (Say, when you learn <dest-ip, mask>
in the route table with certain attributes, open an LSP to <dest-ip,
mask>).

Rahul

---

From: Arthi Ayyangar <[email-masked]>
Date: Wed, 17 Nov 1999 13:22:53 -0500 (EST)

Hi,

But in case of multicast communication the LSPs are data-driven, right?

arthi