Subject: Re: Why MPLS is called so

From: "G.B.Naidu" <[email-masked]>
Date: Wed, 3 Nov 1999 14:35:50 +0530 (IST)

Hi

The reason for using "label switching" rather than "label routing" could
be as follows:

In MPLS  the labels have only local significance between two LSRs. As the
packet is switched in a LSP(Labeled switched path), the label keeps
changing between two adjacant LSRs.

The philosophy of MPLS is to use the L3 routing concepts along with L2
switching concepts to get maximum advantage. It is not to replace IP
routing, but to support it.

Hope this clarifies your doubt.

On Wed, 3 Nov 1999, Telecom Tom wrote:

> G.B.,
> 
> Would you know why the name "label switching" was used instead of
> "label routing"?  I have also seen "tag switching" in regard to cisco
> equipment. Did cisco use it with ATM switches?
> 

Might be so, cisco might have used it's own ATM switches. Besically it is
the label or tag that was switched in L2.

regards
-- gbnaidu

> --thanks, TT
> 
> -------- Original Message --------
> Subject: Re: Why MPLS is called so
> Date: Wed, 3 Nov 1999 12:48:45 +0530 (IST)
> From: "G.B.Naidu" <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
> 
> Because the label switching can be done using any L2 protocol such as
> ATM,
> Frame Relay, Etehrnet, FDDI and Point-to-Point links.
> 
> corrections if any please...
> 
> regards
> -- [email-masked]
> 
> 
> On Wed, 3 Nov 1999 [email-masked] wrote:
> 
> > 
> > 
> > Hi all,
> > A very basic doubt...
> > Why is MPLS called multiprotocol?
> > 
> > regs,
> > Ravi.
> > 
> >
>

---

From: Lou Berger <[email-masked]>
Date: Thu, 04 Nov 1999 13:23:00 -0500

This is the same problem that VPN or stacked label traffic has.  i.e., the 
traffic get's dropped.  A similar problem occurs when the transit nodes 
don't maintain a full internet routing table.

Lou

At 10:07 AM 11/4/99 -0800, Vijay Krishnaswamy wrote:

>hi all,
>
>With a VoMPLs stack, one would not be able to
>hop-by-hop routing, incase LSP is not available all the way
>upto the voice termination point. How would VoMPLs
>address those situations ?
>
>/vijay.
>
>
> >       Hi Antti,
> >
> >       I would think that providing the Voice/MPLS stack is
> > the same as the IP/MPLS stack up to the shim layer, then an
> > existing LSR would be able to switch it. One could include
> > the labelled voice sample directly after the shim header
> > (i.e. instead of the labelled IP packet), or possibly (e.g.
> > in  trunking applications) concatenate them in order to
> > improve efficiency further and reduce packet numbers going
> > thru the lsr. Anyway, having had a look at your web site
> > (following Yakov's hint) i'm sure you've put a lot more
> > thought into it than i!
> >
> >       cheers,
> >       john
> >
> > > Yakov Rekhter wrote:
> > >
> > > > John,
> > > >
> > > > > > But, for now, who cares about multiprotocol apart from IP.
> > > > >
> > > > > Well I'd like to send small voice packets over this
> > kind of network
> > > > > without h aving to load them up with IP headers, SHIM
> > headers and so
> > > > > on. 12 to 16 (say) b ytes of packetized voice sample doesn't get
> > > > > transported very efficiently if you add 20 bytes of IP
> > header, plus 20
> > > > > bytes of UDP header ... plus 4 bytes of SHIM etc, etc.
> > In other words
> > > > > an LSP for packetised voice traffic that uses a
> > compressed VoIP/MPLS
> > > > > stack that can still be switched by LSRs.
> > > >
> > > > You may talk to Antti Kankkunen (Integral Access Inc).
> > > >
> > > > Yakov.
> > >
> > > We do indeed see an important class of applications where
> > it makes sense to
> > > carry voice directly over MPLS. I would be very interested
> > in sharing ideas
> > > with other parties who have recognized this fact. Please
> > send me an e-mail
> > > and lets see if we can get some common effort going around VoMPLS.
> > >
> > > Best regards,
> > >
> > > Antti K.
> > >
> > > --
> > > Antti Kankkunen
> > > Integral Access Inc.
> > > 321 Billerica Rd.
> > > Chelmsford, MA 01824
> > > Phone: +1 978 256 8833 x 232
> > > Mobile: +1 617 513 2172
> > > Fax: +1 978 256 8077
> > > e-mail: [email-masked]
> > >
> >