Subject: RE: bridging over mpls

From: Adrian Farrel <[email-masked]>
Date: Tue, 23 Nov 1999 19:14:59 -0000

Kireeti wrote,

> > Of course it's fine to say that it is a configuration issue or an
> > implementation issue, but that doesn't seem to solve the 
> > interoperation
> > issues that will arise.
> 
> The interoperation issue is strictly between the endpoints of the
> LSP: all the intermediate routers just forward MPLS frames.

Well, at the risk of opening up old discussion...

If an intermediate router discovers an error it may want to send some form
of error message (e.g. ICMP).  It can only do this if it knows the protocol
being carried.

The previous discussion of this point suggested that the tunnel should be
treated as opaque and errors should cause frame discard.

Regards,
Adrian
--
Adrian Farrel  mailto:[email-masked]
ATM, MPLS and Telecoms Development Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

---

From: "PHILIP MATTHEWS" <[email-masked]>
Date: Wed, 24 Nov 1999 08:54:29 -0500

> treated as opaque and errors should cause frame discard.

For this reason, and the others discussed on this thread, I also support the proposal
to have a way to indicate the payload type through the signalling mechanism.
RSVP already has this mechanism, and CR-LDP could add it easily,
however, LDP seems to be a bit of a problem, especially in Independent mode.

- Philip Matthews
Newbridge Networks Corp