Subject: RE: Session Negotiation.

From: T M Kishore <[email-masked]>
Date: Wed, 17 Nov 1999 19:29:48 +0530

Hello Bob,
          
         Please see the following situation .
              s1            s2
         A --------> B---------> C  .

            LSR A supports DoD, LSR B supports Both Dod and unsolicited and LSR C supports only Unsolicited and all liks are ATM .
In above situation, session  s1 uses DoD and session s2 uses Unsolicited .
Is It?
Or session can not established?

              Suppose, we want to establish LSP between A to C, How will be established  ? 
Please Clarify My doubt .

Thanks in Advance.
Kishore

-----Original Message-----
From:	Bob Thomas [SMTP:[email-masked]]
Sent:	Wednesday, November 17, 1999 6:45 PM
To:	T M Kishore
Cc:	[email-masked]'; [email-masked]'; [email-masked]'
Subject:	Re: Session Negotiation. 

Kishore,

>             My understanding is that one LSR Can support both Downstream On 
> Demand and Unsolicited  at  a time.
>              If  the LSR supports both Downstream On Demand and 
> Unsolicited, How the LSR will inform to its neighbour that it is supporting 
> both.

I don't think it is necessary for an LSR to inform a given peer that
it supports both.  It only needs to state in the Initialization message
its preference for the peer session.

>          In draft draft-ietf-mpls-ldp-06.txt   ,  Page No : 54 , it says as 
> follows.
> 
>          If one LSR proposes Downstream Unsolicited and the other
>          proposes Downstream on Demand, the rules for resolving this
>          difference is:
> 
>            - If the session is for a label-controlled ATM link or a
>              label-controlled Frame Relay link, then Downstream on
>              Demand must be used.
> 
>           A -----> B
>         If  LSR  A is supporting Downstream On Demand and LSR B is 
> supporting Unsolicited over an ATM Link, If LSR B sends initialization 
> Message ( with Unsolicited Mode) to LSR A , session between A and B should 
> use Downstream on Demand . So LSR B has to switch over to Downstream On   
> Demand Mode for this session.

Correct.

>           If one LSR supports Unsolicited, Is that mean that it has to 
> support Downstream On Demand also ?

If it supports label distribution for label-controlled ATM and/or FR
links, and if it needs to interoperate with other LSRs that prefer
DoD for such links (in my opinion, other LSRs are likely to prefer DoD
for such links), then it will need to support DoD.

Bob

>       Please Clarify my doubt.
> Thanks in advance,
> Kishore .
> 
> T M Kishore,
> Senior Software Engineer,
> HDF, Future Software Pvt Ltd,
> 480 - 481, Anna Salai, Nandanam,
> Chennai - 600 035
> India.
> Phone : +91-44-4330550 Ext.412

---

From: Bob Thomas <[email-masked]>
Date: Wed, 17 Nov 1999 09:18:25 -0500

Kishore,

Correct.

>               Suppose, we want to establish LSP between A to C, How will be established  ? 

Not sure what the question is here.  Is it about DU / DoD or
about the fact that A and C are not directly connected?

Bob