Subject: RE: Questions on draft-swallow-rsvp-bypass-label-00.txt

From: Vishal Sharma <[email-masked]>
Date: Tue, 23 Nov 1999 12:19:46 -0500

On Tuesday, November 23, 1999 11:47 AM, George Swallow [SMTP:[email-masked]] 
wrote:
> >Would you please define what you mean by local repair?
>
> I mean the upstream router which is closest to the point of failure
> (be that failure the next link or the next router).

Great, that is consistent with what we have defined in our framework
draft. Perhaps a change of the text in the second para of the introduction
in the bypass tunnels draft will make this clear. (As it stands now, the
term local repair ends up meaning something quite different.)

> >(iii) In either one of the  examples considered in the draft, what happens 
if
> >
> >link R3-R4 fails?
>
> As far as local repair goes that's up to R3.  R3 *may* endup routing
> back through R2, but R2 would have no special role to play in such an
> event.

Thanks, this is consistent with our understanding as well.

> >Is there an assumption
> >that R3-R4 is protected by say SONET APS?
>
> The only assumption is that R2 doesn't have to worry about the link
> R3-R4.

So the bypass tunnel in this example is only protecting against failure of link
R2-R3, and failure of node R3.

-Vishal

---

From: George Swallow <[email-masked]>
Date: Tue, 23 Nov 1999 14:13:41 -0500

Vishal-

>R2-R3, and failure of node R3.

Correct.

...George

==================================================================
George Swallow       Cisco Systems                   (978) 244-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824