Subject: RE: About mpls forwarding

From: Rahul Kasralikar <[email-masked]>
Date: Tue, 16 Nov 1999 11:41:41 -0800

You _can_ discard the IP frames, but if you have a IP route
entry and you can forward, why would you do so?

BTW, the flow-based LSP establishment does not scale. Topology-based
does.) This is something to consider..

Rahul

> -----Original Message-----
> From: Shelon [mailto:[email-masked]]
> Sent: Tuesday, November 16, 1999 6:18 AM
> To: 'Adrian Farrel'; 'Peter Ashwood-Smith'
> Cc: 'MPLS Mailing List'
> Subject: RE: About mpls forwarding
> 
> 
> Hi Adrian,
> You suggest that IP frames should continue to be forwarded in the old
> way until the LSP has been set up. But if IP frames is 
> discarded, is there 
> some serious problem?
> 
> Thanks
> Shelon
> 
> -----Original Message-----
> From:	Adrian Farrel [SMTP:[email-masked]]
> Sent:	Tuesday, November 16, 1999 7:32 PM
> To:	Shelon; 'Peter Ashwood-Smith'
> Cc:	'MPLS Mailing List'
> Subject:	RE: About mpls forwarding
> 
> Shelon,
> 
> That's right.  Flow-driven LSP set up is not a requirement.
> It is, however, something that individual switch 
> manufacturers may opt to
> include to distinguish them from the competition.
> 
> I would suggest that IP frames should continue to be 
> forwarded in the old
> way until the LSP has been set up (buffering them sounds disastrous!)
> 
> Regards,
> Adrian
> --
> Adrian Farrel  mailto:[email-masked]
> Data Connection Ltd., Chester, UK
> http://www.datcon.co.uk/
> Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422
> 
> 
> > -----Original Message-----
> > From: Shelon [mailto:[email-masked]]
> > Sent: Tuesday, November 16, 1999 1:50 PM
> > To: 'Peter Ashwood-Smith'
> > Cc: 'MPLS Mailing List'
> > Subject: RE: About mpls forwarding
> > 
> > 
> > Peter, thanks for your help.
> > So, as you say, LER is only recommended to adopt topology 
> > driven by mpls protocol
> > and flow driven is not required! 
> > Am I correct?
> > 
> > Shelon
> > 
> > -----Original Message-----
> > From:	Peter Ashwood-Smith [SMTP:[email-masked]]
> > Sent:	Tuesday, November 16, 1999 9:45 AM
> > To:	Shelon
> > Cc:	'MPLS Mailing List'
> > Subject:	Re: About mpls forwarding
> > 
> > Shelon wrote:
> > > 
> > > Hi, All
> > > I have a question about mpls forwarding.
> > > When a unlabeled packet arrived (it need be forwarded), LSR 
> > should request to establish a lsp for this packet.
> > > But it will take some time to establish the lsp. So, how to 
> > process the packet? Discard it or forward as normal
> > > unlabeled packet?
> > > 
> > > Regards
> > > Shelon
> > 
> >   Sheldon,
> > 
> >   An MPLS LER (it's the label edge router that encapsulates 
> > the packet) probably
> > will not establish an LSP in response to traffic flow, at 
> > least it is not required
> > to. Initially you will see LER's that will pre-establish LSPs 
> > either through 
> > provisioning (CR-LDP/RSVP-TE) or as IP routes come and go 
> > (LDP). If no LSP is
> > available the packet is forwarded normally.
> > 
> > 
> >   That's not to say that some vendors will not offer the 
> > ability to locally 
> > measure flows and establish LSPs, it's just that this is not 
> > mandated by any
> > of the MPLS protocols so far.
> > 
> >   Hope this helps,
> > 
> >   Peter Ashwood-Smith
> > 
>

---

From: Lee Thomas <[email-masked]>
Date: Mon, 22 Nov 1999 10:59:36 -0600

Hi Rahul,

When you mention topology-based establishment scales, are you referring to
constraint-based establishment where the establishment is dynamic but the
path is somewhat constrained?

Lee

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Rahul
Kasralikar
Sent: Tuesday, November 16, 1999 1:42 PM
To: 'Shelon'; 'Adrian Farrel'; 'Peter Ashwood-Smith'; [email-masked]'
Subject: RE: About mpls forwarding

Rahul