Subject: Testing MPLS

From: "Nava Zvaig" <[email-masked]>
Date: Fri, 5 Nov 1999 09:57:07 -1000

Hi,

Here at Adtech we develop broadband test equipment (ATM, Frame Relay,
Ethernet, IP).  We would like to add support for testing MPLS LSRs.  We are
looking into what and how to test it.  Any suggestions or comments?

Thanks,
Nava

/--------------------------------------------------\
Nava Zvaig
Adtech, Inc.
3465 Waialae Avenue, Suite 200
Honolulu, HI 96816
Phone: (808) 734-3300
Email: [email-masked]
http://adtech-inc.com
\--------------------------------------------------/

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Fri, 05 Nov 1999 23:28:39 -0500

> looking into what and how to test it.  Any suggestions or comments?

  Apart from the obvious stuff, I personally would like to have the
ability to test large numbers of Explicitly routed LSP establishments.
One of the hardest problems I have encountered in the past is the
proper pacing and flow control of thousands of requests/releases
during failures.

  The ability to bombard an LSR with label requests and see how it
deals with them is a valuable bullet-proofing excercise and one we
usually wind up writing custom tools for. At least that's what we do
with our proprietary and ATM protocols.

  I will forward your email around to some of the designers here to
see what sort of stuff they would like to have.

  Cheers,

  Peter

---

From: Aparna Khatri <[email-masked]>
Date: Mon, 08 Nov 1999 14:59:56 +0530

> looking into what and how to test it.  Any suggestions or comments?

Hi

	In order to test any protocol, one needs to
verify that it corresponds to the specifications.
Also it is important to ensure that it is able to
withstand stress and to test the protocol in a
true life scenario.
	In order to test an LSR, one of the test tools
required is a Peer Simulator that can simulate a
peer for the protocol under test. (LDP, RSVP ). In
addition to having the capability of encoding and
decoding all protocol related messages, this tool
should also have the capability of bombarding the
LSR with messages of any kind. Also it should give
the tester the ability to send incorrectly encoded
messages to the LSR under test, so as to test the
robustness of the LSR. 
	The advantage of having a tool doing the encoding
and decoding, and testing against this, will be
that an implementation can be tested with another
implementation and interoperability issues can be
minimized. Also, the tool should provide a lot of
flexibility to the tester with regards to contents
of messages (TLVs), number of messages, timing
between messages so as to ensure complete stress
testing and negative testing.

Regards
Aparna

----------------------------------------------
Aparna Khatri
Ficon Technology
E-Mail : [email-masked]
Web    : www.ficon-tech.com