Subject: RE: Why MPLS is called so

From: John Hopkins <[email-masked]>
Date: Thu, 4 Nov 1999 16:11:13 -0000

> But, for now, who cares about multiprotocol apart from IP. 

Well I'd like to send small voice packets over this kind of network without having to load them up with IP headers, SHIM headers and so on. 12 to 16 (say) bytes of packetized voice sample doesn't get transported very efficiently if you add 20 bytes of IP header, plus 20 bytes of UDP header ... plus 4 bytes of SHIM etc, etc.  In other words an LSP for packetised voice traffic that uses a compressed VoIP/MPLS stack that can still be switched by LSRs.

I can live without IPX though :-)

John

> -----Original Message-----
> From:	Peter Tam [SMTP:[email-masked]]
> Sent:	04 November 1999 15:35
> To:	[email-masked]; [email-masked]
> Cc:	[email-masked]
> Subject:	RE: Why MPLS is called so
> 
> Hi, 
> 
> At the end of tunnel (based on the Stack bit), MPLS control is turned back to the L.3 network protocol as per the SHIM header. Currently it can only be an IP SHIM. Ideally,  MPLS should be multi-protocol supporting any network protocols not just IP. This area is not addressed and the mechanism to identify which SHIM type is not yet standardized. IMHO, there are 2 possible ways to define a SHIM type for a tunnel: use the 3 Unused bits in the MPLS header. The cons are that everybody wants to get the hand on these bits. The pros are that, on a single LSP, applications can multiplex and switch to different network layer protocols (e.g. between IPX and IP) as they wish. The other method is to create a SHIM TLV in the LDP/CR-LDP/RSVP+ label signaling protocols to bind labels to network layer protocols at LSP setup time. This TLV object should be optional defaulting to IP for backward compatibility.
> 
> But, for now, who cares about multiprotocol apart from IP. 
> 
> Regards...Peter Tam, 
> Nortel Networks, Canada 
> 
> 	-----Original Message----- 
> From:   [email-masked] [SMTP:[email-masked]] 
> Sent:   Wednesday, November 03, 1999 2:19 AM 
> To:     [email-masked] 
> Cc:     [email-masked] 
> Subject:        Re: Why MPLS is called so 
> 
> 	Because the label switching can be done using any L2 protocol such as ATM, 
> Frame Relay, Etehrnet, FDDI and Point-to-Point links. 
> 
> 	corrections if any please... 
> 
> 	regards 
> -- [email-masked] 
> 
> 
> 	On Wed, 3 Nov 1999 [email-masked] wrote: 
> 
> 	> 
> > 
> > Hi all, 
> > A very basic doubt... 
> > Why is MPLS called multiprotocol? 
> > 
> > regs, 
> > Ravi. 
> > 
> > 
> 
>

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 04 Nov 1999 08:40:57 -0800

John,

> Well I'd like to send small voice packets over this kind of network
> without h aving to load them up with IP headers, SHIM headers and so
> on. 12 to 16 (say) b ytes of packetized voice sample doesn't get
> transported very efficiently if you add 20 bytes of IP header, plus 20
> bytes of UDP header ... plus 4 bytes of SHIM etc, etc.  In other words
> an LSP for packetised voice traffic that uses a compressed VoIP/MPLS
> stack that can still be switched by LSRs.

You may talk to Antti Kankkunen (Integral Access Inc).

Yakov.

---

From: Antti Kankkunen <[email-masked]>
Date: Thu, 04 Nov 1999 12:19:13 -0500

> You may talk to Antti Kankkunen (Integral Access Inc).

We do indeed see an important class of applications where it makes sense to
carry voice directly over MPLS. I would be very interested in sharing ideas
with other parties who have recognized this fact. Please send me an e-mail
and lets see if we can get some common effort going around VoMPLS.

Best regards,

Antti K.

--
Antti Kankkunen
Integral Access Inc.
321 Billerica Rd.
Chelmsford, MA 01824
Phone: +1 978 256 8833 x 232
Mobile: +1 617 513 2172
Fax: +1 978 256 8077
e-mail: [email-masked]