Subject: RE: which layer does the label encapsulation...

From: Henrik Villför <[email-masked]>
Date: Fri, 26 Nov 1999 02:01:20 +0100

Hi,
	I'm probably about to put my foot in it but this layer business has
me constantly confused. What layer model are we talking about? IP fits in
the DoD stack and ATM fits in the ATM stack. None of them fit neatly in the
OSI stack but that what we usually use, right? 

So if we assume the OSI stack (which is also implied in gbnaidu's mail) then
we should probably look at what function it performs rather than what format
it has. The way I see it the main function of the label is to allow
forwarding to the correct edge node in the MPLS network. This is a network
function and thus MPLS belongs in layer 3. 

Cheers,
	Henrik Villfor
	Telia Research

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: den 25 november 1999 19:22
To: 'Brahma Naidu Golla'; [email-masked]
Subject: RE: which layer does the label encapsulation...

Hi,

I think since MPLS uses L3 routing information, it should reside at or below
L3. But MPLS can use the services (label encapsulation)of either L3 or L2 or
none based on the media. For example in IPV6 you may have the label inside
the IPV6 header (L-3), while in ATM it is part of ATM header (L-2), and in
PPP case it is neither in L2, or L-3. Therefore I think theoretically MPLS
can be part of L3 or L2 or a separate layer in between. But most commonly it
is referred to as layer 2.5.

I hope that helps.

Shahram

> -----Original Message-----
> From: Brahma Naidu Golla [mailto:[email-masked]]
> Sent: Thursday, November 25, 1999 3:28 AM
> To: [email-masked]
> Subject: which layer does the label encapsulation...
> 
> 
> Hi
> 
> I have a doubt regarding the layer changes when we are 
> implementing the
> MPLS.
> 
> Which layer does the label encapsulation either Network or 
> Data link layer
> or is there any separate layer like MPLS layer? While 
> implementing MPLS,
> what could be the changes that have to be done to IP?
> 
> quick responses are appreciated.
> 
> thanks
> -- gbnaidu.
> 
>

---

From: "Sunny John" <[email-masked]>
Date: Thu, 25 Nov 1999 21:52:01 -0500

Can you all please take off the mailing list.
Thanks

---

From: "Sunny John" <[email-masked]>
Date: Thu, 25 Nov 1999 21:52:42 -0500

Can you all please take me off the mailing list.
Thanks