Subject: RE: encapsulate a labeled frame on ethernet - rfc3032

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 1 Nov 2001 08:05:20 -0800

If you send out MPLS packets, it means you have terminated
the MAC domain and therefore the Ethertype is removed along
with the rest of the original MAC header.  

An exception is if you use MPLS to provide L2 VPN service
for Ethernet frames.  In that case, the entire Ethernet
frame is encapsulated within an MPLS header, and if going
out over Ethernet, you would have a separate "outer" MAC 
header.

-Anoop

> -----Original Message-----
> From: Fu, Jingsong [mailto:[email-masked]]
> Sent: Wednesday, October 31, 2001 3:57 PM
> To: MPLS Mailing List
> Subject: encapsulate a labeled frame on ethernet - rfc3032
> 
> 
> 
> 
> When encasulating a label frame ove ethernet, 0x8847/0x8848 
> is uesed in
> ethertype to indicate that a frame is MPLS packet. Where should be the
> original ethertype, or is it removed?
> 
> Thanks,
> 
> Jingsong Fu
>

---

From: "Arun M. Thomas" <[email-masked]>
Date: Thu, 1 Nov 2001 09:22:13 -0800

Today, the labels 0 and 3 are reserved labels which identify the
encapsulation of the
content beneath the MPLS shim layer.  Is it possible, therefore, to assign
specific
label values to certain ethertypes which an LER might understand and encode
correctly
in outgoing packets?  Is there any long term approach (I haven't seen any,
but I also
haven't read all the drafts out there) in the works?

Cheers,
-AMT

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Anoop
Ghanwani
Sent: Thursday, November 01, 2001 8:05 AM
To: 'Fu, Jingsong'; MPLS Mailing List
Subject: RE: encapsulate a labeled frame on ethernet - rfc3032

-Anoop