Subject: Re: question on e-lsp and l-lsp

From: David Charlap <[email-masked]>
Date: Thu, 01 Nov 2001 14:12:29 -0500

"Fan, Zhong" wrote:
> 
> Can anybody shed some light on the differences between e-lsp and
> l-lsp please? I'm reading draft-ietf-mpls-diff-ext-09.txt at the
> moment. Although the draft gives denifition of these two kinds of
> LSPs, I am still confused. Is this all about the mapping of diffserv
> classes to MPLS FEC or EXP?

The draft explains the differences.

In superbrief summary;

- An L-LSP has one QoS for all packets.  It is determined at LSP
  setup.  This is similar to setting up an LSP without any DiffServ
  extensions, except that the objects used in the signaling are
  different.

- An E-LSP has up to 8 QoS levels for the single LSP.  The EXP bits
  determine the appropriate QoS on a per-packet basis.  The QoS that
  is assigned to each EXP value is signaled at LSP setup (or is a
  configured default if the values are not signaled.)

-- David

---

From: "Proch, Daniel" <[email-masked]>
Date: Thu, 1 Nov 2001 16:40:07 -0500

Vishal,

Somewhere I read that E-LSP shouldn't be used for
ATM-LSR. Could someone please explain why ?

MPLS over ATM (cell) interfaces uses the existing ATM cell structure and
what were the contents of the VPI field or the combined VPI/VCI fields to
infer a label.  There are no EXP bits in the header and therefore only
L-LSPs can be supported on LC-ATM interfaces.  

dan

-----Original Message-----
From: Vishal M [mailto:[email-masked]]
Sent: Thursday, November 01, 2001 3:59 PM
To: [email-masked]
Subject: Re: question on e-lsp and l-lsp

Hi,

I have some followup questions on L-LSP and E-LSPs:

1. Can we map multiple CTs onto a single L-LSP ? The
draft seem to suggest that creation of a separate LSP
can be done for every CT. 

Is creation of separate L-LSP mandatory for every CT
or  is it left to the implementation?

2. Somewhere I read that E-LSP shouldn't be used for
ATM-LSR. Could someone please explain why ?

Thanks for your time,
Vishal.

In superbrief summary;

- An L-LSP has one QoS for all packets.  It is
determined at LSP
  setup.  This is similar to setting up an LSP without
any DiffServ
  extensions, except that the objects used in the
signaling are
  different.

- An E-LSP has up to 8 QoS levels for the single LSP. 
The EXP bits
  determine the appropriate QoS on a per-packet basis.
 The QoS that
  is assigned to each EXP value is signaled at LSP
setup (or is a
  configured default if the values are not signaled.)

-- David

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: "Iren, Sami" <[email-masked]>
Date: Fri, 2 Nov 2001 09:41:38 -0500

I think the use of the term "class type" is not clear here.
*If you are referring to the "class type" as defined in 
 draft-ietf-tewg-diff-te-reqts-01.txt and 
 draft-lefaucheur-diff-te-proto-00.txt, the mapping
 is in the form of service class to class type. That is
 every service class (PSC) belongs to a class type.
 When an lsp is signalled, the class type is signalled
 in the CLASSTYPE object. And only one classtype can be
 signalled per lsp (be it L-LSP or E-LSP). See above
 drafts for more information.

*If you are referring to service class (PSC) such
 as EF, BE, or AF classes, then each L-LSP can
 signal only one service class. That is a single
 L-LSP can only carry traffic belonging to a single
 service class. If you want to carry several service
 classes together in a single lsp, you have to use E-LSPs.

Regards,
--Sami 

> From: Yongjun Im [mailto:[email-masked]]
> Sent: Thursday, November 01, 2001 8:36 PM
> To: Vishal M
> Cc: [email-masked]
> ----- Original Message ----- 
> From: "Vishal M" <[email-masked]>
> To: "Yongjun Im" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, November 01, 2001 7:28 PM
> > > What is CT?
> > ...I apologize...CT stands for Class Type...
> > So can we map multiple Class Types onto a single
> > L-LSP ?
> In order to map multiple class types to LSP, the class type should be
> mapped into EXP fileld in a shim header. That is the 
> definition of E-LSP.
> In case of L-LSP, the only class identifier available to an 
> LSR is a label value.
> That is the definition of L-LSP.
> > 
> > Thanks,
> > Vishal.
> > 
> > > > 
> > Find a job, post your resume.
> > http://careers.yahoo.com
> > 
> 
>