Subject: RE: EXP<=>PHBID maps in DIFFSERV Object

From: "Iren, Sami" <[email-masked]>
Date: Tue, 6 Nov 2001 10:31:59 -0500

Vishal:
The mappings you mentioned in your message is per LSP,
not per LSR. So, for every LSP the mapping could be
different. The inconsistency between the LSRs is not
an issue here.

When these mappings are not signalled, a default mapping
is used per LSR. The draft states that, unless configured
otherwise by the operator, the default mapping is that all 
EXP values refer to Best effort service.

The inconsistency between LSRs is an issue only when the
mappings are not signalled and default per LSR mappings
are inconsistent among the LSRs in a domain.

Regards,
--Sami

> -----Original Message-----
> From: Vishal M [mailto:[email-masked]]
> Sent: Monday, November 05, 2001 11:04 PM
> To: [email-masked]
> Subject: EXP<=>PHBID maps in DIFFSERV Object 
> 
> 
> 
> Hello,
> 
> The DIFFSERV Object defined in "MPLS Support for
> DiffServ, version 09.txt", Section 5.2 defines MAP
> sub-fields that carries EXP <==> PHBID mappings for a
> given LSP.
> 
> Are these mappings specified anywhere ? What EXP value
> would map to what PHBID ?
> 
> Is it network administrator's responsibility for
> guarantee the uniqueness/consistancy of such mappings
> ? 
> 
> Consider the following:
> 
>       ----LSR1 ----> LSR 2 <----- LSR3-----
> 
> LSR1 advertises EXP 4 ==> PHB AF12 map to LSR2
> LSR3 advertises EXP 4 ==> PHB CS2 map to LSR2
> 
> How would LSR 2 handle these ? 
> 
> Only way one could guarantee this is if the LSP is
> within a particular domain, in which case consistency
> can be guaranteed (by a single network admin). 
> 
> But if LSP is crossing domain boundaries, it could be
> an issue. Not sure if network operators are really
> into these inter-domain LSPs at this point...
> 
> Could someone please comment on this.
> 
> Thanks,
> Vishal.
> 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Find a job, post your resume.
> http://careers.yahoo.com
>

---

From: Vishal M <[email-masked]>
Date: Tue, 6 Nov 2001 11:49:41 -0800 (PST)

Hi Sami,

If the EXP<=>PHBID mapping are per-LSP instead of
per-LSR, doesn't that pose a scalablity issue. 
As it is, a core router (LSR) has to maintain states
for each LSP in RSVP. With this solution (of DiffServ)
it would have to maintain these additional mappings
for each LSP.

Some followup questions:
========================
1. Has someone really implemented this ? Does it
really scale well ? Not sure if we can go into
vendor-specifics here...

2. How about the forwarding ASIC ? It would have to
program inLabel<=>EXP <=mapto=> outLabel<=>EXP for
each label*numberOfEXPSupported.

3. This could be an issue during Fast-Reroute.
While re-routing, LSR would have to do a lot more work
to find the alternate route. 

If all the above are real issues, could someone please
comment on why was this mapping (EXP<=>PHBID) done on
per-LSP and not per-LSR basis? 

Thanks for your time,
Vishal.