Subject: RE: CLASSTYPE object

From: "Iren, Sami" <[email-masked]>
Date: Wed, 7 Nov 2001 13:35:24 -0500

Nabil:
The problem you are describing is a generic problem
with E-LSPs, not specific to CLASSTYPE (or DiffServ TE).
When an E-LSP is signalled, the signalled bandwidth
is associated collectively to the whole LSP, not
individual PSCs. Therefore, it is not possible
to do diffserv resource adjustments (e.g., queue bandwidth)
based on the signalled bandwidth.
The draft you are pointing out is a good first attempt
to solve some of these issues. However, IMHO, E-LSPs and
DiffServ TE concepts still require a lot of work.

Regards,
--Sami

> -----Original Message-----
> From: Nabil Seddigh [mailto:[email-masked]]
> Sent: Wednesday, November 07, 2001 11:29 AM
> To: Iren, Sami
> Cc: 'Vishal M'; [email-masked]
> Subject: Re: CLASSTYPE object
> 
> 
> Sami,
> 
> Currently, the CLASSTYPE object cannot really be used with 
> E-LSPs in the manner you describe. The CLASSTYPE object is only
> useful with L-LSPs.
> 
> In order to utilize the concept of bandwidth pools in E-LSP,
> one needs to be able to signal traffic parameters per class 
> or per-PSC. That capability is not present in the standards today.
> 
> The closest proposal to achieve what you describe is the following:
> http://www.ietf.org/internet-drafts/draft-ganti-mpls-diffserv-
elsp-00.txt

Best,
Nabil Seddigh

> 
> Your understanding that the CLASSTYPE is used to
> specify the bandwidth pool to be used for allocating
> resources during LSP Setup is correct. In this context,
> the service class which is signalled via EXP bits
> (in the case of E-LSPs) dictate the treatment given
> to the individual packets, and the CLASSTYPE, which
> is signalled per LSP, dictates where the bandwidth
> is coming from (used in CAC).
> 
> [....deleted....]
>
> Ideally, I would prefer to get rid of the CLASSTYPE
> concept and advertise available bandwidth per service class.

---

From: Nabil Seddigh <[email-masked]>
Date: Wed, 07 Nov 2001 14:04:36 -0500

Sami,

I think we may be saying roughly the same thing.

The point I wanted to stress is that CLASSTYPE alone is useless if
you are using E-LSPs. I think this point is recognized by a number
of folks. As the WG drafts exist today, this object can only 
be used with L-LSPs. i.e. where you only need signal one set of
traffic parameters per LSP.

Nabil

---

From: Vishal M <[email-masked]>
Date: Wed, 7 Nov 2001 12:07:54 -0800 (PST)

Sami and Nabil,

My understanding of implementing DiffServ with MPLS
RSVP TE is:

1. With E-LSPs, we can signal upto 8 PSCs; all mapping
to a single LSP.

2. During LSP establishment:
2a. SENDER_TSPEC object specifies the bandwidth
requirement for the LSP (i.e. commulative bandwidth
requirement for all 8 PSCs). This SENDER_TSPEC remains
the same as for traditional RSVP or MPLS RSVP TE.

2b. CLASSTYPE Object specifies the bandwidth pool to
be used for performing CAC etc for that LSP. This
object is defined in the "Protocol extensions for
support of  
Diff-Serv-awae MPLS Traffic Engineering";
draft-lefaucheur-diff-te-proto-00.txt.

2c. DIFFSERV Object specifies the EXP<=>PHBID mapping
for that particular LSP. This object is defined in 
"MPLS Support of Diff-Serv", draft-ietf-mpls-diff-ext-
09.txt). There are issues in signalling these mapping
for each LSP (currently being discussed in a different
thread).

With the above mentioned drafts/specs, there is no way
to signal bandwidth requirement for each PSC carried
in the LSP. 
The draft draft-ganti-mpls-diffserv-elsp-00.txt
addresses this issue.

Questions:
==========
Nabil, you mentioned that CLASSTYPE object is not used
when signalling E-LSPs and is only used for L-LSPs. I
don't understand this one...could you please
elaborate? 

1. Why is it useless to specify CLASSTYPE with E-LSPs
?
2. What does CLASSTYPE signify for L-LSPs ?

Thanks again for your time,

Regards,
Vishal.

> > > concept and advertise available bandwidth per

__________________________________________________
Do You Yahoo!?
Find a job, post your resume.
http://careers.yahoo.com