Subject: RE: traffic engineering

From: "Mina Azad" <[email-masked]>
Date: Thu, 8 Nov 2001 15:48:17 -0500

K m a,

The answer to your question is user-plane MPLS OAM, which is the focus of
upcoming BOF at IETF 52. "MPLS OAM" BOF is scheduled for 3:30-5:30 on
Thursday Dec. 13th. 

Meanwhile, if I may suggest, please browse through the following three
drafts that are being revised for the BOF

[ALLAN-FRMWRK] Allan et. al. A Framework for MPLS User Plane OAM
draft-allan-
mpls-oam-frmwk-00.txt, July 2001.

[HARRISON-REQ] Harrison et. al. "Requirements for OAM in MPLS Networks",
draft-
harrison-mpls-oam-req-00.txt, May 2001

[AZAD-MSG] Azad et. al. MPLS user-plane OAM messaging
draft-azad-mpls-oam-messaging-00.txt.

You also could find excellent background information in 
[HARRISON-MECH] Harrison et. al. "OAM Functionality for MPLS Networks",
draft-
harrison-mpls-oam-00.txt, February 2001

Regards,

Mina

> -----Original Message-----
> From: k m a [mailto:[email-masked]]
> Sent: Thursday, November 08, 2001 3:07 PM
> To: [email-masked]
> Subject: traffic engineering
> 
> 
> 
> hi all,
> i have a doubt in the traffic engineering aspect of MPLS..i 
> wanted to ask as to how the edge router which recives the 
> packets from outside ,route them into the core...does it 
> checks for links everytime a packet arrives....i mean how 
> does it decide on an LSP...and does it have to probe the 
> links for every packet that comes to it!
> in short my question is referring to how the edge router in 
> contarsts to a normal router behaves..for routing 
> packets.....does it probe the available links packet by 
> packet..or does it do once in the beginning and then sends 
> them to a particular LSP the packet which r of same destination!!
> hope am clear....!!
> thanx
>  
> 
> 
>

---

From: Jim Boyle <[email-masked]>
Date: Thu, 8 Nov 2001 16:12:23 -0500 (EST)

That is the answer to *a* question, but not to the question asked.

In traffic engineering applications LSP Tunnels are established, and if
the route selection process decides to use them, then the associated
prefixes are bound to the LSPs.  This works even when one doesn't have OAM
on the LSP (which is not defined/supported)