Subject: CLASSTYPE object

From: Vishal M <[email-masked]>
Date: Mon, 5 Nov 2001 19:36:06 -0800 (PST)

Hello,

MPLS header has 3 bits for EXP, so there are 8
possible combinations of different traffic types.

Draft "Protocol extensions for support of
DiffServ-aware MPLS TE, version 00.txt", Section 11.2
defines a new CLASSTYPE Object. The values for CT are
defined (or restricted) to be 1, 2 and 3.

My understanding is that the CLASSTYPE is used to
specify the bandwidth pool to be used for allocating
resources during LSP Setup.

The draft seem to limit the scope of CT to just three
different bandwidth pools. 

Questions:
1. Is there any particular reason why it was done that

way ? 
2. Instead of atleast having 8 such bandwidth pools
(allowing CT to be from 1 to 8), why is it restricted
to 1 to 3 ?

Or Am I mis-interpreting something ? 

Thanks for your time,

Vishal.

__________________________________________________
Do You Yahoo!?
Find a job, post your resume.
http://careers.yahoo.com

---

From: "Roberto Mameli (ERI)" <[email-masked]>
Date: Thu, 8 Nov 2001 12:41:42 +0100

Hello all,

undoubtely the concept of CLASSTYPE is very useful to reduce IGP flooding in a MPLS network, but as far as E-LSP are managed today, there is no possibility to signal per PSC bandwidth requirements and thus to distinguish among different resource pools. Another proposal in this direction is the draft http://www.ietf.org/internet-drafts/draft-iovanna-rsvp-mpls-flowspec-00.txt.

Regards

> -----Original Message-----
> From: Nabil Seddigh [mailto:[email-masked]]
> Sent: Wednesday, November 07, 2001 5:29 PM
> To: Iren, Sami
> Cc: 'Vishal M'; [email-masked]
> Subject: Re: CLASSTYPE object
> 
> 
> Sami,
> 
> Currently, the CLASSTYPE object cannot really be used with 
> E-LSPs in the manner you describe. The CLASSTYPE object is only
> useful with L-LSPs.
> 
> In order to utilize the concept of bandwidth pools in E-LSP,
> one needs to be able to signal traffic parameters per class 
> or per-PSC. That capability is not present in the standards today.
> 
> The closest proposal to achieve what you describe is the following:
> http://www.ietf.org/internet-drafts/draft-ganti-mpls-diffserv-
elsp-00.txt

Best,
Nabil Seddigh

> 
> Your understanding that the CLASSTYPE is used to
> resources during LSP Setup is correct. In this context,
> the service class which is signalled via EXP bits
> (in the case of E-LSPs) dictate the treatment given
> to the individual packets, and the CLASSTYPE, which
> is signalled per LSP, dictates where the bandwidth
> is coming from (used in CAC).
> 
> [....deleted....]
>
> Ideally, I would prefer to get rid of the CLASSTYPE
> concept and advertise available bandwidth per service class.