Subject: RSVP questions---two session objects in one rsvp path msg

From: "Hong Liao" <[email-masked]>
Date: Mon, 12 Nov 2001 18:04:54 -0500

Hi,

Is it correct to have two session objects in one Path msg?

I observed that once Ingress sent out the path msg, the Intermediate router
will forward a path msg with two session objects, and one session contains
correct session contents, and other one contains very strange info which is
not info from the configuration.

Has anyone seen this situation before?  Is it correct for this or not(for
me, it is not)?

Thanks,
Julia

---

From: "Feng, Mark" <[email-masked]>
Date: Mon, 12 Nov 2001 16:19:30 -0800

IMO, this is incorrect. The SESSION object, as the name implies, is used to
identify the session the Path belongs to. If there are more than one SESSION
objects, the node cannot identify the session.

- Mark

> -----Original Message-----
> From: Hong Liao [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 3:05 PM
> To: [email-masked]
> Subject: RSVP questions---two session objects in one rsvp path msg
> 
> 
> Hi,
>

---

From: "KHARE,MADHUKAR (A-NewEngland,ex1)" <[email-masked]>
Date: Tue, 13 Nov 2001 08:03:12 -0700

There is a case where an implementation could choose to use only the first
of the two session objects, 
and discard the other, specifically when they are duplicates, but that is an
implementation specific decision.

> From: Feng, Mark [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 7:20 PM
> To: 'Hong Liao'; [email-masked]
> Subject: RE: RSVP questions---two session objects in one rsvp path msg
> 
>