Subject: Why LSR need to know of EXP<->PSC maps in MPLS DiffServ model

From: Vishal M <[email-masked]>
Date: Thu, 15 Nov 2001 16:00:28 -0800 (PST)

Hi,

This is quite a basic question on on MPLS Support of
Diff Serv (draft-ietf-mpls-diff-ext-09.txt).

The draft talks about having EXP<=>PHB mappings on all
the LSRs a LSP passes through.

I understand the need for having PSC mapping to EXP on
the ingress LER. i.e. an ingress LER that converts IP
to MPLS would have to use the IP DSCP bits to generate
MPLS EXP bits.

Consider a core LSR (acting as transit for LSP), why
does it need to know about the PSCs (i.e. mapping
EXP<=>PSC) ? 

It could possibly make all the decisions about
internal scheduling etc based on EXP bits on the
incoming MPLS packets.

Could someone please clarify this.

Thanks a lot for your time,

Regards,
Vishal.

__________________________________________________
Do You Yahoo!?
Find the one for you at Yahoo! Personals
http://personals.yahoo.com

---

From: Vishal M <[email-masked]>
Date: Thu, 15 Nov 2001 20:15:46 -0800 (PST)

Perhaps I should re-phrase my question:

The packet is classified by the ingress LER and EXP
bits are marked. IP packet is prefixed with MPLS shim
header and forwarded in the MPLS cloud.

Questions:
==========
Why do we need to propagate (or signal) EXP<=>PHB
mapping to the core-LSRs ?

Why can't the core LSRs do the scheduling just based
on the EXP bits ? What additional functionality does
the PHBID serve at the core-LSRs?

Could someone pls help...

Thanks,
Vishal.