Subject: Re: question on e-lsp and l-lsp

From: Vishal M <[email-masked]>
Date: Thu, 1 Nov 2001 12:59:27 -0800 (PST)

Hi,

I have some followup questions on L-LSP and E-LSPs:

1. Can we map multiple CTs onto a single L-LSP ? The
draft seem to suggest that creation of a separate LSP
can be done for every CT. 

Is creation of separate L-LSP mandatory for every CT
or  is it left to the implementation?

2. Somewhere I read that E-LSP shouldn't be used for
ATM-LSR. Could someone please explain why ?

Thanks for your time,
Vishal.

"Fan, Zhong" wrote:
> 
> Can anybody shed some light on the differences
between e-lsp and
> l-lsp please? I'm reading
draft-ietf-mpls-diff-ext-09.txt at the
> moment. Although the draft gives denifition of these
two kinds of
> LSPs, I am still confused. Is this all about the
mapping of diffserv
> classes to MPLS FEC or EXP?

The draft explains the differences.

In superbrief summary;

- An L-LSP has one QoS for all packets.  It is
determined at LSP
  setup.  This is similar to setting up an LSP without
any DiffServ
  extensions, except that the objects used in the
signaling are
  different.

- An E-LSP has up to 8 QoS levels for the single LSP. 
The EXP bits
  determine the appropriate QoS on a per-packet basis.
 The QoS that
  is assigned to each EXP value is signaled at LSP
setup (or is a
  configured default if the values are not signaled.)

-- David

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: "Yongjun Im" <[email-masked]>
Date: Thu, 1 Nov 2001 15:25:40 -0600

----- Original Message ----- 
From: "Vishal M" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, November 01, 2001 2:59 PM
Subject: Re: question on e-lsp and l-lsp

> can be done for every CT. 

What is CT?
> ATM-LSR. Could someone please explain why ?

Since ATM-LSR has only cell switching capability, it is not able to
look into EXP field in the shim header. Howerver, Edge ATM-LSR can look into 
EXP field.

---

From: David Charlap <[email-masked]>
Date: Thu, 01 Nov 2001 16:58:29 -0500

Vishal M wrote:
> 
> 2. Somewhere I read that E-LSP shouldn't be used for ATM-LSR. Could
> someone please explain why ?

ATM switches usually do not have the ability to make switching/queueing
decisions based on more information than what's in the 5-byte cell
header.  Without this capability, E-LSPs can not be properly
implemented.

-- David

---

From: Yongjun Im <[email-masked]>
Date: Thu, 01 Nov 2001 19:35:44 -0600

----- Original Message ----- 
From: "Vishal M" <[email-masked]>
To: "Yongjun Im" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, November 01, 2001 7:28 PM
Subject: Re: question on e-lsp and l-lsp

> ...I apologize...CT stands for Class Type...
> So can we map multiple Class Types onto a single
> L-LSP ?
In order to map multiple class types to LSP, the class type should be
mapped into EXP fileld in a shim header. That is the definition of E-LSP.
In case of L-LSP, the only class identifier available to an LSR is a label value.
That is the definition of L-LSP.
> Thanks,
> Find a job, post your resume.
> http://careers.yahoo.com
>

---

From: Vishal M <[email-masked]>
Date: Thu, 1 Nov 2001 17:28:54 -0800 (PST)

Thanks,
Vishal.