Subject: MIBs and TTL

From: "David Allan" <[email-masked]>
Date: Mon, 26 Nov 2001 13:39:13 -0500

Quick question,

From what I can see, none of the MPLS MIBs seem to acknowledge TTL. There's
a couple of issues to address:

- what to do at the egress of a non-TTL capable link. (e.g. how much to
decrement the value). This looks like an LSR-MIB "in-segment" table issue.
- whether to use pipe or uniform model at an LSR ingress point (which looks
like it hits a bunch of places, FTN, MPLS-TE and LSR).

Did I miss it somewhere?

thanks
Dave

---

From: Eric Gray <[email-masked]>
Date: Mon, 26 Nov 2001 15:44:04 -0500

David,

    For non-TTL capable links, the TTL should have been decremented at
the ingress, rather than the egress.  The ingress - for example - may
decrement by one, or by the hop-count.  If these are the choices, the
actual decrement at the ingress will depend on the model of the LSP.

You wrote:

>
>
> Quick question,
>
> From what I can see, none of the MPLS MIBs seem to acknowledge TTL. There's a couple of issues to address:
>
> - what to do at the egress of a non-TTL capable link. (e.g. how much to decrement the value). This looks like an LSR-MIB "in-segment" table issue.
>
> - whether to use pipe or uniform model at an LSR ingress point (which looks like it hits a bunch of places, FTN, MPLS-TE and LSR).
>
> Did I miss it somewhere?
>
> thanks
> Dave
>
>
>

--
Eric Gray (mailto:[email-masked])
http://www.mindspring.com/~ewgray