Subject: RE: MIBs and TTL

From: [email-masked]
Date: Tue, 27 Nov 2001 09:08:04 -0000

Eric....what happens if you decrement at an ingress by N say (N being the
'guessed/known' number of hops) and then protection switching occurs such
that the hops change to M now.....does one have to re-set the ingress
decrement to the new 'guess/known' number of hops?

regards, Neil

> -----Original Message-----
> From: Eric Gray [mailto:[email-masked]]
> Sent: 26 November 2001 20:44
> To: David Allan
> Cc: mpls
> Subject: Re: MIBs and TTL
> 
> 
> David,
> 
>     For non-TTL capable links, the TTL should have been decremented at
> the ingress, rather than the egress.  The ingress - for example - may
> decrement by one, or by the hop-count.  If these are the choices, the
> actual decrement at the ingress will depend on the model of the LSP.
> 
<snipped to end>

---

From: Eric Gray <[email-masked]>
Date: Tue, 27 Nov 2001 11:36:06 -0500

Neil,

    Three comments WRT this question:

    1) This is one of the really good reasons why you might use the pipe model -
        you probably would not want to age a customer's packets differently because
        of an internal routing change (or - in your example - mishap);

    2) Unless the LSR is patently incapable of being an intermediate LSR, it will
        almost certainly have stored the current hop-count for whatever Label it is
        presently using for any particular LSP;

    3) If you're alluding to the idea that hop-count may not have been provided, I
        believe this to be very unlikely in the non-TTL capable LSP case.

--
Eric Gray (mailto:[email-masked])
http://www.mindspring.com/~ewgray