Subject: RE: CLASSTYPE object

From: "Iren, Sami" <[email-masked]>
Date: Tue, 6 Nov 2001 10:56:37 -0500

Vishal:
The EXP bits in the shim header is used to signal
the per hop behavior (PHB) which implies the service
class (PSC). It has nothing to do with the CLASSTYPE 
mentioned in the draft you pointed out
(Protocol extensions for support of DiffServ-aware
MPLS TE).

Your understanding that the CLASSTYPE is used to
specify the bandwidth pool to be used for allocating
resources during LSP Setup is correct. In this context,
the service class which is signalled via EXP bits 
(in the case of E-LSPs) dictate the treatment given
to the individual packets, and the CLASSTYPE, which
is signalled per LSP, dictates where the bandwidth
is coming from (used in CAC).

There are various other drafts on this issue and as far
as I know, no clear cut solution exists today.
Ideally, I would prefer to get rid of the CLASSTYPE
concept and advertise available bandwidth per service class.
(Or keep the CLASSTYPE concept but have one CLASSTYPE
per service class, instead of limiting it to 4).
However, because of the scalability problem, the current
draft suggests that there should be 4 CLASSTYPES
(CLASSTYPE 0 is implicit and indicates the link bandwidth).
Each service class is assigned to one of these four
CLASSTYPEs.
A related draft (draft-ietf-tewg-diff-te-reqts-01.txt)
suggests that DS-TE must support a minimum of 4 CLASSTYPEs.

I hope this is helpful for you.
Regards,
--Sami

> -----Original Message-----
> From: Vishal M [mailto:[email-masked]]
> Sent: Monday, November 05, 2001 10:36 PM
> To: [email-masked]
> Subject: CLASSTYPE object
> 
> 
> 
> Hello,
> 
> MPLS header has 3 bits for EXP, so there are 8
> possible combinations of different traffic types.
> 
> Draft "Protocol extensions for support of
> DiffServ-aware MPLS TE, version 00.txt", Section 11.2
> defines a new CLASSTYPE Object. The values for CT are
> defined (or restricted) to be 1, 2 and 3.
> 
> My understanding is that the CLASSTYPE is used to
> specify the bandwidth pool to be used for allocating
> resources during LSP Setup.
> 
> The draft seem to limit the scope of CT to just three
> different bandwidth pools. 
> 
> Questions:
> 1. Is there any particular reason why it was done that
> 
> way ? 
> 2. Instead of atleast having 8 such bandwidth pools
> (allowing CT to be from 1 to 8), why is it restricted
> to 1 to 3 ?
> 
> Or Am I mis-interpreting something ? 
> 
> Thanks for your time,
> 
> Vishal.
> 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Find a job, post your resume.
> http://careers.yahoo.com
>

---

From: Nabil Seddigh <[email-masked]>
Date: Wed, 07 Nov 2001 11:28:41 -0500

Sami,

Currently, the CLASSTYPE object cannot really be used with 
E-LSPs in the manner you describe. The CLASSTYPE object is only
useful with L-LSPs.

In order to utilize the concept of bandwidth pools in E-LSP,
one needs to be able to signal traffic parameters per class 
or per-PSC. That capability is not present in the standards today.

The closest proposal to achieve what you describe is the following:
http://www.ietf.org/internet-drafts/draft-ganti-mpls-diffserv-elsp-00.txt

Best,
Nabil Seddigh

> [....deleted....]