Subject: next hop change in CRLDP

From: "Venkat Dabbara" <[email-masked]>
Date: Mon, 19 Nov 2001 21:31:23 +1000

hai ,

         This is regarding next hop change in CRLDP ( Better next hop avalability ) .
         I could find some discussion happening before on this but it wasn't satisfactory 

         Some one had asked 

>Suppose a CRLSP is setup with no-pin option and  LSR-A is 
> part of LSP as 
> loose hop member. 
> When LSR-A finds better nexthop, it is supposed to taer down 
> LSP along old 
> path  and send label request to new nexthop. For this, LSR-A 
> has to store 
> all the TLVs it received in CRLSP initiation request so that 
> it can initiate 
> request along new nexthop. Does not it imply that CR-LDP is 
> not scalable? 

And some one had answered it saying 

>" This is not a scalability issue but a simple engineering issue, 
> no-pinning with a CR-LDP loose hop is an unlikely scenario. 
> No pinning is most appropriate with LDP. "

Ruling out such a scenario doesn't seem  to solve the problem ..What if the scenario comes in ??
Surely we can react as it is being done in LDP where u just tear down the path .
Some thing of " make and break"  policy should be done which would be of some meaning rather than going for
 "break and make "
as done in LDP where u land up tearing down the CRLSP for every better next hop avalibility.

As pointed out by some one , will it be scalable to store the list of remaining hops present in ERTlv
at every hop ??? If yes ,this would solve the purpose to some extent ...

Please correct me if i am wrong.

regards
venkat

---

From: "abhay" <[email-masked]>
Date: Tue, 20 Nov 2001 16:23:02 +0530

hello venkat,
                 Yes,why not,there is no hard based rule for not storing ER-TLV's
                   Ref T.E MIB
                  One reason for not doing so would be that usually Loose hops
                  are not directly connected.
                  In other words the administrator does not know the stable topology
                  and gives it a shot by specifying the next hop to be loose,which means
                  the loose hop can be reached through any router.(Here if route pinning is
                  applied,then a better next hop is no use).

                  But,to do that,your MPLS management should very very efficient
                  In such cases,when you might have a lot of communication between
                  your signaling and forwarding management.
                  
                  Also,there arises a question,of controlling the child like Ingress of the Initiated LSP
                  to sustain the paths,since this is a downstream on demand mode
                  
                  Also,whats the used of the better next hop ?.I dont see any good use of it,when one
                  has a CR-LSP.
                  I guess it more of engineering and adding an extra rear view mirror to CR-LDP
                  Hope this helps,
                  Regards,
                  Abhay

----- Original Message ----- 
From: Venkat Dabbara <[email-masked]>
To: <[email-masked]>
Sent: Monday, November 19, 2001 5:01 PM
Subject: next hop change in CRLDP 

hai ,

         Some one had asked 

regards
venkat

---

From: "Venkat Dabbara" <[email-masked]>
Date: Tue, 20 Nov 2001 17:25:18 +0530 (IST)

hai abhay ,

            Thanks for the reply ...Well , i too don't see
         ne good reason for having a new next hop availablity 
        in CRLDP . Just wanted to knoe that if there is any 
        standard way in which a LSR should behave when it 
        comes accross a situation ...

         I feel route pinning every CRLSP by default would 
        solve things wherein u never respond to a new next hop
         availablity and continue to use the same old pinned
        path ....Is that ok ??

thanks and regards
venkat

On Tue, 20 Nov 2001, abhay wrote:

> From: Venkat Dabbara +ADw-venkat.dabb+AEA-wipro.com+AD4-
> To: +ADw-mpls+AEA-UU.NET+AD4-
> +AD4-Suppose a CRLSP is setup with no-pin option and  LSR-A is 
> +AD4- part of LSP as 
> +AD4- loose hop member. 
> +AD4- When LSR-A finds better nexthop, it is supposed to taer down 
> +AD4- LSP along old 
> +AD4- path  and send label request to new nexthop. For this, LSR-A 
> +AD4- has to store 
> +AD4- all the TLVs it received in CRLSP initiation request so that 
> +AD4- it can initiate 
> +AD4- request along new nexthop. Does not it imply that CR-LDP is 
> +AD4- not scalable? 
> 
> +AD4AIg- This is not a scalability issue but a simple engineering issue, 
> +AD4- no-pinning with a CR-LDP loose hop is an unlikely scenario. 
> +AD4- No pinning is most appropriate with LDP. +ACI-
> 
> Some thing of +ACI- make and break+ACI-  policy should be done which would be of some meaning rather than going for
>  +ACI-break and make +ACI-