Subject: Re : changes to unnumbered and link bundling

From: "manoj juneja" <[email-masked]>
Date: Wed, 28 Nov 2001 02:37:33 -0700

Hi Yakov,
          Should we assume these changes as final ? Does this mean that for 
establishing bi-directional LSP, if_index need to be specified and there is 
no need to specify component_id_upstream/downstream for bi-directional LSP ?

Regards,
manoj.

>-----Original Message-----
>From: Yakov Rekhter [mailto:[email-masked]]
>Sent: Friday, November 02, 2001 9:02 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: changes to unnumbered and link bundling
>
>
>Folks,
>
>Based on the results of the e-mail exchange on this list
>I plan to make the following changes in draft-ietf-mpls-bundle,
>draft-ietf-mpls-rsvp-unnum, and in draft-ietf-mpls-crldp-unnum:
>
>1) Mandate that one always use the IF_ID HOP on bundled links
>    (thus eliminating the Implicit Indication from
>     draft-ietf-mpls-bundle-00.txt).
>
>2) Do away with the COMPONENT_IF_* TLV, and just use IF_INDEX for
>    identifying (unnumbered) components in link bundling
>
>3) Mandate that one always use the IF_ID HOP object on an unnumbered
>    link.
>
>4) Make handling numbered and unnumberd interfaces in the ERO
>    more consistent/uniform by changing the semantics of the Unnumbered
>    interface subobject (or more precisely the Interface ID field
>    of this subobject) from:
>
>        The Interface ID is the outgoing interface identifier with
>        respect to the LSR specified by the router ID.
>
>    to
>
>        The Interface ID is the interface identifier assigned to
>        the interface by the LSR specified by the router ID.
>
>    and making other appropriate changes in the text to reflect this.
>
>Yakov.

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 29 Nov 2001 06:58:30 -0800

Manoj,

> no need to specify component_id_upstream/downstream for bi-directional LSP ?

see draft-ietf-mpls-bundle-01.txt.

Yakov.