Subject: MessageID in PathErr/ResvErr/PathTear/ResvTear

From: Manoj Agiwal <[email-masked]>
Date: Tue, 12 Feb 2002 17:30:00 +0530

Hi ,
       Whether the message ID which will be carried in PathErr / ResvErr ,
is uniquely generated ,  or is it the same MessageID which is received in
the Path message , Resv Message .
       Whether the message ID in Path Tear / Resv Tear should be 
 that of the corresponding Path State or Resv State or it should
 be uniquely generated at each node .
Regards ,
Manoj

---

From: Suresh Katukam <[email-masked]>
Date: Tue, 12 Feb 2002 08:31:28 -0800

Manoj,

It should be uniquely generated at each node. Only Refresh
messages should use previous PATH/RESV message ids.

Thanks,
Suresh

---

From: Khuzema Pithewan <[email-masked]>
Date: Wed, 13 Feb 2002 15:28:02 +0530

But I think Err messages can use the message IDs of the corresponding
Path/Resv messages which has caused the error. In RFC it says Error messages
are implicit acknowledgements for the trigger messages, and Ack Message
contain the same the message ID as of the trigger message which it is
acknowledging, so I think Err messages can also contain same message ID as
that of trigger messages.

Regards,
Khuzema.
> ----------
> From: 	Suresh Katukam[SMTP:[email-masked]]
> Sent: 	Tuesday, February 12, 2002 10:01 PM
> To: 	Manoj Agiwal
> Cc: 	[email-masked]'; [email-masked]'
> Subject: 	Re: MessageID in PathErr/ResvErr/PathTear/ResvTear
> 
> 
> Manoj,
>

---

From: Manoj Agiwal <[email-masked]>
Date: Thu, 14 Feb 2002 12:40:55 +0530

Hi ,

      In case if each node is generating unique message ID
      for PathErr , ResvErr , PathTear , Resv Tear how do we 
      check out of order messages ?

     The RFC says for Out of order check .
      
    "This  check should be performed for any message that 
    installs  or changes state.  (Includes at least: Path, Resv, 
    PathTear,  ResvTear, PathErr and ResvErr.)"

     In case of PathTear / Resv Tear , since the same node
     which generates the Resv message or Path message also
     generates Path Tear / Resv Tear , we can check out of order
     with respect to corresponding Message ID of Path State and 
     Resv State .And PathTear and Resv Tear is responsible for
     changing the state .

     But in case of Path Err / Resv Err since it is getting generated
     by a different node , how can we check out of order condition.
     Moreover PathErr / Resv Err is just forwarded and does
     not change any state . 

Regards ,
Manoj