Subject: Re: LDP error code

From: "Igor Achkinazi" <[email-masked]>
Date: Wed, 20 Feb 2002 15:30:17 +0000

Hi,

Note 2 to "A.1.1. Receive Label Request" section in rfc3036 says:
"A duplicate label request is considered a protocol error and
should be dropped by the receiving LSR (perhaps with a suitable
notification returned to MsgSource)."

What is this suitable notification code?

Thanks,
Igor

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

---

From: "HariKishan" <[email-masked]>
Date: Wed, 20 Feb 2002 10:25:10 -0800

There RFC did not define any specific notification code
to handle this case. It should not cause any problem if
the LSR silently drops the duplicate label request.
As a result of this the problem can only be debugged on 
the downstream LSR side as it is the one which detects 
the duplicate label requests. At the same time we don't
loose anything by introducing a new notification code
to handle this case. It could be named as "Duplicate
label request" with both E bit and F bit set to 0. This
helps the upstream LSR to realize that it is misbehaving.
>From the upstream LSR point of view it is a bad protocol
implementation (in fact a bug), which should never happen.

The duplicate label request detection on the downstream
LSR would just guard against misbehaving upstream peers.
Silently ignoring a duplicate label request message 
would not cause any problem to the actual LSP set up
initiated by the original label request.

--Kishan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Igor
> Achkinazi
> Sent: Wednesday, February 20, 2002 7:30 AM
> To: [email-masked]
> Subject: Re: LDP error code
> 
> 
> Hi,
>