Subject: LSPID in ERO

From: "Vijayanand C - CTD, Chennai." <[email-masked]>
Date: Wed, 27 Feb 2002 13:05:58 +0530

Hello all,
I have a question regarding RSVP-TE.

There is no support for LSPID in Explicit Route object whereas in CR LDP
LSPID is supported as an ER-HOP. This is useful in establishing heirarchy of
tunnels and splicing. Why is LSPID not included in RSVP-TE ERO ?

PLease correct me if I made any fundamental error.

Thanks in advance,
Regards,
Vijay

---

From: David Charlap <[email-masked]>
Date: Wed, 27 Feb 2002 11:59:22 -0500

"Vijayanand C - CTD, Chennai." wrote:
> There is no support for LSPID in Explicit Route object whereas in
> CR LDP LSPID is supported as an ER-HOP. This is useful in
> establishing heirarchy of tunnels and splicing. Why is LSPID not
> included in RSVP-TE ERO ?

The hierarchical LSP draft authors chose not to use this mechanism for
RSVP.  Instead, they require an LSR to compare the entire path of an ERO
with the path of an FA-LSP, and use this to decide when an LSP should be
tunneled through another.

Personally, I would much rather use the CR-LDP mechanism, but that
doesn't seem to be an option anymore.

-- David

---

From: "Vijayanand C - CTD, Chennai." <[email-masked]>
Date: Thu, 28 Feb 2002 10:33:00 +0530

David,
Using it like the way it is done in CR LDP has some advantages in some
situations. I wonder why it has been prevented in RSVP.

Is any work being proposed in this direction.

Regards.
Vijay

-----Original Message-----
From: David Charlap [mailto:[email-masked]]
Sent: Wednesday, February 27, 2002 10:29 PM
To: Vijayanand C - CTD, Chennai.
Subject: Re: LSPID in ERO

-- David