Subject: Re: penultimate hop popping!!!

From: Robert Raszuk <[email-masked]>
Date: Wed, 20 Feb 2002 01:13:15 +0100

Mohammed,

>  LSR 4 knows that it is the egress because its
> adjacent is not LSR. But LSR 3 ( penultimate node for
> that LSP)has to do penultimate hop popping .. but it
> has no way to know about this unless informed by LSR
> 4.

Well LSR 3 has to do PHP only if LSR 4 advertised to him implicit-null
label for a given FEC. 
 
> QUERY : How does LSR 4 inform LSR 3 that it has to do
> penultimate hop popping ... DOES it gives LSR 3 an
> IMPLICIT NULL LABEL.

It does but only for connected routes (at least in one implementation
:). So in your case if you are pinging the R5's interfaces towards the
R4 sure LSR3 will do PHP and in the forwarding table for this FEC you
will see "Pop tag". 

On the other hand if your destination is on R5 (loopback) or behind R5
LSR 3 will not do any PHP. LSR 4 entry in the forwarding table will be
untagged and by removing the label the packet will be send to LSR5
unlabeld. 

Also it is probably worth of noting that the difference between "Pop
tag" & "untagged" is that pop tag pops one label on the stack and sends
resulting labeled or unlabeled packet out while untagged removes all
labels from the stack and if the number of removed labels is one the IP
packet is send if it is bigger then one packet is discarded.

Rgs,
R.

>Mohammed wrote:
> 
> Hi all,
> 
>   I have a query regarding penultimate hop popping.
> Please refer to the following figure ..
> 
> 
>       0 --- 1 --- 2 --- 3 ---- 4 --- 5
>             ---------- ----------
>                 MPLS DOMAIN.
> 
>  Lets assume that nodes 1,2,3 and 4 form the MPLS
> domain. Lets say node 0 and node 5 are ip nodes.
> 
>  For traffic generated by node 0 and destined to node
> 5 the path would be 0->1->2->3->4->5 where 1-2-3-4 is
> an LSP.
> 
>  LSR 4 knows that it is the egress because its
> adjacent is not LSR. But LSR 3 ( penultimate node for
> that LSP)has to do penultimate hop popping .. but it
> has no way to know about this unless informed by LSR
> 4.
> 
> QUERY : How does LSR 4 inform LSR 3 that it has to do
> penultimate hop popping ... DOES it gives LSR 3 an
> IMPLICIT NULL LABEL.
> 
>  Any pointers in this area are welcome. PLease also
> suggest other points that i may be missing.
> 
>  Thanks to one and all!
> 
>  Sincerely,
>  Abrar.
> 
> =====
> Abrar Hussain.
> Graduate Student/Network Designer.
> The University of Toledo.
> Toledo,OH.
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Sports - Coverage of the 2002 Olympic Games
> http://sports.yahoo.com
> 
> -------
> The MPLS-OPS Mailing List
> Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
> Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: "HariKishan" <[email-masked]>
Date: Tue, 19 Feb 2002 17:27:33 -0800

As per the RFC3031, LSR 4 is not prohibited from
advertising IMPLICIT NULL label to
LSR 3, for a FEC which covers a destination
on or behind LSR 5. Robert's description
is probably a specific method
of distributing IMPLICIT NULL label.
As per the RFC 3031, if an LSR is egress or
proxy egress for a FEC, it may advertise
IMPLICIT-NULL to the upstream peer.

The following two statements from RFC3031
clarify the above

"A LSR MUST NOT request a label distribution peer to pop
 the label stack unless it is capable of doing so."

"An LSR which is capable of popping the label stack at all MUST do
 penultimate hop popping when so requested by its downstream label
 distribution peer."

---------------------------------
HariKishan Desineni,
Software Engineer,
IP Access,
BU BMSN,
Ericsson,
70 Castilian Drive,
Santa Barbara,
California - 93117
U.S.A

Office:(805) 562 6419
Cell:(805) 252 2641
Home:(805) 562 8841
Fax: (805) 685 4465

> -----Original Message-----
> From: Robert Raszuk [mailto:[email-masked]]
> Sent: Tuesday, February 19, 2002 4:13 PM
> To: Mohammed
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: penultimate hop popping!!!
>
>
> Mohammed,
>

---

From: Mohammed <[email-masked]>
Date: Tue, 19 Feb 2002 14:37:51 -0800 (PST)

Hi all,

 Thanks to one and all!
 
 Sincerely,
 Abrar.

=====
Abrar Hussain.