Subject: fast reroute question

From: [email-masked]
Date: Tue, 12 Feb 2002 11:08:47 -0600

Hi
I refer to the draft "Note also that the
> backup tunnel path computation may be performed by a centralized path
> computation server or may use some distributed backup path computation
> algorithms." 
Does this imply the following:
When the PLR receives the original path message with a fast reroute 
object he could either run CSPF on its own 
or contact the path computation server such that the path computation 
server runs CSPF and sends the ERO for the detour back to the PRL ?

Claus

Dr. Claus Bauer
Research engineer
Tellabs Research Center
One Kendall Square
Bldg. 100, Suite 121
Cambridge, MA, 02139
USA

Tel.: +1 617 577 8787
Fax.: +1 617 494 0118

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Tue, 12 Feb 2002 23:33:18 +0100

Hi Claus,

>server runs CSPF and sends the ERO for the detour back to the PRL ?

What we mean here is that the bypass tunnel path computation may be done in 
different ways:
- static config on every PLR,
- dynamic backup path computation done by the PLR (CSPF is an option)
- backup path computation done by a Path Computation Server,
- ...
Of course the backup path computation complexity is directly correlated to 
the set of constraints that should be taken into account.

JP.