Subject: logical flow of an lsp set up

From: Pratik Shah <[email-masked]>
Date: Fri, 1 Feb 2002 12:45:31 -0800 (PST)

Hi

Iam trying to understand the flow of an lsp set up and
having a confusing time figuring it out. The way I see
the flow is this, but then there are things which
contradict that...

A simple hop-by-hop lsp (not an ER-LSP)::
1.
Fill in the details in the mplsTunnelTable. (Here the
mplsTunnelTable asks for mplsTunnelXCPointer..but then
wouldn't the inseg, outseg and XC be created when we
get the resv back from the next hop ??. Do I have to
fill the mplsTunnelHopTable, and the other tables even
when it is not an ER-LSP.  )

2.
Once details are filled, considering that the
signalling protocol is RSVP, RSVP sets up the path
state and initiates a PATH Msg.

3.
On receiving the resv msg, the inseg, outseg, xc
structures are set up, and the label allocated.

---Would be nice if someone can correct me. OR, is
there any site that has good material on this ?

thanks,
Pratik

__________________________________________________
Do You Yahoo!?
Great stuff seeking new owners in Yahoo! Auctions! 
http://auctions.yahoo.com

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 01 Feb 2002 16:32:02 -0500

>when it is not an ER-LSP.  )

         If you want to set up a simple hand-routed hop-by-hop LSP,
you can set this up just using the MPLS-LSR MIB and avoid
the MPLS-TE MIB altogether. You can set up in/out/XC entries
in the LSR MIB on each LSR along the path. That is, assuming that the LSR
allows this sort of configuration.

         By using the MPLS-TE MIB you are setting up a
traffic-engineered tunnel. As a side-effect, you do get many of
the features offered by the TE tunnel as well. If you specify all hops
(explicit path), then you will get what you want -- a hand-routed LSP --
if such a path can be established that meets the traffic parameters
you specified (or left as default). I just wanted to make the distinction that
you are actually setting up a TE tunnel (and perhaps an associated
TE tunnel interface) as well as the LSP (if the tunnel can be signaled).

>structures are set up, and the label allocated.

         Yes, this is how it works. Let me know if you
have any more questions.

         --Tom

>there any site that has good material on this ?

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.