Subject: Re: non-RSVP routers.

From: "Sean Crocker" <[email-masked]>
Date: Sun, 3 Feb 2002 11:25:38 -0600

>On Fri, 1 Feb 2002, Subhakar K S wrote:
>
>SKS>
>SKS>How does an intermediate router finds if its
>SKS>downstream router is RSVP aware or not.
>
>In the context of MPLS-TE if we configure TE we should enable RSVP at the
>seme time.  If we go with this assumption, then if we receive IGP LSA/LSPs
>describing a link then we can assume it has RSVP turned on.
>
>Of course if this is not the case we'll know when we don't receive RESV
>messages after we send PATH messages :-)

If for some reason the sender didn't do CSPF (and use the IGP-TE info)
before sending PATH, hopefully the node that's downstream to the non-
RSVP node will send back PATHERR with an error code 24 (Routing Problem)
subcode 8 (non-RSVP-capable router stands in the path).

Sean

>
>-ajay
>
>SKS>
>SKS>
>SKS>thanks,
>SKS>S.
>SKS>
>SKS>__________________________________________________
>SKS>Do You Yahoo!?
>SKS>Great stuff seeking new owners in Yahoo! Auctions!
>SKS>http://auctions.yahoo.com
>SKS>
>
>-- 
>Ajay Simha
>MPLS Deployment Engineer
>IOS Technology Division
>Cisco Systems
>(919) 392-3141
>
>"Study as if you were to live forever
> Live as if you were to die tomorrow"
>
> - Mahatma Gandhi
>
>

---

From: Eric Osborne <[email-masked]>
Date: Mon, 4 Feb 2002 00:39:31 -0500

> subcode 8 (non-RSVP-capable router stands in the path).

I don't think so....see rfc3209.  An mpls-te Path message isn't going
to be of much use without a LABEL_REQUEST object, and the unrecognized
object should be rejected.  This implies that the Class-Num for
label_request is of the form 0bbbbbbb, although that doesn't seem to
be explicitly spelled out for this particular object.

---------------
4.2.5. Non-support of the Label Request Object

   An RSVP router that does not recognize the LABEL_REQUEST object sends
   a PathErr with the error code "Unknown object class" toward the
   sender.  An RSVP router that recognizes the LABEL_REQUEST object but
   does not recognize the C_Type sends a PathErr with the error code
   "Unknown object C_Type" toward the sender.  This causes the path
   setup to fail.  The sender should notify management that a LSP cannot
   be established and possibly take action to continue the reservation
   without the LABEL_REQUEST.
----------------

eric

---

From: Tricci So <[email-masked]>
Date: Mon, 04 Feb 2002 10:59:34 -0800

Hi all,

Could somebody please comment on the following email regarding if this is a
correct interpretation of the spec for PHOP to forward IP packet?  Obviously,
the same question applies for POS as well.

Many thanks in advance........
Tricci

=====> Forwarded Message.....

mpls over ethernet

     From: "Zhao, Xingguo" <[email-masked]>
     Date: Wed, 14 Nov 2001 17:03:40 -0600

Hi,

Can Ethernet frame (EtherType = "0x8847", MPLS) carry an unlabelled IP packet?
This looks like illegal.

But we observed Cisco 12000 actually sent out such a frame.

Thanks!