Subject: Re: LDP error code

From: "Igor Achkinazi" <[email-masked]>
Date: Mon, 18 Feb 2002 20:07:37 +0000

Example can be a maximum number of LSPs associated with one FEC. If global 
label space is configured on the LSR, such restriction can help to avoid too 
much wasting of label space.

Thanks,
Igor

>From: Eric Gray <[email-masked]>
>To: Igor Achkinazi <[email-masked]>
>CC: [email-masked]
>Subject: Re: LDP error code
>Date: Mon, 18 Feb 2002 14:56:38 -0500
>
>Igor,
>
>    A quick answer:  You can release an unsolicited Mapping
>without providing a status code.  If the local LSR peer is not
>asking for the label mapping, then rejecting it for local policy
>reasons does not have to look dfferent then releasing it for any
>other reason.  The concept of 'unwanted Label Request' is an
>interesting one - which probably means you need to give some
>sort of example.
>
>You wrote:
>
>>Hi,
>>
>>What error code should be sent by LDP in case incoming Label Request
>>or Unsolicited Label Mapping is rejected by some internal policy
>>decision? In section 3.9 rfc3036 there are 3 status codes for response
>>to incoming Label Request in LDP: No Route, No Label Resources, Label
>>Resources Available, plus 8 CR-LDP specific codes described in
>>rfc3212. There are no codes at all in response to Unsolicited Label
>>Mapping that can be actually released just using regular Label Release
>>message. I still cannot find a status code to reject unwanted Label
>>Request.
>>
>>Thanks a lot,
>>Igor
>>
>>
>>_________________________________________________________________
>>Chat with friends online, try MSN Messenger: http://messenger.msn.com
>>
>
>
>--
>--
>Eric Gray (mailto:[email-masked])
>http://www.mindspring.com/~ewgray
>
>
>

_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

---

From: "HariKishan" <[email-masked]>
Date: Mon, 18 Feb 2002 13:34:40 -0800

This can be implemented with the existing
"No Label resources" mechanism. When you
reach the max limit of labels in global 
label space send "NO Label resources".

Whenever the LSR moves from "NO labels" to
"Labels available" state in global label 
space, send "Label resources available" to 
the peer. 

I don't see the requirement for
a new error code for the case you described.

Thanks,
Kishan
---------------------------------
HariKishan Desineni,
Software Engineer,
IP Network Edge Access Unit,
BU BMSN,
Ericsson,
70 Castilian Drive,
Santa Barbara,
California - 93117
U.S.A

Office:(805) 562 6419
Cell:(805) 252 2641
Home:(805) 562 8841
Fax: (805) 685 4465