Subject: RE: Penultimate Hop layer-2 EtherType setting for MPLS

From: Shahram Davari <[email-masked]>
Date: Mon, 4 Feb 2002 14:06:04 -0800

Tricci,

The behavior that you described below is not a right behavior. When there is no MPLS label, the Ethertype value should indicate IP, regardless of it being produced by an MPLS PHP node or an IP node. By using 0x8847, The downstream node has no way of knowing that there is no label in the encapsulated packet, and will interpret the first 4 byte of the IP header as MPLS label.

Yours,
-Shahram

> -----Original Message-----
> From: Tricci So [mailto:[email-masked]]
> Sent: Monday, February 04, 2002 2:00 PM
> Cc: [email-masked]
> Subject: Penultimate Hop layer-2 EtherType setting for MPLS 
> 
> 
> Hi all,
> 
> Could somebody please comment on the following email 
> regarding if this is a
> correct interpretation of the spec for PHOP to forward IP 
> packet?  Obviously,
> the same question applies for POS as well.
> 
> Many thanks in advance........
> Tricci
> 
> =====> Forwarded Message.....
> 
> mpls over ethernet
> 
>      From: "Zhao, Xingguo" <[email-masked]>
>      Date: Wed, 14 Nov 2001 17:03:40 -0600
> 
> Hi,
> 
> Can Ethernet frame (EtherType = "0x8847", MPLS) carry an 
> unlabelled IP packet?
> This looks like illegal.
> 
> But we observed Cisco 12000 actually sent out such a frame.
> 
> Thanks!
>

---

From: Tricci So <[email-masked]>
Date: Mon, 04 Feb 2002 14:03:24 -0800

Shahram, I agree.  Thanks.

Cheers,
Tricci