Subject: RE: Label Set Object

From: John Drake <[email-masked]>
Date: Wed, 8 May 2002 18:37:32 -0700

Is it the case that ALL current SONET/SDH equipment has the restriction that
the labels (timeslots) must be the same in both directions?  If this is the
case, then it's really simple; for an SONET/SDH LSP, only the upstream label
needs to be specified, and the downstream label MUST be the same.

One the other hand, if not all current SONET/SDH equipment has this
restriction or the current SONET/SDH standards allow the labels (timeslots)
to be different in each direction, then label set with one value or explicit
label control would be useful for equipment that does have this restriction.

-----Original Message-----
From: Suresh Katukam [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 3:23 PM
To: Zafar Ali
Cc: Manoj Agiwal; Manoj Agiwal; 'Ccamp (E-mail); mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

For TDM, since you have to use same labels in both directions, why do you 
have to specify anything at all?
How can a downstream TDM node pick a label that does not match with 
Upstream label for
a bidirectional LSP? If it picks any other label, LSP is not functional.

If there are Uni-directional LSPs in TDM and if you have different types of 
time slots available
in both directions, then one may be able to setup bidirectional LSP on 
different links or
different labels. This is in theory and not in practice.

So in practice, one does not need to specify LABEL SET or Suggested label 
for TDM links.

Thanks,
Suresh

At 01:53 AM 5/8/2002 -0400, Zafar Ali wrote:
>At 11:11 AM 5/8/2002 +0530, Manoj Agiwal wrote:
>>Hi ,
>>    I guess in that case we can use Suggested Label , Label Set still can 
>> still be avoided .
>
>Hi Manoj,
>
>No, the use of suggested label in this case would NOT be correct, as the 
>suggested labels can be ignored/ overridden by the receiving node.
>
>Thanks
>
>Regards... Zafar
>
>>Regards ,
>>Manoj
>>-----Original Message-----
>>From: Zafar Ali [mailto:[email-masked]]
>>Sent: Wednesday, May 08, 2002 11:05 AM
>>To: Manoj Agiwal; 'Ccamp (E-mail)
>>Cc: mpls@UU. NET (E-mail)
>>Subject: Re: Label Set Object
>>
>>At 10:00 AM 5/8/2002 +0530, Manoj Agiwal wrote:
>>>Hi ,
>>>        In gmpls signaling extensionsions for RSVP-TE , ccamp 
>>> architecture on
>>>gmpls has described Label Set object usage
>>>     only for the "optical" domain viz. for carrying wavelengths (
Section
>>>9.9 draft-ietf-ccamp-gmpls-architecture-02.txt) .
>>>
>>>        Do we require to send Label set(i.e. time slots) for TDM 
>>> switching as
>>>well . In what way it can be useful .
>>Dear Manoj,
>>
>>Yes, label set object is also useful in TDM case. E.g., SONET poses an 
>>additional requirement that the two interfaces of a bidirectional LSP 
>>SHOULD traverse the exact same link with the same SUKLM values for the 
>>two directions.
>>  The label set object can be used to constrain the downstream label to 
>> the same as the upstream label.
>>
>>Thanks
>>
>>Regards... Zafar
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>>Regards ,
>>>Manoj
>>===============
>>Zafar Ali
>>Cisco Systems
>>(734) 276-2459
>>100 S Main St. #200
>>Ann Arbor, MI 48104.
>>email: [email-masked]
>
>===============
>Zafar Ali
>Cisco Systems
>(734) 276-2459
>100 S Main St. #200
>Ann Arbor, MI 48104.
>email: [email-masked]

---

From: "sushantm" <[email-masked]>
Date: Thu, 9 May 2002 10:45:11 +0530

Hi  John ,
I agree to the first case but in the second case, suppose the ERO is not
used , why would we have
to restrict the Label set to only one label value ?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of John
Drake
Sent: Thursday, May 09, 2002 7:08 AM
To: 'Suresh Katukam'; Zafar Ali
Cc: Manoj Agiwal; Manoj Agiwal; 'Ccamp (E-mail); mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

-----Original Message-----
From: Suresh Katukam [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 3:23 PM
To: Zafar Ali
Cc: Manoj Agiwal; Manoj Agiwal; 'Ccamp (E-mail); mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Thanks,
Suresh

Section

---

From: "sushantm" <[email-masked]>
Date: Thu, 9 May 2002 10:45:11 +0530

Hi  John ,

-----Original Message-----
From: Suresh Katukam [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 3:23 PM
To: Zafar Ali
Cc: Manoj Agiwal; Manoj Agiwal; 'Ccamp (E-mail); mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Thanks,
Suresh

Section

---

From: Maarten Vissers <[email-masked]>
Date: Mon, 13 May 2002 14:07:50 +0200

John,

John Drake wrote:
> the labels (timeslots) must be the same in both directions?  

Nobody can answer this question, while none of us has a complete overview of
equipment in the field and under design :-).

SDH/SONET (and OTN) networks are networks optimised for bi-directional
connectivity. Uni-directional connections are supported as kind of "exception"
on the generic bidirectional rule. SDH standards are assuming bidirectional
connectivity.
Sometimes a unidirectional connection causes the set up of a bidirectional
connection of which only one direction is used (and alarming in the other
direction is disabled). 

People are asking questions with respect to unidirectional connection support in
SDH standards. The use of functional modelling method supports so far the
specific unidirectional connection issues (e.g. no RDI/REI return) raised; but
it is only at this point where you can show how a unidir connection would/should
behave.

> If this is the

SDH/SONET networks are build with the requirement that the timeslots in the two
directions are the same. (Note - same requirement applies to ATM networks in
which VPI/VCI for the two directions must be the same).

Regards,

Maarten

---

From: Suresh Katukam <[email-masked]>
Date: Mon, 13 May 2002 11:32:17 -0700

>equipment in the field and under design :-).

Well said.

>connection of which only one direction is used (and alarming in the other

This is usually correct. A new term is being used in some emails  called
"pure Unidirectional" when the reverse direction of a unidirectional 
circuit can
be used to setup another unidirectional circuit.

>it is only at this point where you can show how a unidir connection 

this requires quite a bit of co-ordination between two end points in a pure
unidirectional connections about informing alarms from drop to source etc. As
you said, it is not yet known how to do this..

>which VPI/VCI for the two directions must be the same).

When you have pure unidirectional connections, it is possible to have 
different time
slots in two directions. Again, this is a theory and a distant possibility.

Thanks,
Suresh

---

From: "Venkat Dabbara" <[email-masked]>
Date: Wed, 15 May 2002 20:32:45 +1000

hai ,

            In draft-ietf-mpls-generalized-cr-ldp-06.txt
      2.5.1. Procedures
                A Label Set is defined via one or more Label Set TLVs.
Specific
               labels/subchannels can be added to or excluded from a Label
Set via
               Action zero (0) and one (1) TLVs respectively.  Ranges of
               labels/subchannels can be added to or excluded from a Label
Set via
               Action two (2) and three (3) TLVs respectively.

    The first line of the sec 2.5.1 says a label set is defined via one or
more LabelSet TLVs. My interpretation
    about this is that a label request can have multiple Label Set TLVs in
it with different action types corresponding
     to each label set TLV. Am i right ??
     If  i am wrong please do clarify ...

     If yes, then assume i get a request with one label set TLV with action
type 0 which has a list of labels
    and other Label set TLV with action type 1 which has a range of Labels.
Now in this case i go about
    picking up a label from the second label set TLV only if i am not able
to pick up a label from the first
    label set TLV....Is that true ??

    Now situation may get even worse when i have a Label set TLV with action
type to include a label
    set and other Label Set TLV with action type exclude. I knoe such
situations are not practical but
    sure needs to be handled someway.

    Please do clarify

venkat

PS: Please don't bother about the disclaimer which come attached with this
mail.