Subject: RE: WG Last call - draft-ietf-mpls-bundle-mib-01.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 2 May 2002 00:14:14 +0200

Sorry to say so, but when I see something in WG (or whatever)
Last Call and I see so many syntax issues, I sort of think:
  oh well... I will not waste my time
I suspect many other MIB people may do the same.
Why don't you fix those things first?

Bert 

> -----Original Message-----
> From: Martin Dubuc [mailto:[email-masked]]
> Sent: Thursday, May 02, 2002 12:03 AM
> To: Wijnen, Bert (Bert); Loa Andersson; George Swallow; Thomas Nadeau
> (E-mail); [email-masked]; [email-masked]; [email-masked]; Scott
> Bradner
> Subject: RE: WG Last call - draft-ietf-mpls-bundle-mib-01.txt
> 
> 
> Bert,
> 
> I requested Last Call for the link bundling MIB at the same 
> time as LMP MIB. I didn't know before these two requests that 
> I could use a stricter level of error checking with smilint. 
> I do intend to clean up both LMP and link bundling MIBs of 
> all errors reported by smilint with the highest level of checking.
> 
> I still believe that the link bundling MIB addresses key 
> concepts and is worth going to Last Call at this point.
> 
> Regards,
> 
> Martin 
> 
> -----Original Message-----
> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Wednesday, May 01, 2002 5:45 PM
> To: Loa Andersson; George Swallow; Thomas Nadeau (E-mail); 
> Martin Dubuc;
> [email-masked]; [email-masked]
> Cc: Scott Bradner
> Subject: RE: WG Last call - draft-ietf-mpls-bundle-mib-01.txt
> 
> 
> I really wonder how you can do a WG Last Call for this doc.
> If I do a SMICng compile to do syntax check, I get
> 14 errors and 22 warnings. I have not looked at the content yet.
> But if WGs deliver this type of stuff to the ADs, then I 
> wonder if we should in fact even spend time on it?
> 
> Sorry, but I get rather frustrated of this. I think I mentioned
> this type of concern many times to this WG and to some of the
> authors before.
> 
> Bert 
> ------------ SMICng log ---------------
> In file mplsbundle.mi2
>     80:    REVISION
>     81:        "200105223200Z"  -- 22 May 2001 12:00:00 EST
>                ^
> W: REVISION value "200105223200Z" is not a valid extended UTC time
>   1124: 
>   1125:       OBJECT      teLinkRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkRowStatus"
>   1132: 
>   1133:       OBJECT      teLinkStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkStorageType"
>   1140: 
>   1141:       OBJECT      teLinkDescrRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkDescrRowStatus"
>   1147: 
>   1148:       OBJECT      teLinkDescrStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkDescrStorageType"
>   1156:       OBJECT      teLinkOspfLinkId
>   1157:       SYNTAX      INTEGER { pointToPoint(1) }
>                           ^
> E: Syntax type does not match that for "teLinkOspfLinkId"
>   1155: 
>   1156:       OBJECT      teLinkOspfLinkId
>                           ^
> E: MIN-ACCESS value incompatible with access specified for 
> "teLinkOspfLinkId"
>   1163: 
>   1164:       OBJECT      srlgRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for "srlgRowStatus"
>   1171: 
>   1172:       OBJECT      srlgStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "srlgStorageType"
>   1179: 
>   1180:       OBJECT      teLinkBandwidthRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkBandwidthRowStatus"
>   1187: 
>   1188:       OBJECT      teLinkBandwidthStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkBandwidthStorageType"
>   1195: 
>   1196:       OBJECT      dataBearingChannelRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "dataBearingChannelRowStatus"
>   1203: 
>   1204:       OBJECT      dataBearingChannelStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "dataBearingChannelStorageType"
>   1211: 
>   1212:       OBJECT      dataBearingChannelDescrRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "dataBearingChannelDescrRowStatus"
>   1218: 
>   1219:       OBJECT      dataBearingChannelDescrStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "dataBearingChannelDescrStorageType"
>   1226: 
>   1227:       OBJECT      dataBearingChannelBwRowStatus
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "dataBearingChannelBwRowStatus"
>   1234: 
>   1235:       OBJECT      dataBearingChannelBwStorageType
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "dataBearingChannelBwStorageType"
>   1211: 
>   1212:       OBJECT      dataBearingChannelDescrRowStatus
>                           ^
> E: OBJECT-TYPE "dataBearingChannelDescrRowStatus" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1218: 
>   1219:       OBJECT      dataBearingChannelDescrStorageType
>                           ^
> E: OBJECT-TYPE "dataBearingChannelDescrStorageType" is not in 
> a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1226: 
>   1227:       OBJECT      dataBearingChannelBwRowStatus
>                           ^
> E: OBJECT-TYPE "dataBearingChannelBwRowStatus" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1234: 
>   1235:       OBJECT      dataBearingChannelBwStorageType
>                           ^
> E: OBJECT-TYPE "dataBearingChannelBwStorageType" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1314:       OBJECT      teLinkOspfLinkId
>   1315:       SYNTAX      INTEGER { pointToPoint(1) }
>                           ^
> E: Syntax type does not match that for "teLinkOspfLinkId"
>   1313: 
>   1314:       OBJECT      teLinkOspfLinkId
>                           ^
> W: MIN-ACCESS value identical to access specified for 
> "teLinkOspfLinkId"
>   1375: 
>   1376:       OBJECT      dataBearingChannelEncodingType
>                           ^
> E: OBJECT-TYPE "dataBearingChannelEncodingType" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1380: 
>   1381:       OBJECT      dataBearingChannelDescrPriority
>                           ^
> E: OBJECT-TYPE "dataBearingChannelDescrPriority" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1385: 
>   1386:       OBJECT      dataBearingChannelMinReservableBandwidth
>                           ^
> E: OBJECT-TYPE "dataBearingChannelMinReservableBandwidth" is 
> not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1390: 
>   1391:       OBJECT      dataBearingChannelDescrRowStatus
>                           ^
> E: OBJECT-TYPE "dataBearingChannelDescrRowStatus" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1397: 
>   1398:       OBJECT      dataBearingChannelDescrStorageType
>                           ^
> E: OBJECT-TYPE "dataBearingChannelDescrStorageType" is not in 
> a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1405: 
>   1406:       OBJECT      dataBearingChannelBwRowStatus
>                           ^
> E: OBJECT-TYPE "dataBearingChannelBwRowStatus" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>   1413: 
>   1414:       OBJECT      dataBearingChannelBwStorageType
>                           ^
> E: OBJECT-TYPE "dataBearingChannelBwStorageType" is not in a 
> MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
>      4:    MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
>      5:    experimental, Integer32, Unsigned32
>                          ^
> W: "Integer32" imported but not used
>     10: 
>     11:    TEXTUAL-CONVENTION, TruthValue, RowStatus, StorageType,
>            ^
> W: "TEXTUAL-CONVENTION" imported but not used
>     11:    TEXTUAL-CONVENTION, TruthValue, RowStatus, StorageType,
>     12:    RowPointer, TimeStamp
>            ^
> W: "RowPointer" imported but not used
>                        ^
> W: "TimeStamp" imported but not used
>     14: 
>     15:    InterfaceIndex, InterfaceIndexOrZero, ifIndex
>            ^
> W: "InterfaceIndex" imported but not used
>     21: 
>     22:    InetAddressType, InetAddress
>            ^
> W: "InetAddressType" imported but not used
> 
> *** 14 errors and 22 warnings in parsing
>

---

From: "Martin Dubuc" <[email-masked]>
Date: Wed, 1 May 2002 18:02:32 -0400

Bert,

I requested Last Call for the link bundling MIB at the same time as LMP MIB. I didn't know before these two requests that I could use a stricter level of error checking with smilint. I do intend to clean up both LMP and link bundling MIBs of all errors reported by smilint with the highest level of checking.

I still believe that the link bundling MIB addresses key concepts and is worth going to Last Call at this point.

Regards,

Martin 

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: Wednesday, May 01, 2002 5:45 PM
To: Loa Andersson; George Swallow; Thomas Nadeau (E-mail); Martin Dubuc;

Bert 
------------ SMICng log ---------------
In file mplsbundle.mi2
    80:    REVISION
    81:        "200105223200Z"  -- 22 May 2001 12:00:00 EST
               ^
W: REVISION value "200105223200Z" is not a valid extended UTC time
  1124: 
  1125:       OBJECT      teLinkRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkRowStatus"
  1132: 
  1133:       OBJECT      teLinkStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkStorageType"
  1140: 
  1141:       OBJECT      teLinkDescrRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkDescrRowStatus"
  1147: 
  1148:       OBJECT      teLinkDescrStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkDescrStorageType"
  1156:       OBJECT      teLinkOspfLinkId
  1157:       SYNTAX      INTEGER { pointToPoint(1) }
                          ^
E: Syntax type does not match that for "teLinkOspfLinkId"
  1155: 
  1156:       OBJECT      teLinkOspfLinkId
                          ^
E: MIN-ACCESS value incompatible with access specified for "teLinkOspfLinkId"
  1163: 
  1164:       OBJECT      srlgRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "srlgRowStatus"
  1171: 
  1172:       OBJECT      srlgStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "srlgStorageType"
  1179: 
  1180:       OBJECT      teLinkBandwidthRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkBandwidthRowStatus"
  1187: 
  1188:       OBJECT      teLinkBandwidthStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkBandwidthStorageType"
  1195: 
  1196:       OBJECT      dataBearingChannelRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "dataBearingChannelRowStatus"
  1203: 
  1204:       OBJECT      dataBearingChannelStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "dataBearingChannelStorageType"
  1211: 
  1212:       OBJECT      dataBearingChannelDescrRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "dataBearingChannelDescrRowStatus"
  1218: 
  1219:       OBJECT      dataBearingChannelDescrStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "dataBearingChannelDescrStorageType"
  1226: 
  1227:       OBJECT      dataBearingChannelBwRowStatus
                          ^
W: MIN-ACCESS value identical to access specified for "dataBearingChannelBwRowStatus"
  1234: 
  1235:       OBJECT      dataBearingChannelBwStorageType
                          ^
W: MIN-ACCESS value identical to access specified for "dataBearingChannelBwStorageType"
  1211: 
  1212:       OBJECT      dataBearingChannelDescrRowStatus
                          ^
E: OBJECT-TYPE "dataBearingChannelDescrRowStatus" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1218: 
  1219:       OBJECT      dataBearingChannelDescrStorageType
                          ^
E: OBJECT-TYPE "dataBearingChannelDescrStorageType" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1226: 
  1227:       OBJECT      dataBearingChannelBwRowStatus
                          ^
E: OBJECT-TYPE "dataBearingChannelBwRowStatus" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1234: 
  1235:       OBJECT      dataBearingChannelBwStorageType
                          ^
E: OBJECT-TYPE "dataBearingChannelBwStorageType" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1314:       OBJECT      teLinkOspfLinkId
  1315:       SYNTAX      INTEGER { pointToPoint(1) }
                          ^
E: Syntax type does not match that for "teLinkOspfLinkId"
  1313: 
  1314:       OBJECT      teLinkOspfLinkId
                          ^
W: MIN-ACCESS value identical to access specified for "teLinkOspfLinkId"
  1375: 
  1376:       OBJECT      dataBearingChannelEncodingType
                          ^
E: OBJECT-TYPE "dataBearingChannelEncodingType" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1380: 
  1381:       OBJECT      dataBearingChannelDescrPriority
                          ^
E: OBJECT-TYPE "dataBearingChannelDescrPriority" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1385: 
  1386:       OBJECT      dataBearingChannelMinReservableBandwidth
                          ^
E: OBJECT-TYPE "dataBearingChannelMinReservableBandwidth" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1390: 
  1391:       OBJECT      dataBearingChannelDescrRowStatus
                          ^
E: OBJECT-TYPE "dataBearingChannelDescrRowStatus" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1397: 
  1398:       OBJECT      dataBearingChannelDescrStorageType
                          ^
E: OBJECT-TYPE "dataBearingChannelDescrStorageType" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1405: 
  1406:       OBJECT      dataBearingChannelBwRowStatus
                          ^
E: OBJECT-TYPE "dataBearingChannelBwRowStatus" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
  1413: 
  1414:       OBJECT      dataBearingChannelBwStorageType
                          ^
E: OBJECT-TYPE "dataBearingChannelBwStorageType" is not in a MANDATORY or conditional group for module "LINK-BUNDLING-MIB"
     4:    MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE,
     5:    experimental, Integer32, Unsigned32
                         ^
W: "Integer32" imported but not used
    10: 
    11:    TEXTUAL-CONVENTION, TruthValue, RowStatus, StorageType,
           ^
W: "TEXTUAL-CONVENTION" imported but not used
    11:    TEXTUAL-CONVENTION, TruthValue, RowStatus, StorageType,
    12:    RowPointer, TimeStamp
           ^
W: "RowPointer" imported but not used
                       ^
W: "TimeStamp" imported but not used
    14: 
    15:    InterfaceIndex, InterfaceIndexOrZero, ifIndex
           ^
W: "InterfaceIndex" imported but not used
    21: 
    22:    InetAddressType, InetAddress
           ^
W: "InetAddressType" imported but not used