Subject: RE: Label Set Object

From: John Drake <[email-masked]>
Date: Wed, 8 May 2002 11:25:57 -0700

Explicit Label Control is used to handle the SONET/SDH case.  Its semantics
are different than Label Set, in the sense that there is one and only one
value, rather than a set that is manipulated end-end 
 
Thanks,
 
John
 
-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 10:31 AM
To: Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: Re: Label Set Object

Dear Vinay, 

Please see comments in-lined. 

Thanks

Regards... Zafar 
At 07:56 PM 5/8/2002 +0530, Vinay Vernekar wrote:

Hi Zafar,
The Label Set Object can't be sent to constrain the downstream label when
the LSP encoding type is Sonet/SDH. Consider the example where a request is
sent to downstream with SONET/SDH traffic parameters as NVC=n and MT=m. The
label expected from the downstream would be 'm' set of labels each set
consisting of 'n' labels further that identify each of the virtual
concatenated components. So a Label Set in this scenario would consist of
say 'p' sets each consisting of 'm' sets of 'n' labels. Such a Label Set
cannot be encoded using the object/TLV structure of Label Set as in
"Generalized MPLS - Signalling Functional Description -
draft-ietf-mpls-generalized-signaling-08.txt". 

I think, this would be a second level question/ issue. IMO, we should be
able to build on the concept of a label set to incorporate technologies
other than WDM. Can we, in principle, agree on this or you are aware of an
alternative for the case you mentioned above? 

Label Set Object can be sent only in WDM scenario where a single wavelength
is requested as a label and the upstream has a restriction on the usable
wavelengths.

IMHO this would be an undesirable restriction. Why its cannot cover the
single label case in SONET? 

Correct me if I am going wrong anywhere.
 
Regards
Vinay    

----- Original Message ----- 
From: Zafar Ali <mailto:[email-masked]>  
To: Manoj Agiwal <mailto:[email-masked]>  ; 'Ccamp (E-mail)
<mailto:[email-masked]>  
Cc: mpls@UU. NET (E-mail) <mailto:mpls@UU. NET (E-mail)>  
Sent: Wednesday, May 08, 2002 11:04 AM
Subject: Re: Label Set Object

At 10:00 AM 5/8/2002 +0530, Manoj Agiwal wrote:

Hi ,
       In gmpls signaling extensionsions for RSVP-TE , ccamp architecture on
gmpls has described Label Set object usage
    only for the "optical" domain viz. for carrying wavelengths ( Section
9.9 draft-ietf-ccamp-gmpls-architecture-02.txt) . 

       Do we require to send Label set(i.e. time slots) for TDM switching as
well . In what way it can be useful . 

Dear Manoj, 

Yes, label set object is also useful in TDM case. E.g., SONET poses an
additional requirement that the two interfaces of a bidirectional LSP SHOULD
traverse the exact same link with the same SUKLM values for the two
directions.
 The label set object can be used to constrain the downstream label to the
same as the upstream label. 

Thanks

Regards... Zafar 

Regards ,
Manoj

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: "Juneja, Manoj" <[email-masked]>
Date: Wed, 8 May 2002 11:48:11 -0700

Hi John,
               Did u mean Explicit label control is used only for SDH/SONET
case  and is not used for FSC/LSC LSPs ? If this is the case then it should
be clearly mentioned in the draft. Furthermore, it should also be mentioned
that label set is not used for SDH/SONET LSPs.
 
Regards,
manoj.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:26 AM
To: 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Thanks,
 
John
 
-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 10:31 AM
To: Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: Re: Label Set Object

Dear Vinay, 

Thanks

Regards... Zafar 

Hi Zafar,

 
Regards
Vinay    

----- Original Message ----- 
From: Zafar Ali <mailto:[email-masked]>  
To: Manoj Agiwal <mailto:[email-masked]>  ; 'Ccamp (E-mail)

Hi ,

Dear Manoj, 

Thanks

Regards... Zafar 

Regards ,
Manoj

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: John Drake <[email-masked]>
Date: Wed, 8 May 2002 11:49:35 -0700

I didn't say that.

-----Original Message-----
From: Juneja, Manoj [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:48 AM
To: John Drake; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Hi John,
 
Regards,
manoj.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:26 AM
To: 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Thanks,
 
John
 
-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 10:31 AM
To: Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: Re: Label Set Object

Dear Vinay, 

Thanks

Regards... Zafar 

Hi Zafar,

 
Regards
Vinay    

----- Original Message ----- 
From: Zafar Ali <mailto:[email-masked]>  
To: Manoj Agiwal <mailto:[email-masked]>  ; 'Ccamp (E-mail)
<mailto:[email-masked]>  
Cc: mpls@UU. NET  <mailto:mpls@UU. NET (E-mail)> (E-mail) 
Sent: Wednesday, May 08, 2002 11:04 AM
Subject: Re: Label Set Object

Hi ,

Dear Manoj, 

Thanks

Regards... Zafar 

Regards ,
Manoj

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: "Juneja, Manoj" <[email-masked]>
Date: Wed, 8 May 2002 11:57:06 -0700

Hi Jonh,
              Sorry for creating the confusion. Should the label set be used
for establishing the SDH/SONET LSPs ? 
 
Regards,
manoj.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:50 AM
To: 'Juneja, Manoj'; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp
(E-mail)

I didn't say that.

-----Original Message-----
From: Juneja, Manoj [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:48 AM
To: John Drake; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Hi John,
 
Regards,
manoj.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:26 AM
To: 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Thanks,
 
John
 
-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 10:31 AM
To: Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: Re: Label Set Object

Dear Vinay, 

Thanks

Regards... Zafar 

Hi Zafar,

 
Regards
Vinay    

----- Original Message ----- 
From: Zafar Ali <mailto:[email-masked]>  
To: Manoj  <mailto:[email-masked]> Agiwal ; 'Ccamp (E-mail)

Hi ,

Dear Manoj, 

Thanks

Regards... Zafar 

Regards ,
Manoj

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: Hang Liu <[email-masked]>
Date: Wed, 8 May 2002 16:10:15 -0400

Hi.
 
Explicit label control seems to be used by the ingress node to control the
label selection, but Label Set seems more related to the label selection
between two adjacent nodes. In the GMPLS RSVP-TE draft, the upstream node
needs to copy the value in downstream Label ERO subobject into a Label Set
object of the outgoing Path Message (upstream Label ERO goes to Upstream
Label object). Please correct me if I am wrong anywhere.
 
Hang Liu
Tellium, Inc.

-----Original Message-----
From: Juneja, Manoj [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 2:57 PM
To: 'John Drake'; Juneja, Manoj; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal;
'Ccamp (E-mail)

Hi Jonh,
 
Regards,
manoj.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:50 AM
To: 'Juneja, Manoj'; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp
(E-mail)

I didn't say that.

-----Original Message-----
From: Juneja, Manoj [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:48 AM
To: John Drake; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Hi John,
 
Regards,
manoj.

-----Original Message-----
From: John Drake [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:26 AM
To: 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Thanks,
 
John
 
-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 10:31 AM
To: Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: Re: Label Set Object

Dear Vinay, 

Thanks

Regards... Zafar 

Hi Zafar,

 
Regards
Vinay    

----- Original Message ----- 
From: Zafar Ali <mailto:[email-masked]>  
To: Manoj  <mailto:[email-masked]> Agiwal ; 'Ccamp
<mailto:[email-masked]> (E-mail) 
Cc: mpls@UU. NET (E-mail) <mailto:mpls@UU. NET (E-mail)>  
Sent: Wednesday, May 08, 2002 11:04 AM
Subject: Re: Label Set Object

Hi ,

Dear Manoj, 

Thanks

Regards... Zafar 

Regards ,
Manoj

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: John Drake <[email-masked]>
Date: Wed, 8 May 2002 16:26:58 -0700

In the SONET/SDH case, there's always one and only one label, so isn't label
set overkill?  That's what I meant by 'more natural'.
 
As George pointed out, in the downstream direction either explicit label
control or a label set with one value is a useful thing in the manner of
'belt and suspenders' 
-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 4:05 PM
To: John Drake; 'Juneja, Manoj'; Vinay Vernekar; Manoj Agiwal; 'Ccamp
(E-mail); [email-masked]
Cc: mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

At 01:07 PM 5/8/2002 -0700, John Drake wrote:

Label Set and Explicit Label Control are used for different purposes, and as
I understand it, Explicit Label Control is more natural  for establishing
SONET/SDH LSPs, while Label Set is more natural for establishing wavelength
LSPs.  
You could, however, use Label Set for SONET/SDH LSPs and Explicit Label
Control for wavelength LSPs.

Hi John, 

While I agree with the last statement, I didn't understand why you mentioned
that explicit label control is more natural for SONET/ SDH. IMHO the label
set is a more natural way of constraining labels in all scenarios. 

Any way, this is a non-debate, in the light of the email sent by Suresh in
which he suggested that the constraints are implied by the nature of the TDM
circuits. I agree with Suresh that there is no point of copying the same
parameters using the other means, if they can be implied. 

Thanks

Regards... Zafar

-----Original Message----- 

From: Juneja, Manoj [ mailto:[email-masked]
<mailto:[email-masked]> ] 

Sent: Wednesday, May 08, 2002 11:57 AM 

To: John Drake; Juneja, Manoj; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal;
'Ccamp (E-mail) 

Hi Jonh, 

Regards, 

manoj. 

-----Original Message----- 

From: John Drake [ mailto:[email-masked] <mailto:[email-masked]> ] 

I didn't say that. 

-----Original Message----- 

From: Juneja, Manoj [ mailto:[email-masked]
<mailto:[email-masked]> ] 

Hi John, 

Regards, 

manoj. 

-----Original Message----- 

From: John Drake [ mailto:[email-masked] <mailto:[email-masked]> ] 

Thanks, 

John 

-----Original Message----- 

From: Zafar Ali [ mailto:[email-masked] <mailto:[email-masked]> ] 

Dear Vinay, 

Thanks

Regards... Zafar 

Hi Zafar, 

Regards 

Vinay    

----- Original Message ----- 

Hi , 

Dear Manoj, 

Thanks

Regards... Zafar 

Regards , 

Manoj

=============== 

Zafar Ali 

Cisco Systems 

(734) 276-2459 

100 S Main St. #200 

Ann Arbor, MI 48104. 

email: [email-masked] 

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: "Diego Caviglia" <[email-masked]>
Date: Fri, 10 May 2002 10:21:35 +0200

Anca,
                comment in line.

Regards, Diego.

----------------------------------------------------------------
Diego Caviglia
Optical Network - ASON strategy
E-mail: [email-masked]
Tel: +39 0 10 6003 808
Via A. Negrone 1A 16153 Genoa (Italy)
http://www.marconi.com

Anca Zamfir <[email-masked]>@ops.ietf.org on 09/05/2002 22.44.28

Sent by:  [email-masked]

To:   "Adrian Farrel" <[email-masked]>
cc:   "John Drake" <[email-masked]>, "Zafar Ali" <[email-masked]>,
      "'Juneja, Manoj'" <[email-masked]>, "Vinay Vernekar"
      <[email-masked]>, "Manoj Agiwal" <[email-masked]>,
      "'Ccamp \(E-mail\)" <[email-masked]>, <[email-masked]>,
      "mpls@UU. NET \(E-mail\)" <[email-masked]>

[CUT]

>Could we say that bidirectional uses Upstream Label only, and
unidirectional
>uses Label Set only?
>Yes.

This is probably true for SONET LSPs. For other types this restriction may
be undesirable.

[dc] I'd like to add a comment on the use of Label Set and Upstream Label
in case of bidirectional SDH circuit.
In bidirectional SDH LSP, both the Upstream and the Downstream label must
be the same.
Therefore request message must contain an Upstream Label (with say value A)
and a Label Set with the single value A to express the specific SDH
restriction.

[CUT]