Subject: MESSAGE_ID in Resv message

From: Gopalkrishna Panicker <[email-masked]>
Date: Tue, 21 May 2002 18:27:59 -0700 (PDT)

Hello,

I have a question regarding the use of MESSAGE_ID
object in a resv message.

Per my understanding of RFC 2209, a Resv state block
is created for every {Flowspec, Filterspec(s)}.
 
If a session uses FF style and there are 
multiple senders, a SINGLE resv message carries 
a {flowspec,filterspec} set for each sender.
This will result in RSB being created for each such
set. 

Now if ROR is used and as only one MESSAGE_ID object 
is allowed per message, should a separate resv message
be sent for each distinct reservation ? 

Cheers,

Gopal

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

---

From: David Charlap <[email-masked]>
Date: Wed, 22 May 2002 11:07:34 -0400

> is created for every {Flowspec, Filterspec(s)}.

If your implementation is based on the architecture that RFC 2209, then
you have an RSB for every uniquely received Resv message.  Which is
keyed on session, sender (filterspec) and next-hop address.

Flowspec is not a key, but a value.

> This will result in RSB being created for each such

Correct.

> be sent for each distinct reservation ?

No.  It just means that the one MESSAGE_ID will refresh multiple RSBs
when it appears in an SRefresh message.

-- David

---

From: Ping Pan <[email-masked]>
Date: Tue, 28 May 2002 16:58:27 -0700

Each RSVP Resv message can be represented via a MESSAGE_ID.

This implies the following:

1. Per RSVP, you can combine multiple filters within a single Resv, in 
which case you need to track the message id for all the filters at both 
sending and receiving nodes. I know, it can be a pain in the ass to 
handle this. :-)

2. To simplify the code, when you send refresh messages, you have the 
option to force one filter per Resv.

Hope this will help!

- Ping