Subject: RE: Basic LDP Question

From: Shahram Davari <[email-masked]>
Date: Fri, 31 May 2002 11:08:36 -0700

Vijay,

> -----Original Message-----
> From: Vijay Bollapragada [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 2:06 PM
> To: Shahram Davari
> Cc: [email-masked]'; [email-masked]'
> Subject: Re: Basic LDP Question
> 
> 
> In the 2547 case, typically u have 2 labels, the vpn_label 
> (bottom label)
> and the top label is the label to get the packet to the far 
> end PE, Now,
> LDP is used for this top label.
> 
> I think u are questioning why use LDP for this bottom_label 
> and why not
> simply encapsulate the MPLS packet in IP to get the packet to 
> the next_hop
> PE. If this is your Q, You are absolutely correct and this is what the
> following draft talks about
> 
> http://search.ietf.org/internet-drafts/draft-ietf-ppvpn-gre-ip
> -2547-01.txt
> 
> IMHO, this is certainly do-able but MPLS in the core give us 
> the ability
> to do things like Traffic Enginnering

But LDP does not give you the TE ability. So why use LDP?

-Shahram

 which are quite a challenge over
> pure IP.
> 
> Thanks,
> Vijay
> 
> 
> 
> On Fri, 31 May 2002, Shahram Davari wrote:
> 
> > Hi,
> > 
> > What problem a mp2p LDP-based MPLS network is trying to 
> solve (like the one used in RFC2547) that can't be done with 
> pure IP forwarding?
> > 
> > Note: Don't tell me fast forwarding, because we can do fast 
> IP lookup as well.
> > 
> > Yours,
> > Shahram
> > 
> > 
>

---

From: Vijay Bollapragada <[email-masked]>
Date: Fri, 31 May 2002 14:34:18 -0400 (Eastern Daylight Time)

> But LDP does not give you the TE ability. So why use LDP?

Agreed, that LDP does not give the ability to do TE, I only said use MPLS
in the core, not necassarily LDP :-) but in any case, Here is what 2547
draft says about using LDP for the top label..

Section 4.3.2

"All that matters for the VPN architecture is that some label switched
path between the router and its BGP next hop exists.  However, to ensure
interoperability  among systems which implement this VPN architecture,
all such systems must support LDP [MPLS-LDP]."

Of course, once could use many other mechanisms to get the vpn_labeled
packet from one edge PE to another edge PE, Interoperability is the key
here.

Thanks,
Vijay