Subject: RE: Static LSP Configuration

From: Shahram Davari <[email-masked]>
Date: Mon, 6 May 2002 13:56:23 -0700

Curtis,

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, May 06, 2002 4:31 PM
> To: Sudheer Dharanikota
> Cc: Gary Tam; Ajay Simha; [email-masked]; Ron Bonica; Brijesh
> Kumar; 'Curtis Villamizar '; [email-masked]; CCAMP WG
> Subject: Re: Static LSP Configuration 
> 
> 
> 
> In message <[email-masked]>, Sudheer Dharanikota writes:
> > 
> > Transport networks are *built* to provide 50 msec recovery
> > times (e.g., rings, span, 1+1 etc). Hence a failures are 
> scoped to be
> > within a domain (typically a ring or a span or in the worst case
> > end-to-end[1+1 case]).  Excluding failure detection time in this
> > 50 msec (taking from SONET knowledge), failure reporting
> > and recovery should take 50 msec. Obviously this cannot
> >  be done with OSS intervention. One can use SONET's
> > inband signaling mechanisms for failure reporting or use
> > *directed notification* mechanisms such as the ones proposed
> > for signaling protocols. Note that if we assume a ring topology then
> > the messages are only one hop away (with the assumption that
> > only the DCS are the intelligent devices). So your worry of 5-10
> > hop path is not valid in my opinion.
> > 
> > Regards,
> > 
> > sudheer
> 
> 
> The discussion was about MPLS but an underlying assumption seemded to
> enter into the thread with that last email that either APS was running
> under MPLS or L2 was the application and APS was running over MPLS
> provided over multiple end to end L2 tunnels.
> 
> I don't know of anyone doing SONET APS over the L2 tunnels of an MPLS
> backbone.
> 
> I do know of providers who want to eliminate the APS on the sonet
> links under their MPLS network cutting some costs significantly (but
> with all things considered, not in half).

What mechanism will they use to detect the failure then?

-Shahram

  MPLS restoration needs to
> work quite well to do this and still meet SLAs and carrying L2 service
> is even more demanding.
> 
> Curtis
>

---

From: Sudheer Dharanikota <[email-masked]>
Date: Mon, 06 May 2002 14:27:26 -0700

> What mechanism will they use to detect the failure then?

With most of the *recent* L2/L1 technologies, failure dection is not the
only problem.
Without APS-like mechanisms (sub-second) failure reporting is also a major
problem.
In my opinion, for the sake of the underlying technologies which does not
have
APS-like reporting mechanisms, we need to optimize our signaling protocols
and propose sensible control plane topologies.

Regards,

sudheer

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 06 May 2002 20:45:41 -0400

In message <[email-masked]
> What mechanism will they use to detect the failure then?

SONET framing is still used.  What is not used is a SONET protect
path.  SONET is involved in the detection, but plays no role in the
recovery.  It seems a few providers did buildouts in recent years
costing lots of money, and used SONET protect paths while there was
excess capacity.  Not the most efficient, but it works great.  Then as
the capacity filled but revenue had not yet met the demands of incured
debt, decided that they don't want the increased debt of a further
buildout and are seeking a more cost effective way to meet their SLAs.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 06 May 2002 20:48:59 -0400

> and propose sensible control plane topologies.

SONET detection is used.  SONET APS protection is not.  FRR yields
<50msec restroation is needed, and standby LSPs yields a few seconds
at worst (consistently sub second is certainly possible with standby,
but not yet acheived by today's implementations afaik).

Curtis