Subject: RE: Basic LDP Question

From: Shahram Davari <[email-masked]>
Date: Fri, 31 May 2002 10:59:33 -0700

Giles,

> -----Original Message-----
> From: Giles Heron [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 2:48 PM
> To: Shahram Davari
> Cc: [email-masked]'; [email-masked]'
> Subject: RE: Basic LDP Question
> 
> 
> On Fri, 2002-05-31 at 17:41, Shahram Davari wrote:
> > Giles,
> > 
> > > -----Original Message-----
> > > From: Giles Heron [mailto:[email-masked]]
> > > Sent: Friday, May 31, 2002 2:37 PM
> > > To: Shahram Davari
> > > Cc: [email-masked]'; [email-masked]'
> > > Subject: Re: Basic LDP Question
> > > 
> > > 
> > > 1.  Efficient encapsulation of VPN traffic
> > 
> > Do you mean the difference between 4 bytes label and 20 
> bytes IP header?
> 
> yes.

Although you save 16 bytes per packet (~ 3% BW saving, assuming ~500 bytes average IP packet size), but you create another problem:

MPLS is much more prune to failure than IP. If an LSR's MPLS switching table is
corrupted, the packet ends up in wrong PE, while if a router's IP routing table
is corrupted, the next hops could sent the packet to the right destination PE.

> 
> > > 2.  Ability to run VPN on current hardware
> > 
> > But current hardware have IP already, it is much easier to run
> > IP rather than LDP MPLS. isn't it?
> 
> don't think so.  I believe many current routers with MPLS support can
> push multiple labels when sending a packet, but can't "push" 
> an extra IP
> header?

May be, but when LDP was created there was no box doing VPN. 

-Shahram

> 
> Giles
>  
> > -Shahram
> > 
> > > 
> > > There are probably other reasons as well...
> > > 
> > > On Fri, 2002-05-31 at 17:28, Shahram Davari wrote:
> > > > Hi,
> > > > 
> > > > What problem a mp2p LDP-based MPLS network is trying to 
> > > solve (like the one used in RFC2547) that can't be done with 
> > > pure IP forwarding?
> > > > 
> > > > Note: Don't tell me fast forwarding, because we can do fast 
> > > IP lookup as well.
> > > > 
> > > > Yours,
> > > > Shahram
> > > > 
> > > > 
> > > -- 
> > > =================================================================
> > > Giles Heron    Principal Network Architect    PacketExchange Ltd.
> > > ph: +44 7880 506185              "if you build it they will yawn"
> > > =================================================================
> > > 
> > 
> -- 
> =================================================================
> Giles Heron    Principal Network Architect    PacketExchange Ltd.
> ph: +44 7880 506185              "if you build it they will yawn"
> =================================================================
>

---

From: Giles Heron <[email-masked]>
Date: 31 May 2002 19:05:17 +0000

> is corrupted, the next hops could sent the packet to the right destination PE.

agreed.  Though of course it always depends on how the IP routing table
is corrupted.  If it sends packets back the way they came - or into the
bit bucket - then you still have a problem :(
> May be, but when LDP was created there was no box doing VPN. 

true.  But I think when LDP was created the performance issue which
kicked the whole MPLS thing off was still true?

Giles