Subject: RE: Label Set Object

From: Manoj Agiwal <[email-masked]>
Date: Wed, 8 May 2002 11:11:01 +0530

Hi ,
   I guess in that case we can use Suggested Label , Label Set still can
still be avoided .
Regards ,
Manoj

-----Original Message-----
From: Zafar Ali [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:05 AM
To: Manoj Agiwal; 'Ccamp (E-mail)
Cc: mpls@UU. NET (E-mail)
Subject: Re: Label Set Object

At 10:00 AM 5/8/2002 +0530, Manoj Agiwal wrote:

Hi ,
       In gmpls signaling extensionsions for RSVP-TE , ccamp architecture on
gmpls has described Label Set object usage
    only for the "optical" domain viz. for carrying wavelengths ( Section
9.9 draft-ietf-ccamp-gmpls-architecture-02.txt) . 

       Do we require to send Label set(i.e. time slots) for TDM switching as
well . In what way it can be useful . 

Dear Manoj, 

Yes, label set object is also useful in TDM case. E.g., SONET poses an
additional requirement that the two interfaces of a bidirectional LSP SHOULD
traverse the exact same link with the same SUKLM values for the two
directions.
 The label set object can be used to constrain the downstream label to the
same as the upstream label. 

Thanks

Regards... Zafar 

Regards ,
Manoj

===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: Zafar Ali <[email-masked]>
Date: Wed, 08 May 2002 01:53:05 -0400

>    I guess in that case we can use Suggested Label , Label Set still can 

Hi Manoj,

No, the use of suggested label in this case would NOT be correct, as the 
suggested labels can be ignored/ overridden by the receiving node.

Thanks

Regards... Zafar

>additional requirement that the two interfaces of a bidirectional LSP 
>SHOULD traverse the exact same link with the same SUKLM values for the two 
>directions.
>  The label set object can be used to constrain the downstream label to 
> the same as the upstream label.
>
>Thanks
>
>Regards... Zafar
>
>
>
>
>
>>Regards ,
>>Manoj
>===============
>Zafar Ali
>Cisco Systems
>(734) 276-2459
>100 S Main St. #200
>Ann Arbor, MI 48104.
>email: [email-masked]
===============
Zafar Ali
Cisco Systems
(734) 276-2459
100 S Main St. #200
Ann Arbor, MI 48104.
email: [email-masked]

---

From: Suresh Katukam <[email-masked]>
Date: Wed, 08 May 2002 15:23:04 -0700

For TDM, since you have to use same labels in both directions, why do you 
have to specify anything at all?
How can a downstream TDM node pick a label that does not match with 
Upstream label for
a bidirectional LSP? If it picks any other label, LSP is not functional.

If there are Uni-directional LSPs in TDM and if you have different types of 
time slots available
in both directions, then one may be able to setup bidirectional LSP on 
different links or
different labels. This is in theory and not in practice.

So in practice, one does not need to specify LABEL SET or Suggested label 
for TDM links.

Thanks,
Suresh

At 01:53 AM 5/8/2002 -0400, Zafar Ali wrote:
>>SHOULD traverse the exact same link with the same SUKLM values for the 
>>two directions.

---

From: George Swallow <[email-masked]>
Date: Wed, 08 May 2002 18:33:32 -0400

> So in practice, one does not need to specify LABEL SET or Suggested label 

While I agree with your assessment of what is necessary, it might help
interoperability by including a label set with one label which is the
same label as the upstream label.  This covers you if someone else
changes their practice (for some stange and/or broken reason).

...George

==================================================================
George Swallow       Cisco Systems                  (978) 497-8143
                     250 Apollo Drive
                     Chelmsford, Ma 01824