Subject: RE: GMPLS - PSC switching capability

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 28 May 2002 07:33:14 -0400

Bharathi,

Though I do not know much about GMPLS, however the draft

http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-routing-04.txt

states that
"If an interface is of type PSC-1 through PSC-4, it means that the node
receiving data over this interface can switch the received data on a
packet-by-packet basis, based on the label carried in the "shim" header
[RFC3032]. The various levels of PSC establish a hierarchy of LSPs tunneled
within LSPs."
Hope this is what you were looking for,

Thanks,
Vishwas
>  -----Original Message-----
> From: 	Bharathi R [mailto:[email-masked]] 
> Sent:	Tuesday, May 28, 2002 4:04 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	GMPLS - PSC switching capability
> 
> Hi,
> Can anyone tell me why GMPLS routing Extension mention 4 different PSC
> switching capabilities?
> What is the significance of having 4 different PSC switching capabilities?
> Thanks & Regards,
> Bharathi
>

---

From: "Bharathi R" <[email-masked]>
Date: Tue, 28 May 2002 18:37:51 +0530

Hi Vishwas,
If my understanding is correct, "The Various levels of PSC" means PSC-1,
PSC-2..PSC-4?
If so then in PSC-2 label stack depth is 2 and PSC-3 means label stack of
depth 3 and so on.
If so then why it is restricted to 4 levels?
Thanks & Regards,
Bharathi
 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]]  On Behalf Of Manral,
Vishwas
Sent:	Tuesday, 28 May 2002 5:03 PM
To:	[email-masked]'; [email-masked]
Cc:	[email-masked]
Subject:	RE: GMPLS - PSC switching capability

Bharathi,

states that

Thanks,
Vishwas
> What is the significance of having 4 different PSC switching capabilities?

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 28 May 2002 09:46:13 -0400

In message <[email-masked]>, "Bharat
> If so then why it is restricted to 4 levels?

PSC-1 would be N+1, where N is the number of labels that already
exist.  For example, LSPs are already used with VPN label, LDP label,
MPLS/TE label with no hierarchy designation.  This would add up to 4
levels of hierarchy intended to improve scaling to whatever labels
already exist.  Also note that a PSC-3 LSP can contain an LSP with no
hierarchy designation, a PSC-1, a PSC-2, but not another PSC-3 or
anything higher in the hierarchy.  So PSC-3 does not mean 3 labels,
nor does it mean N+3.

Curtis

---

From: "M.N.V.Suryanarayana" <[email-masked]>
Date: Tue, 28 May 2002 19:44:50 +0530

Hi,

Can someone provide an example in which the interface switching capability
is set to PSC-2/PSC-3/PSC-4. The examples in section 7 of
draft-ietf-ccamp-gmpls-routing-04.txt does not cover the
PSC-2/PSC-3/PSC-4 interface switching capability.

Thanks & Regards,
Surya

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Manral,
> Vishwas

states that

Thanks,
Vishwas

---

From: Zafar Ali <[email-masked]>
Date: Tue, 28 May 2002 19:24:07 -0400

>PSC-2/PSC-3/PSC-4 interface switching capability.

Hi Suryanarayana,

You can construct a deployment scenario by thinking in terms of VP and VC 
level switching hierarchy in ATM. This way you can aggregate many flows 
into a single LSP at the higher level in the hierarchy, etc. While ATM 
hierarchy is limited to the two level, MPLS technology can support such 
(packet) hierarchy at PSC-1, 2, ..., 4 levels.

Thanks

Regards... Zafar

> > What is the significance of having 4 different PSC switching capabilities?
===============================================
Zafar Ali
Cisco Systems
100 S Main St. #200
Ann Arbor, MI 48104.
Mobile: (734) 276-2459, Off: (734) 302-4143, Fax: (734) 302-4190
email: [email-masked]

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 29 May 2002 04:07:19 -0700 (PDT)

> If so then in PSC-2 label stack depth is 2 and PSC-3 means label stack of

PSC-1...PSC-4 refer to levels of LSP hierarchy in the packet-switched
domain.  For example, one can full mesh one's core with TE LSPs, and
then engineer region-to-region TE LSPs, giving a two-level hierarchy.

> If so then why it is restricted to 4 levels?

Do you have a preferred magic number?

Kireeti.