Subject: Basic LDP Question

From: Shahram Davari <[email-masked]>
Date: Fri, 31 May 2002 10:28:26 -0700

Hi,

What problem a mp2p LDP-based MPLS network is trying to solve (like the one used in RFC2547) that can't be done with pure IP forwarding?

Note: Don't tell me fast forwarding, because we can do fast IP lookup as well.

Yours,
Shahram

---

From: Giles Heron <[email-masked]>
Date: 31 May 2002 18:36:40 +0000

1.  Efficient encapsulation of VPN traffic
2.  Ability to run VPN on current hardware

There are probably other reasons as well...

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 31 May 2002 10:41:04 -0700

Giles,

> There are probably other reasons as well...

One of the "other reasons" is straightforward protection against packet 
spoofing.

Yakov.

> > What problem a mp2p LDP-based MPLS network is trying to solve (like the one
 used in RFC2547) that can't be done with pure IP forwarding?

---

From: Lars Eggert <[email-masked]>
Date: Fri, 31 May 2002 10:44:53 -0700

> One of the "other reasons" is straightforward protection against packet 

More straightforward than an IP firewall?

Lars
-- 
Lars Eggert <[email-masked]>           USC Information Sciences Institute

---

From: Vijay Bollapragada <[email-masked]>
Date: Fri, 31 May 2002 14:05:36 -0400 (Eastern Daylight Time)

In the 2547 case, typically u have 2 labels, the vpn_label (bottom label)
and the top label is the label to get the packet to the far end PE, Now,
LDP is used for this top label.

I think u are questioning why use LDP for this bottom_label and why not
simply encapsulate the MPLS packet in IP to get the packet to the next_hop
PE. If this is your Q, You are absolutely correct and this is what the
following draft talks about

http://search.ietf.org/internet-drafts/draft-ietf-ppvpn-gre-ip-2547-01.txt

IMHO, this is certainly do-able but MPLS in the core give us the ability
to do things like Traffic Enginnering which are quite a challenge over
pure IP.

Thanks,
Vijay

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 31 May 2002 11:05:15 -0700

> More straightforward than an IP firewall?

yes.

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 31 May 2002 11:11:36 -0700

Vijay,

> http://search.ietf.org/internet-drafts/draft-ietf-ppvpn-gre-ip-2547-01.txt

Glad you mentioned this draft, as Section 7 in that draft talks about
the issue of packet spoofing.

Yakov.

---

From: Sukanta ganguly <[email-masked]>
Date: Fri, 31 May 2002 11:06:13 -0700 (PDT)

Lars,
  I am not sure about the more straight forwardness
than an IP firewall, but I certainly agree to the
layering of labels allowing multiple predictive paths
that can be choosen quite dynamically which IP does
not allow.

  As a matter of fact I would actually like to know
your reasoning as far as the simplicity of straight
forwardness that you see on an MPLS based firewall,
which does not exists in the IP firewall. 

SG

> ATTACHMENT part 2 application/x-pkcs7-signature
name=smime.p7s

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com