Subject: RE: Basic LDP Question

From: Shahram Davari <[email-masked]>
Date: Fri, 31 May 2002 10:41:30 -0700

Giles,

> -----Original Message-----
> From: Giles Heron [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 2:37 PM
> To: Shahram Davari
> Cc: [email-masked]'; [email-masked]'
> Subject: Re: Basic LDP Question
> 
> 
> 1.  Efficient encapsulation of VPN traffic

Do you mean the difference between 4 bytes label and 20 bytes IP header?

> 2.  Ability to run VPN on current hardware

But current hardware have IP already, it is much easier to run
IP rather than LDP MPLS. isn't it?

-Shahram

> 
> There are probably other reasons as well...
> 
> On Fri, 2002-05-31 at 17:28, Shahram Davari wrote:
> > Hi,
> > 
> > What problem a mp2p LDP-based MPLS network is trying to 
> solve (like the one used in RFC2547) that can't be done with 
> pure IP forwarding?
> > 
> > Note: Don't tell me fast forwarding, because we can do fast 
> IP lookup as well.
> > 
> > Yours,
> > Shahram
> > 
> > 
> -- 
> =================================================================
> Giles Heron    Principal Network Architect    PacketExchange Ltd.
> ph: +44 7880 506185              "if you build it they will yawn"
> =================================================================
>

---

From: Giles Heron <[email-masked]>
Date: 31 May 2002 18:48:07 +0000

> Do you mean the difference between 4 bytes label and 20 bytes IP header?

yes.

> IP rather than LDP MPLS. isn't it?

don't think so.  I believe many current routers with MPLS support can
push multiple labels when sending a packet, but can't "push" an extra IP
header?

Giles