Subject: RE: Label Set Object

From: John Drake <[email-masked]>
Date: Wed, 8 May 2002 19:42:29 -0700

Lou and I just reviewed section 5.1.1 of
draft-ietf-mpls-generalized-rsvp-te-07.txt (rather than
draft-ietf-mpls-generalized-signaling-08.txt, which is what I looked at this
morning), and it's pretty clear.

The upstream node processing the ERO for the outgoing link checks whether
there are explicit label control subobjects for upstream or downstream.  An
explicit label control for upstream is replaced in the ERO with an upstream
label and an explicit label control for downstream is replaced with a label
set with the same label.  This is so done so that there is only one
mechanism for an upstream node to specify the downstream label; explicit
label control is only used by a remote node.  

So the only question is whether for SONET/SDH LSPs, this mechanism is
required.

-----Original Message-----
From: Anca Zamfir [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 4:48 PM
To: Zafar Ali
Cc: John Drake; 'Juneja, Manoj'; Vinay Vernekar; Manoj Agiwal; 'Ccamp
(E-mail); [email-masked]; mpls@UU. NET (E-mail)
Subject: RE: Label Set Object

Trying to find the answer to the original question.
If a node wants to use Label Set to make sure the downstream label has the 
same value as the upstream one, then, I don't see why it cannot fill in the 
Label Set in the same way it fills in the Upstream Label, as described in 
draft-ietf-ccamp-gmpls-sonet-sdh-03.txt, section 3, for the case NVC=n and 
MT=m case. (Theoretically a node could apply this algorithm p times)
A node that receives and chooses to interpret LabelSet would know how to 
interpret its content by looking at the traffic parameters (in particular 
for this example at the NVC and MT values) which would provide a way to 
"decode" the ordered set of SUKLM labels present in Label Set.
I may be wrong, but I think in theory it is possible to use Label Set for 
this case. As others pointed out, not sure how practical it is.

Anca

At 07:04 PM 5/8/2002 -0400, Zafar Ali wrote:
>At 01:07 PM 5/8/2002 -0700, John Drake wrote:
>>Label Set and Explicit Label Control are used for different purposes, and 
>>as I understand it, Explicit Label Control is more natural  for 
>>establishing SONET/SDH LSPs, while Label Set is more natural for 
>>establishing wavelength LSPs.
>>You could, however, use Label Set for SONET/SDH LSPs and Explicit Label 
>>Control for wavelength LSPs.
>
>Hi John,
>
>While I agree with the last statement, I didn't understand why you 
>mentioned that explicit label control is more natural for SONET/ SDH. IMHO 
>the label set is a more natural way of constraining labels in all
scenarios.
>
>Any way, this is a non-debate, in the light of the email sent by Suresh in 
>which he suggested that the constraints are implied by the nature of the 
>TDM circuits. I agree with Suresh that there is no point of copying the 
>same parameters using the other means, if they can be implied.
>
>Thanks
>
>Regards... Zafar
>>-----Original Message-----
>>From: Juneja, Manoj [mailto:[email-masked]]
>>Sent: Wednesday, May 08, 2002 11:57 AM
>>To: John Drake; Juneja, Manoj; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 
>>'Ccamp (E-mail)
>>Cc: mpls@UU. NET (E-mail)
>>Subject: RE: Label Set Object
>>
>>Hi Jonh,
>>               Sorry for creating the confusion. Should the label set be 
>> used for establishing the SDH/SONET LSPs ?
>>
>>Regards,
>>manoj.
>>-----Original Message-----
>>From: John Drake [mailto:[email-masked]]
>>Sent: Wednesday, May 08, 2002 11:50 AM
>>To: 'Juneja, Manoj'; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp 
>>(E-mail)
>>Cc: mpls@UU. NET (E-mail)
>>Subject: RE: Label Set Object
>>
>>I didn't say that.
>>-----Original Message-----
>>From: Juneja, Manoj [mailto:[email-masked]]
>>Sent: Wednesday, May 08, 2002 11:48 AM
>>To: John Drake; 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
>>Cc: mpls@UU. NET (E-mail)
>>Subject: RE: Label Set Object
>>
>>Hi John,
>>                Did u mean Explicit label control is used only for 
>> SDH/SONET case  and is not used for FSC/LSC LSPs ? If this is the case 
>> then it should be clearly mentioned in the draft. Furthermore, it should 
>> also be mentioned that label set is not used for SDH/SONET LSPs.
>>
>>Regards,
>>manoj.
>>-----Original Message-----
>>From: John Drake [mailto:[email-masked]]
>>Sent: Wednesday, May 08, 2002 11:26 AM
>>To: 'Zafar Ali'; Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
>>Cc: mpls@UU. NET (E-mail)
>>Subject: RE: Label Set Object
>>
>>Explicit Label Control is used to handle the SONET/SDH case.  Its 
>>semantics are different than Label Set, in the sense that there is one 
>>and only one value, rather than a set that is manipulated end-end
>>
>>Thanks,
>>
>>John
>>
>>-----Original Message-----
>>From: Zafar Ali [mailto:[email-masked]]
>>Sent: Wednesday, May 08, 2002 10:31 AM
>>To: Vinay Vernekar; Manoj Agiwal; 'Ccamp (E-mail)
>>Cc: mpls@UU. NET (E-mail)
>>Subject: Re: Label Set Object
>>
>>Dear Vinay,
>>
>>Please see comments in-lined.
>>
>>Thanks
>>
>>Regards... Zafar
>>At 07:56 PM 5/8/2002 +0530, Vinay Vernekar wrote:
>>>Hi Zafar,
>>>The Label Set Object can't be sent to constrain the downstream label 
>>>when the LSP encoding type is Sonet/SDH. Consider the example where a 
>>>request is sent to downstream with SONET/SDH traffic parameters as NVC=n 
>>>and MT=m. The label expected from the downstream would be 'm' set of 
>>>labels each set consisting of 'n' labels further that identify each of 
>>>the virtual concatenated components. So a Label Set in this scenario 
>>>would consist of say 'p' sets each consisting of 'm' sets of 'n' labels. 
>>>Such a Label Set cannot be encoded using the object/TLV structure of 
>>>Label Set as in "Generalized MPLS - Signalling Functional Description - 
>>>draft-ietf-mpls-generalized-signaling-08.txt".
>>I think, this would be a second level question/ issue. IMO, we should be 
>>able to build on the concept of a label set to incorporate technologies 
>>other than WDM. Can we, in principle, agree on this or you are aware of 
>>an alternative for the case you mentioned above?
>>>Label Set Object can be sent only in WDM scenario where a single 
>>>wavelength is requested as a label and the upstream has a restriction on 
>>>the usable wavelengths.
>>IMHO this would be an undesirable restriction. Why its cannot cover the 
>>single label case in SONET?
>>
>>>Correct me if I am going wrong anywhere.
>>>
>>>Regards
>>>Vinay
>>>>----- Original Message -----
>>>>From: <mailto:[email-masked]>Zafar Ali
>>>>To: <mailto:[email-masked]>Manoj Agiwal ; 
>>>><mailto:[email-masked]>'Ccamp (E-mail)
>>>>Cc: <mailto:mpls@UU. NET (E-mail)>mpls@UU. NET (E-mail)
>>>>Sent: Wednesday, May 08, 2002 11:04 AM
>>>>Subject: Re: Label Set Object
>>>>
>>>>At 10:00 AM 5/8/2002 +0530, Manoj Agiwal wrote:
>>>>>Hi ,
>>>>>        In gmpls signaling extensionsions for RSVP-TE , ccamp 
>>>>> architecture on
>>>>>gmpls has described Label Set object usage
>>>>>     only for the "optical" domain viz. for carrying wavelengths ( 
>>>>> Section
>>>>>9.9 draft-ietf-ccamp-gmpls-architecture-02.txt) .
>>>>>
>>>>>        Do we require to send Label set(i.e. time slots) for TDM 
>>>>> switching as
>>>>>well . In what way it can be useful .
>>>>Dear Manoj,
>>>>
>>>>Yes, label set object is also useful in TDM case. E.g., SONET poses an 
>>>>additional requirement that the two interfaces of a bidirectional LSP 
>>>>SHOULD traverse the exact same link with the same SUKLM values for the 
>>>>two directions.
>>>>  The label set object can be used to constrain the downstream label to 
>>>> the same as the upstream label.
>>>>
>>>>Thanks
>>>>
>>>>Regards... Zafar
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>>Regards ,
>>>>>Manoj
>>>>===============
>>>>Zafar Ali
>>>>Cisco Systems
>>>>(734) 276-2459
>>>>100 S Main St. #200
>>>>Ann Arbor, MI 48104.
>>>>email: [email-masked]
>
>
>===============
>Zafar Ali
>Cisco Systems
>(734) 276-2459
>100 S Main St. #200
>Ann Arbor, MI 48104.
>email: [email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 9 May 2002 15:53:35 -0400

Suppose (just suppose) that I want a unidirectional sonet LSP and that I want to
constrain the label choice to a specific value.  Note that this is distinct from
the question of what labels to use in each direction for bidirectional.
It is clear how I signal it.  No issues. Label Request, Label Set with one
member...

Now suppose I also want a bidirectional sonet LSP.
How do I indicate that it is bidirectional?
I  believe the only method is to include an Upstream Label.

Could we say that bidirectional uses Upstream Label only, and unidirectional
uses Label Set only?
Yes.

Would that be a good idea?
I don't see think that having multiple choices of presence of objects is useful.

Could an implementation choose to ignore one of the objects and act only on the
other?
Of course.

Adrian

----- Original Message -----
From: "John Drake" <[email-masked]>
To: "'Anca Zamfir'" <[email-masked]>; "Zafar Ali" <[email-masked]>
Cc: "'Juneja, Manoj'" <[email-masked]>; "Vinay Vernekar"
<[email-masked]>; "Manoj Agiwal" <[email-masked]>; "'Ccamp
(E-mail)" <[email-masked]>; <[email-masked]>; "mpls@UU. NET (E-mail)"
<[email-masked]>
Sent: Wednesday, May 08, 2002 10:42 PM
Subject: RE: Label Set Object

---

From: Anca Zamfir <[email-masked]>
Date: Thu, 09 May 2002 16:44:28 -0400

>It is clear how I signal it.  No issues. Label Request, Label Set with one

You can also allow the downstream node to pick one (maybe complex) label 
from a set with more than one member by including multiple labels in the 
Label Set.

>I  believe the only method is to include an Upstream Label.

Correct.

>Could we say that bidirectional uses Upstream Label only, and unidirectional

This is probably true for SONET LSPs. For other types this restriction may 
be undesirable.

>I don't see think that having multiple choices of presence of objects is 

IMO, assuming most GMPLS implementations are meant to cover more than one 
type of LSP domain, for the reason of maximizing the code re-use, it would 
be nice to have as few domain specific restrictions as possible.