Subject: Re: RSVPTE question

From: "Hong Liao" <[email-masked]>
Date: Thu, 20 Jun 2002 13:56:40 -0400

David,

I know it is SENDER_TSPEC, but is it Peak data rate or the token bucket
size?

Hong (Julia) Liao
ATM/Broadband Network Integration
Telcordia Technologies, Inc

Tel:  (973) 829-4570
Fax: (973) 829-5962

                    David Charlap                                                                      
                    <David.Charlap@ma        To:     [email-masked]                                       
                    rconi.com>               cc:     (bcc: Hong Liao/Telcordia)                        
                                             Subject:     Re: RSVPTE question                          
                    06/20/02 01:47 PM                                                                  

Hong Liao wrote:
>
> I want to know which field in the path msg is the one which
> requests for the bandwidth.  (Is the TBS?)

The SENDER_TSPEC

-- David

---

From: David Charlap <[email-masked]>
Date: Thu, 20 Jun 2002 14:23:32 -0400

Hong Liao wrote:
> 
> I know it is SENDER_TSPEC, but is it Peak data rate or the token
> bucket size?

It definitely won't be the token bucket size - that's used for
configuing queue sizes.

The IntServ RFCS explain the IntServ objects.  Three values together
define your QoS:

r - the data rate - this is the "bandwidth" if you only need one number

b - the bucket size - this is (roughly) the size of the queue for
buffering non-conformant packets.

p - the peak data rate - this is the maximum rate data may arrive.

The three together form the parameters for a "leaky bucket" type
queueing system.  I think it's similar to, but not identical to, ATM's
"double leaky bucket" algorithm, if that means anything to you.

-- David