Subject: RE: your mail

From: Shahram Davari <[email-masked]>
Date: Sat, 29 Jun 2002 18:45:32 -0700

Silly or not, I am afraid it is the reality. LDP is inherently unable to do load ballancing, that is why this kludge is there.

-Shahram

-----Original Message-----
From: Eric Osborne
To: Shahram Davari
Cc: 'Eric Osborne'; George Sheng; [email-masked]; [email-masked]
Sent: 6/27/02 7:11 PM
Subject: Re: your mail

On Thu, Jun 27, 2002 at 01:02:53PM -0700, Shahram Davari wrote:
> > ECMP is inherent in the architecture. 
> 
> What? ECMP is a kludge to overcome LDP's inability to TE. 

That seems to be an Extremely Silly statement; if you want TE, use
RSVP.  RFC3209, in case you've missed it...:)

eric

> If you think about it doing hashing of multiple labels and perhaps
> IP header in the middle of an LSP actually defeats the purpose of
> MPLS, which was supposed to be have a simple label lookup in the
> core.

> -Shahram

---

From: Ajay Simha <[email-masked]>
Date: Sun, 30 Jun 2002 06:42:24 -0400 (EDT)

On Sat, 29 Jun 2002, Shahram Davari wrote:

>SD: Silly or not, I am afraid it is the reality. LDP is inherently unable to
>SD:do load ballancing, that is why this kludge is there.

Shahram,

What are we comparing this against? IP? Please explain how in the IP world one
achieved IP vs non-IP load balancing and how it is different when you run LDP?

-ajay
>SD:
>SD:-Shahram
>SD:
>SD:-----Original Message-----
>SD:From: Eric Osborne
>SD:To: Shahram Davari
>SD:Cc: 'Eric Osborne'; George Sheng; [email-masked]; [email-masked]
>SD:Sent: 6/27/02 7:11 PM
>SD:Subject: Re: your mail
>SD:
>SD:On Thu, Jun 27, 2002 at 01:02:53PM -0700, Shahram Davari wrote:
>SD:> > ECMP is inherent in the architecture.
>SD:>
>SD:> What? ECMP is a kludge to overcome LDP's inability to TE.
>SD:
>SD:That seems to be an Extremely Silly statement; if you want TE, use
>SD:RSVP.  RFC3209, in case you've missed it...:)
>SD:
>SD:
>SD:
>SD:eric
>SD:
>SD:> If you think about it doing hashing of multiple labels and perhaps
>SD:> IP header in the middle of an LSP actually defeats the purpose of
>SD:> MPLS, which was supposed to be have a simple label lookup in the
>SD:> core.
>SD:
>SD:> -Shahram
>SD:>
>SD: