Subject: RE: your mail

From: Shahram Davari <[email-masked]>
Date: Thu, 27 Jun 2002 13:02:53 -0700

> ECMP is inherent in the architecture. 

What? ECMP is a kludge to overcome LDP's inability to TE. If you think about it doing hashing of multiple labels and perhaps IP header in the middle of an LSP actually defeats the purpose of MPLS, which was supposed to be have a simple label lookup in the core.

-Shahram

---

From: Eric Osborne <[email-masked]>
Date: Thu, 27 Jun 2002 22:11:54 -0400

On Thu, Jun 27, 2002 at 01:02:53PM -0700, Shahram Davari wrote:
> What? ECMP is a kludge to overcome LDP's inability to TE. 

That seems to be an Extremely Silly statement; if you want TE, use
RSVP.  RFC3209, in case you've missed it...:)

eric

> If you think about it doing hashing of multiple labels and perhaps
> IP header in the middle of an LSP actually defeats the purpose of
> MPLS, which was supposed to be have a simple label lookup in the
> core.

---

From: Eric Rosen <[email-masked]>
Date: Fri, 28 Jun 2002 11:09:49 -0400

Shahram> ECMP is a kludge to overcome LDP's inability to TE. 

EricO> That seems to be an Extremely Silly statement

Yes, indeed.  That's  a bit like saying that dynamic routing  is a kludge to
overcome IP's inability to set up end-to-end circuits for individual flows.

The ability to do load  balancing without creating extra states is generally
construed as  a good  thing, but I  guess not  by the "CO  networking rules"
crowd.  Next  we'll be  hearing  that  equal  cost load  balancing  couldn't
possibly work; violates some ITU architecture, no doubt.  ;-)