Subject: RE: Basic LDP Question

From: Shahram Davari <[email-masked]>
Date: Mon, 3 Jun 2002 08:11:36 -0700

Ajay,

> >SD:Yes, I know it is called "IP tunnel". The point was that this
> >SD:so called "IP tunnel" does not need to be created in advance.
> 
> Advance to what? I don't understand, surely you are not 
> suggesting we do it in
> the forwarding plane. Could you please elaborate here?
> 

Advance to sending any packet. This is the normal IP forwarding.
Just stick an IP header on top of the packet, with the IP destination address of the PE on the other side of the network (BGP next hop),  and just forward
this IP packet to the IGP next hop.

I don't understand your concern !

-Shahram

---

From: Ajay Simha <[email-masked]>
Date: Mon, 3 Jun 2002 11:21:15 -0400 (EDT)

On Mon, 3 Jun 2002, Shahram Davari wrote:

>SD:Ajay,
>SD:
>SD:
>SD:> >SD:Yes, I know it is called "IP tunnel". The point was that this
>SD:> >SD:so called "IP tunnel" does not need to be created in advance.
>SD:>
>SD:> Advance to what? I don't understand, surely you are not
>SD:> suggesting we do it in
>SD:> the forwarding plane. Could you please elaborate here?
>SD:>
>SD:
>SD:Advance to sending any packet. This is the normal IP forwarding.
>SD:Just stick an IP header on top of the packet, with the IP destination address of the PE on the other side of the network (BGP next hop),  and just forward
>SD:this IP packet to the IGP next hop.
>SD:
>SD:I don't understand your concern !

Sorry you are right that should be ok.

-ajay
>SD:
>SD:-Shahram
>SD:

--