Subject: RE: RSVP tear down from intermediate node

From: "Paola Iovanna (ERI)" <[email-masked]>
Date: Thu, 13 Jun 2002 16:55:19 +0200

Hi David,
We agree with you about the possibility to use PathErr and PathTear to tear down a LSP, but our problem is different. We are using RAPI ver.5.2 and we'd like to know if it is possible to send from the RAPI to the daemon a request
for PathErr. By reading the draft it seems it is not allowed, is it rigth? 
Is there another way to force error messages to the daemon? 
Thanks
Paola, Pietro, Daniela

-----Original Message-----
From: David Charlap [mailto:[email-masked]]
Sent: giovedì 13 giugno 2002 15.59
To: [email-masked]
Subject: Re: RSVP tear down from intermediate node

Pietro Tou wrote:
> 
> we have a question: how can we force RSVP to tear down an LSP from
> an intermediate node?

You can't.  It can send a PathErr to the ingress node.  Depending on the
kind of error you send, the ingress node should respond by tearing the
LSP.

> We thought about triggering a Resv Err message from the
> intermediate node to the destination node of the LPS to be torn
> down.

ResvErr won't help, because the egress node is not the node that must do
the actual tear.

> In fact, Resv Error message is used to notify preemption
> (according to RFC), but how can the message be sent?

ResvErr is used for many things.

And preemption should cause _both_ a PathErr and ResvErr to be
generated.

> Is there a way to make the "administrative preemption"?
> RAPI calls seem to not cover this request, because all error
> messages seem to be managed only internally in the RSVP daemon.

If there isn't an error code/value that describes exactly what you want,
pick one that comes close.  If you want to define a new one, write a
draft and submit it here for us to discuss.

-- David

---

From: David Charlap <[email-masked]>
Date: Thu, 13 Jun 2002 11:12:13 -0400

"Paola Iovanna (ERI)" wrote:
> 
> We agree with you about the possibility to use PathErr and PathTear
> to tear down a LSP, but our problem is different. We are using RAPI
> ver.5.2 and we'd like to know if it is possible to send from the
> RAPI to the daemon a request for PathErr. By reading the draft it
> seems it is not allowed, is it rigth?

What daemon?  You're talking about an implementation, not the protocol.

No draft is ever going to say anything about specific implementations. 
I suggest you ask your stack vendor how to make the request.

-- David