Subject: Re: target ldp question:

From: "Chetan Pinto" <[email-masked]>
Date: Fri, 21 Jun 2002 17:28:07 -0700

>The requirement for router("r" in below ase) between 2
>targeted session peer is capable of mpls forwarding.
>
>Question: in the case where R2 as the egress for FEC x
>and R2 assigns label 0 as label binding for fec x on
>its session with R1 ;  now  If transit LSR 'r'
>forward the mpls frame(w/ label 0) to R1, does it
>violate the RFC since RFC says LSR has to pop mpls
>frame w/ label 0 ?

First of all R1 needs to forward the frame to 'r'.
I think this is what u meant [not the other way around]

At R1, there needs be a 2 level label stack for the LSP
corresponding to FEC x outgoing towards r
The bottom most is the one corresponding R2's label [value = 0]
The top most is the one corresponding to r's label [value = 'a']

When the MPLS packet reaches 'r', it replaces 'a' by
some label distributed by R2 [say 'b'] corresponding to FEC 'x'

'r' should never look at the bottom-most label in this case
as it does not understand it [at least in this case]

And the job of popping the label '0' is that of R2

If b is 3, 'r' should not send the top-most label
but pop the remains i.e. label = 0
Well there might be some discrepancy in here
Even though a label value of 0 is just to do IP forwarding,
does it make sense to do so even though R2 never distributed 0 to r?

chetan

>
>
>carlos
>
>
>----
>Jay Karthik wrote:
>
>    Yes, R2 will send out label mappings to R1,
>provided the method of label
>    distribution is downstream unsolicited. (This is
>regardless of whether R1
>    initially sends R2 the label mappings for the
>corresponding FECs)
>
>    Jay
>
>    At 12:58 PM 6/21/02 -0700, Srikrishna Venkataraman
>wrote:
>    >Hi
>    >
>    >I have a configuration as shown below:
>    >
>    >R1-----------R--------R2
>    >
>    >There is an extended session between R1 & R2.
>    >R2 learns of New routes from R1 through the middle
>    >router.
>    >Will R2 send out labels for the new routes to R1?
>    >
>    >
>    >thanks
>
>__________________________________________________
>Do You Yahoo!?
>Yahoo! - Official partner of 2002 FIFA World Cup
>http://fifaworldcup.yahoo.com

############################################################
Chetan Francis Pinto
Phone : Res : 408-244-1352
############################################################

_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

---

From: Carlos Patriawan <[email-masked]>
Date: Thu, 27 Jun 2002 14:21:36 -0700 (PDT)

First of all R1 needs to forward the frame to 'r'.
I think this is what u meant [not the other way around]
---
Thanks for the correction.

At R1, there needs be a 2 level label stack for the LSP
corresponding to FEC x outgoing towards r
The bottom most is the one corresponding R2's label [value = 0]
The top most is the one corresponding to r's label [value = 'a']
---
Targeted session with 2 label stack (rsvp over ldp) is more to vendor implementation, 
as per-RFC there's no requirement for targeted session that should be in two label stack format. 

To be more precise, in targeted session w/ one label stack environment, is it acceptable 
for transit LSR  to forward mpls frame with exp-null label ?

Carlos

---------------------------------
Do You Yahoo!?
Sign-up for Video Highlights of 2002 FIFA World Cup