Subject: RE: draft-ietf-mpls-tc-mib-06a.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 1 Oct 2003 10:30:11 +0200

[Do we need to keep the long cc: list if we post to MPLS WG list ??]

Thomas writes/responds:

> >> >> 	The reason why the multiple fields
> >> >> were left in place was because someone (Arun
> >> >> I think) pointed out that you may want to
> >> >> specify a hop address AND an AS number for
> >> >> the case where you want to get to a specific
> >> >> AS *through* a specific HOP.
> >> >> 
> >> >
> >> >a TeHopAddress can contain an AS number.
> >> >So if you have a separate field for AS number what would then
> >> >be in the TeHopAddress??? And why would you need two addesses
> >> >to get to one place? SOrry I am confused here
> >> 
> >> 	Because a hop can be identified by BOTH an
> >> AS number and an IP address. Suppose you want to
> >> choose an AS via a particular interface on an
> >> LSR?
> >> 
> >And an IP address on another interface?
> >Maybe that would mean two entries in the table??
> 
> 	Perhaps, but the example that was given
> for needing both was the one I gave above. No
> one has asked for what you suppose above.
> 

Tom, maybe you can be a bit more elaborate (and not assume that we
are all MPLS and TE Tunneling experts). PLEASE explain how a system
would use an entry that has both an AS number and another TeHopAddress
in an entry in the table. 

And if you feel that two columns are needed, then I would ask, why not
3 columns or maybe 4 columns. If you claim that one entry needs to
identify the next TeHop with both an IP address AND a AS number,
would one never want to be able to identify it by 
IP address (maybe an IPv4 AND and IPv6 address?), ASnumber, 
unnumbered, lspid ??? In other words, why do you have an arbitrary
set there.

Even if you did want it to be identifyable by 2 or 3 address types,
then I would create multiple "discriminated unions" by having multiple
pairs of TeHopAddressType/TeHopAddress columns.

Bert
> 	--Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 1 Oct 2003 09:01:35 -0400

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf 
>Of Wijnen, Bert (Bert)
>Sent: Wednesday, October 01, 2003 4:30 AM
>To: [email-masked]'; 'Mpls (E-mail)'
>Cc: [email-masked]; [email-masked]; 
>[email-masked]; [email-masked]; 'Joan 
>Cucchiara x302'; 'Kireeti Kompella'; [email-masked]; 
>[email-masked]; [email-masked]; [email-masked]; [email-masked]
>Subject: RE: draft-ietf-mpls-tc-mib-06a.txt
>
>

	Yes, some folks don't read [email-masked] any longer.

>in an entry in the table. 

	I am not sure how much simpler I can make the 
example:  you want to include/exclude a HOP when
running CSPF for the head of a tunnel that has an AS 
number and an IP address of an LSR because you want 
to include or exclude a HOP from your final tunnel's 
ERO (i.e.: explicitly routed path).  In the more
common case, you only give CSPF an IP address or
an AS number of that HOP, but not both.

>unnumbered, lspid ??? In other words, why do you have an arbitrary

	No, I don't think so.  The two columns seem 
fine to handle %100 of the cases that were asked
for of the MIB. We spent quite a while going back and
forth to make sure that the descriptions made sure that
the objects were applicable when necessary (or not).
The rare case I explained above, and the more common 
(i.e.: %99 of the time) cases of either an AS number 
or the IP address of an LSR (but not both).  I don't think we 
need to go down the road of additional ways of addressing 
a HOP; the WG did not ask for those, just the three I
listed above.

>pairs of TeHopAddressType/TeHopAddress columns.

	We could. OTOH, the text and objects that are 
in the MIB now are described correctly, compile cleanly,
and achieve the same thing, so I would rather leave
things as they are than skin the cat yet another way
if it is okay with you. 8)

	--Tom