Subject: I-D ACTION:draft-farrel-mpls-rsvpte-attributes-00.txt

From: [email-masked]
Date: Fri, 10 Oct 2003 15:37:56 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Encoding of Attributes for  Multiprotocol Label 
			  Switching (MPLS) Label Switched Path (LSP) 
			  Establishment Using RSVP-TE
	Author(s)	: A. Farrel, D. Papadimitriou, J. Vasseur
	Filename	: draft-farrel-mpls-rsvpte-attributes-00.txt
	Pages		: 11
	Date		: 2003-10-10
	
Multiprotocol Label Switching (MPLS) Label Switched Paths (LSPs) may
be established using the Resource Reservation Protocol Traffic
Engineering extensions (RSVP-TE). This protocol includes an object
(the SESSION_ATTRIBUTE object) which carries a flags field used to
indicate options and attributes of the LSP. That flags field has
eight bits allowing for eight options to be set.

Recent proposals in many documents that extend RSVP-TE for signaling
additional features and function for MPLS LSPs have suggested uses
for each of the previously unused bits.

This document defines a new object for RSVP-TE messages that allows
the signaling of further attribute bits and also the carriage of
arbitrary attribute parameters. This makes RSVP-TE easily extensible
to support new requirements.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-farrel-mpls-rsvpte-attributes-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-farrel-mpls-rsvpte-attributes-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-farrel-mpls-rsvpte-attributes-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 11 Oct 2003 00:14:08 +0100

All,

At the last IETF it was observed that there was a shortage of bit flags in the Session
Attribute object.

Building on a similar feature recently proposed in the OSPF WG, and on a requirement and
solution similarly expressed in draft-vasseur-inter-as-te we are suggesting a new protocol
object to allow more space for attribute bit flags and also to allow arbitrary attribute
TLVs.

We would welcome your comments.
In particular, we have introduced two objects, one with C-num 11bbbbbb and one with C-num
0bbbbbbb. Are they both necessary?

The CCAMP WG will be invited to comment on the MPLS list to keep the cross-list traffic
down.

Thanks,
Adrian

---

From: "zafar ali" <[email-masked]>
Date: Fri, 10 Oct 2003 20:13:27 -0400

Hi Adrian, 

I think these extensions are much needed to reduce complexity while move
forward with the new features. 

Thanks

Regards... Zafar

------------------------------------------------------------------------
--
Zafar Ali, Ph.D. 
Technical Leader              
Cisco Systems 
100 South Main St. #200
Ann Arbor, MI 48104, USA.
Phone: (734) 276-2459.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf 
>Of Adrian Farrel
>Sent: Friday, October 10, 2003 7:14 PM
>To: [email-masked]'
>Subject: RSVP-TE Session Attribute bit shortage
>
>
>All,
>
>At the last IETF it was observed that there was a shortage of 
>bit flags in the Session Attribute object.
>
>Building on a similar feature recently proposed in the OSPF 
>WG, and on a requirement and solution similarly expressed in 
>draft-vasseur-inter-as-te we are suggesting a new protocol 
>object to allow more space for attribute bit flags and also to 
>allow arbitrary attribute TLVs.
>
>In particular, we have introduced two objects, one with C-num 
>11bbbbbb and one with C-num 0bbbbbbb. Are they both necessary?
>
>The CCAMP WG will be invited to comment on the MPLS list to 
>keep the cross-list traffic down.
>
>Thanks,
>Adrian
>
>
>> indicate options and attributes of the LSP. That flags field 
>has eight 
>> bits allowing for eight options to be set.
>>
>> additional features and function for MPLS LSPs have 
>suggested uses for 
>> each of the previously unused bits.
>>
>http://www.ietf.org/internet-drafts/draft->farrel-mpls-rsvpte-attribute
>> s-00.txt
>>
>> Internet-Drafts are also available by anonymous FTP. Login with the 
>> username "anonymous" and a password of your e-mail address. After 
>> logging in, type "cd internet-drafts" and then "get 
>> draft-farrel-mpls-rsvpte-attributes-00.txt".
>>
>> http://www.ietf.org/shadow.html or 
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>>
>feature, 
>> insert the command "ENCODING mime" before the "FILE" command.  To 
>> decode the response(s), you will need "munpack" or a MIME-compliant 
>> mail reader.  Different MIME-compliant mail readers exhibit 
>different 
>> behavior, especially when dealing with "multipart" MIME 
>messages (i.e. 
>> documents which have been split up into multiple messages), so check 
>> your local documentation on how to manipulate these messages.
>>
>>