Subject: LDP LSP FEC Table Index - LDP MIB draft ver 13

From: "M. ELK" <[email-masked]>
Date: Thu, 16 Oct 2003 14:24:27 +0000

Hi

1- The index of LDP LSP FEC Table is given by :

        INDEX { mplsLdpEntityLdpId,
                      mplsLdpEntityIndex,
                      mplsLdpPeerLdpId,
                      mplsLdpLspFecSegment,
                      mplsLdpLspFecSegmentIndex,
                      mplsLdpLspFecIndex
                     }

Could it be :

        INDEX { mplsLdpEntityLdpId,
                      mplsLdpEntityIndex,
                      mplsLdpPeerLdpId,
                      mplsLdpLspFecIndex
                      mplsLdpLspFecSegment,
                      mplsLdpLspFecSegmentIndex,
                                          }

my guess the above is logical where for certain PEER Peer1 :  for each FEC 
the In and out segment pointer is listed in 2 sucessive entry .

2- actually my requirement that knowing mplsLdpLSPFecIndex associated by 
FEC1 , i need to get
the In-Segment stat and Out-Segment stat fast enough so the ideal :

  INDEX { mplsLdpLspFecIndex
                     mplsLdpEntityLdpId,
                      mplsLdpEntityIndex,
                      mplsLdpPeerLdpId,
                      mplsLdpLspFecSegment,
                      mplsLdpLspFecSegmentIndex,
                                          }

From LDP LSP Table description :
        DESCRIPTION
           "A table which shows the relationship between  LDP LSPs and FECs. 
  Each row represents
           a single LDP LSP to FEC association."

       Could it be :

DESCRIPTION
           "A table which shows the relationship between  FECs and LDP LSPs 
.  Each row represents
           a single  FEC to LDP LSP association."

Brgds

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

---

From: Joan Cucchiara x302 <[email-masked]>
Date: Thu, 16 Oct 2003 12:11:17 -0400

> -----Forwarded Message-----
> From: "M. ELK" <[email-masked]>
> Sent: Oct 16, 2003 10:24 AM
> To: [email-masked], [email-masked]
> Subject: LDP LSP FEC Table Index -  LDP MIB draft ver 13 
> 
> 
> Hi
> 

The current indexing allows an LDP LSP, with Insegment and/or Outsegment, 
to one or more FECs.

>            a single  FEC to LDP LSP association."

I am unclear how the alternative indexing you propose will
help obtain the InSegment and OutSegment statistics any faster.  
That aside, the current tables are designed to allow a FEC to be
assigned to zero, one or more LDP LSP Segments (if that is so configured), 
or one LDP LSP Segment to one or more FECs (if that is so configured), so
these tables are flexible.  The change you are proposing is less
flexible, so would rather keep the flexibility.

You could create a table in an enterprise MIB with the indexing
you propose.

  -Joan