Subject: [mpls] Label number mapping

From: Leonardo Balliache <[email-masked]>
Date: Wed, 17 Nov 2004 07:35:47 -0400

Hi, all.

Perhaps I'm missing something but I've got a question about mpls.

Should there be some previous agreement between lsr about label numbers to 
be mapped and flooded?
If so, where the specs talk about this?

Have a look to the following scenario; let's suppose we are using 
unsolicited ordered control:

	a ------ x ------ y ------- b

1.- x and y are mpls lsr.
2.- x is egress for a then it maps label 1 to fec a, install it for 
forwarding and advertise this map to y.
3.- y is egress for b then it maps label 1 to fec b, install it for 
forwarding and advertise this map to x.
4.- x tries to install mapping 1-b received from y.
5.- y tries to install mapping 1-a received from x.
6.- Then both lsr could have the same label "1" mapped to two different 
fecs: a and b.

Is this possible? Is there something I haven't understand yet?

Best regards,

Leonardo Balliache

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Shahram Davari <[email-masked]>
Date: Thu, 18 Nov 2004 13:56:02 -0800

This is possible and very common. There is no need for any agreement or coordination.

-Shahram

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Leonardo Balliache
> Sent: Wednesday, November 17, 2004 6:36 AM
> To: Mpls list
> Subject: [mpls] Label number mapping
> 
> 
> Hi, all.
>