Subject: RE: [mpls] Applying Qos on VPNs

From: [email-masked]
Date: Thu, 9 Dec 2004 12:24:05 -0500

Sort of. The part up to tunnel lookup is correct. TOS stamping takes
place on the CE along with some sort of rate limiting usually. Mapping
the packets to tunnels would be done on a routing basis I believe. If
I'm not mistaken you can also use half-duplex VRF to do this as well. As
the CE TOS bit is encapsulated in the MPLS info the experimental bit
will be used. Make sense?

Jordan Britnell, CCNA

 IP Technology Research

 BCE/Bell Canada

 (416) 215-3729

[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: December 9, 2004 12:16 PM
To: Britnell, Jordan (5000008); [email-masked]
Cc: [email-masked]
Subject: RE: [mpls] Applying Qos on VPNs

Does it imply that the CEs linked to the ingress PE would send IP
packet's TOS field to mark a QoS service.

And additionally the PE would lookup the TOS field on all its inbound CE
interfaces and mark EXP bit and forward them to any of the TE tunnels
that which may have an EXP bit mapping?

Thanks

Kurien

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 09, 2004 8:46 AM
To: [email-masked]
Subject: RE: [mpls] Applying Qos on VPNs

Absolutely. You can use half-duplex VRF routing as well as MPLS
experimental bits to define how you would like traffic from a customer
to be handled. A search on Cisco's site will show you the necessary
steps. 

Jordan Britnell, CCNA

 IP Technology Research

 BCE/Bell Canada

 (416) 215-3729

[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
Sent: December 9, 2004 11:25 AM
To: [email-masked]
Subject: [mpls] Applying Qos on VPNs

Can QoS be applied to Layer 3 MPLS VPNs in such a manner that, two
customers connected to the same ingress PE router but offered two types
of services like GoldVoIP and SilverVoIP and two TE tunnels having
different Path options but terminating together on a common egress PE?

Since the Egress PE for the both VPNs is the same, is it possible to
have VPN traffic classified and routed to different tunnels?

Could someone pass a link to any cisco or juniper configuration guide ?

Thanks

Kurien

R & D Engineer, 
MPLS/VPN Assurance 
OSSD, 
Agilent Technologies. 

Tel : 916 788 6678 ( TELNET 788 6678) 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Sam Munzani <[email-masked]>
Date: Thu, 09 Dec 2004 11:59:36 -0600

> I’m not mistaken you can also use half-duplex VRF to do this as well. 
> As the CE TOS bit is encapsulated in the MPLS info the experimental 
> bit will be used. Make sense?
>
What mechanism can ensure CE will not setup TOS bit differently than 
they paid for? You may not have control on their equipments.

Sam

> Jordan Britnell, CCNA
>
> IP Technology Research
>
> BCE/Bell Canada
>
> (416) 215-3729
>
> [email-masked] <mailto:[email-masked]>_
>
> *From:* [email-masked] [mailto:[email-masked]]
> *Sent:* December 9, 2004 12:16 PM
> *To:* Britnell, Jordan (5000008); [email-masked]
> *Cc:* [email-masked]
> *Subject:* RE: [mpls] Applying Qos on VPNs
>
> packet’s TOS field to mark a QoS service.
>
> And additionally the PE would lookup the TOS field on all its inbound 
> CE interfaces and mark EXP bit and forward them to any of the TE 
> tunnels that which may have an EXP bit mapping?
>
> Thanks
>
> Kurien
>
> ------------------------------------------------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]]
> *Sent:* Thursday, December 09, 2004 8:46 AM
> *To:* [email-masked]
> *Subject:* RE: [mpls] Applying Qos on VPNs
>
> to be handled. A search on Cisco’s site will show you the necessary 
> steps.
>
> Jordan Britnell, CCNA
>
> IP Technology Research
>
> BCE/Bell Canada
>
> (416) 215-3729
>
> [email-masked] <mailto:[email-masked]>_
>
> *From:* [email-masked] 
> [mailto:[email-masked]] *On Behalf Of 
> [email-masked]
> *Sent:* December 9, 2004 11:25 AM
> *To:* [email-masked]
> *Subject:* [mpls] Applying Qos on VPNs
>
> customers connected to the same ingress PE router but offered two 
> types of services like GoldVoIP and SilverVoIP and two TE tunnels 
> having different Path options but terminating together on a common 
> egress PE?
>
>------------------------------------------------------------------------
>