Subject: RE: [mpls] Comments on draft-vasseur-mpls-number-0-bw-te-lsps-00 ?

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Tue, 21 Mar 2006 18:33:27 +0100

Hi JP, all

Advertising within the IGP the number of 0-bw LSPs sounds useful. This would help data plane load balancing but also maybe control plane load optimization (avoid concentration of RSVP-TE states on the same LSR)?

The proposed extension is quite straightforward. This implies similar IGP load as the unreserved bandwidth sub-TLVs, provided that appropriate hysterisis and dampening mechanisms are used.

By the way why not also advertising the number of non-0-bw LSPs?
This could also be used for control plane load optimization...

Hence the work should be pursued.

Regards,

JL 

> -----Message d'origine-----
> De : JP Vasseur [mailto:[email-masked]] 
> Envoyé : lundi 20 mars 2006 17:15
> À : [email-masked]
> Objet : [mpls] Comments on draft-vasseur-mpls-number-0-bw-te-lsps-00 ?
> 
> Dear WG,
> 
> Right after the presentation this morning, it was suggested 
> to gather feed-back on the usefulness of this ID before 
> moving forward. I got some feed-back off-line and on-line 
> (Kenji - KDDI).
> 
> Could you tell me whether you think that it is worth being pursed ?
> 
> Send comments if any.
> 
> Thanks.
> 
> JP.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: JP Vasseur <[email-masked]>
Date: Wed, 22 Mar 2006 17:54:26 -0500

Hi Jean-Louis,

Thanks for the positive feed-back. See below,

On Mar 21, 2006, at 12:33 PM, LE ROUX Jean-Louis RD-CORE-LAN wrote:

> Hi JP, all
>
> Advertising within the IGP the number of 0-bw LSPs sounds useful.  
> This would help data plane load balancing but also maybe control  
> plane load optimization (avoid concentration of RSVP-TE states on  
> the same LSR)?
>

Right both are motivations for this extensions indeed.

> The proposed extension is quite straightforward.

Indeed :-)

> This implies similar IGP load as the unreserved bandwidth sub-TLVs,  
> provided that appropriate hysterisis and dampening mechanisms are  
> used.
>

Also correct.

> This could also be used for control plane load optimization...

Yes I originally thought of doing this also ... Just wanted to first  
focus on the "obvious" case where the info is really required to  
optimize the data plane. We could easily define the exact same sub- 
TLV for the non-0 bw TE LSP and let an implement decide whether to  
advertise the info (in any case, both sub-TLVs would be optional of  
course). Will be added to the next revision.

> Hence the work should be pursued.

Thanks for the feed-back.

JP.