Subject: [mpls] Signaling Requirement for P2MP

From: YongLucy 73674 <[email-masked]>
Date: Wed, 17 May 2006 10:27:50 -0500

Seisho,
This (4461) is good and comprehensive document. It covers a lot of information.
Since P2MP LSP is unidirectional paths with many end points, this brings a lot of specialties for the signaling and transmission.
If this is only for unidirectional, should we specify if signaling initiates from a source point or a sink point, or both. What restriction applies.
Failure discovery becomes an issue for unidirectional transmission, should signaling assists on the failure discovery?
Adding/removing a branch, should only allows sink point to initiate the request or the transit point could do it so?
Any commont on these?
Thanks,
Lucy

*******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *******************************************************************************************

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 19 May 2006 17:45:27 +0100

Hi Lucy,

> Since P2MP LSP is unidirectional paths with many end points, this brings a 
> lot
> of specialties for the signaling and transmission.
>
> If this is only for unidirectional, should we specify if signaling 
> initiates from a
> source point or a sink point, or both. What restriction applies.

The requirements RFC deliberately does not specify an answer to this 
question because it does not tie the solution to any one existing signaling 
protocol.

But you should note that draft-ietf-mpls-rsvp-te-p2mp-05.txt defines 
extensions to RSVP-TE which is a source-to-destination signaling procedure. 
That is, the signaling initiates from the source point.

Mechanisms for the source point to discover the leaves are out of scope. And 
so (in particular) leaf-initiated-join is out of scope.

> Failure discovery becomes an issue for unidirectional transmission,

Failure is always an issue!

You can see some "interesting" discussion of this in 
draft-ietf-mpls-p2mp-oam-reqs-01.txt

> should signaling assists on the failure discovery?

Potentially. But it is not always possible for signaling to discover 
failure, especially if the data and control channels are disjoint. It can, 
however, isolate them and report them.

> Adding/removing a branch, should only allows sink point to
> initiate the request or the transit point could do it so?

The requirements have nothing to say about this, as described above.

The current solution assumes that the ingress is responsible for all 
additions and can control removals. But just like in P2P, any LSR along the 
path (and particulalry the egress) can initiate a removal (but the ingress 
might try to add it back in again).

> Any commont on these?

Hope this helps.

Regards,
Adrian