Subject: [mpls] [MPLS-OPS]: ldp hello hold timer question

From: shilpa goel <[email-masked]>
Date: Thu, 20 Sep 2007 15:47:00 +0530

Yes Sunil, it appears it is misconfiguration and the operator at router R2
will have to reconfigure the hello and hold times.

regards,
Shilpa

On 9/19/07, sunil <[email-masked]> wrote:
>
>  Hi
>
> If two routers are configured with ldp hello times as
>
> R1 - hello 1sec and hold time 3 sec
>
> R2 - hello 4 sec and hold time 12 sec
>
> What should be the negotiated hold time among them
>
> According to rfc the negotiated should be minimum of the two hold values
> The min value is 3, if hold time of 3 is considered then does ldp session
> doesn't comesup, bcz R2 sends hellos every 4 sec and R1 hold expires every 3
> sec.
>
> Is it misconfiguration??
>
>
>
> Thanks
>
_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "shilpa goel" <[email-masked]>
Date: Thu, 20 Sep 2007 15:47:00 +0530

regards,
Shilpa

---

From: "shilpa goel" <[email-masked]>
Date: Fri, 21 Sep 2007 09:05:25 +0530

Does hello time automatically become 1/3 of the minimum hold time (at Router
R2 in the given example)? As per my understanding, RFC 3036 only recommends
this but doesn't enforce it.

On 9/20/07, Ramesh Huliyar <[email-masked]> wrote:
>
> Hello Sunil,
>
> Yes, the hold time is considered the minimum of the two values. Similarly,
> the hello will become 1/3 of the minimum hold time. So, in the below given
> example, hold time will be 3 secs and hello will be 1 sec.
>
> Thanks
> Ramesh Huliyar
>
> *shilpa goel <[email-masked]>* wrote:
>
> > The min value is 3, if hold time of 3 is considered then does ldp
> > session doesn't comesup, bcz R2 sends hellos every 4 sec and R1 hold expires
> > every 3 sec.
> > Is it misconfiguration??
> >
> > Thanks
> >
>
> ------------------------------
> Bring your gang together - do your thing. Start your group.<http://in.rd.yahoo.com/tagline_groups_2/*http://in.promos.yahoo.com/groups>
>
>

---

From: shilpa goel <[email-masked]>
Date: Fri, 21 Sep 2007 09:05:25 +0530

---

From: Ramesh Huliyar <[email-masked]>
Date: Sun, 23 Sep 2007 17:17:18 +0100 (BST)

Hello Shilpa,

Yes, though RFC 3036 doesn't enforce it, most vendors implement it. This is necessary for smooth operation of LDP.

Thanks
Ramesh Huliyar

shilpa goel <[email-masked]> wrote: Does hello time automatically become 1/3 of the minimum hold time (at Router R2 in the given example)? As per my understanding, RFC 3036 only recommends this but doesn't enforce it.

 On 9/20/07, Ramesh Huliyar <[email-masked]> wrote: Hello Sunil,

Yes, the hold time is considered the minimum of the two values. Similarly, the hello will become 1/3 of the minimum hold time. So, in the below given example, hold time will be 3 secs and hello will be 1 sec. 

Thanks
Ramesh Huliyar

shilpa goel <[email-masked] > wrote:
 Yes Sunil, it appears it is misconfiguration and the operator at router R2 will have to reconfigure the hello and hold times. 

regards,
Shilpa 

On 9/19/07,  sunil < [email-masked]> wrote:                Hi
  If two routers are configured with ldp hello times as 
  R1 - hello 1sec and hold time 3 sec
   R2 - hello 4 sec and hold time 12 sec
  What should be the negotiated hold time among them
   According to rfc the negotiated should be minimum of the two hold values
 The min value is  3, if hold time of 3 is considered then does ldp session doesn't comesup, bcz R2 sends hellos every 4 sec and R1 hold expires every 3 sec.
   Is it misconfiguration??
   
  Thanks 

---------------------------------
 Bring your gang together - do your thing.   Start your group.

       
---------------------------------
 Bring your gang together - do your thing.  Start your group.

---

From: "sunil" <[email-masked]>
Date: Fri, 21 Sep 2007 14:29:48 -0700

Hi

RFC didn't explicitly said to change the hello timer based on the negotiated
hold timer

I think its implementation dependant.

I checked in cisco router and its changing its hello timer to 1/3 of the
negotiated hold timer

Sunil

  _____  

From: shilpa goel [mailto:[email-masked]] 
Sent: Thursday, September 20, 2007 8:35 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] [MPLS-OPS]: ldp hello hold timer question

Hello Sunil,

Thanks
Ramesh Huliyar

regards,
Shilpa

On 9/19/07, sunil < <mailto:[email-masked]>  [email-masked]>
wrote:

Hi

Is it misconfiguration??

Thanks 

  _____  

Bring your gang together - do your thing. Start your group.
<http://in.rd.yahoo.com/tagline_groups_2/*http:/in.promos.yahoo.com/groups>