Subject: [mpls] last call on three mpls wg documents

From: Loa Andersson <[email-masked]>
Date: Mon, 20 Oct 2008 23:51:57 +0200

Working group,

the authors of

draft-ietf-mpls-gmpls-lsp-reroute-02.txt
draft-ietf-mpls-soft-preemption-13.txt
draft-ietf-mpls-3209-patherr-03.txt

has asked that we issue a working group last call on these
document as a group. This mail starts the wg last call.

There has gone quite an effort to align the three document and
to create a coherent structure.

The working group last call will end on Nov 7.

Please send comments to the working group mailing-list or to the
working group co-chairs.

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Nic Neate <[email-masked]>
Date: Wed, 29 Oct 2008 17:40:58 +0000

Hi Lou, Dimitri, JP,

draft-ietf-mpls-gmpls-lsp-reroute doesn't explicitly include or exclude P2MP LSPs, but I think most of the function applies equally to both P2P and P2MP.  I'd like to suggest a couple of tweaks for explicit P2MP support.

1.  Section 2.3 recommends that ingress nodes use make-before-break for rerouting:

   ... When an
   alternate path is identified, a corresponding make-before-break LSP
   SHOULD be initiated, and standard make-before-break procedures MUST
   be followed.

For P2MP LSPs, the PathErr will only apply to one sub-group (or a subset of the S2L sub-LSPs in a sub-group).  It would therefore be more efficient to use sub-group-based re-optimization (RFC 4875 section 14.2) rather than make-before-break.

2.  Section 2.2 of your draft states that transit nodes MUST use "standard local repair processing":

   When the reroute request can be processed locally, standard local
   repair processing MUST be followed.

For P2MP LSPs, I think that means sub-group-based re-optimization.  If you agree, it would be helpful to state it explicitly.  If not, please could you clarify.

Thanks,

Nic

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: 20 October 2008 22:52
To: [email-masked]
Cc: Ross Callon; Cisco - David Ward
Subject: [mpls] last call on three mpls wg documents

Working group,

the authors of

has asked that we issue a working group last call on these document as a group. This mail starts the wg last call.

There has gone quite an effort to align the three document and to create a coherent structure.

Please send comments to the working group mailing-list or to the working group co-chairs.

/Loa

--
Loa Andersson

                                           [email-masked] _______________________________________________