Subject: [mpls] I-D Action:draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt

From: "Mohammad Hanif" <[email-masked]>
Date: Wed, 15 Jul 2009 12:16:07 -0700

Any comment on this draft?

________________________________

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
 
        Title           : Signaling BFD configuration for a backup path
in an FRR environment
        Author(s)       : M. Hanif, L. Nguyen
        Filename        : draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt
        Pages           : 7
        Date            : 2009-07-06
 
Today there is no support in the RSVP protocol to dynamically signal
the enabling and configuring of the BFD (Bi-directional Forwarding
Detection) on a backup path.  This document introduces a new RSVP
object called "FRR backup BFD object".  The procedures described in
this document are only applicable to Fast Reroute LSPs [RFC4090].
 
A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hanif-rsvp-te-bfd-frr-backup-p
ath-00.txt
 
Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/
 
Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

<ftp://ftp.ietf.org/internet-drafts/draft-hanif-rsvp-te-bfd-frr-backup-p
ath-00.txt>
<ftp://ftp.ietf.org/internet-drafts/draft-hanif-rsvp-te-bfd-frr-backup-p
ath-00.txt>

---

From: "Attila Takacs" <[email-masked]>
Date: Fri, 17 Jul 2009 09:37:53 +0200

Hi Mohammad,
 
There is ongoing work in the ccamp wg to add OAM configuration support
to RSVP-TE. Please see, draft-ietf-ccamp-oam-configuration-fwk-01. 
 
Technology specific extensions to the framework are described in 
-draft-ietf-ccamp-rsvp-te-eth-oam-ext-01 for Ethernet,
-draft-kern-ccamp-rsvp-te-sdh-otn-oam-ext-00 for SDH/OTN,
-draft-bellagamba-ccamp-rsvp-te-mpls-tp-oam-ext-00 targeting MPLS-TP
OAM, but currently only covering basic BFD aspects.
 
I think it would be good to have a common approach. It seems, after a
first read, that you proposal could be easily aligned with
draft-ietf-ccamp-oam-configuration-fwk.
 
Best regards,
Attila

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mohammad Hanif
	Sent: Wednesday, July 15, 2009 9:16 PM
	To: [email-masked]
	Subject: [mpls] I-D
Action:draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt

	A New Internet-Draft is available from the on-line
Internet-Drafts directories.
	 
	        Title           : Signaling BFD configuration for a
backup path in an FRR environment
	        Author(s)       : M. Hanif, L. Nguyen
	        Filename        :
draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt
	        Pages           : 7
	        Date            : 2009-07-06
	 
	Today there is no support in the RSVP protocol to dynamically
signal
	the enabling and configuring of the BFD (Bi-directional
Forwarding
	Detection) on a backup path.  This document introduces a new
RSVP
	object called "FRR backup BFD object".  The procedures described
in
	this document are only applicable to Fast Reroute LSPs
[RFC4090].

	 
	 
	Below is the data which will enable a MIME compliant mail reader
	implementation to automatically retrieve the ASCII version of
the
	Internet-Draft.

---

From: "Mohammad Hanif" <[email-masked]>
Date: Fri, 17 Jul 2009 10:15:31 -0700

Thanks a lot Attila for your comments/suggestions.  I will look in to
the drafts from ccamp wg.

--Hanif.

From: Attila Takacs [mailto:[email-masked]] 
Sent: Friday, July 17, 2009 12:38 AM
To: Mohammad Hanif; [email-masked]
Subject: RE: [mpls] I-D
Action:draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt

Hi Mohammad,

Best regards,

Attila

---

From: Nitin Bahadur <[email-masked]>
Date: Fri, 17 Jul 2009 11:41:54 -0700

Hi Mohammad,

    Disclaimer: I haven't read your draft.

draft-ietf-bfd-mpls specifies how bfd is to be configured/enabled for mpls lsps.

Attilla's draft in CCAMP is broad-based, but currently defined only for Ethernet OAM (from the last time I read it).
You could add your extensions there. But from a pragmatic perspective, I would rather have new extensions along the
lines of draft-ietf-bfd-mpls. Once you start having multiple ways of configuring/enabling a feature, it is a nightmare for
service providers.

My 2 cents.
Nitin

On 7/17/09 12:37 AM, "Attila Takacs" <[email-masked]> wrote:

Hi Mohammad,

There is ongoing work in the ccamp wg to add OAM configuration support to RSVP-TE. Please see, draft-ietf-ccamp-oam-configuration-fwk-01.

Technology specific extensions to the framework are described in
-draft-ietf-ccamp-rsvp-te-eth-oam-ext-01 for Ethernet,
-draft-kern-ccamp-rsvp-te-sdh-otn-oam-ext-00 for SDH/OTN,
-draft-bellagamba-ccamp-rsvp-te-mpls-tp-oam-ext-00 targeting MPLS-TP OAM, but currently only covering basic BFD aspects.

I think it would be good to have a common approach. It seems, after a first read, that you proposal could be easily aligned with draft-ietf-ccamp-oam-configuration-fwk.

Best regards,
Attila

________________________________
From: [email-masked]  [mailto:[email-masked]] On Behalf Of Mohammad  Hanif
Sent: Wednesday, July 15, 2009 9:16 PM
To:  [email-masked]
Subject: [mpls] I-D  Action:draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Signaling BFD configuration for a backup path in an FRR environment
        Author(s)       : M. Hanif, L. Nguyen
        Filename        : draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt
        Pages           : 7
        Date            : 2009-07-06

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt

<ftp://ftp.ietf.org/internet-drafts/draft-hanif-rsvp-te-bfd-frr-backup-path-00.txt>