Subject: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

From: The IESG <[email-masked]>
Date: Mon, 21 Sep 2009 15:54:16 -0700 (PDT)

The IESG has received a request from the Multiprotocol Label Switching WG 
(mpls) to consider the following document:

- 'MPLS TP Network Management Requirements '
   <draft-ietf-mpls-tp-nm-req-05.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send substantive comments to the
[email-masked] mailing lists by 2009-10-05. Exceptionally, 
comments may be sent to [email-masked] instead. In either case, please 
retain the beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-mpls-tp-nm-req-05.txt

IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=18244&rfc_flag=0

---

From: "Shahram Davari" <[email-masked]>
Date: Mon, 21 Sep 2009 16:24:25 -0700

Hi,

Just for clarification, does this draft require using a PID for BFD and LSP-ping? If not how are the various OAM types identified?

Thanks,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of The IESG
Sent: Monday, September 21, 2009 3:54 PM
To: IETF-Announce
Cc: [email-masked]
Subject: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: <[email-masked]>
Date: Tue, 22 Sep 2009 00:32:22 +0100

Sharam,

The draft describes network management requirements and at most states that OAM must be configurable by network management. It presupposes nothing about the OAM mechanism used or now the individual network elements (LSRs) recognise the OAM packets themselves. So I don't understand your question in regards to the draft as the question you ask is not relevant within the scope of the draft.

Ben

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Shahram Davari [[email-masked]]
Sent: Tuesday, September 22, 2009 12:24 AM
To: [email-masked]; IETF-Announce
Cc: [email-masked]
Subject: Re: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

Hi,

Thanks,
Shahram

---

From: "Shahram Davari" <[email-masked]>
Date: Mon, 21 Sep 2009 16:39:23 -0700

Hi Ben,

Basically I want to understand whether PID is required for OAM or not? Also is OAM a type of MCC traffic?

Thanks,
Shahram 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, September 21, 2009 4:32 PM
To: Shahram Davari; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

Sharam,

Ben

Hi,

Thanks,
Shahram

---

From: <[email-masked]>
Date: Tue, 22 Sep 2009 01:31:10 +0100

Sharam,

Which is a fine question to ask but IMO is not relevant in the context of the NM requirements draft.

Within the OAM requirements it is relevant as it is a requirement to be able to distinguish between OAM traffic and data traffic.

Within the solutions drafts it is relevant as they should define the mechanism by which OAM packets are identified.

A MCC may run OAM but your question is still not relevant in the context of the NM requirements draft as the OAM requirements for the MCC should inherit from the OAM requirements draft and the OAM solutions themselves.

Ben
________________________________________
From: Shahram Davari [[email-masked]]
Sent: Tuesday, September 22, 2009 12:39 AM
To: Niven-jenkins,B,Ben,DMF R; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

Hi Ben,

Thanks,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, September 21, 2009 4:32 PM
To: Shahram Davari; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

Sharam,

Ben

Hi,

Thanks,
Shahram

---

From: "Shahram Davari" <[email-masked]>
Date: Mon, 21 Sep 2009 17:42:22 -0700

Ben,

OK let me put it in another way:

Is PID always required after the G-ACH Channel type or it depends on the Channel Type? I think this question is very relevant to this draft.

Thanks,
Shahram 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, September 21, 2009 5:31 PM
To: Shahram Davari
Cc: [email-masked]
Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

Sharam,

Ben

Hi Ben,

Thanks,
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, September 21, 2009 4:32 PM
To: Shahram Davari; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP Network Management Requirements) to Proposed Standard

Sharam,

Ben

Hi,

Thanks,
Shahram

---

From: "BUSI ITALO" <[email-masked]>
Date: Tue, 22 Sep 2009 18:46:13 +0200

Shahram,

I have changed the title of the mail as I think that both of you are
correct:
- Ben is right in claiming your question outside the scope of NM
Requirements draft
- you are right in asking additional clarification about the ACH
architecture

The main idea of RFC 5586 is that the ACH channel type identifies the
type of G-ACh message that follows and whether or not the ACH is
followed by an ACH TLV header.

Each draft/RFC defining a protocol to be carried within the ACH will
require IANA to allocate a specific value for the Channel Type and
define the exact structure of the G-ACh message following the ACH
including whether or not an ACH TLV header follows the ACH.

In this context, draft-ietf-mpls-tp-gach-dcn-06, defines the protocol
solution for SCC and MCC packets. According to this draft the ACH
channel type xx identifies an MCC packet while the ACH channel type yy
identifies an SCC packet.

In both cases, there is no ACH TLV header following the ACH and a PID
field is inserted, within the G-ACh message, to identify the specific L3
PDU following the PID (IPv4 or IPv6 or OSI packet).

This structure is specific to the MCC and SCC solution and do not
necessarily apply to BFD or other OAM protocols.

For BFD there are some drafts which are going to be merged. According to
the presentation we had at the IETF 75, we can foresee two ACH channel
types:

- 0x07 (as defined in vccv bfd) to indicate that the G-ACh message
contains a BFD packet w/o the ACH TLV header (and w/o any PID field)

- a new TBD value to indicate that the G-ACh message containing a BFD
packet with the ACH TLV header (and w/o any PID field)

In both cases there will be no PID field in a packet carrying BFD.

Work still needs to be done for other OAM tools but I do not foresee any
need to encode a PID field in other OAM tools.

I hope this helps clarifying the issue.

Italo

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Shahram Davari
> Sent: Tuesday, September 22, 2009 2:42 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls] Last Call: draft-ietf-mpls-tp-nm-req 
> (MPLS TP Network Management Requirements) to Proposed Standard
> 
> Ben,
> 
> Is PID always required after the G-ACH Channel type or it 
> depends on the Channel Type? I think this question is very 
> relevant to this draft.
> 
> Thanks,
> Shahram 
> 
> Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req 
> (MPLS TP Network Management Requirements) to Proposed Standard
> 
> Sharam,
> 
> Which is a fine question to ask but IMO is not relevant in 
> the context of the NM requirements draft.
> 
> Within the OAM requirements it is relevant as it is a 
> requirement to be able to distinguish between OAM traffic and 
> data traffic.
> 
> Within the solutions drafts it is relevant as they should 
> define the mechanism by which OAM packets are identified.
> 
> A MCC may run OAM but your question is still not relevant in 
> the context of the NM requirements draft as the OAM 
> requirements for the MCC should inherit from the OAM 
> requirements draft and the OAM solutions themselves.
> 
> Ben
> Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req 
> (MPLS TP Network Management Requirements) to Proposed Standard
> 
> Hi Ben,
> 
> Basically I want to understand whether PID is required for 
> OAM or not? Also is OAM a type of MCC traffic?
> 
> Thanks,
> Shahram
> 
> Subject: RE: [mpls] Last Call: draft-ietf-mpls-tp-nm-req 
> (MPLS TP Network Management Requirements) to Proposed Standard
> 
> Sharam,
> 
> The draft describes network management requirements and at 
> most states that OAM must be configurable by network 
> management. It presupposes nothing about the OAM mechanism 
> used or now the individual network elements (LSRs) recognise 
> the OAM packets themselves. So I don't understand your 
> question in regards to the draft as the question you ask is 
> not relevant within the scope of the draft.
> 
> Ben
> 
> Subject: Re: [mpls] Last Call: draft-ietf-mpls-tp-nm-req 
> (MPLS TP Network Management Requirements) to Proposed Standard
> 
> Hi,
> 
> Just for clarification, does this draft require using a PID 
> for BFD and LSP-ping? If not how are the various OAM types identified?
> 
> Thanks,
> Shahram
> 
> Subject: [mpls] Last Call: draft-ietf-mpls-tp-nm-req (MPLS TP 
> Network Management Requirements) to Proposed Standard
>