Subject: [mpls] draft-bishnoi-mpls-ldp-node-group-00

From: <[email-masked]>
Date: Wed, 6 Jan 2010 15:11:50 +0100

Hi Sandeep,

I think the mLDP (draft-mpls-ldp-p2mp) draft from Ice and others addresses the upstream node selection in section 2.4.1.1. Determining one's 'upstream LSR'. I think furthermore your method goes more into the direction of contraint-based routing. Is this right? If yes, then my question is why not using RSVP-TE to setup a constraint based P2MP-LSP.

Best regards

Rüdiger

---

From: "BISHNOI Sandeep" <[email-masked]>
Date: Wed, 13 Jan 2010 13:55:06 -0600

Hi Rudiger,

Purpose of this draft is to allow creating disjoint P2MP trees and also to restrict flow of P2P LSP to a set of preferred routes among available ECMP routes. It uses a "constraint" method but that is only to give preference to certain routes among ECMP.

-          For this to work properly, the network must be provisioned with a rich topology to support ECMP routes.

-          It does not create constraint based routes as it is using a subset of routes available from "classic" routing and not creating a superset of routes

-          mLDP draft has provision to select an upstream node but does not allow any method to create disjoint P2MP trees

-          Method is applicable to P2P case too where the requirement is to not use all available ECMP paths but to prefer or restrict flow to a subset of ECMP paths. This would help in case of "out of control ECMP" where the ECMP routes multiply with increase in links and nodes across network.

-          RSVP creates a superset of routes so falls under the domain of constraint based routing.

We would appreciate comments from the WG.

Thanks,

Sandeep

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, January 06, 2010 6:12 AM
To: [email-masked]
Subject: [mpls] draft-bishnoi-mpls-ldp-node-group-00

Hi Sandeep, 

Best regards 

Rüdiger

---

From: <[email-masked]>
Date: Fri, 15 Jan 2010 10:24:15 +0100

Hi Sandeep,
 
i completely understand your intention and i suppose we have the same situation in our network, where we use ECMP paths and have the need to use a preferred path for a special kind of traffic.
On the other side i have little concerns regarding the "constraint-extensions" of LDP. IETF decided to use RSVP-TE instead of LDP (CR-LDP) for constraint-based routing. Anyway, this approach could be useful for us in a special case. I suggest to have a short discussion on the next IETF.
 
Best regards
 
Rüdiger