Subject: [mpls] RFC 4379: Calculating Length of a TLV in presence of sub-TLV's

From: Greg Mirsky <[email-masked]>
Date: Mon, 18 Jan 2010 11:43:54 -0800

Dear Kireeti and George,
I've got a question on proper calculation of a Length value for a TLV that
consists of more than one sub-TLV.
On p.9 on RFC 4379 second drawing depicts format of a Target Stack FEC TLV
with two sub-TLVs. The length in TLV displayed as 12 and I believe this is
not correct. As the Legth must reflect length of the Value field of a TLV
(all encompassed sub-TLVs), in this case it is equal to 29 (3 bytes of
padding appended).
My apologies if this was answered before (couldn't find reference in the
archive).

Regards,
Greg

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Tue, 19 Jan 2010 07:05:08 -0600

http://www.rfc-editor.org/errata_search.php?rfc=4379

eric

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Greg Mirsky
> Sent: Monday, January 18, 2010 2:44 PM
> To: [email-masked]; George Swallow (swallow)
> Cc: [email-masked]
> Subject: [mpls] RFC 4379: Calculating Length of a TLV in presence
> ofsub-TLV's
> 
> Dear Kireeti and George,
> I've got a question on proper calculation of a Length value for a TLV
> that consists of more than one sub-TLV.
> On p.9 on RFC 4379 second drawing depicts format of a Target Stack FEC
> TLV with two sub-TLVs. The length in TLV displayed as 12 and I believe
> this is not correct. As the Legth must reflect length of the Value
> field of a TLV (all encompassed sub-TLVs), in this case it is equal to
> 29 (3 bytes of padding appended).
> My apologies if this was answered before (couldn't find reference in
> the archive).
> 
> Regards,
> Greg