Subject: [mpls] working group last call on draft-ietf-mpls-ldp-igp-sync-bcast-00.txt

From: Loa Andersson <[email-masked]>
Date: Sat, 27 Feb 2010 13:10:11 +0100

All,

this is to start a mpls working group last call on
draft-ietf-mpls-ldp-igp-sync-bcast-00.txt

Please sen your comments to the mpls working group mailing
list ([email-masked]).

The working group last call end eob March 12.

/Loa
-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: <[email-masked]>
Date: Sun, 28 Feb 2010 18:37:23 +0000

Loa, authors,

See below for my comments following a review of
draft-ietf-mpls-ldp-igp-sync-bcast-00.txt

Major:
1) Run the draft through the idnits tool
(http://tools.ietf.org/tools/idnits/) and correct the 5 errors & 3 warnings
it produces.

2) Page 4, final paragraph of Section 1.
In the second interpretation of of [LDP-IGP-SYNC] it is not clear to me why
A would have B as the nexthop for PE2, as A has advertised a maximum cost
for that link, effectively costing it out of the SPF calculation.

3) If you are going to define a new term "cut-edge" then it needs a clearer
definition of what circumstances lead to an interface being defined as a
"cut-edge" interface.

E.g. expand the text in the paragraph on page 4 that starts "In another
alternative interpretation..." to describe what constitutes a "cut-edge"
interface.

Minor:
4) Expand acronyms on first usage through the document.

Nits:
5) Abstract:
s/when IGP is operational/when an IGP is operational

6) Introduction, first paragraph, first sentence:
s/link, IGP advertises the link/link, the IGP advertises the link

7) Introduction, sencond paragraph, first sentence:
s/On broadcast links, IGP advertises/On broadcast links, the IGP advertises/

8) Introduction, third paragraph
s/Till LDP becomes operational/Until LDP becomes operational/

Ben

---

From: Sriganesh Kini <[email-masked]>
Date: Sun, 28 Feb 2010 14:41:23 -0500

Ben,

Thanks for the review and comments. Pls see inline @ [Sri]. Will update next rev with all 'Accepted' comments.

- Sri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, February 28, 2010 10:37 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] working group last call on draft-ietf-mpls-ldp-igp-sync-bcast-00.txt

Loa, authors,

See below for my comments following a review of draft-ietf-mpls-ldp-igp-sync-bcast-00.txt

Major:
1) Run the draft through the idnits tool
(http://tools.ietf.org/tools/idnits/) and correct the 5 errors & 3 warnings it produces.

[Sri] Accepted.

2) Page 4, final paragraph of Section 1.
In the second interpretation of of [LDP-IGP-SYNC] it is not clear to me why A would have B as the nexthop for PE2, as A has advertised a maximum cost for that link, effectively costing it out of the SPF calculation.

[Sri] Only B advertises the maximum cost. See first two sentences of final paragraph of section 1. When A runs SPF, its cost to B will not be the maximum cost, hence the nexthop to PE2 will be through B.

3) If you are going to define a new term "cut-edge" then it needs a clearer definition of what circumstances lead to an interface being defined as a "cut-edge" interface.

E.g. expand the text in the paragraph on page 4 that starts "In another alternative interpretation..." to describe what constitutes a "cut-edge"
interface.

[Sri] Page 4, third paragraph of section 3 defines a 'cut-edge' interface. It is fairly standard terminology in graph-theory to describe a link. However we can add an extra sentence in section 3 to further clarify. Accepted.

Minor:

[Sri] Accepted.

Nits:
5) Abstract:

[Sri] Accepted

[Sri] Accepted

[Sri] Accepted

[Sri] Accepted

Ben

On 27/02/2010 12:10, "Loa Andersson" <[email-masked]> wrote:

> Please sen your comments to the mpls working group mailing list 
> ([email-masked]).
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls