Subject: [mpls] [Technical Errata Reported] RFC5960 (2533)

From: RFC Errata System <[email-masked]>
Date: Wed, 29 Sep 2010 10:39:31 -0700 (PDT)

The following errata report has been submitted for RFC5960,
"MPLS Transport Profile Data Plane Architecture".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5960&eid=2533

--------------------------------------
Type: Technical
Reported by: Italo Busi <[email-masked]>

Section: 3.2

Original Text
-------------
   A section MUST provide a means of identifying the type of payload it
   carries.

Corrected Text
--------------
   A section MAY be required to provide a mechanism for multiplexing MPLS
   with other protocols.  

Notes
-----
This change is intended to clarify that providing a multiplexing capability for a section layer is optional.

See https://datatracker.ietf.org/liaison/916/

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5960 (draft-ietf-mpls-tp-data-plane-04)
--------------------------------------
Title               : MPLS Transport Profile Data Plane Architecture
Publication Date    : August 2010
Author(s)           : D. Frost, Ed., S. Bryant, Ed., M. Bocci, Ed.
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Benjamin Niven-Jenkins <[email-masked]>
Date: Thu, 30 Sep 2010 01:18:42 +0100

While the intent of reported errata is technically correct I'm somewhat torn between whether I think it should be rejected, or whether I don't care.

My thinking is:

The errata is technically correct because a corner case does exist where a section layer that doesn't support higher layer protocol multiplexing can still be used to support MPLS-TP in some scenarios.

I don't like the proposed replacement text because the original text is placing a requirement on the section layer technology and I think it is reasonable to say "if you want your section layer to work with MPLS-TP it MUST do/support X", however I don't think it's reasonable to say "if you want your section layer to work with MPLS-TP it MAY have to do X" (which is essentially the change the proposed text makes) because it leaves it unclear as to what is actually required from the section layer which practically reduces to section layers having to support X anyway so it becomes a (implicit) MUST in any case.

Furthermore the original text only states that a section layer MUST have a means of identifying the type of payload. If a section layer does not support multiplexing then it has an implicit means of identifying the payload by the interface over which the payload arrived and therefore it meets the requirement as stated by the original text.

Ben

On 29 Sep 2010, at 18:39, RFC Errata System wrote:

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls