Subject: [mpls] MPLS concept

From: Dibu Philip <[email-masked]>
Date: Sun, 26 Sep 2010 19:31:05 +0530

Hello everybody,

Myself Dibu Philip, a final year student of Electronics engineering.

I'm too much in love with networks and related stuff, but only in the very
budding state regarding concepts.

Can somebody please help me with a doubt I have? While forwarding packets
with labels, routers still have to store the labels in the LIBs; the same
thing happens with IP forwarding. So can somebody explain to me in very
simple words the advantage of MPLS. I've being thinking over this for a long
time. I would be really grateful if somebody could help me.

Plus, is GMPLS in optical networks already implemented in large scale, or is
it still under development?

I'm sorry if such a post is not expected here.

Thank you
Regards,
Dibu Philip

---

From: srinivas pv <[email-masked]>
Date: Mon, 27 Sep 2010 01:56:55 +0530

Hi,

One advantage of MPLS is that, the label lookup is faster than IP lookup.
But with recent switching mechanisms, this may not be the real advantage.

The main advantages are that, the other applications MPLS facilitates like :
MPLS L2 & L3 VPNs, TE etc.

Thanks,
Srinivas

On Sun, Sep 26, 2010 at 7:31 PM, Dibu Philip <[email-masked]> wrote:

> Plus, is GMPLS in optical networks already implemented in large scale, or
> is it still under development?
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Arijit Paul <[email-masked]>
Date: Mon, 27 Sep 2010 10:59:18 +0530

Hi,

In addition to what Srinivas has mentioned, the primary advantage of using MPLS -

*         It is highly scalable (BGP free core....)

*         Many services(L2, L3 VPN, TE etc...) can be offered without having to maintain separate networking infrastructure for each. It gives immense flexibility (Till date..) to the network designers to offer new/innovative services to meet the ever changing demand of the customers.

*         SONET like recovery with FRR etc.

To compare it with traditional IP routing, here is the difference-

*         Instead of traditional longest prefix lookup, in case of MPLS you are just doing fixed size label lookup, which makes the processing much simpler.

*         In case of MPLS, the FEC is determined only once, at the ingress PE and subsequently all routers do the label swap (except PHP...). In case of traditional routing, the FEC is determined at every router, by looking up the destination route and then again doing a recursive lookup for the nexthop if not directly connected.

My few cents....

Thanks
Arijit

From: [email-masked] [mailto:[email-masked]] On Behalf Of srinivas pv
Sent: Monday, September 27, 2010 1:57 AM
To: Dibu Philip
Cc: [email-masked]
Subject: Re: [mpls] MPLS concept

Hi,

One advantage of MPLS is that, the label lookup is faster than IP lookup. But with recent switching mechanisms, this may not be the real advantage.

The main advantages are that, the other applications MPLS facilitates like : MPLS L2 & L3 VPNs, TE etc.

Thanks,
Srinivas

On Sun, Sep 26, 2010 at 7:31 PM, Dibu Philip <[email-masked]<mailto:[email-masked]>> wrote:
Hello everybody,

I'm too much in love with networks and related stuff, but only in the very budding state regarding concepts.

Can somebody please help me with a doubt I have? While forwarding packets with labels, routers still have to store the labels in the LIBs; the same thing happens with IP forwarding. So can somebody explain to me in very simple words the advantage of MPLS. I've being thinking over this for a long time. I would be really grateful if somebody could help me.

Plus, is GMPLS in optical networks already implemented in large scale, or is it still under development?

Thank you
Regards,
Dibu Philip

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls