Subject: Re: [mpls] [mpls-tp] RE: Re: Basic questions ondraft-huang-mpls-ring-signaling-extensions

From: [email-masked]
Date: Tue, 16 Nov 2010 16:30:22 +0800

Hi Oliver，

Do you mean that the protection LSP is static configured? not via a 
control plane protocol, such as LDP or RSVP-TE?

Best Regards，
xuehui

"Huang Yong (Oliver)" <[email-masked]> 
2010-11-16 15:28

收件人
[email-masked], 'Giles Heron' <[email-masked]>
抄送
[email-masked], [email-masked], 
[email-masked], 
[email-masked]
主题
RE: [mpls-tp] 答复: Re:  [mpls] Basic questions 
ondraft-huang-mpls-ring-signaling-extensions

Hello Xuehui,
 
           When two links on the ring fail at the same time,  the solution 
in  the draft  can not handle it.   But I  think  it is a tradeoff between 
the  failure possibility and  the  provision and monitoring  effort  which 
operators may  consider when selecting the solutions. 
 
           The protection LSP and how a node knows which port is on ring 
are all provisioned by  operators in advance.
 
Best  Regards,
Oliver

From: [email-masked] [mailto:[email-masked]] On Behalf 
Of [email-masked]
Sent: Tuesday, November 16, 2010 11:17 AM
To: Giles Heron
Cc: [email-masked]; [email-masked]; 
[email-masked]; 
[email-masked]
Subject: [mpls-tp] 答复: Re: [mpls] Basic questions 
ondraft-huang-mpls-ring-signaling-extensions

some more questions needs authors'clarifications： 

 1. If two links of the ring fails simultaneously,and the two links are 
not adjacent, for example, figure 2 in your draft, link A-B and link C-D 
occur failures at the same time, how can your scheme deal with such 
condition? if this is within the scope of your draft? 

2. needs a closed protection lsp to protect all service lsps, and from 
your descriptions, working LSP is created via control plane, then how does 
the protection LSP be created? 

3. Abstract: 
This document describes a MPLS ring mechanism and some extensions on
  signaling protocol to facilitate the establishment of Label Switched
  Paths (LSPs) using Label Distribution Protocol [LDP] or RSVP-TE
  protocol [RSVP-TE] to achieve automated link and node protection. 
my question is how can a node knows whether it's on a ring topology? 

Best Regards

Giles Heron <[email-masked]> 
发件人:  [email-masked] 
2010-11-16 01:01 

收件人
"Eric Osborne (eosborne)" <[email-masked]>, "Weingarten, Yaacov (NSN - 
IL/Hod HaSharon)" <[email-masked]>, <[email-masked]>, 
<[email-masked]> 
抄送
[email-masked] 
主题
Re: [mpls-tp] [mpls] Basic questions 
ondraft-huang-mpls-ring-signaling-extensions

A few more issues with the draft:

The draft is rather "unusual" in that it proposes sending label mappings 
in
a notification message, and since the label mapping advertised in the
notification has no associated FEC.  Surely the label mapping message is a
better choice for sending label mappings?

There's also a mistake in section 4 I think - where it states that "Node C
sends a new message to Node C".  I believe the authors meant to say "Node 
B
sends a new message to Node C".

One major issue with the draft is that it appears to require a form of
upstream label allocation.  Specifically, the label mapping <L2-to-L4> at
node C is the result of a combination of local instantiation of the 
mapping
<L3-to-L4> by node C and upstream notification of the mapping <L2-to-L3> 
by
node B.  So you'd have a problem if node C had already allocated L2 itself 
-
unless of course the mapping <L2-to-L4> is only valid in the context of
protection label P4 (the authors fail to mention this point, so I suspect
they may have missed it).

So overall I think a better approach would be to use next next-hop labels
and to assign them using the label mapping message...

Giles

On 15/11/2010 10:48, "Eric Osborne (eosborne)" <[email-masked]> wrote:

> I share Yaacov's questions, and I have one more to add.  The wrapping
> behaviors shown in sections 3.1.1 and 3.1.2 appear, to my mind, to look
> exactly like bypass tunnels as defined in rfc4090 and as implemented in
> many networks today.  I'm afraid I don't quite understand the text in
> section 4 which defined what this signaling extension does, but the
> sentence " The new label switching information can help node C to finish
> the work described in section 3.1.2." makes me thing that the purpose of
> the signaling extension is to deliver, not enhance, the behaviors
> described in 3.1.1 and 3.1.2.  Can you clarify what the label stacks and
> LSP paths look like when the extension in this draft is implemented?
> 
> Also, I see that the draft talks about an LDP extension.  This seems
> like a useful idea by itself; especially in link protection, this is
> straightforward to understand and implement.  There's nothing
> ring-specific here, though; the extension you describe might be used in
> LFA FRR, which is not restricted to just rings
> 
> 
> 
> 
> eric
> 
> 
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
> Behalf
>> Of Weingarten, Yaacov (NSN - IL/Hod HaSharon)
>> Sent: Monday, November 15, 2010 3:38 AM
>> To: [email-masked]; [email-masked]
>> Cc: [email-masked]
>> Subject: [mpls-tp] Basic questions ondraft-huang-mpls-ring-signaling-
>> extensions
>> 
>> Hi all,
>> 
>> After hearing your presentation at IETF79, I have some questions about
> the
>> intention of this document:
>> 
>> 1. In addition to the signaling extensions that appear in the title of
>> this document, you also seem to be defining ring-protection procedures
>> based only on wrapping.  Is the intention of this draft to define ring
>> protection?  Could you explain whether this is different from the
> wrapping
>> procedures already defined in the pre-existing I-D that address ring-
>> protection?
>> 
>> 2. Is your draft addressing generic MPLS or MPLS-TP?  The title seems
> to
>> be directed at MPLS and not MPLS-TP, or is this my misinterpretation?
>> 
>> 3.  In continuation to the previous question - you seem to be
> describing
>> methods for unidirectional p2p LSPs, not sure how the signaling
> extensions
>> are intended for use with bidirectional LSP and in particular
> co-routed
>> bidirectional LSPs as defined for MPLS-TP.
>> 
>> 4.  Regarding your protection method using a SPME - is this SPME p2mp
> or
>> mp2mp?
>> 
>> Best regards,
>> 
>> 
>> 
>> Yaacov Weingarten
>> 
>> Industry Environment, Packet Transport
>> 
>> Nokia Siemens Networks
>> 
>> Hod Hasharon, Israel 45241
>> 
>> Tel: +972-9-775 1827
>> 
>> Mob: +972-54-220 0977
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Huang Yong (Oliver)" <[email-masked]>
Date: Tue, 16 Nov 2010 17:11:44 +0800

Xuehui,

          I  think  that  nowadays there is no mechanism to create the
closed protection LSP by signaling.   Moreover ,  I  assume  provision the
protection LSP on  the ring  before system running is acceptable by
operators.    The dynamic provision is focus on  service LSPs  across the
ring  which may  has quiet  a large number. 

Best Regards,

Oliver

  _____  

From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, November 16, 2010 4:30 PM
To: Huang Yong (Oliver)
Cc: [email-masked]; 'Giles Heron';
[email-masked]; [email-masked]; [email-masked]
Subject: RE: RE: [mpls-tp] RE: Re: [mpls] Basic questions
ondraft-huang-mpls-ring-signaling-extensions

Hi Oliver， 

Do you mean that the protection LSP is static configured? not via a control
plane protocol, such as LDP or RSVP-TE? 

Best Regards， 
xuehui 

2010-11-16 15:28 

收件人

抄送

主题

 

Hello Xuehui, 

  
Best  Regards, 
Oliver 

  _____  

1. If two links of the ring fails simultaneously,and the two links are not
adjacent, for example, figure 2 in your draft, link A-B and link C-D occur
failures at the same time, how can your scheme deal with such condition? if
this is within the scope of your draft? 

2. needs a closed protection lsp to protect all service lsps, and from your
descriptions, working LSP is created via control plane, then how does the
protection LSP be created? 

3. Abstract: 
This document describes a MPLS ring mechanism and some extensions on
 signaling protocol to facilitate the establishment of Label Switched
 Paths (LSPs) using Label Distribution Protocol [LDP
<http://tools.ietf.org/html/draft-huang-mpls-ring-signaling-extension-01#ref
-LDP> ] or RSVP-TE
 protocol [RSVP-TE
<http://tools.ietf.org/html/draft-huang-mpls-ring-signaling-extension-01#ref
-RSVP-TE> ] to achieve automated link and node protection. 
my question is how can a node knows whether it's on a ring topology? 

Best Regards

2010-11-16 01:01 

收件人

抄送

主题

  

The draft is rather "unusual" in that it proposes sending label mappings in
a notification message, and since the label mapping advertised in the
notification has no associated FEC.  Surely the label mapping message is a
better choice for sending label mappings?

There's also a mistake in section 4 I think - where it states that "Node C
sends a new message to Node C".  I believe the authors meant to say "Node B
sends a new message to Node C".

One major issue with the draft is that it appears to require a form of
upstream label allocation.  Specifically, the label mapping <L2-to-L4> at
node C is the result of a combination of local instantiation of the mapping
<L3-to-L4> by node C and upstream notification of the mapping <L2-to-L3> by
node B.  So you'd have a problem if node C had already allocated L2 itself -
unless of course the mapping <L2-to-L4> is only valid in the context of
protection label P4 (the authors fail to mention this point, so I suspect
they may have missed it).

Giles

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Tue, 16 Nov 2010 11:15:59 +0100

Resending to try and get under the size limit on messages to mailing list!!

Hi,

I am still a little confused by the protection LSP  - Is there 

1. a protection LSP for each working LSP  that crosses your ring? Is this a p2mp LSP that needs to connect the ingress to each of the nodes on the working LSP?  If this is true – then using your Figure 1, the LSP is configured to start at Node A and continue to B and onto node A forming a closed loop!  But then how does Node B transmit the wrapped packet on this LSP?  Or are we describing the magical stitched LSP described (or not) in draft-umansky that is created on the fly from the set of Pn labels?

2. Or is this a singular LSP for the ring, i.e. one CCW LSP that is used for protection of all LSP that traverse the ring?  What kind of BW is required for this LSP?  And again is it mp2mp (since we do not know a-priori which link/node will fail)?

Thanx and BR,

yaacov

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Huang Yong (Oliver)
Sent: Tuesday, November 16, 2010 11:12
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] [mpls-tp] RE: Re: Basic questions ondraft-huang-mpls-ring-signaling-extensions

Xuehui,

          I  think  that  nowadays there is no mechanism to create the closed protection LSP by signaling.   Moreover ,  I  assume  provision the protection LSP on  the ring  before system running is acceptable by operators.    The dynamic provision is focus on  service LSPs  across the ring  which may  has quiet  a large number. 

Best Regards,

Oliver

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, November 16, 2010 4:30 PM
To: Huang Yong (Oliver)
Cc: [email-masked]; 'Giles Heron'; [email-masked]; [email-masked]; [email-masked]
Subject: RE: RE: [mpls-tp] RE: Re: [mpls] Basic questions ondraft-huang-mpls-ring-signaling-extensions

Hi Oliver， 

Do you mean that the protection LSP is static configured? not via a control plane protocol, such as LDP or RSVP-TE? 

Best Regards， 
xuehui 

2010-11-16 15:28 

收件人

抄送

[email-masked], [email-masked], [email-masked], [email-masked] 

主题

RE: [mpls-tp] 答复: Re:  [mpls] Basic questions ondraft-huang-mpls-ring-signaling-extensions

Hello Xuehui, 
  
           When two links on the ring fail at the same time,  the solution in  the draft  can not handle it.   But I  think  it is a tradeoff between the  failure possibility and  the  provision and monitoring  effort  which operators may  consider when selecting the solutions. 
  
           The protection LSP and how a node knows which port is on ring  are all provisioned by  operators in advance. 
  
Best  Regards, 
Oliver 

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, November 16, 2010 11:17 AM
To: Giles Heron
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls-tp] 答复: Re: [mpls] Basic questions ondraft-huang-mpls-ring-signaling-extensions 

1. If two links of the ring fails simultaneously,and the two links are not adjacent, for example, figure 2 in your draft, link A-B and link C-D occur failures at the same time, how can your scheme deal with such condition? if this is within the scope of your draft? 

2. needs a closed protection lsp to protect all service lsps, and from your descriptions, working LSP is created via control plane, then how does the protection LSP be created? 

3. Abstract: 
This document describes a MPLS ring mechanism and some extensions on
 signaling protocol to facilitate the establishment of Label Switched
 Paths (LSPs) using Label Distribution Protocol [LDP <http://tools.ietf.org/html/draft-huang-mpls-ring-signaling-extension-01#ref-LDP> ] or RSVP-TE
 protocol [RSVP-TE <http://tools.ietf.org/html/draft-huang-mpls-ring-signaling-extension-01#ref-RSVP-TE> ] to achieve automated link and node protection. 
my question is how can a node knows whether it's on a ring topology? 

Best Regards

2010-11-16 01:01 

收件人

"Eric Osborne (eosborne)" <[email-masked]>, "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>, <[email-masked]>, <[email-masked]> 

抄送

主题

Re: [mpls-tp] [mpls] Basic questions ondraft-huang-mpls-ring-signaling-extensions

Giles

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Tue, 16 Nov 2010 08:47:04 -0600

I'm not clear.  The draft is "Signaling extension for MPLS ring protection", but you're proposing a static (e.g. non-signaling) mechanism?

eric

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Huang Yong (Oliver)
> Sent: Tuesday, November 16, 2010 4:12 AM
> Cc: [email-masked]; [email-masked]; [email-masked]; draft-
> [email-masked]
> Cc: [email-masked]; 'Giles
> Heron'; [email-masked]; [email-masked]; [email-masked]
> [email-masked], [email-masked], draft-huang-mpls-ring-signaling-
> [email-masked], [email-masked]
> 
> 主题
> 
> Cc: [email-masked]; [email-masked]; draft-huang-mpls-ring-signaling-
> [email-masked]; [email-masked]
> failures at the same time, how can your scheme deal with such condition?
> if this is within the scope of your draft?
> 
> <http://tools.ietf.org/html/draft-huang-mpls-ring-signaling-extension-
> 01#ref-LDP> ] or RSVP-TE
>  protocol [RSVP-TE <http://tools.ietf.org/html/draft-huang-mpls-ring-
> signaling-extension-01#ref-RSVP-TE> ] to achieve automated link and node
> protection.

---

From: [email-masked]
Date: Wed, 17 Nov 2010 13:14:04 +0800

Olive，

Based on your assumption, then how can you deside the BW of the protection 
LSP? since when you configured the protection LSP, you may can't judge how 
many working LSPs will be created through a ring and how much bandwidth 
will be consumed by each working lsp.

Another question, there may exist both P2P LSPs and P2MP LSPs on a ring, 
then you will configure a P2P protection LSP and a P2MP protection LSP? 

Best Regards,
xuehui

"Eric Osborne (eosborne)" <[email-masked]> 
2010-11-16 22:47

收件人
"Huang Yong (Oliver)" <[email-masked]>, <[email-masked]>
抄送
<[email-masked]>, <[email-masked]>, <[email-masked]>, 
<[email-masked]>
主题
RE: [mpls] [mpls-tp] RE: Re: Basic questions 
ondraft-huang-mpls-ring-signaling-extensions

I'm not clear.  The draft is "Signaling extension for MPLS ring 
protection", but you're proposing a static (e.g. non-signaling) mechanism?

eric

> Subject: Re: [mpls] [mpls-tp] RE: Re: Basic questions 
ondraft-huang-mpls-
> ring-signaling-extensions
> 
> Xuehui,
> 
> 
> 
Behalf
> 1. If two links of the ring fails simultaneously,and the two links are 
not