Subject: Re: [mpls] [PWE3][AHMPLS-TP][mpls-tp] poll on draft-he-mpls-tp-csf-03.txt

From: [email-masked]
Date: Sun, 12 Dec 2010 11:13:15 +0800

Hi John,
I am not talking about draft-he, only talking about statement "Viz, any L2 
technology will go through a PW and PWs already have a CSF equivalent."
Actually, in current defined MPLS in IETF, the statement is not true. 
There is a case that L2 technology will go through LSP, not PW. In 
draft-ietf-l2vpn-vpls-mcast, section 14.1.2, you can find that case. 
However this case is for P2MP LSP, not P2P. I think draft-he does not 
include P2MP LSP.

Regards
Lizhong

> ------------------------------
> 
> Message: 2
> Date: Thu, 2 Dec 2010 06:57:40 -0800
> From: John E Drake <[email-masked]>
> Subject: Re: [mpls] [PWE3]   [AHMPLS-TP]   Re:[mpls-tp]
>    pollondraft-he-mpls-tp-csf-03.txt
> To: "[email-masked]" <[email-masked]>,
>    "[email-masked]" 
<[email-masked]>,
>    "[email-masked]" <[email-masked]>, "[email-masked]"
>    <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>,   "[email-masked]"
>    <[email-masked]>,   "[email-masked]"
>    <[email-masked]>,   "[email-masked]" <[email-masked]>,
>    "[email-masked]" <[email-masked]>
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
> 
> I think you are missing the point.  Viz, any L2 technology will go 
> through a PW and PWs already have a CSF equivalent.  The other TP 
> clients are IP and MPLS, and they have their own detection mechanisms. 
> 
> Sent from my iPhone
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf 
Of
> > [email-masked]
> > Sent: Thursday, December 02, 2010 6:40 AM
> > To: [email-masked]; [email-masked];
> > [email-masked]
> > Cc: [email-masked]; [email-masked]; [email-masked];
> > [email-masked]; [email-masked]
> > Subject: Re: [mpls] [PWE3] [AHMPLS-TP] Re:[mpls-tp] pollondraft-he-
> > mpls-tp-csf-03.txt
> > 
> > 
> > Agree with Lieven.
> > 
> > We need to avoid making predictions about the capability & complexity
> > (& even existence) of a certain client layer technology (most of all
> > considering terminal nodes connected by attachment circuits), but 
still
> > provide effective fault notifications in packet transport 
applications.
> > Herefore, IMHO, CSF is helpful and required.
> > 
> > Of course, we also strongly need to avoid confusing control plane and
> > data plane tasks (e.g. relying on LDP session timeouts for fault
> > detection).
> > 
> > Best regards
> > Manuel
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of
> > > LEVRAU, LIEVEN (LIEVEN)
> > > Sent: Thursday, December 02, 2010 2:17 PM
> > > To: Rajiv Asati (rajiva); Yuanlong Jiang
> > > Cc: [email-masked]; Sprecher,Nurit (NSN - IL/Hod HaSharon); MPLS-TP 
ad
> > hoc
> > > team; [email-masked]; [email-masked]
> > > Subject: Re: [mpls] [PWE3] [AHMPLS-TP] Re:[mpls-tp] pollondraft-he-
> > mpls-
> > > tp-csf-03.txt
> > >
> > > provocative statement alert- We should as we are talking about MPLS-
> > TP and
> > > not about IP network layer.
> > >
> > > ./
> > > Lieven
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of
> > > Rajiv Asati (rajiva)
> > > Sent: 02 December 2010 14:14
> > > To: Yuanlong Jiang
> > > Cc: Sprecher, Nurit (NSN - IL/Hod HaSharon); MPLS-TP ad hoc team;
> > > [email-masked]; [email-masked]; [email-masked]
> > > Subject: Re: [mpls] [PWE3] [AHMPLS-TP] Re: [mpls-tp] pollondraft-he-
> > mpls-
> > > tp-csf-03.txt
> > >
> > > Are we ignoring the existence of BFD altogether?
> > >
> > > Cheers,
> > > Rajiv
> > >
> > > Sent from my Phone
> > >
> > > On Dec 1, 2010, at 8:19 PM, Yuanlong Jiang <[email-masked]>
> > wrote:
> > >
> > > > John,
> > > >
> > > > Typically, IP will only detect a failure in a time scale of
> > minutes.
> > > > That is one reason why MPLS-TP OAM and Protection & Switching is
> > needed.
> > > > I am not sure which mechanism in MPLS provides the CSF-like
> > capability,
> > > could you give more hints?
> > > >
> > > > Thanks
> > > > Yuanlong
> > > >
> > > > ----- Original Message ----- From: "John E Drake"
> > <[email-masked]>
> > > > To: "Sprecher, Nurit (NSN - IL/Hod HaSharon)"
> > <[email-masked]>;
> > > "Yuanlong Jiang" <[email-masked]>; "Loa Andersson" <[email-masked]>;
> > > <[email-masked]>; <[email-masked]>; <[email-masked]>; "MPLS-TP ad 
hoc
> > > team" <[email-masked]>
> > > > Sent: Wednesday, December 01, 2010 9:29 PM
> > > > Subject: RE: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll 
ondraft-he-mpls-
> > tp-
> > > csf-03.txt
> > > >
> > > >
> > > >> Nurit,
> > > >>
> > > >> As I understand the original requirement from Malcolm Betts, this
> > > capability is required for those cases in which a client is unable 
to
> > > detect the failure of its peer.  In MPLS-TP, we have three clients,
> > PW, IP,
> > > and MPLS, and I am quite sure that IP and MPLS clients can take care
> > of
> > > themselves wrt detecting peer failure.
> > > >>
> > > >> Thanks,
> > > >>
> > > >> John
> > > >>
> > > >> Sent from my iPhone
> > > >>
> > > >>> -----Original Message-----
> > > >>> From: Sprecher, Nurit (NSN - IL/Hod HaSharon)
> > > >>> [mailto:[email-masked]]
> > > >>> Sent: Wednesday, December 01, 2010 4:47 AM
> > > >>> To: John E Drake; Yuanlong Jiang; Loa Andersson; [email-masked];
> > mpls-
> > > >>> [email-masked]; [email-masked]; MPLS-TP ad hoc team
> > > >>> Subject: RE: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll ondraft-he-
> > mpls-tp-
> > > >>> csf-03.txt
> > > >>>
> > > >>> But what about other client services... e.g. adapted by service-
> > LSP
> > > and
> > > >>> not by PWE3?
> > > >>>
> > > >>> -----Original Message-----
> > > >>> From: [email-masked] [mailto:[email-masked]] On
> > Behalf
> > > Of
> > > >>> ext John E Drake
> > > >>> Sent: Wednesday, December 01, 2010 2:35 PM
> > > >>> To: Yuanlong Jiang; Loa Andersson; [email-masked]; mpls-
> > [email-masked];
> > > >>> [email-masked]; MPLS-TP ad hoc team
> > > >>> Subject: Re: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll
> > > >>> ondraft-he-mpls-tp-csf-03.txt
> > > >>>
> > > >>> I am not convinced.  It seems like it belongs in the Pseudo Wire
> > > >>> application, which already has this capability.
> > > >>>
> > > >>> Sent from my iPhone
> > > >>>
> > > >>>
> > > >>> > -----Original Message-----
> > > >>> > From: Yuanlong Jiang [mailto:[email-masked]]
> > > >>> > Sent: Wednesday, December 01, 2010 1:07 AM
> > > >>> > To: Loa Andersson; [email-masked]; [email-masked];
> > [email-masked];
> > > >>> > MPLS-TP ad hoc team
> > > >>> > Subject: [AHMPLS-TP] Re: [mpls-tp] poll on draft-he-mpls-tp-
> > csf-
> > > >>> 03.txt
> > > >>> >
> > > >>> > Support.
> > > >>> >
> > > >>> > I believe this mechanism is needed in MPLS-TP.
> > > >>> >
> > > >>> > Thanks
> > > >>> > Yuanlong
> > > >>> >
> > > >>> > ----- Original Message -----
> > > >>> > From: "Loa Andersson" <[email-masked]>
> > > >>> > To: <[email-masked]>; <[email-masked]>; <[email-masked]>;
> > "MPLS-TP
> > > ad
> > > >>> > hoc
> > > >>> > team" <[email-masked]>
> > > >>> > Sent: Thursday, November 18, 2010 7:56 PM
> > > >>> > Subject: [mpls-tp] poll on draft-he-mpls-tp-csf-03.txt
> > > >>> >
> > > >>> >
> > > >>> > > all,
> > > >>> > >
> > > >>> > > this is to start a two week poll on making
> > > >>> > >
> > > >>> > > http://www.ietf.org/internet-drafts/draft-he-mpls-tp-csf-
> > 03.txt
> > > >>> > >
> > > >>> > > a mpls working group document.
> > > >>> > >
> > > >>> > > Please send comments support/not support to the mpls-tp
> > maililng
> > > >>> > list.
> > > >>> > >
> > > >>> > > The poll ends Thursday Dec 2, 2010.
> > > >>> > >
> > > >>> > > /Loa
> > > >>> > > --
> > > >>> > >
> > > >>> > >
> > > >>> > > Loa Andersson                         email:
> > > >>> > [email-masked]
> > > >>> > > Sr Strategy and Standards Manager            [email-masked]
> > > >>> > > Ericsson Inc                          phone: +46 10 717 52 
13
> > > >>> > >                                              +46 767 72 92 
13
> > > >>> > > _______________________________________________
> > > >>> > > mpls-tp mailing list
> > > >>> > > [email-masked]
> > > >>> > > https://www.ietf.org/mailman/listinfo/mpls-tp
> > > >>>
> > > >>> _______________________________________________
> > > >>> pwe3 mailing list
> > > >>> [email-masked]
> > > >>> https://www.ietf.org/mailman/listinfo/pwe3
> > > >
> > > > _______________________________________________
> > > > pwe3 mailing list
> > > > [email-masked]
> > > > https://www.ietf.org/mailman/listinfo/pwe3
> > > _______________________________________________
> > > mpls mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/mpls
> > > _______________________________________________
> > > mpls mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/mpls
> > _______________________________________________
> > mpls mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/mpls
> 
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Phil Bedard <[email-masked]>
Date: Sun, 12 Dec 2010 12:48:23 -0500

The L2 native clients themselves may not have a CSF equivalent, but PWE3
does through status signaling and OAM message mapping.   Some vendors have
also added functions in the PW adaptation to shut off AC ports or signal a
physical fault.   At this point adding the CSF function seems to duplicate
functionality already widely deployed for PWE3.

For LSP/IP I'm on the fence about the necessity of the draft because I
realize mechanisms like BFD exist for monitoring liveness of an IP interface
or an LSP, but to date the ability to scale those sessions or run them at
very low intervals has been limited.   However, I have seen more recent
implementations which have the ability to scale a number of BFD sessions
running with intervals as low as 10ms.    The benefit of the draft is a
single on-demand fault notification packet which may improve restoration,
but how fast of restoration is really needed?   That's a subjective
requirement.     

Phil 

From:  <[email-masked]>
Date:  Sun, 12 Dec 2010 11:13:15 +0800
To:  <[email-masked]>
Cc:  <[email-masked]>, <[email-masked]>, <[email-masked]>,
<[email-masked]>, <[email-masked]>, <[email-masked]>
Subject:  Re: [mpls-tp] [mpls][PWE3][AHMPLS-TP] poll on
draft-he-mpls-tp-csf-03.txt

Hi John,
I am not talking about draft-he, only talking about statement "Viz, any L2
technology will go through a PW and PWs already have a CSF equivalent."
Actually, in current defined MPLS in IETF, the statement is not true. There
is a case that L2 technology will go through LSP, not PW. In
draft-ietf-l2vpn-vpls-mcast, section 14.1.2, you can find that case. However
this case is for P2MP LSP, not P2P. I think draft-he does not include P2MP
LSP.

Regards
Lizhong

>    "[email-masked]" <[email-masked]>,
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> > [email-masked]
> > considering terminal nodes connected by attachment circuits), but still
> > provide effective fault notifications in packet transport applications.
> > > Cc: [email-masked]; Sprecher,Nurit (NSN - IL/Hod HaSharon); MPLS-TP ad
> > hoc
> > > <[email-masked]>; <[email-masked]>; <[email-masked]>; "MPLS-TP ad hoc
> > > > Subject: RE: [PWE3] [AHMPLS-TP] Re: [mpls-tp] poll ondraft-he-mpls-
> > tp-
> > > csf-03.txt
> > > >
> > > >
> > > >> Nurit,
> > > >>
> > > capability is required for those cases in which a client is unable to
> > > >>> > > Ericsson Inc                         phone: +46 10 717 52 13
> > > >>> > >                                            +46 767 72 92 13
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is
solely property of the sender's organization. This mail communication is
confidential. Recipients named above are obligated to maintain secrecy and
are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended
solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the originator of the
message. Any views expressed in this message are those of the individual
sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.
_______________________________________________ mpls-tp mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/mpls-tp