Subject: [mpls] Question for clarification on On-Demand CV draft

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 18 May 2011 08:18:34 +0200

Hi,

In reviewing this document and the TP-Identifiers document there seems
to be a discrepancy between the PW identification format between these
two documents.

On the one hand - the TP Identifiers documents describes the PW
identifier by the string -
"AGI::East-Global_Node_ID::East-AC_ID::West-Global_Node_ID::West-AC_ID."

While on the other hand - the sub-TLV in section 2.3.2 for a static PW
includes fields for both E&W Global Node_ID, and both E&W AC_ID, however
does not include a field for the AGI - (Attachment Group Identification)
- part of the FEC129 definition.

Could you please clarify what lies behind this difference?

Best regards,
Yaacov Weingarten
Nokia Siemens Networks
Industry Environment, PTE
ph#:  +972-9-775 1827
mob#: +972-54-220 0977

---

From: binny jeshan <[email-masked]>
Date: Wed, 18 May 2011 13:05:25 +0530

Hi Yaakov, Group,

I could remember the same question being posted last August 2010, and i feel
this is still open and not answered in the recent drafts also.If in case its
"intentionally" not included, kindly share your thoughts behind that.

Hovever, presently, in case of IP based MEGs, during MEG Validation this AGI
would be validated (AGI:Global_ID::Node_ID::AC_ID,
) , but in case of ICC, this is still open.
 AGI being unique differentiator added to the FEC129 PW, i feel that
somewhere it needs to be validated and as it is closely associated with the
PW and not with the MEG, it could be best to validate it as a part of the
FEC Sub-TLV.
Thanks,
Binny.

On 18 May 2011 11:48, Weingarten, Yaacov (NSN - IL/Hod HaSharon) <
[email-masked]> wrote:

>  Hi,
>
> In reviewing this document and the TP-Identifiers document there seems to
> be a discrepancy between the PW identification format between these two
> documents.
>
> On the one hand – the TP Identifiers documents describes the PW identifier
> by the string – "
> AGI::East-Global_Node_ID::East-AC_ID::West-Global_Node_ID::West-AC_ID."
>
> does not include a field for the AGI – (Attachment Group Identification) –part of the FEC129 definition.
>
> *******Yaacov Weingarten*******
>
> Nokia Siemens Networks
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Eric Gray <[email-masked]>
Date: Thu, 19 May 2011 15:08:15 -0400

Yaacov,

    As you know, the last call has closed.  However, we are (unfortunately) still
addressing a few comments straggling in.

    I plan to discuss this particular question with my co-authors before giving a
detailed response on the mailing list.

    Thanks for you vigilence, patience and undurance!
--
Eric
________________________________
From: Weingarten, Yaacov (NSN - IL/Hod HaSharon) [mailto:[email-masked]]
Sent: Wednesday, May 18, 2011 2:19 AM
To: [email-masked]; [email-masked]
Subject: Question for clarification on On-Demand CV draft

Hi,

In reviewing this document and the TP-Identifiers document there seems to be a discrepancy between the PW identification format between these two documents.

On the one hand - the TP Identifiers documents describes the PW identifier by the string - "AGI::East-Global_Node_ID::East-AC_ID::West-Global_Node_ID::West-AC_ID."

While on the other hand - the sub-TLV in section 2.3.2 for a static PW includes fields for both E&W Global Node_ID, and both E&W AC_ID, however does not include a field for the AGI - (Attachment Group Identification) - part of the FEC129 definition.

Best regards,

Yaacov Weingarten

Nokia Siemens Networks

ph#:  +972-9-775 1827

mob#: +972-54-220 0977