Subject: [mpls] R: Re: Mixing ICC and Global-IDs in MPLS-TP Identifiers?

From: "[email-masked]" <[email-masked]>
Date: Wed, 18 May 2011 22:53:34 +0200 (CEST)

I am a bit surprised by the decision to cut such an important discussion.

While it is true that there is no (yet?) agreement on mixing of Global-IDs and ICC’s, the discussion has clarified that there are major holes both in the Requirements RFC (at least RFC5680) as well as in this document (which also do not fullfill the incomplete set of requirements of RFC5680).

One of the argument against the proposal was the lack of requirements for supporting inter-domain LSP/PW. However, during the discussion it appeared that this scenario is required by RFC5680. As the draft in its current form does not address this scenario, it is clearly not fullfilling the requirements of RFC5680,

There are other related issues which I am going to raise by replying to some mails on this thread.

----Messaggio originale----
Da: [email-masked]
Data: 18-mag-2011 20.40
A: "[email-masked]"<[email-masked]>
Ogg: Re: [mpls] Mixing ICC and Global-IDs in MPLS-TP Identifiers?

Mixing ICC and Global-IDs in MPLS-TP Identifiers?@font-face
	{font-family:Calibri;
	panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
	{font-family:Tahoma;
	panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
	{font-family:Verdana;
	panose-1:2 11 6 4 3 5 4 4 2 4;}

p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;
	margin-bottom:.0001pt;
	font-size:12.0pt;
	font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
	{mso-style-priority:99;
	color:blue;
	text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{mso-style-priority:99;
	color:purple;
	text-decoration:underline;}
span.EmailStyle17
	{mso-style-type:personal-reply;
	font-family:"Calibri","sans-serif";
	color:#1F497D;}
.MsoChpDefault
	{mso-style-type:export-only;
	font-size:10.0pt;}
@page WordSection1
	{size:8.5in 11.0in;
	margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
	{page:WordSection1;}

@list l0
	{mso-list-id:1179468456;
	mso-list-template-ids:-1043187258;}
@list l0:level1
	{mso-level-tab-stop:.5in;
	mso-level-number-position:left;
	text-indent:-.25in;}
ol
	{margin-bottom:0in;}
ul
	{margin-bottom:0in;}
->@font-face
	{font-family:Calibri;
	panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
	{font-family:Tahoma;
	panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
	{font-family:Verdana;
	panose-1:2 11 6 4 3 5 4 4 2 4;}

p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;
	margin-bottom:.0001pt;
	font-size:12.0pt;
	font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
	{mso-style-priority:99;
	color:blue;
	text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{mso-style-priority:99;
	color:purple;
	text-decoration:underline;}
span.EmailStyle17
	{mso-style-type:personal-reply;
	font-family:"Calibri","sans-serif";
	color:#1F497D;}
.MsoChpDefault
	{mso-style-type:export-only;
	font-size:10.0pt;}
@page WordSection1
	{size:8.5in 11.0in;
	margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
	{page:WordSection1;}

@list l0
	{mso-list-id:1179468456;
	mso-list-template-ids:-1043187258;}
@list l0:level1
	{mso-level-tab-stop:.5in;
	mso-level-number-position:left;
	text-indent:-.25in;}
ol
	{margin-bottom:0in;}
ul
	{margin-bottom:0in;}
->

-->

After discussion on the MPLS WG email list, there is no consensus to change draft-ietf-mpls-tp-identifiers to allow mixing of Global-IDs and ICC’s for the same Tunnel, LSP, PW, or Section. Instead, the (admittedly rough) consensus is to leave the document as currently defined. The authors are therefore instructed to continue progression of draft-ietf-mpls-tp-identifiers without a change in this area.
 
This decision neither supports nor precludes the possibility that at some point in the future, after draft-ietf-mpls-tp-identifiers is approved and published as an RFC, the WG might consider additional work to extend the MPLS protocols to allow mixed identifiers. 
 
Thanks,
Ross and Loa (as MPLS WG chairs)
 
[Note that since George is co-author of draft-ietf-mpls-tp-identifiers, for this one document he is recused from his role as WG co-chair.]

From: [email-masked] [mailto:[email-masked]] On Behalf Of George Swallow
Sent: Monday, April 25, 2011 5:17 PM
To: [email-masked]
Subject: [mpls] Mixing ICC and Global-IDs in MPLS-TP Identifiers?
 
All -

Many of the comments received from the ITU on draft-ietf-mpls-tp-identifiers-04 have to do with the Global and ICC identifiers.

The identifiers for Tunnel, LSP, PW, and MEG include fields to identify each end of an LSP.  Currently the draft allows a Tunnel, LSP, PW, or MEG to use either the Global-ID for both ends or or the ICC for both ends.  Mixed use is not permitted.

The ITU liaison requests that we allow mixed use.

The authors of the draft are very reluctant to do this.  

Obtaining an AS Number (from which the Global-ID is derived) is a fairly trivial procedure.  Many organizations if not most already have AS Numbers. 
Such an addition will add numerous object formats, and test cases. 
The extent inter-provider MPLS-TP is as yet unknown.  If mixed modes of ICC and Global-ID identification is required, they can be added later. 
For signaled connections, there is no plan to allow routing based on either the Global-ID or ICC.  That would be a radical change to how IP works.  However for IP routing to work (in order to forward the signaling messages), the providers involved will need to run BGP and have AS numbers. 

We are looking for input/consensus from the WG.

George, Eric, &amp; Matthew

---

From: Eric Gray <[email-masked]>
Date: Fri, 20 May 2011 12:16:30 -0400

Never-the-less, the decision is clearly traceable to the fact that there is
no consensus to change.

A number of SDOs require this.  The reason is obvious: it is always true
that one can construct an argument to change the direction of work in
progress, and - if we allowed each such argument to cause a change in
the direction of the work in progress - we would never make progress.

Hence there must be agreement to change, not simply arguments that
support it.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 18, 2011 4:54 PM
To: [email-masked]; [email-masked]
Subject: [mpls] R: Re: Mixing ICC and Global-IDs in MPLS-TP Identifiers?

While it is true that there is no (yet?) agreement on mixing of Global-IDs and ICC's, the discussion has clarified that there are major holes both in the Requirements RFC (at least RFC5680) as well as in this document (which also do not fullfill the incomplete set of requirements of RFC5680).

----Messaggio originale----
Da: [email-masked]
Data: 18-mag-2011 20.40
A: "[email-masked]"<[email-masked]>
Ogg: Re: [mpls] Mixing ICC and Global-IDs in MPLS-TP Identifiers?

After discussion on the MPLS WG email list, there is no consensus to change draft-ietf-mpls-tp-identifiers to allow mixing of Global-IDs and ICC's for the same Tunnel, LSP, PW, or Section. Instead, the (admittedly rough) consensus is to leave the document as currently defined. The authors are therefore instructed to continue progression of draft-ietf-mpls-tp-identifiers without a change in this area.

Thanks,

All -

 1.  Obtaining an AS Number (from which the Global-ID is derived) is a fairly trivial procedure.  Many organizations if not most already have AS Numbers.
 2.  Such an addition will add numerous object formats, and test cases.
 3.  The extent inter-provider MPLS-TP is as yet unknown.  If mixed modes of ICC and Global-ID identification is required, they can be added later.
 4.  For signaled connections, there is no plan to allow routing based on either the Global-ID or ICC.  That would be a radical change to how IP works.  However for IP routing to work (in order to forward the signaling messages), the providers involved will need to run BGP and have AS numbers.

George, Eric, & Matthew