Subject: [mpls] My WG LC comments on draft-ietf-mpls-tp-fault-03 not addressed in the -04 version

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 6 May 2011 08:16:13 +0300

Loa, Ross, and all,
I've read the -04 version of draft-ietf-mpls-tp-fault, and, to the best of my understanding, neither of my WG  LC comments sent to the list on March 1, 2011, (see http://www.ietf.org/mail-archive/web/mpls/current/msg05807.html) has been addressed (and, by implication, not resolved) in the new version of the draft.

I also think that after (recent) approval of draft-ietf-pwe3-oam-msg-map for publication as a PS, it would be helpful to consider correlation between AIS/LDI indications defined in draft-ietf-mpls-tp-fault with PW defects defines in the RFC-to-be which, for obvious reasons, does not mention "server LSP LDI as a potential of PW defect in the receive-from-PSN direction. IMO the onus of defining such a correlation (if it exists) lies with the Editors and authors of this draft.

One possible way to resolve these comments would be an Applicability Statement section that would discuss potential caveats.

Regards,
     Sasha

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: <[email-masked]>
Date: Fri, 6 May 2011 08:30:03 +0100

Folks,

I'll say it one more time (though I fully expect it will get ignored yet again):

-	we should not be applying AIS/FDI to any packet layer technologies....it is obvious why IMO for the cl-ps mode (eg IP) but it vis equally true (if less obvious why) for the co-ps mode.  AIS is an artefact of the co-cs mode (regular time-slice of resource labelling/management, ie TDM) and really only makes sense there.

-	more specifically there should not be OAM mapping between different technologies at non-TOS layer network interfaces.  These are NOT peer interfaces...we are always dealing with a client/server relationship here.  In particular one should never (under any circumstances) map a client defect condition (or a client layer AIS indication) to a server layer OAM message.

regards, Neil

BT Design

This email contains BT information, which may be privileged or confidential.
It's meant only for the individual(s) or entity named above. If you're not the intended
recipient, note that disclosing, copying, distributing or using this information
is prohibited. If you've received this email in error, please let me know immediately
on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: 06 May 2011 06:16
To: [email-masked]; Loa Andersson
Cc: [email-masked]; [email-masked]; Mishael Wexler; [email-masked]; [email-masked]; Rotem Cohen
Subject: [mpls] My WG LC comments on draft-ietf-mpls-tp-fault-03 not addressed in the -04 version

Loa, Ross, and all,

Regards,
     Sasha