Subject: [mpls] Fwd: poll on draft-asati-pignataro-mpls-ldp-gtsm-01

From: Loa Andersson <[email-masked]>
Date: Mon, 09 May 2011 18:25:25 +0200

Working group,

we have a poll going on this draft, but so far the number of responses
has been low. Can you please review the draft and see if it ready to
become a working group document.

/Loa

-------- Original Message --------
Subject: [mpls] poll on draft-asati-pignataro-mpls-ldp-gtsm-01
Date: Sat, 30 Apr 2011 10:55:56 -0700
From: Loa Andersson <[email-masked]>
To: [email-masked] <[email-masked]>
CC: Ross Callon <[email-masked]>, 
[email-masked]

Working Group,

this is to start a two week poll on making

draft-asati-pignataro-mpls-ldp-gtsm-01

an mpls working group document.

If you support the document becoming a working group document
please respond to this poll with "yes/support"

If you do not support the document becoming a working group
document please respond to this poll with "no/do not support"
and at the same time give the technical reasons why you are
not supporting the document.

If you have technical comments or in any other way want to
discuss the document, please send these comments to the mpls
working group mailing list, but with another subject than what
is on this mail.

The poll ends May 14th.

/Loa
-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Sun, 15 May 2011 20:31:14 -0500

Yes/support.
Luyuan

-------- Original Message --------
Subject: [mpls] poll on draft-asati-pignataro-mpls-ldp-gtsm-01
Date: Sat, 30 Apr 2011 10:55:56 -0700
From: Loa Andersson <[email-masked]>
To: [email-masked] <[email-masked]>
CC: Ross Callon <[email-masked]>, 

Working Group,

The poll ends May 14th.

/Loa
-- 

--

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 16 May 2011 10:27:00 +0200

I support.

Cheers,
Andy

---

From: Vero Zheng <[email-masked]>
Date: Mon, 16 May 2011 17:51:54 +0800

I support the working group looking into the LDP Hello security problem.
GTSM is only good for one hop, thus can protect the Basic Hello to some
extent. But the Remote Hello is relatively more vulnerable to attacks and
deserves security mechanisms.

Draft-zheng-mpls-ldp-hello-crypto-auth
(http://tools.ietf.org/html/draft-zheng-mpls-ldp-hello-crypto-auth-01 )
introduces a optional Cryptographic Authentication TLV which is used in LDP
Hello message against spoofing attack, and an LSR can be configured to only
accept Hello messages from specific peers when authentication is in use. We
believe it's simple, it's backward compatible and it's secure. We would like
ask the WG to read the draft and give constructive comments.

BR,
Vero

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Loa
> Andersson
> Sent: Tuesday, May 10, 2011 12:25 AM
> To: [email-masked]
> Subject: [mpls] Fwd: poll on draft-asati-pignataro-mpls-ldp-gtsm-01
> 
> Working group,
>

---

From: Carlos Pignataro <[email-masked]>
Date: Mon, 16 May 2011 08:52:49 -0400

Hi Vero,

Please find one technical comment inline.

> introduces a optional Cryptographic Authentication TLV which is used in LDP

One quote from <http://tools.ietf.org/html/rfc5082>:

   In particular, while cryptographic techniques can protect the router-
   based infrastructure (e.g., BGP [RFC4271], [RFC4272]) from a wide
   variety of attacks, many attacks based on CPU overload can be
   prevented by the simple mechanism described in this document.  Note

So the techniques in this I-D are based on a high protection ROI (cheap
check, strong protection) for a given set of scenarios only. And:

   Since TTL spoofing is considered nearly
   impossible, a mechanism based on an expected TTL value can provide a
   simple and reasonably robust defense from infrastructure attacks
   based on forged protocol packets from outside the network.  Note,
   however, that GTSM is not a substitute for authentication mechanisms.

Thanks,

-- Carlos.

---

From: Carlos Pignataro <[email-masked]>
Date: Mon, 16 May 2011 09:05:21 -0400

>    however, that GTSM is not a substitute for authentication mechanisms.

[sorry inadvertently hit Send, meant to add:]

So this provides complementary (and orthogonal) security protection
where, conversely, cryptographic mechanisms are not substitute for GTSM
for where it is applicable.

Thanks,

-- Carlos.

---

From: "Rajiv Papneja" <[email-masked]>
Date: Mon, 16 May 2011 10:06:06 -0400

Yes/Support.

/Rajiv
> If you support the document becoming a working group document please 
> respond to this poll with "yes/support"
>
> If you do not support the document becoming a working group document 
> please respond to this poll with "no/do not support"
> and at the same time give the technical reasons why you are not 
> supporting the document.
>
> If you have technical comments or in any other way want to discuss the 
> document, please send these comments to the mpls working group mailing 
> list, but with another subject than what is on this mail.
>
> The poll ends May 14th.
>
> /Loa
> --
>
>
> Loa Andersson                         email: 
> [email-masked] Sr Strategy and Standards Manager            
> [email-masked] Ericsson Inc                          phone: +46 10 717 52 
> 13
>                                             +46 767 72 92 13 
> Loa Andersson                         email: 
> [email-masked] Sr Strategy and Standards Manager            
> [email-masked] Ericsson Inc                          phone: +46 10 717 52 
> 13
>                                             +46 767 72 92 13

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 16 May 2011 11:57:29 -0700

Support.

-Vishwas

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 16 May 2011 14:58:55 -0400

Yes/support

	Regards,
		Greg

Loa
> [email-masked]
> [email-masked]