Subject: Re: [mpls] AD review of draft-ietf-mpls-tp-identifiers

From: George Swallow <[email-masked]>
Date: Fri, 01 Jul 2011 14:27:16 -0400

Adrian -

On 6/27/11 5:38 PM, "Adrian Farrel" <[email-masked]> wrote:

> Hi,
> 
> I have done my AD review of this document. In view of the fact that my
> comments
> are quite small, could you please handle them as part of the IETF last call
> which I will start forthwith.
> 
> Thanks,
> Adrian
> 
> ---
>   
> You seem to be missing a section on MEP_IDs for MPLS_TP Sections.
> Insert before 7.2.1?
> 
Added the following section:

7.2.1.  MPLS-TP Section MEP_IDs

   IP compatible MEP_IDs for MPLS-TP are simply the IF_IDs of each end
   of the section.  For example, for a section whose MEG_ID is

      A1-IF_ID::Z9-IF_ID

   the Section MEP_ID at A1 would be

      A1-IF_ID

   and the Section MEP_ID at Z9 would be

      Z9-IF_ID.

   Where the Section MEP_ID needs to be globally unique, this is
   accomplished by using globally unique Node_IDs as defined above.
   Thus a globally unique Section MEP_ID becomes

      Global_ID::IF_ID.

> 
> ---
> 
> Nits
> 
> 1.3
> 
> OLD
> The notation does define a preferred ordering of the fields.
> NEW
> The notation defines a preferred ordering of the fields.
> END
> 
Done.
> 
> OLD
>  Z9 is used to indicated the
> NEW
>  Z9 is used to indicate the
> END
> 
Done.

...George
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 7 Jul 2011 17:58:14 -0400

Hi George,
I have a question to new Section MEP-ID. In MPLS-TP a Section can be either physical link or logical, section layer LSP, link. I think that listed Section MEP_ID addresses the former case. Would Section MEP-ID in the latter case be the LSP MEP-ID? I think that both cases must be identified and their Section MEP-IDs listed.

    Regards,
        Greg

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of George Swallow
Sent: Friday, July 01, 2011 11:27 AM
To: Adrian Farrel; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] AD review of draft-ietf-mpls-tp-identifiers

Adrian -

Hi,

I have done my AD review of this document. In view of the fact that my comments
are quite small, could you please handle them as part of the IETF last call
which I will start forthwith.

Thanks,
Adrian

---

      A1-IF_ID::Z9-IF_ID

      A1-IF_ID

      Z9-IF_ID.

      Global_ID::IF_ID.

---

Nits

1.3

OLD

Done.

OLD

Done.

...George

---

From: George Swallow <[email-masked]>
Date: Fri, 08 Jul 2011 09:37:52 -0400

Thanks,  I¹ll fix that.

...George

On 7/7/11 5:58 PM, "Gregory Mirsky" <[email-masked]> wrote:

> Hi George,
> I have a question to new Section MEP-ID. In MPLS-TP a Section can be either
> physical link or logical, section layer LSP, link. I think that listed Section
> MEP_ID addresses the former case. Would Section MEP-ID in the latter case be
> the LSP MEP-ID? I think that both cases must be identified and their Section
> MEP-IDs listed.
>  
>     Regards,
>         Greg
> 
>