Subject: [mpls] R: RE: R: Re: Last Call: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt> (Proactive Connectivity Verification, Continuity Check and Remote Defect indication for MPLS Transport Profile) to Proposed Standard

From: "[email-masked]" <[email-masked]>
Date: Wed, 13 Jul 2011 22:27:53 +0200 (CEST)

Do you mean that ITU-T comments were discussed and resolution agreed during the 
ITU-T meeting?

If this is the case, why the LS just provides the comments and not the agreed 
resolution?

Why some ITU-T comments have been then rejected?

>----Messaggio originale----
>Da: [email-masked]
>Data: 6-lug-2011 19.35
>A: "[email-masked]"<[email-masked]>, "[email-masked]"
<[email-masked]>, "Rui Costa"<[email-masked]>
>Cc: "[email-masked]"<[email-masked]>, "[email-masked]"<[email-masked]>, "IETF-
Announce"<[email-masked]>
>Ogg: RE: [mpls] R: Re: Last Call:	&lt;draft-ietf-mpls-tp-cc-cv-rdi-05.txt&gt;	
(Proactive Connectivity	Verification, Continuity Check and Remote Defect 
indication for	MPLS	Transport	Profile) to Proposed Standard
>
>Hi Erminio:
>
>Two of the three document editors were present at SG15 plenary in February 
where the comments originated. The revised meeting schedule resulted in a day 
spent going through the document with the editors. IMO there were lots of 
discussion and legitimate issues with the document identified and corrected so 
it was a useful session. The liaison of same was in many ways *after the 
fact*.
>Cheers
>Dave

---

From: David Allan I <[email-masked]>
Date: Wed, 13 Jul 2011 18:24:00 -0400

HI Erminio:

The comments that were raised during the day long discussion with the editors at the SG15 plenary resulted in those comments appearing in the liasion IMO in an actionable form and resulted in a constructive outcome. I enjoyed that level of cooperation.

The comments that were punted over the wall with no discussion (depsite requests to allocate meeting time to do so) in some cases were sufficiently vague as to have no constructive value or not have a recognizable issue to be addressed.

A request to have the commenters identified in the liaison so that comments that were unclear could be followed up upon by the editors was refused. Apparently that is not done and I would go so far as to suggest that blanket of anonymity diminished the quality of the liaison.  The result of this process was that the only recourse to go "what does this mean?" was a complete liaison cycle. For some comments, stomaching a multi-month delay to clarify what the actual issue was that resulted in a comment like "describe the start-up procedure" was not reasonable, especially given SG15s continual complaint on how slow the IETF was. Such comments had to be weighed against the nature of comments from the larger reviewing community that seemed to have no issue with the completeness of the document content and perhaps had actually read it and the supporting documents.

I'll call out an example: a comment that appeared more than once in the liaison was "clarify the raising/clearing of defects as well as any consequent actions" which I can only interpret as section 3.7 of the document not having been read. E.g. the TOC is:

3.7.1. Session initiation and Modification	13
3.7.2. Defect entry criteria				13
3.7.3. Defect entry consequent action		14
3.7.4. Defect exit criteria				15
3.7.5. State machines					15

...and if there was a deficiency in the descriptions it was not identified, and we're not mind readers.

So that is both the history and why some comments were rejected. If you can suggest a constructive way to proceed that is not simply a waste of everyone's time, I'll listen..

Cheers
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, July 13, 2011 1:28 PM
To: David Allan I; [email-masked]; Rui Costa
Cc: [email-masked]; [email-masked]; IETF-Announce
Subject: R: RE: [mpls] R: Re: Last Call: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt> (Proactive Connectivity Verification, Continuity Check and Remote Defect indication for MPLS Transport Profile) to Proposed Standard

Do you mean that ITU-T comments were discussed and resolution agreed during the ITU-T meeting?

If this is the case, why the LS just provides the comments and not the agreed resolution?

>Two of the three document editors were present at SG15 plenary in 
where the comments originated. The revised meeting schedule resulted in a day spent going through the document with the editors. IMO there were lots of discussion and legitimate issues with the document identified and corrected so it was a useful session. The liaison of same was in many ways *after the fact*.