Subject: [mpls] R: Re: Last Call: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt> (Proactive Connectivity Verification, Continuity Check and Remote Defect indication for MPLS Transport Profile) to Proposed Standard

From: "[email-masked]" <[email-masked]>
Date: Wed, 6 Jul 2011 19:33:58 +0200 (CEST)

The way this draft has been developed is a bit strange.

The poll for its adoption as a WG document was halted by the MPLS WG chair 
because "it is not possible to judge consensus":

http://www.ietf.org/mail-archive/web/mpls/current/msg04502.html

The lack of consensus was motivated by serious technical concerns raised by 
several transport experts during the poll.

Nevertheless the MPLS WG chair decided to adopt the draft as a WG document:

http://www.ietf.org/mail-archive/web/mpls/current/msg04512.html

After several WG revisions and WG LCs, the technical issues have not been 
resolved.

>Several service providers regarded this draft as not meeting their transport 
networks' needs.	

This is a true statement: the solution in this draft is useless for many MPLS-
TP deployments.

>----Messaggio originale----
>Da: [email-masked]
>Data: 5-lug-2011 0.02
>A: "[email-masked]"<[email-masked]>, "IETF-Announce"<[email-masked]>
>Cc: "[email-masked]"<[email-masked]>
>Ogg: Re: [mpls] Last Call:	&lt;draft-ietf-mpls-tp-cc-cv-rdi-05.txt&gt;	
(Proactive	Connectivity	Verification, Continuity Check and Remote Defect 
indication for	MPLS	Transport	Profile) to Proposed Standard
>
>IMHO and for the record:	
>
>ITU-T comments regarding this draft haven't been discussed with ITU-T but 
were simply ignored. No LS describing these comments' resolution was sent.	
>
>Several service providers regarded this draft as not meeting their transport 
networks' needs.	
>
>[The v03 draft was published in Feb and went to WG LC.	
>The v04 draft addressing WG LC comments was published on the 28th June (same 
date as the proto write-up).	
>When was the WG LC launched, to verify LC comments resolution?]	
>
>Regards,	
>Rui
>
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of The 
IESG
>Sent: quinta-feira, 30 de Junho de 2011 14:47
>To: IETF-Announce
>Cc: [email-masked]
>Subject: [mpls] Last Call: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt> (Proactive 
Connectivity Verification, Continuity Check and Remote Defect indication for 
MPLS Transport Profile) to Proposed Standard
>
>
>The IESG has received a request from the Multiprotocol Label Switching WG
>(mpls) to consider the following document:
>- 'Proactive Connectivity Verification, Continuity Check and Remote
>   Defect indication for MPLS Transport Profile'
>  <draft-ietf-mpls-tp-cc-cv-rdi-05.txt> as a Proposed Standard
>
>The IESG plans to make a decision in the next few weeks, and solicits
>final comments on this action. Please send substantive comments to the
>[email-masked] mailing lists by 2011-07-14. Exceptionally, comments may be
>sent to [email-masked] instead. In either case, please retain the
>beginning of the Subject line to allow automated sorting.
>
>Abstract
>
>   Continuity Check, Proactive Connectivity Verification and Remote
>   Defect Indication functionalities are required for MPLS-TP OAM.
>
>   Continuity Check monitors the integrity of the continuity of the
>   label switched path for any loss of continuity defect. Connectivity
>   verification monitors the integrity of the routing of the label
>   switched path between sink and source for any connectivity issues.
>   Remote defect indication enables an End Point to report, to its
>   associated End Point, a fault or defect condition that it detects on
>   a pseudo wire, label switched path or Section.
>
>   This document specifies methods for proactive continuity check,
>   continuity verification, and remote defect indication for MPLS-TP
>   label switched paths, pseudo wires and Sections using Bidirectional
>   Forwarding Detection.
>
>
>The file can be obtained via
>http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-cc-cv-rdi/
>
>IESG discussion can be tracked via
>http://datatracker.ietf.org/doc/draft-ietf-mpls-tp-cc-cv-rdi/
>
>
>No IPR declarations have been submitted directly on this I-D.
>_______________________________________________
>mpls mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mpls
>
>
>_______________________________________________
>mpls mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mpls
>

---

From: David Allan I <[email-masked]>
Date: Wed, 6 Jul 2011 14:24:54 -0400

Hi Erminio:

<snipped>
>Several service providers regarded this draft as not meeting their 
>transport networks' needs.	

E> This is a true statement: the solution in this draft is useless for many MPLS- TP deployments.

The two statements do not necessarily follow. 

What we established during discussions at the SG15 plenary in February was that the issue some service providers had was that the IETF BFD solution exceeded their requirements in that there was additional functionality they did not see a need for, and that they considered any additional functionality parasitic.

However this is a consequence of adapting an existing technology to a new application. I do not see any way around that. And the entire joint project was based on the premise of engineering re-use not greenfield design. That is what it said on the tin up front, and IMO why when the IETF started down this path packet transport transitioned from being a minority sport to mainstream, so it is a bit late to cry foul....

My 2 cents
Dave

networks' needs.	
IESG
>Subject: [mpls] Last Call: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt> 
Connectivity Verification, Continuity Check and Remote Defect indication for MPLS Transport Profile) to Proposed Standard
>[email-masked] mailing lists by 2011-07-14. Exceptionally, comments may 
>be sent to [email-masked] instead. In either case, please retain the

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 7 Jul 2011 11:59:12 +0200

Erminio,
I do not think the history is relevant for this specific discussion... 
Also I find it inappropriate to give statements with no justifications
behind. 
You say: "the solution in this draft is useless for many MPLS-TP
deployments.".  in order to seriously consider your comment, you have to
show why it is useless and which requirements are not satisfied.
Otherwise you cannot expect anyone to refer to your point. 
Best regards,
Nurit

P.s. did you mean that the document is useless to available non-standard
deployments, e.g. T-MPLS?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext [email-masked]
Sent: Wednesday, July 06, 2011 8:34 PM
To: [email-masked]; [email-masked]; IETF-Announce
Cc: [email-masked]
Subject: [mpls] R: Re: LastCall: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt>
(Proactive Connectivity Verification,Continuity Check and Remote Defect
indicationfor MPLS Transport Profile) to Proposed Standard

The poll for its adoption as a WG document was halted by the MPLS WG
chair 
because "it is not possible to judge consensus":

The lack of consensus was motivated by serious technical concerns raised
by 
several transport experts during the poll.

Nevertheless the MPLS WG chair decided to adopt the draft as a WG
document:

After several WG revisions and WG LCs, the technical issues have not
been 
resolved.

>Several service providers regarded this draft as not meeting their
transport 
networks' needs.	

This is a true statement: the solution in this draft is useless for many
MPLS-
TP deployments.

>Ogg: Re: [mpls] Last Call:
&lt;draft-ietf-mpls-tp-cc-cv-rdi-05.txt&gt;	
(Proactive	Connectivity	Verification, Continuity Check and
Remote Defect 
indication for	MPLS	Transport	Profile) to Proposed Standard
>ITU-T comments regarding this draft haven't been discussed with ITU-T
but 
were simply ignored. No LS describing these comments' resolution was
sent.	
>Several service providers regarded this draft as not meeting their
transport 
networks' needs.	
IESG
>Subject: [mpls] Last Call: <draft-ietf-mpls-tp-cc-cv-rdi-05.txt>
(Proactive 
Connectivity Verification, Continuity Check and Remote Defect indication
for 
MPLS Transport Profile) to Proposed Standard
>[email-masked] mailing lists by 2011-07-14. Exceptionally, comments may
be

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 7 Jul 2011 13:40:22 +0200

Erminio,

-----Original Message-----

transport 
networks' needs.	

transport 
networks' needs.	
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
The 
IESG
be