Subject: [mpls] Questions about draft-betts-itu-oam-ach-code-point

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 9 Dec 2011 10:49:26 -0000

Hi Malcolm and Huub,

I have squeezed a little time from the current ITU-T meeting to look at your
draft and write-up. I have also read the email threads on the IETF discussion
list and the MPLS list. Sorry that this has taken me a week to process, but your
publication request came at pretty much the worst possible time for getting me
to do this task.

I don't like proliferating threads across multiple mailing lists. On the other
hand it is difficult to ensure that all the constituencies are present, so I am
perpetuating the cross-posting.

My review of the document...

1. idnits (http://www.ietf.org/tools/idnits/) shows a couple of nits. I think
only one of these is real (the spurious space in a citation). The other nits are
spurious caused by citations wrapping across lines. Could you please keep a note
of the nit so that you can fix it the next time the draft is respun or so it can
be captured in an RFC Editor Note at a later stage (you don't have to post a new
revision to address this now unless you really want to).

2. This document requests a code point from a registry that contains code points
that are used equally for MPLS LSPs and pseudowires. I can't tell from the I-D
whether it is your intention that your code point would also be applicable in
both cases. What is your intention? Is this "obvious" from G.8113.1 or does it
need to be clarified?

My review of the write-up and discussions...

3. There seems to be quite a feeling on the mailing lists that this document
should be run through the MPLS working group. The write-up makes a case for
progressing it as AD sponsored. As far as I can see, the main assertions to
answer are as follows. Do you have a view on these points before I make a
decision on what to do?

a. This is a proposal to use an MPLS code point and so is part of MPLS by
definition.

b. The type of network being managed by the OAM described in G.8113.1 is an MPLS
network. Therefore, this is clearly relevant to the MPLS working .

Do you object to this going through the MPLS on principle, or were you just
hoping to save the WG the work? If the latter, and if the WG wants to look at
the draft, the easiest approach seems to be to redirect the work to the working
group.

4. G.8113.1 is clearly important to understanding to which the code point is
being put. Thus, an available and stable copy of group. G.8113.1 will be key to
the last call review of you I-D. Can you make a stable copy available (for
example, through liaison)? How does the editing work currently in progress in
the SG15 meeting affect that availability?

5. Can you clarify for me why the suggested value has been suggested. This will
help guide IANA who would normally do their allocation in a "tidy" way.

Looking forward to your reply.

Thanks,
Adrian

---

From: [email-masked]
Date: Tue, 20 Dec 2011 11:09:41 -0500

Hi Adrian,

Thank you for finding time to respond to this request.  As you know I was 
attending the same 2 week SG 15 meeting and was probably at least as busy 
as you given my official role in the meeting.

I will update draft-betts-itu-oam-ach-code-point early in the new year 
based on  the results of SG 15 the ended last Friday and your comments.  I 
will also discussan update of the shepherd write up  with Huub.

Regards,

Malcolm

"Adrian Farrel" <[email-masked]> 
Sent by: [email-masked]
09/12/2011 05:49 AM
Please respond to
[email-masked]

To
<[email-masked]>, "'Huub helvoort'" 
<[email-masked]>
cc
[email-masked], [email-masked]
Subject
Questions about draft-betts-itu-oam-ach-code-point

Hi Malcolm and Huub,

I have squeezed a little time from the current ITU-T meeting to look at 
your
draft and write-up. I have also read the email threads on the IETF 
discussion
list and the MPLS list. Sorry that this has taken me a week to process, 
but your
publication request came at pretty much the worst possible time for 
getting me
to do this task.

I don't like proliferating threads across multiple mailing lists. On the 
other
hand it is difficult to ensure that all the constituencies are present, so 
I am
perpetuating the cross-posting.

1. idnits (http://www.ietf.org/tools/idnits/) shows a couple of nits. I 
think
only one of these is real (the spurious space in a citation). The other 
nits are
spurious caused by citations wrapping across lines. Could you please keep 
a note
of the nit so that you can fix it the next time the draft is respun or so 
it can
be captured in an RFC Editor Note at a later stage (you don't have to post 
a new
revision to address this now unless you really want to).

2. This document requests a code point from a registry that contains code 
points
that are used equally for MPLS LSPs and pseudowires. I can't tell from the 
I-D
whether it is your intention that your code point would also be applicable 
in
both cases. What is your intention? Is this "obvious" from G.8113.1 or 
does it
need to be clarified?

3. There seems to be quite a feeling on the mailing lists that this 
document
should be run through the MPLS working group. The write-up makes a case 
for
progressing it as AD sponsored. As far as I can see, the main assertions 
to
answer are as follows. Do you have a view on these points before I make a
decision on what to do?

b. The type of network being managed by the OAM described in G.8113.1 is 
an MPLS
network. Therefore, this is clearly relevant to the MPLS working .

Do you object to this going through the MPLS on principle, or were you 
just
hoping to save the WG the work? If the latter, and if the WG wants to look 
at
the draft, the easiest approach seems to be to redirect the work to the 
working
group.

4. G.8113.1 is clearly important to understanding to which the code point 
is
being put. Thus, an available and stable copy of group. G.8113.1 will be 
key to
the last call review of you I-D. Can you make a stable copy available (for
example, through liaison)? How does the editing work currently in progress 
in
the SG15 meeting affect that availability?

5. Can you clarify for me why the suggested value has been suggested. This 
will
help guide IANA who would normally do their allocation in a "tidy" way.

Thanks,
Adrian

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Huub helvoort <[email-masked]>
Date: Wed, 21 Dec 2011 10:51:29 +0000

Hello Russ,

You wrote:

> My understanding is that there is not a stable agreed G.8113.1 document to reference.
> Is my understanding incorrect?

Your understanding is partially incorrect:

The draft recommendation G.8113.1 is stable, there have been no major technical
changes since it was sent to the IETF (when it still had the draft name G.tpoam)
attache to liaison: https://datatracker.ietf.org/liaison/983/
This is also the status I reported when we did discuss this during IETF82 in Taipei.

G.8113.1 could not be approved because of the technical reason that there is
no ACh codepoint assigned.

Best regards, Huub.

======
On Dec 20, 2011, at 11:09 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Adrian,

Thank you for finding time to respond to this request.  As you know I was attending the same 2 week SG 15 meeting and was probably at least as busy as you given my official role in the meeting.

I will update draft-betts-itu-oam-ach-code-point early in the new year based on  the results of SG 15 the ended last Friday and your comments.  I will also discussan update of the shepherd write up  with Huub.

Regards,

Malcolm

"Adrian Farrel" <[email-masked]<mailto:[email-masked]>>
Sent by: [email-masked]<mailto:[email-masked]>

09/12/2011 05:49 AM
Please respond to
[email-masked]<mailto:[email-masked]>

To
        <[email-masked]<mailto:[email-masked]>>, "'Huub helvoort'" <[email-masked]<mailto:[email-masked]>>
cc
        [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Subject
        Questions about draft-betts-itu-oam-ach-code-point

Hi Malcolm and Huub,

Thanks,
Adrian

_______________________________________________
Ietf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 21 Dec 2011 11:59:39 +0100

Huub hi,

I was in the closing plenary, and I heard different reasons for not
approving G.8113.1. 

The main argument that I heard was because of lack of consensus. 

Best regards,

Nurit

From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Huub helvoort
Sent: Wednesday, December 21, 2011 12:51 PM
To: Russ Housley; [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]
Subject: RE: Questions about draft-betts-itu-oam-ach-code-point

Hello Russ,

The draft recommendation G.8113.1 is stable, there have been no major
technical
changes since it was sent to the IETF (when it still had the draft name
G.tpoam) 
attache to liaison: https://datatracker.ietf.org/liaison/983/
This is also the status I reported when we did discuss this during
IETF82 in Taipei.

G.8113.1 could not be approved because of the technical reason that
there is
no ACh codepoint assigned. 

Best regards, Huub.

======

On Dec 20, 2011, at 11:09 AM, [email-masked] wrote:

Hi Adrian, 

Thank you for finding time to respond to this request.  As you know I
was attending the same 2 week SG 15 meeting and was probably at least as
busy as you given my official role in the meeting. 

I will update draft-betts-itu-oam-ach-code-point early in the new year
based on  the results of SG 15 the ended last Friday and your comments.
I will also discussan update of the shepherd write up  with Huub. 

Regards, 

Malcolm 

09/12/2011 05:49 AM 

Please respond to
[email-masked]

To

cc

Subject

		

Hi Malcolm and Huub,

I don't like proliferating threads across multiple mailing lists. On the
other
hand it is difficult to ensure that all the constituencies are present,
so I am
perpetuating the cross-posting.

1. idnits (http://www.ietf.org/tools/idnits/
<http://www.ietf.org/tools/idnits/> ) shows a couple of nits. I think
only one of these is real (the spurious space in a citation). The other
nits are
spurious caused by citations wrapping across lines. Could you please
keep a note
of the nit so that you can fix it the next time the draft is respun or
so it can
be captured in an RFC Editor Note at a later stage (you don't have to
post a new
revision to address this now unless you really want to).

2. This document requests a code point from a registry that contains
code points
that are used equally for MPLS LSPs and pseudowires. I can't tell from
the I-D
whether it is your intention that your code point would also be
applicable in
both cases. What is your intention? Is this "obvious" from G.8113.1 or
does it
need to be clarified?

3. There seems to be quite a feeling on the mailing lists that this
document
should be run through the MPLS working group. The write-up makes a case
for
progressing it as AD sponsored. As far as I can see, the main assertions
to
answer are as follows. Do you have a view on these points before I make
a
decision on what to do?

a. This is a proposal to use an MPLS code point and so is part of MPLS
by
definition.

Do you object to this going through the MPLS on principle, or were you
just
hoping to save the WG the work? If the latter, and if the WG wants to
look at
the draft, the easiest approach seems to be to redirect the work to the
working
group.

4. G.8113.1 is clearly important to understanding to which the code
point is
being put. Thus, an available and stable copy of group. G.8113.1 will be
key to
the last call review of you I-D. Can you make a stable copy available
(for
example, through liaison)? How does the editing work currently in
progress in
the SG15 meeting affect that availability?

5. Can you clarify for me why the suggested value has been suggested.
This will
help guide IANA who would normally do their allocation in a "tidy" way.

Thanks,
Adrian

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf
<https://www.ietf.org/mailman/listinfo/ietf>

---

From: HUANG Feng F <[email-masked]>
Date: Wed, 21 Dec 2011 11:28:56 +0000

Nurit,
    You left Plenary too early and when it was not closed, ITU has decided to send a Liasion to IETF on this issue  the draft of G.8113.1 is stable, the only reason is lack of Ach code point, you can see liaison from ITU-T.

Best Regard
Feng Huang
OPD, Alcatel Lucent Shanghai Bell
86-21-50554550-5515

在 2011-12-21，19:00，"Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]<mailto:[email-masked]>> 写道：

Huub hi,
I was in the closing plenary, and I heard different reasons for not approving G.8113.1.
The main argument that I heard was because of lack of consensus.
Best regards,
Nurit

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of ext Huub helvoort
Sent: Wednesday, December 21, 2011 12:51 PM
To: Russ Housley; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Subject: RE: Questions about draft-betts-itu-oam-ach-code-point

Hello Russ,

The draft recommendation G.8113.1 is stable, there have been no major technical
changes since it was sent to the IETF (when it still had the draft name G.tpoam)
attache to liaison: <https://datatracker.ietf.org/liaison/983/> https://datatracker.ietf.org/liaison/983/
This is also the status I reported when we did discuss this during IETF82 in Taipei.

======
On Dec 20, 2011, at 11:09 AM, <mailto:[email-masked]> [email-masked]<mailto:[email-masked]> wrote:

Hi Adrian,

Regards,

Malcolm

"Adrian Farrel" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
Sent by: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>

09/12/2011 05:49 AM
Please respond to
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>

To

<<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>, "'Huub helvoort'" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>

cc

<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>, <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>

Subject

Hi Malcolm and Huub,

Thanks,
Adrian

_______________________________________________
Ietf mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 21 Dec 2011 12:31:42 +0100

Feng,

I do not care about the liaison…the liaison was not sent by the member states…

I care about the reasons that member states gave when they opposed G.8113.1. The main reason was "lack of consensus"….

But I propose that everyone that have TIES access listen to the audio of the meeting and judge it…

Best regards,

Nurit

From: ext HUANG Feng F [mailto:[email-masked]] 
Sent: Wednesday, December 21, 2011 1:29 PM
To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Cc: ext Huub helvoort; Russ Housley; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Questions about draft-betts-itu-oam-ach-code-point

Nurit,

Best Regard

Feng Huang

86-21-50554550-5515

在 2011-12-21，19:00，"Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]> 写道：

	Huub hi,

	Best regards,

	Nurit

	From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Huub helvoort
	Sent: Wednesday, December 21, 2011 12:51 PM
	To: Russ Housley; [email-masked]
	Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
	Subject: RE: Questions about draft-betts-itu-oam-ach-code-point

	Hello Russ,

	

	Best regards, Huub.

	======

	

	Hi Adrian, 

	
	Regards, 
	
	Malcolm 

09/12/2011 05:49 AM 

Please respond to
[email-masked]

To

<[email-masked]>, "'Huub helvoort'" <[email-masked]> 

cc

Subject

		

	
	Hi Malcolm and Huub,

	
	
	1. idnits (http://www.ietf.org/tools/idnits/ <http://www.ietf.org/tools/idnits/> ) shows a couple of nits. I think

	

	

	
	
	Thanks,
	Adrian
	
	_______________________________________________
	Ietf mailing list
	[email-masked]
	https://www.ietf.org/mailman/listinfo/ietf <https://www.ietf.org/mailman/listinfo/ietf>

---

From: HUANG Feng F <[email-masked]>
Date: Wed, 21 Dec 2011 11:59:26 +0000

Nurit,
   Yes, you can memory the record, US stated because of lacking of ACH code point, they don't support it, other 3 states support US as same position. So the origin is lack of ACH code point.  The liaison recorded the ITU-T status too.

Best Regard
Feng Huang

在 2011-12-21，19:32，"Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]<mailto:[email-masked]>> 写道：

Feng,

From: ext HUANG Feng F [mailto:[email-masked]]
Sent: Wednesday, December 21, 2011 1:29 PM
To: Sprecher, Nurit (NSN - IL/Hod HaSharon)
Cc: ext Huub helvoort; Russ Housley; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Subject: Re: Questi! ons about draft-betts-itu-oam-ach-code-point!

Nurit,

在 2011-12-21，19:00，"Sprecher, Nurit (NSN - IL/Hod HaSharon)" <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> 写道：
Huub hi,
I was in the closing plenary, and I heard different reasons for not approving G.8113.1.
The main argument that I heard was because of lack of consensus. !
Best regards,
Nurit

From: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of ext Huub helvoort
Sent: Wedn! esday, December 21, 2011 12:51 PM
To: Russ Housley; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Cc: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Subject: RE: Questions about draft-betts-itu-oam-ach-code-point

Hello Russ,

======

Hi Adrian,

Thank you for finding time to respond to this request.  As ! you know I was attending the same 2 week SG 15 meeting and was! probabl y at least as busy as you given my official role in the meeting.

Regards,

Malcolm

09/12/2011 05:49 AM
Please respond to

To

cc

Subject

Hi Malcolm and Huub,

of the nit so that you can fix it the next time the draft is respun or so it can!

3. There seems to be quite a feeling on the mailing lists that this document
should be run through the MPLS working group. The write-up makes a case for
progressing it as AD ! sponsored. As far as I can see, the main assertions to
answer are as follows. Do you have a view on these points before I make a
decision on what to do?

b. The type of network being managed by the OAM described in G.8113.1 is an MPLS
netw ork. Therefore, this is clearly relevant to the MPLS working .

4. G.8113.1 is clearly important to understanding to which the code poin! t is

5. Can you clarify for me why the suggested value has been suggested. This will!
help guide IANA who would normally do their allocation in a "tidy" way.

Thanks,
Adrian

_______________________________________________
Ietf mailing list
<mailto:Ietf@iet!
%20f.org>[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/ietf>https://www.ietf.org/mailman/listinfo/ietf

_______________________________________________Ietf mailing list
Ietf@ietf! .org<mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/ietf>https://www.ietf.org/mailman/listinfo/ietf

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 21 Dec 2011 13:03:04 +0100

As mentioned, I proposed you listen to the record…it will help you refreshing your memory!

You may want to listen also to Final and U.K….and I propose you listen again also to what U.S said…

There was also a note on the huge effort to find a compromise that did not work out….:-(

Sent: Wednesday, December 21, 2011 1:59 PM

Nurit,

Best Regard

Feng Huang

86-21-50554550-5515

在 2011-12-21，19:32，"Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]> 写道：

	Feng,

	Best regards,

	Nurit

	Nurit,

	Best Regard

	Feng Huang

	86-21-50554550-5515

	

		Huub hi,

		Best regards,

		Nurit

		Hello Russ,

		

		Best regards, Huub.

		======

		

		Hi Adrian, 

		
		Regards, 
		
		Malcolm 

09/12/2011 05:49 AM 

Please respond to
[email-masked]

To

cc

Subject

		

		
		Hi Malcolm and Huub,

		

		

		

		
		
		Thanks,
		Adrian

		_______________________________________________Ietf mailing list
		Ietf@ietf! .org <mailto:[email-masked]>  
		https://www.ietf.org/mailman/listinfo/ietf