Subject: Re: [mpls] Doubts on draft-helvoort-mpls-tp-ring-protection-switching-03

From: Huub helvoort <[email-masked]>
Date: Mon, 4 Feb 2013 14:54:49 +0000

Dear Naveen,

You replied:

> Thank you very much for clearing up my doubts. Your answers addressed my concerns.

You're welcome.

> I have two more questions.

[Huub] OK.

> This is with respect to the link failure example in the Wrapping solution as described in section 3.1.2.1. As proposed by the solution, when a failure occurs on the link between B and C, the traffic flow and the label usage are as below:
A[W1]->B[P6]->A[P1]->F[P2]->E[P3]->D[P4]->C[W3]->D

[Huub] Indeed.

> Consider the case where the packet has traversed the ring on the protection path (...D[P4]->C) and is now at node C. At this point in time, if the link between B and C comes back up again, i.e., it is operational again, then;

[Huub] do you mean: the failure on the section B C is repaired and the defect (e.g SF) has cleared, and the WTR (wait-to-restore) timer expired?

At that moment the traffic from W2 is forwarded to W3 again and the forwarding of P4 to W3 is disabled.

1) Will the node C swap the label it receives (P4) with the protection label P3 and forward the packet to B? If so, there is a possibility that the packet continues to traverse the ring via the protection path in the loop, or;

[Huub] indeed the traffic from P4 is forwarded to P3, but note that the TTL will be decremented, and the packet discarded when TTL==0, so it will not loop forever.

2) Will the node C always swap the label it receives (P4) with the working label W3 and forward the packet to D irrespective of whether there is a failure on the link between C and B?

[Huub] no that is not the case, because that would mean that packets are duplicated at C if the trafic P4 is merged with traffic W2 into W3. Also, because the Protection LSPs are shared on the ring, these LSPs should only be used during a protection switch.

Best reagrds, Huub.

________________________________
From: Huub helvoort <[email-masked]>
To: Naveen T <[email-masked]>; MRPS Helvoort <[email-masked]>
Sent: Monday, 4 February 2013 6:50 PM
Subject: RE: [mpls] Doubts on draft-helvoort-mpls-tp-ring-protection-switching-03

Dear Naveen,

Thank you very much for your patience.

The last two weeks I have been traveling, and email access was very limited.

Please find below the answers to your questions [Huub].

> The proposed solution recommends the usage of section layer OAM to find signal failures on a link. Since the two nodes will be able to detect failures at either end of a link using the link OAM, why would it be a necessity to send the APS payload to the adjacent node in the direction opposite to the failure?

[Huub] The nodes at each side of a section (e.g. Nodes A and B) can detect failures. However the failure may have occurred only in one direction, e.g node A --> B, the APS message s used to informA that B has detected a failure and will switch to protection, A will have to switch to protection too.
[Huub] also if a node fails e.g. node B located between nodes A and C then both A and C will detect the failure of
the section connecting them to B, and they have to inform the other side C resp. A that they will perform a protectiuoin switch based on the detected failure.
[Huub] there may be more than a single section or node failure in the ring, all the nodes in the ring have to be aware of the failure and its location to take proper protection switch consequent actions.

> If the switching commands Lockout, Manual Switch and Forced Switch are taken out of the equation, and assuming that a signal failure will be the only reason considered for a switch-over, will it still be necessary to use the APS protocol at all?

[Huub] also in this case the APS messages sent colockwise and counter-clockwise will be necessary to inform all the nodes in the ring of the fault location and the switch action. There may be point-to-multipoint connections on the ring, and each node has to decide wich signal should be used.

I hope this addresses your concerns.

Best regards, Huub.

--
================================================================
Always remember that you are unique...just like everyone else...

---

From: Naveen T <[email-masked]>
Date: Mon, 4 Feb 2013 17:29:28 +0800 (SGT)

Dear Authors, et al.,
	1. The proposed solution recommends the usage of section layer OAM to find signal failures on a link. Since the two nodes will be able to detect failures at either end of a link using the link OAM, why would it be a necessity to send the APS payload to the adjacent node in the direction opposite to the failure?

	2. If the switching commands Lockout, Manual Switch and Forced Switch are taken out of the equation, and assuming that a signal failure will be the only reason considered for a switch-over, will it still be necessary to use the APS protocol at all? 
Thanks and Regards,
Naveen T

---

From: Naveen T <[email-masked]>
Date: Mon, 4 Feb 2013 18:56:41 +0800 (SGT)

Dear Authors, et al.,

---

From: Naveen T <[email-masked]>
Date: Mon, 4 Feb 2013 21:48:47 +0800 (SGT)

Dear Huub,

Thanks and Regards,
Naveen T

Dear Naveen,

Best regards, Huub.

---

From: Naveen T <[email-masked]>
Date: Thu, 7 Feb 2013 13:28:45 +0800 (SGT)

Dear Huub, 
Considering the topology below, I have a question.

                                      +-----+                         +-----+
                                       |  F  |--------------------------|  A  |--------------- LSP 1
                                      +-----+                         +-----+ 
                                      /                                         \
                                     /                                           \
                                    /                                             \
                            +-----+                                              +-----+
                             |  E  |                                               |  B  |
                            +-----+                                              +-----+
                                    \                                              /
                                     \                                            /
                                      \                                          /
                                      +-----+                         +-----+
              LSP 1 ---------------|  D  |--------------------------|  C  |
                                      +-----+                         +-----+ 

In case of an associated bidirectional path, the forward and reverse path LSPs may span between the same end pointsbut via different transit nodes.

Let's consider the forward path of the LSP 1 as: A->B->C->D (Clockwise direction) and, thereverse path of the LSP 1 as: D->E->F->A (Clockwise direction).
With this topology, if the link between B->C fails, then, only the forward path LSP will be affected and APS PDUs will be sent via the protection path from B->C and C->B to inform each other of the signal failure and eventually, the traffic on the forward path LSP will be switched to the protection path.
However, the reverse path LSP, D->E->F->A, will not be affected by the link failure between B->C

In this scenario, will there be a necessity to switch the traffic on the reverse path (unaffected by the signal failure between B->C) LSP to the protection path? 
Or, willit be sufficient to switch just the traffic on the forward path LSP to the protection path and leave the traffic on the reverse path LSP as it is?

If traffic on both the forward and reverse path LSPs are switched to the protection path, then, it is bidirectional switching.
But, if only the traffic on the affected LSP is switched on to the protection path, then, it is unidirectional switching.
Does this draft recommend unidirectional switching?
Thanks and Regards,
Naveen T

________________________________
From: Huub helvoort<[email-masked]>
To: Naveen T <[email-masked]>; MRPS Helvoort <[email-masked]>; MPLS <[email-masked]> 
Sent: Monday, 4 February 2013 8:24 PM
Subject: RE: [mpls] Doubts on draft-helvoort-mpls-tp-ring-protection-switching-03

Dear Naveen,

You're welcome.

[Huub] OK.

[Huub] Indeed.

> Consider the case where the packet has traversed the ring on the protection path (...D[P4]->C) and is now at node C. At this point in time, if the link between B and C comes back up again, i.e., it…

[Huub] do you mean: the failure onthe section B C is repaired and the defect (e.gSF) has cleared, and the WTR (wait-to-restore) timer expired? 
At that moment the traffic from W2 is forwarded to W3 again and the forwarding of P4 to W3 is disabled.

[Huub] no that is not the case, because that would mean that packets are duplicated at C if the traficP4 is merged with traffic W2 into W3. Also, because the Protection LSPs are shared on the ring, these LSPs should only be used during a protection switch.

Best reagrds, Huub.

From: Huub helvoort<[email-masked]>

Dear Naveen,

> The proposed solution recommends the usage of section layer OAM to find signal failures on a link. Since the two nodes will be able to detect failures at either end of a link using the link OAM, why would it be a necessity to send the APS payload to the adjacent
nodein the direction opposite to the failure?

[Huub] The nodes ateach side of a section (e.g. Nodes A and B) can detect failures. However the failure may have occurred only in one direction, e.gnode A --> B, the APS message sused to informAthat B has detected a failure and will switch to protection,
A will have to switch to protection too.
[Huub] also if a node fails e.g. nodeB located between nodes A and C then both A and C will detect the failure of
thesection connecting them to B, and they have to inform the other side C resp. A that they will perform a protectiuoinswitch based on the detected failure.
[Huub] there may be more than a single section or node failure in the ring, all the nodes in the ring have to be aware of the failure and its location to take proper protectionswitch consequent actions.

> If the switching commands Lockout, Manual Switch and Forced Switch are taken out of the equation, and assuming that a signal failure will be the only reason considered for a switch-over, will it st…

[Huub] also in this case the APS messages sent colockwiseand counter-clockwise will be necessary to inform all the nodes in the ring of the fault location and the switch action. There may be point-to-multipoint connections on the ring, and each node has to
decide wichsignal should be used.

Best regards, Huub.

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 08 Feb 2013 23:40:24 +0100

Dear Naveen,

You write:

>                 |  F  |--------------|  A  |-------- LSP 1
>                 +-----+              +-----+
>                    /                     \
>                   /                       \
>                  /                         \
>              +-----+                     +-----+
>              |  E  |                     |  B  |
>              +-----+                     +-----+
>                   \                        /
>                    \                      /
>                     \                    /
>                   +-----+            +-----+
> LSP 1 ------------|  D  |------------|  C  |
>                   +-----+            +-----+
>
> In case of an associated bidirectional path, the forward and reverse
 > path LSPs may span between the same end pointsbut via different
 > transit nodes.

In Transport Networks in general co-routed bidirectional path are used.
This has the advantage that the propagation delay is the same in
forward and backward direction. In general the shortest path will be
configured around the ring.

> Let's consider the forward path of the LSP 1 as: A->B->C->D (Clockwise
> direction) and, the reverse path of the LSP 1 as: D->E->F->A (Clockwise
 > direction).
> With this topology, if the link between B->C fails, then, only the
 > forward path LSP will be affected and APS PDUs will be sent via the
 > protection path from B->C and C->B to inform each other of the signal
 > failure and eventually, the traffic on the forward path LSP will be
 > switched to the protection path.

Indeed.

> In this scenario, will there be a necessity to switch the traffic on
 > the reverse path (unaffected by the signal failure between B->C) LSP
 > to the protection path?

In your scenario the traffic on the reverse path will not be switched
because the wrapping of all working traffic to the protection LSPs and
back will take place only in nodes B and C.

> Or, will it be sufficient to switch just the traffic on the forward
 > path LSP to the protection path and leave the traffic on the reverse
 > path LSP as it is?

I would not say it is sufficient, but is is due to the way traffic
is wrapped. Not only LSP1 but all working traffic between B and C
is wrapped.

> If traffic on both the forward and reverse path LSPs are switched to
 > the protection path, then, it is bidirectional switching.

Indeed, but again: only the forward and reverse working traffic between
nodes B and C is switched to the protection LSPs.

> But, if only the traffic on the affected LSP is switched on to the
 > protection path, then, it is unidirectional switching.

No, the switching is still bi-directional, but in your scenario
only the traffic of LSP1 that passes nodes B and C is switched.

> Does this draft recommend unidirectional switching?

No, it recommends bi-directional switching.
Together with the preference for co-routed bi-dirtectional LSPs
I will capture this in the next rev. of the draft.

Cheers, Huub.

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样