Subject: [mpls] Doubts on draft-cheng-mpls-tp-shared-ring-protection-00

From: Naveen T <[email-masked]>
Date: Mon, 4 Feb 2013 17:16:39 +0800 (SGT)

Dear Authors, et al.,

Considering Figure 5 in the draft, which talks about Wrapping Link Failure, in the case of a link failure between link B and C, the following protection path will be taken:
A->B->A->F->E->D->C->D and the labels used are:
[LSP1](Original data packet)-> [RcW_D(B)|LSP1](NodeA)-> [RaP_D(A)|LSP1](NodeB)->[RaP_D(F)|LSP1](NodeA)->[RaP_D(E)|LSP1] (NodeF)->[RaP_D(D)|LSP1] (NodeE)->[RaP_D(C)|LSP1] (NodeD)-> [RcW_D(D)|LSP1](NodeC)->[LSP1](Exit data packet).

Consider the case where the packet has traversed the ring on the protection path and is now at node C. At this point in time, if the link between B and C comes back up again, then, label RaP_D(C) will be swapped with RaP_D(B) and RaP_D(B) will be swapped with RaP_D(A) and so on.
Hence, the packet could loop around within the ring until the next link failure occurs.

Am I missing something here or is this a genuine problem? If it is a genuine problem, how will this be addressed?
 
Thanks and Regards,
Naveen T

---

From: Naveen T <[email-masked]>
Date: Mon, 4 Feb 2013 18:56:03 +0800 (SGT)

Dear Authors, et al.,

 
Thanks and Regards,
Naveen T

---

From: Naveen T <[email-masked]>
Date: Mon, 4 Feb 2013 19:26:08 +0800 (SGT)

Dear Authors, et al.,

Thanks and Regards,
Naveen T

---

From: weiqiang cheng <[email-masked]>
Date: Tue, 5 Feb 2013 15:44:39 +0800

Hi Naveen,

Thank you very much for your comments.
You asked Huub the same question and I fully agree with huub, please
refer to his answer in following link:
http://www.ietf.org/mail-archive/web/mpls/current/msg09495.html

B.R.

Weiqiang Cheng

2013/2/4 Naveen T <[email-masked]>:
> Dear Authors, et al.,
>
> Considering Figure 5 in the draft, which talks about Wrapping Link Failure,
> in the case of a link failure between link B and C, the following protection
> path will be taken:
> [LSP1](Original data packet)-> [RcW_D(B)|LSP1](NodeA)->
> [RaP_D(A)|LSP1](NodeB)->[RaP_D(F)|LSP1](NodeA)->[RaP_D(E)|LSP1]
> (NodeF)->[RaP_D(D)|LSP1] (NodeE)->[RaP_D(C)|LSP1] (NodeD)->
> [RcW_D(D)|LSP1](NodeC)->[LSP1](Exit data packet).
>
> Consider the case where the packet has traversed the ring on the protection
> path and is now at node C. At this point in time, if the link between B and
> C comes back up again, then, label RaP_D(C) will be swapped with RaP_D(B)
> and RaP_D(B) will be swapped with RaP_D(A) and so on.
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Naveen T <[email-masked]>
Date: Tue, 5 Feb 2013 16:21:38 +0800 (SGT)

Thank you Cheng.
 
Thanks and Regards,
Naveen T

----- Original Message -----
From: weiqiang cheng <[email-masked]>
To: Naveen T <[email-masked]>
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Tuesday, 5 February 2013 1:14 PM
Subject: Re: [mpls] Doubts on draft-cheng-mpls-tp-shared-ring-protection-00

Hi Naveen,

B.R.

Weiqiang Cheng