Subject: [mpls] 答复: MPLS-RT review of draft-lim-mpls-proxy-lsp-ping

From: [email-masked]
Date: Fri, 29 Mar 2013 10:58:57 +0800

Hi，Loa

I have read through the draft and my comments is as follows.

I think the draft is coherent and it is useful in P2MP MPLS development 
case.
Based on current RFC, the only tool that we can use is MPLS ping initiated 
from root.
This draft proposes a new MPLS ping which can be initiated from leaf. 
And document is technically sound.

But I think this draft is a revised version of current wg draft 
-draft-ietf-mpls-remote-lsp-ping-03.

And this confuses me. Will the authors replace that remote-lsp-ping draft 
with this one？

wubo

Loa Andersson <[email-masked]> 
2013-03-12 02:15

收件人
Mach Chen <[email-masked]>, [email-masked], 
[email-masked], "[email-masked]" 
<[email-masked]>, "[email-masked]" 
<[email-masked]>, Martin Vigoureux 
<[email-masked]>, 
[email-masked]
抄送

主题
MPLS-RT review of draft-lim-mpls-proxy-lsp-ping

Dave, Wu, Wim and Mach,

You have been selected as an MPLS Review team reviewers for
draft-lim-mpls-proxy-lsp-ping-01.

Note to authors: You have been CC'd on this email so that you can know
that this review is going on. However, please do not review your own
document.

Reviews should comment on whether the document is coherent, is it
useful (ie, is it likely to be actually useful in operational
networks), and is the document technically sound?  We are interested
in knowing whether the document is ready to be considered for WG
adoption (ie, it doesn't have to be perfect at this point, but should be
a good start).

Reviews should be sent to the document authors, WG co-chairs and
WG secretary, and CC'd to the MPLS WG email list. If necessary, comments
may be sent privately to only the WG chairs.

Are you able to review this draft by April 2, 2013?

Thanks, Loa
(as MPLS WG chair)

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consult)        phone: +46 739 81 21 64

---

From: Mach Chen <[email-masked]>
Date: Mon, 1 Apr 2013 03:05:52 +0000

Hi, 

I have done my MPLS-RT review of draft-lim-mpls-proxy-lsp-ping.

I think the draft is useful and could be considered for WG adoption. 

Here are some comments about the draft:

1. In the draft, "Objects" and "sub-objects" are widely used to identify the LSP Ping parameters, this does not align with the convention of the LSP Ping related terminologies (where it uses TLVs or sub-TLVs). So, it's better to change the related terminologies back to TLVs or sub-TLVs. 

2. There are many acronyms that need to be expanded on their first use. 

3. Section 5.1.  Proxy Echo Parameters Object

            Address Family   Type     Length
                 IPv4          1         4
                 IPv6          3        16 
What's the type 2 reserved for?

4. Section 5.4.  Downstream Neighbor Address Object 
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |Dnst Addr Type |Local Addr Type|       MUST be Zero            |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
It defines both destination and Local address types, does it mean that the destination and local address types may be different? Can you please clarify how this will happen? In addition, section 5.3 has the similar situation. 

5. Section 5.1.1
"
Types 5 and 6 are intended to be populated from the local
              address information obtained from a previously returned
              Previous Hop Address Object."
Where is the "Previous Hop Address Object" defined? A reference may need here.

In addition, for the "Next Hop Interface", how does the ingress get the "Next Hop Interface"?

6. Section 5.2 Reply-to Address Object
   " Used to specify the MPLS echo request IP source address.  This
   address must be IP reachable via the Proxy LSR otherwise it will be
   rejected." 
Is the "must be IP reachable via the Proxy LSR" for security reason?

7. Section 5.1.  Proxy Echo Parameters Object
It defines a Destination IP Address field, according to the description in Section 3.1 
"The Destination IP Address is set to the value to be used in
   the MPLS echo request packet.  If the Address Type is IPv4, an
   address is from the range 127/8.  If the Address Type is IPv6, an
   address is from the range ::FFFF:7F00:0/104."
Seems that the " Destination IP Address" is bit redundant here, the proxy LSR can infer the Destination IP Address from the Address type. 

8. This draft mainly discusses LSP Ping using IP encapsulation, is there plan to support proxy LSP Ping using non-IP encapsulation? 

9. The defines Proxy LSP Request and Proxy LSP Reply messages and their related processing, from the current draft, it borrows/reuses the return code and sub return code, is this the intention? Or you may need to define the dedicated error code for the messages. For example " Malformed Proxy Ping request received" other than " Malformed echo request received".

Best regards,
Mach

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Tuesday, March 12, 2013 2:15 AM
> To: Mach Chen; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; Martin Vigoureux;
> Subject: MPLS-RT review of draft-lim-mpls-proxy-lsp-ping
> 
> 
> 
> 
> 
> 
> Dave, Wu, Wim and Mach,
>