Subject: Re: [mpls] Segment routing to an external adjacency in MPLS (draft-filsfils-spring-segment-routing-mpls-00 )

From: Jafar Akhbarizadeh <[email-masked]>
Date: Tue, 4 Mar 2014 19:57:17 +0000

Hi,

I would highly appreciate some response to my question as we are in the process of adding segment-routing to our design.

Thanks,
Jafar Akhbari

Infrastructure and Networking / XGS
Broadcom Corporation

From: Jafar Akhbarizadeh
Sent: Thursday, February 27, 2014 6:18 PM
To: [email-masked]'; [email-masked]'
Cc: Shahram Davari; [email-masked]'
Subject: Segment routing to an external adjacency in MPLS (draft-filsfils-spring-segment-routing-mpls-00 )

Hello Ahmad and Stefano,

Section x in SR architecture draft (draft-filsfils-rtgwg-segment-routing-01) talks about allocating ADJ-SID to an external link across two AS's.
A use case is described for this case in section 4.1.3 of draft-filsfils-rtgwg-segment-routing-use-cases.
However, it is not clear how this 'external peering' should be implemented in MPLS. Should the SR label representing  the remote adjacency be swapped? What about the labels underneath it?
What assumptions must be made regarding MPLS support across the two AS's?
I believe a section needs to be added to segment-routing-mpls draft to address external peering.

Thanks,
Jafar Akhbari

Infrastructure and Networking / XGS
Broadcom Corporation

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 5 Mar 2014 13:50:28 +0000

Hi Jafar,

originally, the idea was to advertise external links into the IP 
(with a SID) so to transport the packet up to that external link 
and release it to the peer (by popping the adj-SID label 
corresponding to the link).

However, there are missing details and after re-reading this 
section I think it requires more work and more details need to 
be described especially in terms of label processing and 
assumptions so we will need to update that section.

Thanks.
s.

On Mar 4, 2014, at 8:57 PM, Jafar Akhbarizadeh wrote:
> Section x in SR architecture draft (draft-filsfils-rtgwg-segment-routing-01) talks about allocating ADJ-SID to an external link across two AS’s.
> However, it is not clear how this ‘external peering’ should be implemented in MPLS. Should the SR label representing  the remote adjacency be swapped? What about the labels underneath it?
> What assumptions must be made regarding MPLS support across the two AS’s?