Subject: [mpls] end of poll, RE: Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

From: Ross Callon <[email-masked]>
Date: Tue, 11 Mar 2014 15:19:59 +0000

Working Group,

This poll has been closed.  We have accepted the draft as an mpls working group document.

Could the authors please re-publish the draft with no other
changes than file-name, date and version as:

draft-ietf-mpls-p2mp-egress-protection-00

After this draft has been posted, the authors should then deal with the comments received during the call for adoption, following normal IETF processes.

Thanks, Ross
(as WG co-chair)

From: mpls [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Thursday, February 13, 2014 2:46 PM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

This is to start a poll on adopting draft-chen-mpls-p2mp-egress-protection-11
as an MPLS working group document. Since many of us will be in transit to the
IETF approximately two weeks from now, I will extent the poll by one week (so
that it will be a three week poll).

Please send your comments (support/not support) to the mpls working group
mailing list ([email-masked]<mailto:[email-masked]>).

This poll will end Friday March 7, 2014. Note that this is the Friday of the IETF,
and thus we will each need to plan our review of the document and response
around our travel plans and IETF activities.

Thanks, Ross

---

From: Ross Callon <[email-masked]>
Date: Tue, 11 Mar 2014 20:33:41 +0000

It has been pointed out that draft-chen-mpls-p2mp-egress-protection is actually about protection for RSVP signaled LSPs, and that it could apply to point-to-point in addition to point-to-multipoint.

For this reason the authors have suggested naming the WG draft:

                draft-ietf-mpls-rsvp-egress-protection-00

If there is any objection to this name, please reply to this email by the end of this week (Friday March 14).

Thanks, Ross
(as WG co-chair)

From: mpls [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Tuesday, March 11, 2014 11:20 AM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] end of poll, RE: Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

Working Group,

Thanks, Ross
(as WG co-chair)

From: mpls [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Thursday, February 13, 2014 2:46 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [mpls] Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

Thanks, Ross

---

From: Yimin Shen <[email-masked]>
Date: Tue, 11 Mar 2014 21:25:36 +0000

Hi,

I don't think this draft is suitable for RSVP point-to-point LSPs. This is because an RSVP point-to-point LSP may carry packets with an _inner_ label (e.g. a layer-2 or 3 VPN label, or any service label) which is allocated by the protected egress router and hence can only be handled by this router.  The draft doesn't provide a solution that can support a backup egress router to properly forward packets based on that inner label when the packets are re-rerouted to it.

This is unlike point-to-multipoint LSPs which normally carry IP packets or MPLS packets with upstream-assigned inner labels which we may assume to be known labels to backup egress routers.

>From this perspective, I think the draft should stay as "p2mp" specific.

Thanks,

Yimin Shen

From: mpls [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Tuesday, March 11, 2014 4:34 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] change of name, RE: end of poll, RE: Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

Thanks, Ross
(as WG co-chair)

Working Group,

Thanks, Ross
(as WG co-chair)

Thanks, Ross

---

From: Yimin Shen <[email-masked]>
Date: Fri, 14 Mar 2014 23:13:52 +0000

Hi chairs, authors,

To help make this draft more generic to cover P2P LSPs, I'd like to suggest the draft to differentiate the problems faced by P2MP LSPs and P2P LSPs, and also to discuss specifically the set of problems of P2P LSPs, which are imposed by inner labels (i.e. service labels).

Of course, a complete solution for P2P LSP egress protection will require extensions to Layer-2/3 VPN service label distribution protocols, which may be out of the scope of RSVP and this draft. However, since these extensions have already been addressed by some existing IETF work and drafts, this draft could refer to them in the text.

Thanks,

/Yimin

From: mpls [mailto:[email-masked]] On Behalf Of Yimin Shen
Sent: Tuesday, March 11, 2014 5:26 PM
To: Ross Callon; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls] change of name, RE: end of poll, RE: Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

Hi,

Thanks,

Yimin Shen

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Thanks, Ross
(as WG co-chair)

Working Group,

Thanks, Ross
(as WG co-chair)

Thanks, Ross

---

From: Huaimo Chen <[email-masked]>
Date: Sat, 15 Mar 2014 00:09:55 +0000

Hi Yimin,

Thanks much for your comments and suggestions!

     To change the file-name of the draft is to address the comment (I copy and paste it below) from MPLS RT member Eric Gray, who posted his comments in MPLS mailing list on Jan. 17, 2014.

                    I assume that the WG version will NOT include "p2mp" in the draft

name (i.e. - it would be more likely be "draft-ietf-mpls-egress-protection"

than "draft-ietf-mpls-p2mp-egress-protection").

The draft provides some solutions for protecting the egress of  a P2P LSP.

We will consider your suggestions to make the draft more generic.

Best Regards,
Huaimo
From: Yimin Shen [mailto:[email-masked]]
Sent: Friday, March 14, 2014 7:14 PM
To: Yimin Shen; Ross Callon; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: change of name, RE: end of poll, RE: Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

Hi chairs, authors,

Thanks,

/Yimin

To: Ross Callon; [email-masked]<mailto:[email-masked]>

Hi,

Thanks,

Yimin Shen

Thanks, Ross
(as WG co-chair)

Working Group,

Thanks, Ross
(as WG co-chair)

Thanks, Ross

---

From: Autumn Liu <[email-masked]>
Date: Sat, 15 Mar 2014 01:02:46 +0000

I am ok with the name change, and agree with Yimin that the egress protection of p2p LSP needs to be addressed specifically with the draft.
-Autumn

Sent: Friday, March 14, 2014 4:14 PM

Hi chairs, authors,

Thanks,

/Yimin

Hi,

Thanks,

Yimin Shen

Thanks, Ross
(as WG co-chair)

Working Group,

Thanks, Ross
(as WG co-chair)

Thanks, Ross

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 14 Mar 2014 18:12:12 -0700

I prefer the document cover both p2p and p2mp and keep the title without specifically mentioning p2p or p2mp.
If there is work to be done to make it generic, authors should edit the doc to reflect the same rather than making it p2mp specific.

cheers
-sam

On Mar 14, 2014, at 4:13 PM, Yimin Shen <[email-masked]> wrote:

> Hi chairs, authors,
>  
> To help make this draft more generic to cover P2P LSPs, I’d like to suggest the draft to differentiate the problems faced by P2MP LSPs and P2P LSPs, and also to discuss specifically the set of problems of P2P LSPs, which are imposed by inner labels (i.e. service labels).
>  
> I don’t think this draft is suitable for RSVP point-to-point LSPs. This is because an RSVP point-to-point LSP may carry packets with an _inner_ label (e.g. a layer-2 or 3 VPN label, or any service label) which is allocated by the protected egress router and hence can only be handled by this router.  The draft doesn’t provide a solution that can support a backup egress router to properly forward packets based on that inner label when the packets are re-rerouted to it.
>  
> From this perspective, I think the draft should stay as “p2mp” specific.
>  
> Thanks,
>  
> Yimin Shen
>  
>  
> mailing list ([email-masked]).
>  
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Ross Callon <[email-masked]>
Date: Mon, 17 Mar 2014 00:56:46 +0000

Working Group,

This poll for adoption has been closed, and the poll on the potential name change has also concluded.  We have accepted the draft as an mpls working group document, and have accepted the change of the internet draft name.

Could the authors please re-publish the draft (draft-chen-mpls-p2mp-egress-protection-11) with no other
changes than file-name, date and version as:

After this draft has been posted, the authors should then deal with the comments received during the call for adoption and during the poll regarding the name change, following normal IETF processes.

Thanks, Ross
(as WG co-chair)

From: Ross Callon
Sent: Tuesday, March 11, 2014 4:34 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: change of name, RE: end of poll, RE: Poll for Adoption draft-chen-mpls-p2mp-egress-protection-11

Thanks, Ross
(as WG co-chair)

Working Group,

Thanks, Ross
(as WG co-chair)

Thanks, Ross