Subject: [mpls] Early AD comments on draft-ietf-mpls-psc-updates

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Mar 2014 18:43:58 -0000

Hi Eric,

A couple of discussion points on draft-ietf-mpls-tp-psc-itu (which is currently
in IESG evaluation) have given rise to two small proposed additions to
draft-ietf-mpls-psc-updates

1. I think this warrants a very small section of its own...

x.y  PSC TLV Format

[RFC6378] defines the capability to carry TLVs in the PSC messages. This section
defines the format to be used by all such TLVs.

Type field (T)
A two octet field that encodes a type value in network byte order. The type
values are recorded in the IANA registry "MPLS PSC TLV Registry".

Length field (L)
A two octet field that encodes the length in octets of the Value field in
network byte order. The value of this field MUST be a multiple of 4.

Value field (V)
The contents of the TLV. This field MUST be a multiple of 4 octets and so may
contain explicit padding.

2. There was a trivial snafu with the 0 value in the "MPLS PSC TLV Registry". It
was agreed that 0 would be reserved, but this was not recorded in RFC 6378.
Therefore, the IANA section of draft-ietf-mpls-psc-updates should include the
text...

IANA is requested to mark the value 0 in the "MPLS PSC TLV Registry" as
"Reserved, not to be allocated" and to update the references to show [RFC6378].
[This.I-D].  Note that this action provides documentation of an action already
taken by IANA but not recorded in RFC 6378.

Hope everyone is comfortable with this.

Thanks,
Adrian

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 17 Mar 2014 20:32:51 +0100

Hello Adrian,

I support these additions.

Cheers, Huub.

===========

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: Eric Osborne <[email-masked]>
Date: Thu, 20 Mar 2014 10:38:34 -0400

Hi Adrian-

  Thanks for these.  I am OK with them and will add them to the
version I post next. I'm not clear on the nuances of your IANA text,
though.  You say:

---
IANA is requested to mark the value 0 in the "MPLS PSC TLV Registry"
as "Reserved, not to be allocated" and to update the references to
show [RFC6378].
[This.I-D].  Note that this action provides documentation of an action
already taken by IANA but not recorded in RFC 6378.
---

What exactly does the [This.I-D] do in its own sentence?  Did you mean
something like " update the references to show [RFC6378] and
[This.I-D].  Note that this action..." or is there something subtle
I'm not picking up on with your original phrasing?

eric

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 20 Mar 2014 16:01:00 -0000

Yes, you're right. Should be a comma not a period.

A

> -----Original Message-----
> From: Eric Osborne [mailto:[email-masked]]
> Sent: 20 March 2014 14:39
> To: Adrian Farrel
> Cc: Eric Osborne; [email-masked]
> Subject: Re: Early AD comments on draft-ietf-mpls-psc-updates
> 
> Hi Adrian-
> 
> 
> 
already

---

From: Eric Osborne <[email-masked]>
Date: Thu, 20 Mar 2014 12:17:30 -0400

OK.
Loa's suggestion is

"... update the reference to RFC 6378 to say [this ID]"

Adrian's is "...update the references to show [RFC6378], [This ID]".

I think Loa's makes more sense...why would we have the registry
allocation point to both 6378 and thisID if 6378 doesn't say anything?

Whatever text you guys agree on, I'll use.

eric

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 20 Mar 2014 16:26:23 -0000

The action was taken for RFC 6378, so it should be mentioned.

> Sent: 20 March 2014 16:18
> To: Adrian Farrel

---

From: Loa Andersson <[email-masked]>
Date: Thu, 20 Mar 2014 17:36:49 +0100

Folks,

I can live with the:
"...update the references to show [RFC6378], [This ID]".

It is correct that the action was taken for RFC 6378, but it is
also correct that it was never mentioned in RFC 6378. So I guess
that what we need to say is:

"IANA is requested to mark the value 0 in the "MPLS PSC TLV Registry"
  as "Reserved, not to be allocated" and to update the references to
  show [RFC6378], [This.I-D].  Note that this action provides
  documentation of an action already taken by IANA but not recorded
  in RFC 6378. This is an update to RFC 6378."

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Eric Osborne <[email-masked]>
Date: Fri, 21 Mar 2014 07:44:51 -0400

OK.  Here's the exact text I've got:

--
8.  IANA Considerations

   IANA is requested to mark the value 0 in the "MPLS PSC TLV Registry"
   as "Reserved, not to be allocated" and to update the references to
   show [RFC6378] and [RFC-ietf-mpls-psc-updates-03].  Note that this
   action provides documentation of an action already taken by IANA but
   not recorded in RFC 6378.

   Note to RFC Editor: this section may be removed on publication as an
   RFC
---

I wasn't sure if [This.ID] was intended to provoke variable
substitution, nor was I sure whether the square brackets meant that
the self-reference should also be a normative reference (to the
eventual This.RFC).  It seems overkill for a document to cite itself
as a normative reference ("in order to understand this document, you
should read it")...but on the other hand, perhaps we should start
doing that for all drafts that come out of MPLS now.

I took the exact formatting from the reference section of the MPLS PSC
TLV Registry, which does it like this:

---
Reference
  [RFC6378][RFC-ietf-mpls-moving-iana-registries-04]
---

and I did not cite the draft itself in its normative reference section.

Please let me know if this exact text is acceptable and then I will
post the draft.

eric

On Thu, Mar 20, 2014 at 12:36 PM, Loa Andersson <[email-masked]> wrote:
>>>>> On Mon, Mar 17, 2014 at 2:43 PM, Adrian Farrel <[email-masked]>
>>>
>>> wrote:
>>>>>>
>>>>>> Hi Eric,
>>>>>>
>>>>>> A couple of discussion points on draft-ietf-mpls-tp-psc-itu (which is
>>>>
>>>> currently
>>>>>>
>>>>>> [RFC6378] defines the capability to carry TLVs in the PSC messages.
>>>>>> This
>>>>
>>>> section
>>>>>>
>>>>>> A two octet field that encodes a type value in network byte order. The
>>
>> type
>>>>>>
>>>>>> The contents of the TLV. This field MUST be a multiple of 4 octets and
>>>>>> so
>>>>
>>>> may
>>>>>>
>>>>>> 2. There was a trivial snafu with the 0 value in the "MPLS PSC TLV
>>>>
>>>> Registry". It
>>>>>>
>>>>>> was agreed that 0 would be reserved, but this was not recorded in RFC
>>
>> 6378.
>>>>>>
>>>>>> Therefore, the IANA section of draft-ietf-mpls-psc-updates should
>>>>>> include
>>>>
>>>> the
>>>>>>
>>>>>> text...
>>>>>>
>>>>>> as
>>>>>> "Reserved, not to be allocated" and to update the references to show
>>>>>
>>>>> [RFC6378].
>>>>>>

---

From: Loa Andersson <[email-masked]>
Date: Fri, 21 Mar 2014 12:52:35 +0100

Folks,

I'm OK with that text, however it is a documentation of change to a
standards track RFC. I'm not sure that it is a good idea to ask the
RFC Editor to remove the text.

I think the RFC Editor will change it to "IANA has marked the
value 0 ..." I think this should stay in the document.

/Loa

--

---

From: Eric Osborne <[email-masked]>
Date: Fri, 21 Mar 2014 09:40:16 -0400

OK, so:

---
8.  IANA Considerations

   not recorded in RFC 6378
---

Adrian?

eric

On Fri, Mar 21, 2014 at 7:52 AM, Loa Andersson <[email-masked]> wrote:
>>>>>>>> A two octet field that encodes the length in octets of the Value
>>>>>>>> field
>>>>>>>> in

---

From: Loa Andersson <[email-masked]>
Date: Fri, 21 Mar 2014 14:47:16 +0100

wfm

/Loa

--

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 21 Mar 2014 21:34:25 -0000

Yes.

You can use [This.I-D] or the formulation you have.

Please post.

Thanks,
Adrian

> Sent: 21 March 2014 13:40
> To: Loa Andersson
> Cc: Adrian Farrel; Eric Osborne; [email-masked]
> Subject: Re: [mpls] Early AD comments on draft-ietf-mpls-psc-updates
> 
> OK, so:
> 
> ---
> 8.  IANA Considerations
>