Subject: [mpls] Clarification on source label usage

From: Mach Chen <[email-masked]>
Date: Tue, 18 Mar 2014 00:51:35 +0000

Hi MPLSers,

Yesterday, there are a lots of discussions on source label, thanks for the discussions. I'd like to make a clarification on the usage of source label, I think there may be a  misunderstanding of the usage of source label. The main purpose for MPLS source label is OAM, source label applies to real packets is optional.

Best regards,
Mach

---

From: Binny Jeshan <[email-masked]>
Date: Tue, 18 Mar 2014 09:00:58 +0200

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

On 18 March 2014 02:51, Mach Chen <[email-masked]> wrote:

>  Hi MPLSers,
>
>
>
> Yesterday, there are a lots of discussions on source label, thanks for the
> discussions. I'd like to make a clarification on the usage of source label,
> I think there may be a  misunderstanding of the usage of source label. The
> main purpose for MPLS source label is OAM, source label applies to real
> packets is optional.
>
>
>
>
>
> Best regards,
>
> Mach
>
>
>
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>
>

---

From: Mach Chen <[email-masked]>
Date: Wed, 19 Mar 2014 08:52:14 +0000

Hi Binny,

No,  G-Ach works fine.

The OAM I mentioned mainly refers to the performance measurement(passive) that is listed as the first use case in the draft, the source label is used for flow identification.

Best regards,
Mach

From: Binny Jeshan [mailto:[email-masked]]
Sent: Tuesday, March 18, 2014 3:01 PM
To: Mach Chen
Cc: [email-masked]
Subject: Re: [mpls] Clarification on source label usage

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

On 18 March 2014 02:51, Mach Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi MPLSers,

Best regards,
Mach

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: Shahram Davari <[email-masked]>
Date: Wed, 19 Mar 2014 14:16:59 +0000

Hi

For flow identification. You could use a MEPID inside the OAM message. Why do you need another label?

Regards,
Shahram

On Mar 19, 2014, at 1:52 AM, "Mach Chen" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Binny,

No,  G-Ach works fine.

Best regards,
Mach

From: Binny Jeshan [mailto:[email-masked]]
Sent: Tuesday, March 18, 2014 3:01 PM
To: Mach Chen
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] Clarification on source label usage

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

Yesterday, there are a lots of discussions on source label, thanks for the discussions. I’d like to make a clarification on the usage of source label, I think there may be a  misunderstanding of the usage of source label. The main purpose for MPLS source label is OAM, source label applies to real packets is optional.

Best regards,
Mach

---

From: Mach Chen <[email-masked]>
Date: Thu, 20 Mar 2014 14:43:10 +0000

Hi Shahram,

Because there are requirements to perform Passive performance measurement, that means to measure the performance of the real traffic, not the performance of the OAM packets.

Best regards,
Mach

From: Shahram Davari [mailto:[email-masked]]
Sent: Wednesday, March 19, 2014 10:17 PM
To: Mach Chen
Cc: Binny Jeshan; [email-masked]
Subject: Re: [mpls] Clarification on source label usage

Hi

Regards,
Shahram

No,  G-Ach works fine.

Best regards,
Mach

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

Best regards,
Mach

---

From: Shahram Davari <[email-masked]>
Date: Thu, 20 Mar 2014 14:51:50 +0000

Hi

So you want source label for data traffic so that you can do direct loss measurement instead of synthetic loss measurement. Is that correct?

If so then this statement is not correct:

"The main purpose for MPLS source label is OAM, source label applies to real packets is optional."

So

Regards,
Shahram

On Mar 20, 2014, at 7:43 AM, "Mach Chen" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Shahram,

Best regards,
Mach

From: Shahram Davari [mailto:[email-masked]]
Sent: Wednesday, March 19, 2014 10:17 PM
To: Mach Chen
Cc: Binny Jeshan; [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] Clarification on source label usage

Hi

Regards,
Shahram

No,  G-Ach works fine.

Best regards,
Mach

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

Best regards,
Mach

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 20 Mar 2014 15:35:39 +0000

Hi Shahram,
synthetic loss measurement is for out-of-service scenario. Use of SLI/SL enables passive performance measurement of not only loss but delay and delay variation on live traffic. That does not require that SLI/SL be always inserted in data traffic, not that even all packets be marked with it. I can refer you to draft-chen-ippm-coloring-based-ipfpm-framework for more clues on how SLI/SL may be used for passive performance measurement.

I think that given that, the statement is accurate.

                Regards,
                                Greg

From: mpls [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Thursday, March 20, 2014 7:52 AM
To: Mach Chen
Cc: [email-masked]
Subject: Re: [mpls] Clarification on source label usage

Hi

So

Regards,
Shahram

Best regards,
Mach

Hi

Regards,
Shahram

No,  G-Ach works fine.

Best regards,
Mach

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

Best regards,
Mach

---

From: Mach Chen <[email-masked]>
Date: Fri, 21 Mar 2014 08:11:51 +0000

Agree.

Best regards,
Mach

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Thursday, March 20, 2014 11:36 PM
To: Shahram Davari; Mach Chen
Cc: [email-masked]
Subject: RE: [mpls] Clarification on source label usage

Hi Shahram,

                Regards,
                                Greg

Hi

So

Regards,
Shahram

Best regards,
Mach

Hi

Regards,
Shahram

No,  G-Ach works fine.

Best regards,
Mach

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

Best regards,
Mach

---

From: Shahram Davari <[email-masked]>
Date: Fri, 21 Mar 2014 14:15:10 +0000

Greg

Let's not play with words. You are adding SLI/SL on customer data packets. This means the SLI/SL is not applied to only OAM packets. In fact you are not using any OAM packet to do LM /DM.

You can argue that this is in demand and does not run all the time but our experience shows many providers run LM/DM proactively since they use it as Signal degrade for protection switching.

Regards,
Shahram

On Mar 20, 2014, at 8:35 AM, "Gregory Mirsky" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Shahram,

                Regards,
                                Greg

Hi

So

Regards,
Shahram

Best regards,
Mach

Hi

Regards,
Shahram

No,  G-Ach works fine.

Best regards,
Mach

Mach,

Do you mean the G-Ach ?

Regards,
Binny.

Aricent

Best regards,
Mach