Subject: [mpls] MPLS IEs in IANA's IP Flow Information Export (IPFIX) Entities registry

From: Gregory Mirsky <[email-masked]>
Date: Wed, 10 Sep 2014 19:22:51 +0000

Dear All,
in several places of describing MPLS Label element IEs the registry still refers to the EXP field even though the RFC 5462 updated RFC 3032 and renamed it "Traffic Class" (TC). Below is the list of IEs that may benefit from updating Description and Reference information:

*         mplsTopLabelStackSection

*         mplsTopLabelStackSection2

*         mplsTopLabelStackSection3

*         mplsTopLabelStackSection4

*         mplsTopLabelStackSection5

*         mplsTopLabelStackSection6

*         mplsTopLabelStackSection7

*         mplsTopLabelStackSection8

*         mplsTopLabelStackSection9

*         mplsTopLabelStackSection10

*         mplsTopLabelExp (should this be deprecated and mplsTopLabelTc be created instead?)

*         postMplsTopLabelExp (should this be deprecated and postMplsTopLabelTc be created instead?)

Regards,
        Greg

---

From: Loa Andersson <[email-masked]>
Date: Fri, 19 Sep 2014 11:28:41 +0200

Greg,

I'm not sure about this - would changing the names require updating all
existing deployed MIBs?

Can we get an mib doctor advice on this?

/Loa

On 2014-09-10 21:22, Gregory Mirsky wrote:
> Dear All,
>
> in several places of describing MPLS Label element IEs the registry
> still refers to the EXP field even though the RFC 5462 updated RFC 3032
> and renamed it “Traffic Class” (TC). Below is the list of IEs that may
> benefit from updating Description and Reference information:
>
> ·mplsTopLabelStackSection
>
> ·mplsTopLabelStackSection2
>
> ·mplsTopLabelStackSection3
>
> ·mplsTopLabelStackSection4
>
> ·mplsTopLabelStackSection5
>
> ·mplsTopLabelStackSection6
>
> ·mplsTopLabelStackSection7
>
> ·mplsTopLabelStackSection8
>
> ·mplsTopLabelStackSection9
>
> ·mplsTopLabelStackSection10
>
> ·mplsTopLabelExp (should this be deprecated and mplsTopLabelTc be
> created instead?)
>
> ·postMplsTopLabelExp (should this be deprecated and postMplsTopLabelTc
> be created instead?)
>
> Regards,
>
>          Greg
>
>
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 19 Sep 2014 09:45:05 +0000

Hi Loa,
I haven't thought of possible impact of RFC 5462 to existing MIBs nor I've checked for it.

	Regards,
		Greg

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Friday, September 19, 2014 10:29 AM
To: Gregory Mirsky; [email-masked]
Cc: [email-masked]; MIB Doctors (E-mail)
Subject: Re: [mpls] MPLS IEs in IANA's IP Flow Information Export (IPFIX) Entities registry

Greg,

I'm not sure about this - would changing the names require updating all existing deployed MIBs?

/Loa

On 2014-09-10 21:22, Gregory Mirsky wrote:
> still refers to the EXP field even though the RFC 5462 updated RFC 
> 3032 and renamed it "Traffic Class" (TC). Below is the list of IEs 
> that may benefit from updating Description and Reference information:
>
> *mplsTopLabelStackSection
>
> *mplsTopLabelStackSection2
>
> *mplsTopLabelStackSection3
>
> *mplsTopLabelStackSection4
>
> *mplsTopLabelStackSection5
>
> *mplsTopLabelStackSection6
>
> *mplsTopLabelStackSection7
>
> *mplsTopLabelStackSection8
>
> *mplsTopLabelStackSection9
>
> *mplsTopLabelStackSection10
>
> *mplsTopLabelExp (should this be deprecated and mplsTopLabelTc be 
> created instead?)
>
> *postMplsTopLabelExp (should this be deprecated and postMplsTopLabelTc 
> be created instead?)
>
> Regards,
>
>          Greg
>
>
>

--

---

From: t.petch <[email-masked]>
Date: Fri, 19 Sep 2014 12:49:57 +0100

----- Original Message -----
From: "Loa Andersson" <[email-masked]>
To: "Gregory Mirsky" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; "MIB Doctors (E-mail)" <[email-masked]>
Sent: Friday, September 19, 2014 10:28 AM

Greg,

<tp>

Yes. See RFC2578 s.10.  You cannot reuse an OID so this would need a new
OID; messy, best left as one of those quaint, historic anomalies that
litter our work.

Updating the DESCRIPTION and REFERENCE is not a problem  (but issuing
any MIB module is a lot of work).

Tom Petch
[not a MIB doctor]

/Loa

> still refers to the EXP field even though the RFC 5462 updated RFC
3032

--

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 19 Sep 2014 11:53:36 +0200

Hi,

IEs are not used by MIB modules. Not sure this is relevant but
according to SMIv2 rules, you can't rename a Textual Convention (TC).
All you can do is create a new one and deprecate the old one. The
question is whether doing this is worth anything.

/js

On Fri, Sep 19, 2014 at 11:28:41AM +0200, Loa Andersson wrote:
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "ietfdbh" <[email-masked]>
Date: Sun, 21 Sep 2014 00:30:16 -0400

Updating the description would be a problem if you change the semantics of
the object.

David Harrington
[email-masked]
+1-603-828-1401
> From: MIB-DOCTORS [mailto:[email-masked]] On Behalf Of
> t.petch
> Sent: Friday, September 19, 2014 7:50 AM
> To: Loa Andersson; Gregory Mirsky; [email-masked]
> Subject: Re: [MIB-DOCTORS] [mpls] MPLS IEs in IANA's IP Flow Information
> Export (IPFIX) Entities registry
> 
> > and renamed it "Traffic Class" (TC). Below is the list of IEs that may
> > .mplsTopLabelStackSection
> >
> > .mplsTopLabelStackSection2
> >
> > .mplsTopLabelStackSection3
> >
> > .mplsTopLabelStackSection4
> >
> > .mplsTopLabelStackSection5
> >
> > .mplsTopLabelStackSection6
> >
> > .mplsTopLabelStackSection7
> >
> > .mplsTopLabelStackSection8
> >
> > .mplsTopLabelStackSection9
> >
> > .mplsTopLabelStackSection10
> >
> > .mplsTopLabelExp (should this be deprecated and mplsTopLabelTc be
> > created instead?)
> >
> > .postMplsTopLabelExp (should this be deprecated and postMplsTopLabelTc
> > be created instead?)
> >
> > Regards,
> >
> >          Greg
> >
> >
> >

---

From: Benoit Claise <[email-masked]>
Date: Mon, 22 Sep 2014 14:25:16 +0200

We could argue whether the semantic was actually changed since the EXP 
bits were used for QoS.
Anyway, let's quote Jürgen: "The question is whether doing this is worth 
anything.". I'm not convinced...

Regards, Benoit
> .