Subject: [mpls] I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt

From: [email-masked]
Date: Wed, 17 Sep 2014 06:53:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

        Title           : IPv6 Router Alert Option for MPLS OAM
        Authors         : Kamran Raza
                          Nobo Akiya
                          Carlos Pignataro
	Filename        : draft-raza-mpls-oam-ipv6-rao-01.txt
	Pages           : 5
	Date            : 2014-09-17

Abstract:
   RFC4379 defines the MPLS LSP Ping/Traceroute mechanism, in which the
   Router Alert option must be set in the IP header of the MPLS Echo
   Request messages, and may conditionally be set in the IP header of
   the MPLS Echo Reply messages.  While a generic "Router shall examine
   packet" Option Value is used for the IPv4 Router Alert Option (RAO),
   there is no generic Router Alert Option Value defined for IPv6 that
   can be used.  This document allocates a new generic IPv6 Router Alert
   Option Value that can be used by MPLS OAM tools, including the MPLS
   Echo Request and MPLS Echo Reply messages for MPLS IPv6.

   The initial motivation to request an IPv6 Router Alert Option (RAO)
   code point for MPLS OAM comes from MPLS LSP Ping/Traceroute.
   However, this codepoint is applicable to all MPLS OAM and not limited
   to MPLS LSP Ping/Traceroute.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-raza-mpls-oam-ipv6-rao/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-raza-mpls-oam-ipv6-rao-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-raza-mpls-oam-ipv6-rao-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Lizhong Jin" <[email-masked]>
Date: Tue, 30 Sep 2014 22:55:59 +0800

Hi Loa, authors,
I review this document. It is a short document, and is usefull and technically sound. And I believe it is ready for adoption.
One small comment is the name of the option value. MPLS OAM is a general term, not a special protocol. Currently IPv6 RAO is only defined for special protocol. My concern is, it seems all kinds of future MPLS OAM protocols are required to use the option value defined in this draft, which may not be a good choice for them.

Regards
Lizhong Jin
 
From: Loa Andersson
Date: 2014-09-17 23:58
To: Osborne, Eric; Lizhong Jin; Dutta, Pranjal K (Pranjal); Eric Gray; [email-masked]; VIGOUREUX, MARTIN (MARTIN)
Subject: MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Eric, Lizhong, Pranjal and Eric,
 
You have be selected as MPLS-RT reviewers for draft-raza-mpls-
oam-ipv6-rao.
 
Note to authors: You have been CC'd on this email so that you can know
that this review is going on. However, please do not review your own
document.
 
Reviews should comment on whether the document is coherent, is it
useful (ie, is it likely to be actually useful in operational
networks), and is the document technically sound?  We are interested
in knowing whether the document is ready to be considered for WG
adoption (ie, it doesn't have to be perfect at this point, but should be
a good start).
 
Reviews should be sent to the document authors, WG co-chairs and
WG secretary, and CC'd to the MPLS WG email list. If necessary, comments
may be sent privately to only the WG chairs.
 
If you have technical comments you should try to be explicit about what
*really* need to be resolved before adopting it as a working group
document, and what can wait until the document is a working group
document and the working group has the revision control.
 
Are you able to review this draft by Oct 1, 2014? Please respond in a
timely fashion. 

Thanks, Loa
(as MPLS WG chair)

-------- Original Message --------
Subject: I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Date: Wed, 17 Sep 2014 06:53:44 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]
CC: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
  This draft is a work item of the Multiprotocol Label Switching Working 
Group of the IETF.

Abstract:

 

 
 
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 30 Sep 2014 14:59:39 +0000

Thanks, Lizhong!

Future MPLS OAM protocols are not required to use this RAO value, but this is available for them to use.

The text currently says:

Thanks,

Carlos.

From: Lizhong Jin <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 30, 2014 at 10:55 AM
To: Loa Andersson <[email-masked]<mailto:[email-masked]>>, "eric.osborne" <[email-masked]<mailto:[email-masked]>>, "pranjal.dutta" <[email-masked]<mailto:[email-masked]>>, "eric.gray" <[email-masked]<mailto:[email-masked]>>, mpls-chairs <[email-masked]<mailto:[email-masked]>>, Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Cc: draft-raza-mpls-oam-ipv6-rao <[email-masked]<mailto:[email-masked]>>, mpls <[email-masked]<mailto:[email-masked]>>
Subject: Re: MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Carlos Pignataro <[email-masked]<mailto:[email-masked]>>, Nobo Akiya <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Loa Andersson <[email-masked]<mailto:[email-masked]>>, Ross Callon <[email-masked]<mailto:[email-masked]>>, Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Resent-Date: Tuesday, September 30, 2014 at 10:56 AM

Hi Loa, authors,

________________________________
Regards
Lizhong Jin

From: Loa Andersson<mailto:[email-masked]>
Date: 2014-09-17 23:58
To: Osborne, Eric<mailto:[email-masked]>; Lizhong Jin<mailto:[email-masked]>; Dutta, Pranjal K (Pranjal)<mailto:[email-masked]>; Eric Gray<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; VIGOUREUX, MARTIN (MARTIN)<mailto:[email-masked]>
Subject: MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Eric, Lizhong, Pranjal and Eric,

Thanks, Loa
(as MPLS WG chair)

-------- Original Message --------
Subject: I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Date: Wed, 17 Sep 2014 06:53:44 -0700
From: [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Abstract:

[email-masked]<mailto:[email-masked]>

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 30 Sep 2014 15:10:51 +0000

Lizhong Jin hi,
Regarding your comment on the option value name (I assume that this is what you have in mind, if ):
Please notice that in the case of IPv4, the (intended) name of the option is "Router shall examine the packet".
This is vague enough IMO to cover multiple protocols. All the rest of specific values deal with nested reservations.
So, I'd say that the IPv6 Router Alert Option value name that says "MPLS OAM" sounds good enough, especially since the draft explicitly claims (in the Introduction) that this value is applicable to all MPLS OAM protocols.

My 2c,
       Sasha
Email: [email-masked]
Mobile: 054-9266302

From: mpls [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Tuesday, September 30, 2014 5:56 PM
To: loa; eric.osborne; pranjal.dutta; eric.gray; mpls-chairs; martin.vigoureux
Cc: mpls; draft-raza-mpls-oam-ipv6-rao
Subject: Re: [mpls] MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt

Hi Loa, authors,

Thanks, Loa
(as MPLS WG chair)

-------- Original Message --------
Subject: I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Date: Wed, 17 Sep 2014 06:53:44 -0700
From: [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Abstract:

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 30 Sep 2014 15:22:34 +0000

Yes, thanks Sasha. That’s exactly what authors had noted and that led to the current definition of “MPLS OAM” which is not as generic as IPv4 and not very specific/limited to leave room open for others to reuse it, if they will.

Thx
-
Kamran
(As a co-author)

From: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 30, 2014 at 11:10 AM
To: Lizhong Jin <[email-masked]<mailto:[email-masked]>>
Cc: mpls <[email-masked]<mailto:[email-masked]>>, draft-raza-mpls-oam-ipv6-rao <[email-masked]<mailto:[email-masked]>>, mpls-chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mpls] MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt

Lizhong Jin hi,
Regarding your comment on the option value name (I assume that this is what you have in mind, if ):
Please notice that in the case of IPv4, the (intended) name of the option is “Router shall examine the packet”.
This is vague enough IMO to cover multiple protocols. All the rest of specific values deal with nested reservations.
So, I’d say that the IPv6 Router Alert Option value name that says “MPLS OAM” sounds good enough, especially since the draft explicitly claims (in the Introduction) that this value is applicable to all MPLS OAM protocols.

My 2c,
       Sasha
Email: [email-masked]<mailto:[email-masked]>
Mobile: 054-9266302

Hi Loa, authors,

Thanks, Loa
(as MPLS WG chair)

-------- Original Message --------
Subject: I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Date: Wed, 17 Sep 2014 06:53:44 -0700
From: [email-masked]<mailto:[email-masked]>
Reply-To: [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Abstract:

---

From: "Lizhong Jin" <[email-masked]>
Date: Wed, 1 Oct 2014 00:13:25 +0800

OK, since it is very loose, leave it as it is.

Regards
Lizhong Jin
 
From: Carlos Pignataro (cpignata)
Date: 2014-09-30 22:59
To: Lizhong Jin; loa; eric.osborne; pranjal.dutta; eric.gray; mpls-chairs; martin.vigoureux
CC: draft-raza-mpls-oam-ipv6-rao; mpls
Subject: Re: MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Thanks, Lizhong!

The text currently says:

Carlos.

From: Lizhong Jin <[email-masked]>
Date: Tuesday, September 30, 2014 at 10:55 AM
To: Loa Andersson <[email-masked]>, "eric.osborne" <[email-masked]>, "pranjal.dutta" <[email-masked]>, "eric.gray" <[email-masked]>, mpls-chairs <[email-masked]>, Martin Vigoureux <[email-masked]>
Cc: draft-raza-mpls-oam-ipv6-rao <[email-masked]>, mpls <[email-masked]>
Subject: Re: MPLS-RT review of I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Resent-From: <[email-masked]>
Resent-To: Carlos Pignataro <[email-masked]>, Nobo Akiya <[email-masked]>, <[email-masked]>, <[email-masked]>, Loa Andersson <[email-masked]>, Ross Callon <[email-masked]>, Martin Vigoureux <[email-masked]>
Resent-Date: Tuesday, September 30, 2014 at 10:56 AM

Hi Loa, authors,

Regards
Lizhong Jin
 
From: Loa Andersson
Date: 2014-09-17 23:58

 

 

Thanks, Loa
(as MPLS WG chair)

-------- Original Message --------
Subject: I-D Action: draft-raza-mpls-oam-ipv6-rao-01.txt
Date: Wed, 17 Sep 2014 06:53:44 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]
CC: [email-masked]

 
Abstract: