Subject: [mpls] draft-kompella-mpls-rmr-00

From: Xuxiaohu <[email-masked]>
Date: Wed, 12 Nov 2014 21:33:37 +0000

Hi Kireeti,

I have read your draft and found it's very interesting.

I wonder whether it's possible to introduce the idea of the RPR (Resilient Packet Ring) technology into the MPLS-enabled ring networks. For instance, for a given node on a ring, it has two types of interfaces, one is ring-interface and the other is non-ring-interface. In addition, the ring-interface is either eastward or westward. When receiving an MPLS packet from a non-ring interface, if the next-hop of that MPLS packet is one of its adjacent peers on the ring, it would impose a label indicating clock-wise forwarding or count-clock-wise forwarding accordingly. When receiving an MPLS packet with the top label being the label indicating clock-wise or counter-clock-wise forwarding, unless the next-hop of the FEC which is indicated by the label below that top label is itself or a peer which is connected via a non-ring interface (i.e., the packet would pop off the ring), that packet should be forwarding according to the top label, e.g., if the top label indicates clock-wise forwarding, it would be forwarded in the clock-wise direction.

The label indicating clock-wise or count-clock-wise forwarding could be an SPL or a local label which is advertised by each ring node. If that label is a local label, it should be swapped accordingly on each hop of the ring. When the packet received from a adjacent peer on the ring should pop off that ring, the top label indicating clock-wise or count-clock-wise forwarding should be stripped before performing the further MPLS forwarding process.

Best regards,
Xiaohu

---

From: Huub van Helvoort <[email-masked]>
Date: Thu, 13 Nov 2014 17:02:17 +0100

Hello Xuxiaohu, 您好

You wrote:

> I have read your draft and found it’s very interesting.
>
> I wonder whether it’s possible to introduce the idea of the RPR
> (Resilient Packet Ring) technology into the MPLS-enabled ring networks.

RPR is designed specifically for connectionless technologies
like native Ethernet and IP.

MPLS is connection oriented, applying RPR may be very complex.

祝好，best regards, Huub.

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: "Osborne, Eric" <[email-masked]>
Date: Thu, 13 Nov 2014 16:38:20 +0000

MPLS-TE and -TP are connection oriented.  LDP is not; if RPR works for IP it ought to work with LDP.

eric

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Huub van Helvoort
> Sent: Thursday, November 13, 2014 11:02 AM
> To: [email-masked]
> Subject: Re: [mpls] draft-kompella-mpls-rmr-00
> 
> Hello Xuxiaohu, 您好
> 
> You wrote:
> 
> RPR is designed specifically for connectionless technologies like native
> Ethernet and IP.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 13 Nov 2014 17:14:33 +0000

Hi Huub,
I think that MPLS may be either, i.e. connectionless (IP/MPLS) and connection-oriented (MPLS-TP).

	Regards,
		Greg

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Thursday, November 13, 2014 8:02 AM
To: [email-masked]
Subject: Re: [mpls] draft-kompella-mpls-rmr-00

Hello Xuxiaohu, 您好

> (Resilient Packet Ring) technology into the MPLS-enabled ring networks.

RPR is designed specifically for connectionless technologies like native Ethernet and IP.

祝好，best regards, Huub.

---

From: Kireeti Kompella <[email-masked]>
Date: Thu, 13 Nov 2014 10:17:08 -1000

Hi Xiaohu,

> I have read your draft and found it’s very interesting.

Thank you!

> I wonder whether it’s possible to introduce the idea of the RPR (Resilient Packet Ring) technology into the MPLS-enabled ring networks. For instance, for a given node on a ring, it has two types of interfaces, one is ring-interface and the other is non-ring-interface. In addition, the ring-interface is either eastward or westward. When receiving an MPLS packet from a non-ring interface, if the next-hop of that MPLS packet is one of its adjacent peers on the ring, it would impose a label indicating clock-wise forwarding or count-clock-wise forwarding accordingly. When receiving an MPLS packet with the top label being the label indicating clock-wise or counter-clock-wise forwarding, unless the next-hop of the FEC which is indicated by the label below that top label is itself or a peer which is connected via a non-ring interface (i.e., the packet would pop off the ring), that packet should be forwarding according to the top label, e.g., if the top label indicates clock-wise forwarding, it would be forwarded in the clock-wise direction. 
>  

Good comment.  Let me see if I understand.  Let’s say that the ring has N nodes.  The way I would do this, each node has 2*(N-1) labels to reach each of the other (N-1) nodes in the two directions (CW or CCW).

What you are suggesting is to have a two-label stack; the outer label says CW or CCW; the inner label says what the egress ring node is.  So, each node has (N-1) inner labels.

So, you are optimizing 2*(N-1) to (N-1) by using hierarchy.  Is N large enough to make this worthwhile?

Note that "unless the next-hop of the FEC which is indicated by the label below that top label is itself” is a non-trivial forwarding step.  I.e., each node needs to look at two labels to determine how to forward the packet.

However, to reach non-ring nodes, I fully support using hierarchy.

Cheers,
Kireeti.

---

From: Shahram Davari <[email-masked]>
Date: Thu, 13 Nov 2014 20:22:46 +0000

Kirteeti,

A typical ring has 8-16 nodes. So there is no point increasing depth of label stack and modifying forwarding behavior to save 16 labels.

Thx
SD

From: mpls [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Thursday, November 13, 2014 12:17 PM
To: Xuxiaohu
Cc: [email-masked]
Subject: Re: [mpls] draft-kompella-mpls-rmr-00

Hi Xiaohu,

On Nov 12, 2014, at 11:33 , Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:

Hi Kireeti,

Thank you!

Cheers,
Kireeti.

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 13 Nov 2014 20:37:26 +0000

As I had mentioned to kireeti in private, the top label indicating clock-wise or count-clock-wise forwarding could actually be inferred according to the interface via which the packet is arrived.

Best regards,
Xiaohu

发件人: Shahram Davari [mailto:[email-masked]]
发送时间: 2014年11月14日 4:23
收件人: Kireeti Kompella; Xuxiaohu
抄送: [email-masked]
主题: RE: [mpls] draft-kompella-mpls-rmr-00

Kirteeti,

Thx
SD

From: mpls [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Thursday, November 13, 2014 12:17 PM
To: Xuxiaohu
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] draft-kompella-mpls-rmr-00

Hi Xiaohu,

Hi Kireeti,

Thank you!

Cheers,
Kireeti.

Best regards,
Xiaohu

---

From: Shahram Davari <[email-masked]>
Date: Thu, 13 Nov 2014 20:38:41 +0000

Labels are already per-interface.

Thx
SD

From: Xuxiaohu [mailto:[email-masked]]
Sent: Thursday, November 13, 2014 12:37 PM
To: Shahram Davari; Kireeti Kompella
Cc: [email-masked]
Subject: Re: [mpls] draft-kompella-mpls-rmr-00

Best regards,
Xiaohu

发件人: Shahram Davari [mailto:[email-masked]]
发送时间: 2014年11月14日 4:23
收件人: Kireeti Kompella; Xuxiaohu
抄送: [email-masked]<mailto:[email-masked]>
主题: RE: [mpls] draft-kompella-mpls-rmr-00

Kirteeti,

Thx
SD

Hi Xiaohu,

Hi Kireeti,

Thank you!

Cheers,
Kireeti.

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 13 Nov 2014 20:39:22 +0000

Sorry. I should have said the top label indicating clock-wise or count-clock-wise forwarding could be avoided since that forwarding direction information could actually be inferred according to the interface via which the packet is arrived.

发件人: Xuxiaohu
发送时间: 2014年11月14日 4:39
收件人: 'Shahram Davari'; Kireeti Kompella
抄送: [email-masked]
主题: Re: [mpls] draft-kompella-mpls-rmr-00

Best regards,
Xiaohu

Kirteeti,

Thx
SD

Hi Xiaohu,

Hi Kireeti,

Thank you!

Cheers,
Kireeti.

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 13 Nov 2014 20:53:22 +0000

In the current rmr draft, yes. However, I wonder whether there is any possibility that we could still use the per-platform label space.

Best regards,
Xiaohu

发件人: Shahram Davari [mailto:[email-masked]]
发送时间: 2014年11月14日 4:39
收件人: Xuxiaohu; Kireeti Kompella
抄送: [email-masked]
主题: RE: [mpls] draft-kompella-mpls-rmr-00

Thx
SD

Best regards,
Xiaohu

Kirteeti,

Thx
SD

Hi Xiaohu,

Hi Kireeti,

Thank you!

Cheers,
Kireeti.

Best regards,
Xiaohu

---

From: Shahram Davari <[email-masked]>
Date: Thu, 13 Nov 2014 21:03:47 +0000

And what would be the advantage ?

Regards,
Shahram

On Nov 13, 2014, at 10:53 AM, "Xuxiaohu" <[email-masked]<mailto:[email-masked]>> wrote:

Best regards,
Xiaohu

Thx
SD

Best regards,
Xiaohu

Kirteeti,

Thx
SD

Hi Xiaohu,

Hi Kireeti,

Thank you!

Cheers,
Kireeti.

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 14 Nov 2014 09:40:29 +0000

Could not agree more.

Best regards,
Xiaohu

-----邮件原件-----
发件人: mpls [mailto:[email-masked]] 代表 Osborne, Eric
发送时间: 2014年11月14日 0:38
收件人: [email-masked]; [email-masked]
主题: Re: [mpls] draft-kompella-mpls-rmr-00

eric