Subject: [mpls] maturity of the MRT technology

From: Loa Andersson <[email-masked]>
Date: Wed, 19 Nov 2014 08:08:05 +0800

Working Groups,

We have don an MPLS-RT of draft-atlas-mpls-ldp-mrt, the reviews has been
posted to the mpls wg mailing list.

In his MPLS-RT review Stewart Bryant says:

"I have concerns about whether or not MRT technology has the  maturity
  expected in the standards track. However that decision needs to be
  taken in RTGWG and MPLS needs to follow their and lead in determining
  the fate and track of this draft. This draft should not be published
  ahead of the drafts that define the technology that it is supporting."

He also says that he see no reason not to go ahead and start the poll to
see if we have consensus to adopt the document as an mpls wg document.

The question Stewart ask is valid, and we'd like input from the rtgwg
and rtgwg chairs (copied on this mail). We will also copy both the
poll for adoption and the wglc to the rtgwg mailing list.

/Loa
mpls wg co-chair
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Alia Atlas <[email-masked]>
Date: Thu, 20 Nov 2014 13:17:23 -0500

Loa,

Without any hats on, I would note:

a) As far as I'm aware, this has seen two independent prototypes
implemented.
b) I have not heard any concrete technical concerns.  Stewart and I did
specificallly
discuss MRT this past IETF.  I am, of course, quite interested in hearing
any
concrete technical concerns.

c) I'd be happy seeing this question asked of more drafts :-)

Regards,
Alia

On Tue, Nov 18, 2014 at 7:08 PM, Loa Andersson <[email-masked]> wrote:

> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Loa Andersson <[email-masked]>
Date: Fri, 21 Nov 2014 09:54:41 +0800

Alia,

Thanks for helpful information. We will go ahead with the mpls-rt review
and unless the we hear anything to the contrary from the rtgwg-chairs
also go ahead with the working group adoption poll (modulo the mpls-rt
review outcome).

/Loa

On 2014-11-21 02:17, Alia Atlas wrote:
> discuss MRT this past IETF.  I am, of course, quite interested in
> hearing any
> On Tue, Nov 18, 2014 at 7:08 PM, Loa Andersson <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Working Groups,
>
>     <mailto:[email-masked]>
>     Senior MPLS Expert [email-masked] <mailto:[email-masked]>
>     <tel:%2B46%20739%2081%2021%2064>
>
>     _________________________________________________
>     rtgwg mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/rtgwg
>     <https://www.ietf.org/mailman/listinfo/rtgwg>
>
>

--

---

From: <[email-masked]>
Date: Fri, 21 Nov 2014 09:22:54 +0000

+1

As for all FRR technologies, MRT has pros and cons, and this does not influence the maturity of the technical solutions. We already had multiple discussions online and offline on technical details leading now to documents that are quite detailed and well understood technology (with pros and cons as I mentioned). I’m not a great supporter of MRT implementation in my network, because it does not address correctly my use cases but despite of this, I deeply think that it’s another item in the FRR toolchest (like LFA, remote LFA …), it will be up to each Service Provider to choose the appropriate technology based on its own use case/constraints. Processing of MRT , IMHO, should be done as LFA and other similar technologies so standard track sounds good to me.

We already seen much less mature technologies going to standard track and being RFC without any running code after …

Best Regards,

Stephane

From: rtgwg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Thursday, November 20, 2014 19:17
To: Loa Andersson
Cc: [email-masked]; [email-masked]; [email-masked]; VIGOUREUX, MARTIN (MARTIN); [email-masked]
Subject: Re: maturity of the MRT technology

Loa,

a) As far as I'm aware, this has seen two independent prototypes implemented.
b) I have not heard any concrete technical concerns.  Stewart and I did specificallly
discuss MRT this past IETF.  I am, of course, quite interested in hearing any
concrete technical concerns.

Regards,
Alia

On Tue, Nov 18, 2014 at 7:08 PM, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
Working Groups,

/Loa
mpls wg co-chair
--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64<tel:%2B46%20739%2081%2021%2064>

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Wunan (Eric)" <[email-masked]>
Date: Fri, 21 Nov 2014 10:27:22 +0000

+1

Can’t agree more:

“I deeply think that it’s another item in the FRR toolchest (like LFA, remote LFA …), it will be up to each Service Provider to choose the appropriate technology based on its own use case/constraints.”

Regards
Eric

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2014年11月21日 17:23
收件人: Alia Atlas; Loa Andersson
抄送: [email-masked]; [email-masked]; [email-masked]; VIGOUREUX, MARTIN (MARTIN); [email-masked]
主题: RE: maturity of the MRT technology

+1

Best Regards,

Stephane

From: rtgwg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Thursday, November 20, 2014 19:17
To: Loa Andersson
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; VIGOUREUX, MARTIN (MARTIN); [email-masked]<mailto:[email-masked]>
Subject: Re: maturity of the MRT technology

Loa,

Regards,
Alia

/Loa
mpls wg co-chair
--

Thank you.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 21 Nov 2014 11:49:58 +0000

My comment to Loa precedes a discussion with Alia at IETF
and to be fair I do not know of any technical issue with the MRT
design.

Unlike LF and RLFA which are "local" to the point of repair, the
scope of MRT is domain wide, in other words MRT is introducing
a new partially ships in the night routing protocol. In my view, a
domain wide system has a higher barrier to entry than a local
repair system.

I have a concern that Loa's statement (a) only tells part of the
story. Whilst I understand there are two independent prototypes,
I understand that they are not two interworking prototypes since
they are based on different link state protocols. However I
understand (and it would be good to have this verified) that if
they are given the same topology they produce the same FIB.
To my mind this ranks it at "one and a half" independent
prototypes.

At the end of the day the utility of MRT depends on who is
interested in deploying it, and as far as I know, none of the
domain wide IPFRR solutions have made it into production networks.
If there are operators prepared to deploy MRT  in their production
networks then obviously it is headed for the standards track.
If it is destined to join the  ranks of the many "possible" domain
wide solutions, then it is clearly still at the informational/
experimental stage of its life.

Stewart

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 21 Nov 2014 19:36:41 +0000

>I’m not a great supporter of MRT implementation in my network, because it does not address correctly my use cases but despite of this,

Is this because of domain wide deployment requirements MRT brings-in (as elaborated by Stewart?) or you are ok with LFA/rLFA coverage in the network?

> I deeply think that it’s another item in the FRR toolchest (like LFA, remote LFA …),
>it will be up to each Service Provider to choose the appropriate technology based on its own use case/constraints.

I agree with above.  It depends on the particular deployment scenario and applicability for that network.

--
Uma C.

From: mpls [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, November 21, 2014 1:23 AM
To: Alia Atlas; Loa Andersson
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] maturity of the MRT technology

+1

Best Regards,

Stephane

Loa,

Regards,
Alia

/Loa
mpls wg co-chair
--

Thank you.

---

From: <[email-masked]>
Date: Sun, 23 Nov 2014 08:47:42 +0000

HI Uma,

> Is this because of domain wide deployment requirements MRT brings-in (as elaborated by Stewart?) or you are ok with LFA/rLFA coverage in the network?

No, domain-wide deployment is not an issue. The issue I see in MRT (for my use case) is unoptimality of the FRR path (at least using lowpoint algorithm). But anyway, as I mentioned, I’m not opposed to make MRT progressing at all. It’s good to have multiple tools.

Best Regards,

From: Uma Chunduri [mailto:[email-masked]]
Sent: Friday, November 21, 2014 20:37
To: LITKOWSKI Stephane SCE/IBNF; Alia Atlas; Loa Andersson
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: maturity of the MRT technology

--
Uma C.

From: mpls [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, November 21, 2014 1:23 AM
To: Alia Atlas; Loa Andersson
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] maturity of the MRT technology

+1

Best Regards,

Stephane

Loa,

Regards,
Alia

/Loa
mpls wg co-chair
--

Thank you.