Subject: [mpls] poll to se if we have consensus to make draft-kini-mpls-spring-entropy-label an mpls wg document

From: Loa Andersson <[email-masked]>
Date: Tue, 11 Nov 2014 20:46:29 +0100

Working Group,

This is to start a two week poll on adopting
draft-kini-mpls-spring-entropy-label as an MPLS working group document.

Please send your comments (support/not support) to the mpls working
group mailing list ([email-masked]). Please give a technical
motivation for your support/not support, especially if you think that
the document should not be adopted as a working group document.

There is no IPR disclosures directly against this document.

The authors has all stated on the working group mailing
list that they are unaware of any IPR claims against this draft.

However we have an outstanding issue on IPRs. There were more than
one solution to entropy labels for spring, they are referenced in the
document, but are labeled as "discounted". One of these proposed
had an IPR disclosure.

However if you are on the the mpls working group mailing list and
aware of IPR that relates to this draft, the time to disclose
this is now.

This poll ends November 25, 2014.

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 11 Nov 2014 10:28:14 -1000

Loa,

This is a well-supported draft with useful functionality, it should be a WG
draft.

Cheers,
Andy

On Tue, Nov 11, 2014 at 9:46 AM, Loa Andersson <[email-masked]> wrote:

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Loa Andersson <[email-masked]>
Date: Tue, 11 Nov 2014 21:31:11 +0100

Need to check up on this fairly quickly!

/Loa

On 2014-11-11 21:28, Andrew G. Malis wrote:
> Loa,
>
> This is a well-supported draft with useful functionality, it should be a
> WG draft.
>
> Cheers,
> Andy
>
> On Tue, Nov 11, 2014 at 9:46 AM, Loa Andersson <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Working Group,
>
>     draft-kini-mpls-spring-__entropy-label as an MPLS working group
>     document.
>
>     group mailing list ([email-masked] <mailto:[email-masked]>). Please
>     give a technical
>     <mailto:[email-masked]>
>     Senior MPLS Expert [email-masked] <mailto:[email-masked]>
>     <tel:%2B46%20739%2081%2021%2064>
>
>     _________________________________________________
>     mpls mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/mpls
>     <https://www.ietf.org/mailman/listinfo/mpls>
>
>

--

---

From: Loa Andersson <[email-masked]>
Date: Tue, 11 Nov 2014 21:34:01 +0100

Folks,

Sorry this was intended for Andy only, but it is correct that I will
have to check up on this is input before closing the wg adoption poll.

/Loa

--

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 11 Nov 2014 10:46:33 -1000

Loa,

Nobo had an email about five days ago that discussed a bug and proposed a
fix, but there's not reason that it can't be fixed while still becoming a
WG document.

Cheers,
Andy

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 11 Nov 2014 21:08:27 +0000

Dear Authors, chairs, et. al,
I've read the current version of the draft and found that my major concern expressed in MPLS-RT comments is still valid. Hence I'm sending it again:
*       No illustration of how rules can be applied to the use case presented in Section 3 to achieve desired load balancing. To make it more practical different RLD values can be assigned to LSRs in the use case in Fig.1.
Entropy label in Segment Routing network is important and useful problem to address, no doubt. But this is not a framework but solution document and I believe that algorithm proposed in Section 4 must be applied to network example presented in the Section 3 of the document to demonstrate that it works, minimizes label stack depth while is beneficial in distribution of data flows across available paths.

        Regards,
                Greg

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Tuesday, November 11, 2014 11:46 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] poll to se if we have consensus to make draft-kini-mpls-spring-entropy-label an mpls wg document

Working Group,

This is to start a two week poll on adopting draft-kini-mpls-spring-entropy-label as an MPLS working group document.

Please send your comments (support/not support) to the mpls working group mailing list ([email-masked]<mailto:[email-masked]>). Please give a technical motivation for your support/not support, especially if you think that the document should not be adopted as a working group document.

The authors has all stated on the working group mailing list that they are unaware of any IPR claims against this draft.

However we have an outstanding issue on IPRs. There were more than one solution to entropy labels for spring, they are referenced in the document, but are labeled as "discounted". One of these proposed had an IPR disclosure.

However if you are on the the mpls working group mailing list and aware of IPR that relates to this draft, the time to disclose this is now.

/Loa
--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Tue, 11 Nov 2014 21:17:39 +0000

Hi Loa, Andy, et al,

For the record, I never said draft-kini-mpls-spring-entropy-label is broken ☺

I think draft-kini-mpls-spring-entropy-label is intending to solve a valid problem and the document is a good starting point.

-        The algorithm provided in the Figure 2 needs to be updated (see my previous email to the list). With that, I think the simple scenario where RLD is considered to be constant for a given SR LSP should work.

-        Shahram brought up an idea of removing the ELI (like PW FAT label), but I don’t believe that is a good idea as we will not be able to synchronize the EL imposition/disposition between ingress/egress. And as other folks pointed out, this is not a discussion specific for draft-kini-mpls-spring-entropy-label but more general topic for EL.

The document and the recommended solution should get more discussions and updated accordingly: (1) whether or not what is currently recommended is the best way to move forward, and (2) the best way to move forward has been backed by data to prove that it works. However, I believe those can be done after the WG adopting this document. Therefore, I do not see any stopper issue for this document to become a WG document.

Thanks!

-Nobo

From: mpls [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Tuesday, November 11, 2014 10:47 AM
To: Loa Andersson
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] :( - Greg and Nobo tells me it is broken -Re: poll to se if we have consensus to make draft-kini-mpls-spring-entropy-label an mpls wg document

Loa,

Nobo had an email about five days ago that discussed a bug and proposed a fix, but there's not reason that it can't be fixed while still becoming a WG document.

Cheers,
Andy

On Tue, Nov 11, 2014 at 10:31 AM, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
Need to check up on this fairly quickly!

/Loa

Cheers,
Andy

On Tue, Nov 11, 2014 at 9:46 AM, Loa Andersson <[email-masked]<mailto:[email-masked]>
<mailto:[email-masked]<mailto:[email-masked]>>> wrote:

    Working Group,

    Please send your comments (support/not support) to the mpls working
    group mailing list ([email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>). Please
    give a technical
    motivation for your support/not support, especially if you think that
    the document should not be adopted as a working group document.

    /Loa
    --

    Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
    <mailto:[email-masked]<mailto:[email-masked]>>
    Senior MPLS Expert [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
    Huawei Technologies (consultant)     phone: +46 739 81 21 64<tel:%2B46%20739%2081%2021%2064>
    <tel:%2B46%20739%2081%2021%2064>

    _________________________________________________
    mpls mailing list
    [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
    https://www.ietf.org/mailman/__listinfo/mpls
    <https://www.ietf.org/mailman/listinfo/mpls>

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64<tel:%2B46%20739%2081%2021%2064>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 11 Nov 2014 23:28:10 +0000

+1

BR
Daniele

From: mpls [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: martedì 11 novembre 2014 10:28
To: Loa Andersson
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mpls] poll to se if we have consensus to make draft-kini-mpls-spring-entropy-label an mpls wg document

Loa,

This is a well-supported draft with useful functionality, it should be a WG draft.

Cheers,
Andy

On Tue, Nov 11, 2014 at 9:46 AM, Loa Andersson <[email-masked]<mailto:[email-masked]>> wrote:
Working Group,

Please send your comments (support/not support) to the mpls working
group mailing list ([email-masked]<mailto:[email-masked]>). Please give a technical
motivation for your support/not support, especially if you think that
the document should not be adopted as a working group document.

/Loa
--

---

From: Loa Andersson <[email-masked]>
Date: Mon, 01 Dec 2014 11:17:45 +0800

"Working Group,

The poll for adoption of draft-kini-mpls-spring-entropy-label is
closed.

We have found that there is a good support for adopting the draft as
an MPLS wg document. We also have a fair number of comments, that we'd
like to see addressed before making it a wg document.

We have therefore asked the authors to work with the reviewers and
re-spin an updated version of the document.

/Loa
for the MPLS wg chairs"

--