Subject: [mpls] I-D Action: draft-akiya-mpls-lsp-ping-lag-multipath-04.txt

From: [email-masked]
Date: Sat, 29 Nov 2014 17:36:16 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

        Title           : Label Switched Path (LSP) Ping/Trace Multipath Support for Link Aggregation Group (LAG) Interfaces
        Authors         : Nobo Akiya
                          George Swallow
                          Stephane Litkowski
                          Bruno Decraene
                          John E. Drake
	Filename        : draft-akiya-mpls-lsp-ping-lag-multipath-04.txt
	Pages           : 22
	Date            : 2014-11-29

Abstract:
   This document defines an extension to the MPLS Label Switched Path
   (LSP) Ping and Traceroute as specified in RFC 4379.  The extension
   allows the MPLS LSP Ping and Traceroute to discover and exercise
   specific paths of Layer 2 (L2) Equal-Cost Multipath (ECMP) over Link
   Aggregation Group (LAG) interfaces.

   This document updates RFC4379 and RFC6424.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-akiya-mpls-lsp-ping-lag-multipath/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-akiya-mpls-lsp-ping-lag-multipath-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-akiya-mpls-lsp-ping-lag-multipath-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Sun, 30 Nov 2014 01:49:12 +0000

Dear MPLS WG,

There was number of comments provided by Loa Andersson (thanks Loa!), so we have made changes to address those comments prior to requesting the chairs to start the WG adoption poll of this document.

The modifications do not make any technical changes, but improved the clarity/readability of the document.

I'd like to highlight that this document makes improvements to LSP Ping/Trace because usage of following approach does not help.

- A problem is detected in a layer X.
- Let's drop down a layer and trouble shoot the layer (X-1) to further diagnose.

Such approach has benefits and will be able to find number of problem, but it won't catch all the problems, unfortunately.

Some aspects of good troubleshooting of layer X can only be done on layer X by having the visibility of the lower layer.

For those who has limited time, here's the pointer to the presentation of this document at IEtF90.

http://www.ietf.org/proceedings/90/slides/slides-90-mpls-4.pdf

Thanks!

-Nobo, on behalf of authors

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Saturday, November 29, 2014 8:36 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [mpls] I-D Action: draft-akiya-mpls-lsp-ping-lag-multipath-04.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls