Subject: Re: [mpls] draft-kompella-mpls-rmr-00

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 13 Nov 2014 16:45:01 +0000

Could not express this better...

Eric,

Lots of thanks!

Thumb typed on my LG,
Sasha

------ Original message ------
From: Osborne, Eric
Date: 13/11/2014 18:38
To: [email-masked];[email-masked];
Subject:Re: [mpls] draft-kompella-mpls-rmr-00

MPLS-TE and -TP are connection oriented.  LDP is not; if RPR works for IP it ought to work with LDP.

eric

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Huub van Helvoort
> Sent: Thursday, November 13, 2014 11:02 AM
> To: [email-masked]
> Subject: Re: [mpls] draft-kompella-mpls-rmr-00
>
> Hello Xuxiaohu, 您好
>
> You wrote:
>
> > I have read your draft and found it’s very interesting.
> >
> > I wonder whether it’s possible to introduce the idea of the RPR
> > (Resilient Packet Ring) technology into the MPLS-enabled ring networks.
>
> RPR is designed specifically for connectionless technologies like native
> Ethernet and IP.
>
> MPLS is connection oriented, applying RPR may be very complex.
>
> 祝好，best regards, Huub.
>
>
> --
> **********************************************************
> *******
>                请记住，你是独一无二的，就像其他每一个人一样
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: "LEVRAU, LIEVEN (LIEVEN)" <[email-masked]>
Date: Thu, 13 Nov 2014 19:04:25 +0000

Interesting – question for clarification:
 why is a control plane aspect dictating how the data plane will be connection oriented or not?

Unless the definition of connection oriented technologies have a control plane aspect that I am not aware off
./
Lieven

From: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Date: Thursday 13 November 2014 17:45
To: "Osborne, Eric" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mpls] draft-kompella-mpls-rmr-00

Eric,

Lots of thanks!

Thumb typed on my LG,
Sasha

------ Original message ------
From: Osborne, Eric
Date: 13/11/2014 18:38
To: [email-masked]<mailto:[email-masked]>;[email-masked]<mailto:[email-masked]>;

eric

> To: [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: "Osborne, Eric" <[email-masked]>
Date: Thu, 13 Nov 2014 19:06:38 +0000

....I'm gonna stand over here in the corner and not get involved in this one.....I'm already out of hair......

eric

> From: LEVRAU, LIEVEN (LIEVEN) [mailto:[email-masked]]
> Sent: Thursday, November 13, 2014 2:04 PM
> To: Alexander Vainshtein; Osborne, Eric; [email-masked];
> [email-masked]
> Unless the definition of connection oriented technologies have a control
> plane aspect that I am not aware off ./ Lieven
> 
> From: Alexander Vainshtein <[email-masked]
> <mailto:[email-masked]> >
> To: "Osborne, Eric" <[email-masked]
> <mailto:[email-masked]> >, "[email-masked]
> <mailto:[email-masked]> " <[email-masked]
> <mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]>
> " <[email-masked] <mailto:[email-masked]> >
> To: [email-masked] <mailto:[email-masked]>
> ;[email-masked] <mailto:[email-masked]> ;
> > To: [email-masked] <mailto:[email-masked]>
> > RPR is designed specifically for connectionless technologies like
> > native Ethernet and IP.
> >
> > [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 13 Nov 2014 19:12:06 +0000

Hi Lieven,
I wouldn’t say that whether MPLS network can be characterized as connectionless or connection-oriented is result of which signaling protocol, label distribution protocol being used. RSVP-TE can be used to signal MPLS-TE LSP that is connectionless as well as MPLS-TP LSP that would be connection-oriented.

                Regards,
                                Greg

From: mpls [mailto:[email-masked]] On Behalf Of LEVRAU, LIEVEN (LIEVEN)
Sent: Thursday, November 13, 2014 11:04 AM
To: Alexander Vainshtein; Osborne, Eric; [email-masked]; [email-masked]
Subject: Re: [mpls] draft-kompella-mpls-rmr-00

Eric,

Lots of thanks!

Thumb typed on my LG,
Sasha

------ Original message ------
From: Osborne, Eric
Date: 13/11/2014 18:38
To: [email-masked]<mailto:[email-masked]>;[email-masked]<mailto:[email-masked]>;

eric

---

From: Loa Andersson <[email-masked]>
Date: Thu, 13 Nov 2014 20:22:19 +0100

Lieven, et.al.,

Maybe because the different control planes makes the data plane behave
different?

I think it is worth looking into the RPR as Xiaohu suggested.

Also we should follow up what Jie Dong said about aligning different
ring protection draft.

What we said before is that we might do solutions for specific
topologies if it comes with enough advantages, for shared ring I
believe this is adequately demonstrated and the rmr has a bit to
go. Maybe it would be best to team up on that work als..

/Loa

On 2014-11-13 20:04, LEVRAU, LIEVEN (LIEVEN) wrote:
> plane aspect that I am not aware off
> ./
> Lieven
>
> <mailto:[email-masked]>>
> <mailto:[email-masked]>>, "[email-masked]
> <mailto:[email-masked]>" <[email-masked]
> <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>"
> <[email-masked] <mailto:[email-masked]>>
> *From: *Osborne, Eric
> *Date: *13/11/2014 18:38
> *To: [email-masked] <mailto:[email-masked]>;[email-masked]
> <mailto:[email-masked]>;
> *Subject:*Re: [mpls] draft-kompella-mpls-rmr-00
>
>> To:[email-masked] <mailto:[email-masked]>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Kireeti Kompella <[email-masked]>
Date: Thu, 13 Nov 2014 10:37:14 -1000

>  why is a control plane aspect dictating how the data plane will be connection oriented or not?

RSVP-TE usually builds point-to-point tunnels; LDP builds multipoint tunnels.

In RMR, I suggest using multipoint tunnels with both LDP and RSVP-TE.

KIreeti.

---

From: Kireeti Kompella <[email-masked]>
Date: Thu, 13 Nov 2014 10:40:34 -1000

On Nov 13, 2014, at 09:22 , Loa Andersson <[email-masked]> wrote:

> topologies if it comes with enough advantages, for shared ring

Not sure what a shared ring is ...

> I believe this is adequately demonstrated and the rmr has a bit to
> go.

Certainly.  Please look for updates.

Kireeti.

---

From: Loa Andersson <[email-masked]>
Date: Thu, 13 Nov 2014 21:44:55 +0100

Kireeti,

section 2.5.1.1 and 2.5.1.2 of draft-cheng-mpls-tp-shared-
ring-protection-03 have simple pictures.

/Loa

--