Subject: Re: [mpls] Barry Leiba's Discuss on draft-ietf-mpls-ipv6-only-gap-03: (with DISCUSS and COMMENT)

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 23 Nov 2014 07:07:37 -0000

[Adding the MPLS WG]

That's a pretty fine question, Barry.

I'd say that, despite the care and work of the working group, it is possible that another gap will be identified. However, I think that might be a lowish possibility and that any new gaps might form a small percentage of the total gaps analysed.

So, my judgement is that this is a bridge to cross when we get there, but others might comment.

And, yes, we can take a pass on the references.

A

> -----Original Message-----
> From: iesg [mailto:[email-masked]] On Behalf Of Barry Leiba
> Sent: 23 November 2014 06:49
> To: The IESG
> Cc: [email-masked]; [email-masked]
> Subject: Barry Leiba's Discuss on draft-ietf-mpls-ipv6-only-gap-03: (with DISCUSS
> and COMMENT)
> 
> Barry Leiba has entered the following ballot position for
> draft-ietf-mpls-ipv6-only-gap-03: Discuss
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> http://datatracker.ietf.org/doc/draft-ietf-mpls-ipv6-only-gap/
> 
> 
> 
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
> 
> This is a DISCUSS in the truest sense: I'd like to discuss a question
> with the shepherd and/or AD, and I fully expect to resolve the question
> satisfactorily from that.
> 
> The first thing I wondered was why this shouldn't be something maintained
> in a place other than an RFC, and I found that covered well in the
> shepherd writeup. Thanks for that!
> 
> What I continue to wonder is whether, in having that discussion, the
> working group considered what the likelihood is of discovering more gaps
> as they (and other working groups) work on dealing with these.  If so, I
> wonder what the working group's plan is for documenting those.
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> I submit that a good number of the references really are normative, in
> that understanding them is necessary in order to understand this
> document.  I'd like to see the authors sort that out, and make an
> appropriate split in the references, so readers can know which ones truly
> do just add extra detail (informative), and which provide necessary
> background (normative).  That said, I don't consider that important
> enough to this document to block on it, so this is a non-blocking
> comment.  Please consider doing this, but there is no need to respond to
> me about it.  Thanks.

---

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Sun, 23 Nov 2014 09:57:22 +0000

Does that meet the discuss criteria?

Stewart

Sent from my iPad

> On 23 Nov 2014, at 07:08, Adrian Farrel <[email-masked]> wrote:
> 
> [Adding the MPLS WG]
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Loa Andersson <[email-masked]>
Date: Sun, 23 Nov 2014 22:32:45 +0800

Barry,

I don't know how much more I have to after Adrian's mail, it seems
cover the issues.

We never had the ambition to find every gap, but believed that
that documenting for the future that we made the effort and also that
the gaps we found would be a good enough idea.

I differ from Adrian on one point, I think it is very likely that we'll
find new gaps, however they will be few and with low impact.

This begs the question how we'll maintain the management of the gaps
and the recommendations around for each gap should be done. An idea
that has been circualted it to use a wiki page, but so far there is no
decision. But - as our ADs have said - with a wiki we don't really need
a decision, just someone that takes on the task to do it.

As for the references I agree that it is possible to take a pass on
them, the thing with how (other than normative informative) one prefer
to have references sort are very personal.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Mark Tinka <[email-masked]>
Date: Sun, 23 Nov 2014 17:02:14 +0200

On Sunday, November 23, 2014 04:32:45 PM Loa Andersson 
wrote:

> This begs the question how we'll maintain the management
> of the gaps and the recommendations around for each gap
> should be done. An idea that has been circualted it to
> use a wiki page, but so far there is no decision. But -
> as our ADs have said - with a wiki we don't really need

I would support a wiki, as that can be edited by the group 
at anytime, and anything in the wiki that makes sense to add 
into an IETF draft or RFC can help ensure the drafts/RFC's 
have the most pertinent information, and don't end up 
getting unnecessarily bloated.

Mark.

---

From: Barry Leiba <[email-masked]>
Date: Mon, 24 Nov 2014 04:06:07 -1000

> Does that meet the discuss criteria?

"Did the working group consider <x>?" absolutely does, yes.  And I
find it disturbing that you would rather ask that question than
address the question I'm asking.

Barry

---

From: Barry Leiba <[email-masked]>
Date: Mon, 24 Nov 2014 04:12:22 -1000

Thanks, Adrian, Loa, and Mark, for the responses.

> find new gaps, however they will be few and with low impact.

That's a good answer, and thanks for adding that.  Mark's comment is

> getting unnecessarily bloated.

That's a perfect use of the working group wiki, and that should take
care of the question entirely.

Off to change my ballot now...

> them

OK.  I'm sad about that, but not terribly so: as I said, I think it
would be helpful, but not so important for this document.  So carry
on, and thanks again for the good responses.

Barry

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 24 Nov 2014 16:10:09 +0000

Hi Barry,

On Nov 24, 2014, at 9:12 AM, Barry Leiba <[email-masked]<mailto:[email-masked]>> wrote:

I believe Loa meant that we can take an editing pass and revisit what’s Normative, not to pass on your offer :-)

We will check them.

Thanks for the comment and discussion!

Carlos.

Barry