Subject: [mpls] FW: IETF MPLS-TE YANG Design Discussions

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Sat, 6 Dec 2014 04:36:44 +0000

Attendees:
Santosh Esale <[email-masked]>; Rakesh Gandhi (rgandhi) <[email-masked]>; Robert Sawaya (rsawaya) <[email-masked]>; Matt Hartley (mhartley) <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Vero Zheng <[email-masked]>; Sam Aldrin <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; [email-masked] <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Lou Berger <[email-masked]>; George Swallow (swallow) <[email-masked]>; Shah, Himanshu <[email-masked]>; VICTOR LOPEZ ALVAREZ <[email-masked]>

A group of us (from above) met on Thursday 12/4 for the first time to discuss MPLS TE YANG model. Below are minutes/notes. Next meeting is scheduled for next Wednesday 12/10.

- Next steps/AIs:
    - Team: to check-in all existing YANG models to GitHub: https://github.com/ietf-mpls-yang/te
    - Team: phase 1 to tackle links and link attributes for phase 1
       * team to communicate proposed attributes over email.
       * in-progress model for TE links will be discussed next week
    - Team: to use email to send proposals
    - Tarek: to send an email with minutes to the WG group
       * include invitations for next meetings
    - Tarek: to schedule weekly meeting for next wednesday onwards

Recording of meeting @
https://cisco.webex.com/ciscosales/lsr.php?RCID=7a824854ae304230ab579f6977974239

Meeting minutes/Notes:
====================
- Meeting organization/time (do we need to meet more often?)
    * Meet weekly,
    * OK to keep Thursday 7:00pm EST
    * Poll for next weekly meeting Wednesday 7:00pm EST
    * Consideration for holidays

- Scope of our work:
    * MPLS TE YANG model:
        TE base yang types
        TE base yang model
        RSVP-TE extensions to TE base yang model
    * MPLS Tunnels/links: Config, operational/state, notification, rpcs
    * Topology (proposal to handle in another effort in TEAS)

- Do we need an alias to communicate/send queries?
    * use mpls WG alias as long as manageable (not noisy)
    * may create another alias to use too

- Agree on tools/process:
    * repository in GitHub: https://github.com/ietf-mpls-yang/te
        * check-in all yang models to date:
            * tagged iet-mpls-te-(1/2/3).yang
        * create ietf-mpls-te.yang
            * to include sanitized/agreed data model to be presented at IETF
        * create common draft draft-common-mpls-te-yang-model
    * review/commit process?
        * Need to converge

- Divide the work into phases
    * ph1: TE Links:
        link attributes (local TE links)
        - Admin Groups, Extended Admin Groups (config)
        - SRLGs (config)
        - local/remote identifiers (config)
        - reservable bandwidth (config)
            - RSVP per interface properties
            - etc.
        - CAC (state) -- LSPs admitted on the link

    * ph2: TE Tunnels:
    * ph3: TE LSPs
    * ph4: TE Globals/templates properties

- Revisit MPLS Yang module(s) hierarchy. Proposal:
+ ietf-mpls-base-types.yang
       |
       + -- ietf-mpls-ldp-types.yang (imports mpls-base-types)
       + -- ietf-mpls-te-types.yang  (imports mpls-base-types)
       + -- ietf-mpls-te-pce-types.yang  (imports mpls-base-types)
       + -- etc.
+ ietf-mpls-base.yang
     + -- ietf-mpls-te-base.yang (augments ietf-mpls-base.yang)
              + -- ietf-mpls-te-rsvp.yang (augments ietf-mpls-te-base.yang)
              + -- ietf-gmpls-te.yang (augments ietf-mpls-te-base.yang ? augments ietf-mpls-te-rsvp.yang, both ?)
                    - encoding types (PSC, LSC, FSC, etc.)?
                    - OTN/Optical
+ ietf-mpls-oam
    - the MPLS OAM YANG model (to augment MPLS-TE model whenever needed)

- Where does MPLS data plane YANG state sit?
    - In respective MPLS Yang models — identified with data plane distinguisher (?)
    - data/control plane state and data plane state may not be in sync always (e.g. in transient post FRR)

Regards,
Tare

---

From: "Osborne, Eric" <[email-masked]>
Date: Tue, 9 Dec 2014 13:25:19 +0000

Where do things go which are not strictly tunnel properties, but which are only used on TE tunnels?  Phase 2?  I'm thinking of things like autoroute/igp-shortcuts - it's nothing to do with the links or the LSP but it really only shows up as a feature used on TE links.

eric

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of Tarek Saad (tsaad)
> Sent: Friday, December 05, 2014 11:37 PM
> To: [email-masked]
> Subject: [mpls] FW: IETF MPLS-TE YANG Design Discussions
> 
> Attendees:
> Santosh Esale <[email-masked]>; Rakesh Gandhi (rgandhi)
> <[email-masked]>; Robert Sawaya (rsawaya) <[email-masked]>; Matt
> Hartley (mhartley) <[email-masked]>; [email-masked]
> <[email-masked]>; [email-masked]
> <[email-masked]>; [email-masked]
> <[email-masked]>; [email-masked]
> <[email-masked]>; Vero Zheng <[email-masked]>; Sam
> Aldrin <[email-masked]>; Vishnu Pavan Beeram
> <[email-masked]>; [email-masked]
> <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Lou Berger
> <[email-masked]>; George Swallow (swallow) <[email-masked]>; Shah,
> Himanshu <[email-masked]>; VICTOR LOPEZ ALVAREZ
> <[email-masked]>
> 
> A group of us (from above) met on Thursday 12/4 for the first time to discuss
> MPLS TE YANG model. Below are minutes/notes. Next meeting is scheduled for
> next Wednesday 12/10.
> 
> - Next steps/AIs:
>     - Team: to check-in all existing YANG models to GitHub:
> https://github.com/ietf-mpls-yang/te <https://github.com/ietf-mpls-yang/te>
>     - In respective MPLS Yang models - identified with data plane distinguisher
> (?)