Subject: [mpls] Implementation poll on draft-ietf-mpls-oam-ipv6-rao

From: Loa Andersson <[email-masked]>
Date: Mon, 22 Dec 2014 12:05:46 +0800

Working Group,

We are preparing draft-ietf-mpls-oam-ipv6-rao for publication request.
One of the questions we have to answer in the Shepherds Write-up is if
there are any existing implementations.

This is to start an implementation poll on draft-ietf-mpls-oam-ipv6-rao.
If you have an implementation or know about one, please send the
information to the mpls wg mailing list or to the mpls wg chairs.

/Loa
for the mpls wg co-chairs
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 22 Dec 2014 13:36:14 +0000

Hi Loa,

Cisco has implemented LSP Ping/Traceroute modifications to support LDP IPv6, during which we found the lack of IPv6 RAO availability for MPLS OAM. The plan is to update this implementation once draft-ietf-mpls-oam-ipv6-rao progresses (which already has) and the code point has been allocated (which has not been done). So the hooks are in place, but the answer is not a complete "yes". However, due to the nature of this document (i.e., defines a code point but absolutely no procedures), I hope that the document can still progress.

Thanks!

-Nobo

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Sunday, December 21, 2014 11:06 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Implementation poll on draft-ietf-mpls-oam-ipv6-rao
> 
> Working Group,
>

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 23 Dec 2014 18:54:31 +0000

+1 (to what Nobo already stated)

‹
Kamran

On 2014-12-22, 8:36 AM, "Nobo Akiya (nobo)" <[email-masked]> wrote:

>Hi Loa,
>
>Cisco has implemented LSP Ping/Traceroute modifications to support LDP
>IPv6, during which we found the lack of IPv6 RAO availability for MPLS
>OAM. The plan is to update this implementation once
>draft-ietf-mpls-oam-ipv6-rao progresses (which already has) and the code
>point has been allocated (which has not been done). So the hooks are in
>place, but the answer is not a complete "yes". However, due to the nature
>of this document (i.e., defines a code point but absolutely no
>procedures), I hope that the document can still progress.
>
>Thanks!
>
>-Nobo
>
>> Cc: [email-masked];
>>[email-masked]