Subject: [mpls] I-D Action: draft-akiya-mpls-lsp-ping-lag-multipath-05.txt

From: [email-masked]
Date: Sun, 21 Dec 2014 06:57:35 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiprotocol Label Switching Working Group of the IETF.

        Title           : Label Switched Path (LSP) Ping/Trace Multipath Support for Link Aggregation Group (LAG) Interfaces
        Authors         : Nobo Akiya
                          George Swallow
                          Stephane Litkowski
                          Bruno Decraene
                          John E. Drake
	Filename        : draft-akiya-mpls-lsp-ping-lag-multipath-05.txt
	Pages           : 27
	Date            : 2014-12-21

Abstract:
   This document defines an extension to the MPLS Label Switched Path
   (LSP) Ping and Traceroute as specified in RFC 4379.  The extension
   allows the MPLS LSP Ping and Traceroute to discover and exercise
   specific paths of Layer 2 (L2) Equal-Cost Multipath (ECMP) over Link
   Aggregation Group (LAG) interfaces.

   This document updates RFC4379 and RFC6424.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-akiya-mpls-lsp-ping-lag-multipath/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-akiya-mpls-lsp-ping-lag-multipath-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-akiya-mpls-lsp-ping-lag-multipath-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Sun, 21 Dec 2014 15:12:07 +0000

Dear MPLS WG,

The authors have published -05 of draft-akiya-mpls-lsp-ping-lag-multipath, addressing comments from MPLS-RT review teams (thanks Eric, Mach, Yimin!).

The authors believe that the document is in good shape, and we would like to request the WG to adopt -05 as a WG document.

Here are the highlights of the changes from -04 to 05:

* Renamed LAG Interface Info TLV to LSR Capability TLV.
* Generalized the usage of the LSR Capability TLV.
* Deleted Interface Index Sub-TLV, and created Local Interface Index Sub-TLV and Remote Interface Index Sub-TLV.
* Updated the responder LSR DDMAP procedures to describe the downstream LAG member link with rules:
  - The Local Interface Index Sub-TLV is mandatory.
  - The Remote Interface Index Sub-TLV is optional.
  - The Multipath Data Sub-TLV is mandatory.
* Explicitly state how a responder LSR obtains remote interface index is outside the scope of the document.
* The LAG member link traversal validation procedures is split into two approaches.
  - Incoming LAG Member Links Verification (what we had before).
  - Individual End-to-End Path Verification (newly added).
* Update initiator/responder procedures to accommodate above changes.

Remaining changes are either minor text changes/additions for better clarifications or language corrections.

Thanks!

Nobo, on behalf of authors

> -----Original Message-----
> From: mpls [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Sunday, December 21, 2014 9:58 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [mpls] I-D Action: draft-akiya-mpls-lsp-ping-lag-multipath-05.txt
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls