Subject: [mpls] MPLS-RT review of draft-bonica-mpls-self-ping

From: Mach Chen <[email-masked]>
Date: Tue, 10 Mar 2015 09:56:03 +0000

Hi Authors,

I am selected as MPLS-RT reviewer for draft-bonica-mpls-self-ping-04, and here are my MPLS-RT review comments on the draft.

1. The draft is well written and the problem is well stated.

2. The draft does not specify the self-ping is designed for all types of LSP or just some of them (e.g., only RSVP-TE LSP), clarification is needed.

3. The self-ping cannot guarantee that the returned Echo Reply is definitely from the egress, hence it can't completely solve the black-holing issue. 

4. LSP Ping and BFD (especially S-BFD) are alternative tools for LSP readiness detection. If the scalability of control plane is the concern, there should be an analyses whether S-BFD cannot satisfy the requirement. 

Best regards,
Mach

> 
> -----Original Message-----
> Subject: MPLS-RT review of draft-bonica-mpls-self-ping
> Date: Tue, 24 Feb 2015 17:42:14 +0800
> From: Loa Andersson <[email-masked]>
> To: Carlos Pignataro (cpignata) <[email-masked]>, Gregory Mirsky
> <[email-masked]>, Mach Chen <[email-masked]>,
> Lizhong Jin <[email-masked]>, [email-masked]
> <[email-masked]>, [email-masked]
> <[email-masked]>, <[email-masked]>
> <[email-masked]>
> 
> Carlos, Greg, Mach and Lizhong,
> 
> You have be selected as MPLS-RT reviewers for draft-bonica-mpls-self- ping-04.
> 
> Note to authors: You have been CC'd on this email so that you can know that this
> review is going on. However, please do not review your own document.
> 
> Reviews should comment on whether the document is coherent, is it useful (ie,
> is it likely to be actually useful in operational networks), and is the document
> technically sound?  We are interested in knowing whether the document is
> ready to be considered for WG adoption (ie, it doesn't have to be perfect at this
> point, but should be a good start).
> 
> Reviews should be sent to the document authors, WG co-chairs and WG
> secretary, and CC'd to the MPLS WG email list. If necessary, comments may be
> sent privately to only the WG chairs.
> 
> If you have technical comments you should try to be explicit about what
> *really* need to be resolved before adopting it as a working group document,
> and what can wait until the document is a working group document and the
> working group has the revision control.
> 
> Are you able to review this draft by Mar 11, 2015? Please respond in a timely
> fashion.
> 
> 
> Thanks, Loa
> (as MPLS WG chair)
> --
> 
> 
> Loa Andersson                        email: [email-masked]
> Senior MPLS Expert                          [email-masked] Huawei
> Technologies (consultant)     phone: +46 739 81 21 64
> 
> 
>

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 19 Mar 2015 15:30:35 +0000

Mach,

In a previous email, you said:

> 4. LSP Ping and BFD (especially S-BFD) are alternative tools for LSP readiness
> detection. If the scalability of control plane is the concern, there should be an
> analyses whether S-BFD cannot satisfy the requirement.

The following text addresses that issue.

                                         Ron

Text
====================================
Consider the following use case: 

- A network contains 100's of iLSRs
- Each iLSR is also an eLSR
- The network contains a full-mesh of RSVP-signaled LSPs (tens of thousands of LSPs)
- A network event occurs, causing half of those LSPs to re-signal
- RSVP churns, CPU's boil.....

Now, each iLSR needs to verify the readiness of its LSPs before attempting to forward traffic through them. The following are requirements of the mechanism used to verify readiness:

- it must return results quickly. (There is no time to set up session state or visit the control plane on the egress).
- it can consume only minimal control plane resources at the ingress
- it cannot consume any control plane resources whatsoever on the egress

The last requirement is very important. If the verification mechanism burns control plane resource on the egress, where CPUs are already saturated, network convergence time will suffer.

Only LSP Self ping fulfills the final requirement. Beyond that, LSP Self ping terminates as soon as it has verified LSP readiness.