Subject: [mpls] FW: New Version Notification for draft-xu-sfc-using-mpls-spring-02.txt

From: Xuxiaohu <[email-masked]>
Date: Wed, 4 Mar 2015 03:30:40 +0000

Hi all,

This document describes how to leverage the MPLS-based source routing (i.e., MPLS-SPRING) mechanism as developed by the SPRING WG to realize the service path layer functionality of the service function chaining. In addition, this document also describes how to carry metadata in an MPLS packet by using the NSH as a metadata container. 

Any comments are suggestions are welcome.

Best regards,
Xiaohu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, March 04, 2015 11:24 AM
> To: Lizhenbin; Luis M. Contreras; Xuxiaohu; Himanshu C. Shah; Xuxiaohu;
> Himanshu Shah; Luis M. Contreras; Lizhenbin
> Subject: New Version Notification for draft-xu-sfc-using-mpls-spring-02.txt
> 
> 
> A new version of I-D, draft-xu-sfc-using-mpls-spring-02.txt
> has been successfully submitted by Xiaohu Xu and posted to the IETF repository.
> 
> Name:		draft-xu-sfc-using-mpls-spring
> Revision:	02
> Title:		Service Function Chaining Using MPLS-SPRING
> Document date:	2015-03-03
> Group:		Individual Submission
> Pages:		8
> URL:
> http://www.ietf.org/internet-drafts/draft-xu-sfc-using-mpls-spring-02.txt
> Status:
> https://datatracker.ietf.org/doc/draft-xu-sfc-using-mpls-spring/
> Htmlized:       http://tools.ietf.org/html/draft-xu-sfc-using-mpls-spring-02
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-xu-sfc-using-mpls-spring-02
> 
> Abstract:
>    Source Packet Routing in Networking (SPRING) WG specifies a special
>    source routing mechanism.  Such source routing mechanism can be
>    leveraged to realize the service path layer functionality of the
>    service function chaining (i.e, steering traffic through a particular
>    service function path) by encoding the service function path or the
>    service function chain information as the explicit path information.
>    This document describes how to leverage the MPLS-based source routing
>    mechanism as developed by the SPRING WG to realize the service path
>    layer functionality of the service function chaining.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 23 Mar 2015 21:04:55 +0000

Hi SFC co-chairs,

I have remove those options (i.e., encoding SFC using a label stack consist of global labels and inserting a protocol field after the label stack for MPLS payload indication) which would cause changes to the MPLS architecture in the latest version (http://tools.ietf.org/html/draft-xu-sfc-using-mpls-spring-03). 

Therefore, we co-authors think it's now becoming suitable for the SFC WG to reconsider this simplified MPLS-SPRING-based SFC solution which doesn't require any change to the MPLS base architecture.

Best regards,
Xiaohu

> From: Xuxiaohu
> Sent: Friday, March 06, 2015 8:49 AM
> To: 'Jim Guichard (jguichar)'; Ron Parker
> Cc: mpls at ietf.org; <spring at ietf.org>; sfc at ietf.org
> Subject: RE: [sfc] New Version Notification for
> draft-xu-sfc-using-mpls-spring-02.txt
> 
> Hi Jim,
> 
> Understood.
> 
> Best regards,
> Xiaohu
> 
> > From: Jim Guichard (jguichar) [mailto:jguichar at cisco.com]
> > Sent: Thursday, March 05, 2015 11:11 PM
> > To: Ron Parker; Xuxiaohu
> > Cc: mpls at ietf.org; <spring at ietf.org>; sfc at ietf.org
> > Subject: Re: [sfc] New Version Notification for
> > draft-xu-sfc-using-mpls-spring-02.txt
> >
> > Hi Xiaohu,
> >
> > Thomas and I read your latest draft and believe that you will need to
> > take it to the MPLS WG as a first step. There are a number of things
> > within the document that may require changes to the base MPLS
> > architecture and the SFC WG is not the right community to address
> > those. Given this we will not be able to consider this document in the
> > SFC WG without agreement from the broader MPLS community.
> >
> > Regards,
> >
> > Jim & Thomas