Subject: [mpls] Pete Resnick's No Objection on draft-ietf-mpls-lsp-ping-registry-02: (with COMMENT)

From: "Pete Resnick" <[email-masked]>
Date: Tue, 03 Mar 2015 21:58:44 -0800

Pete Resnick has entered the following ballot position for
draft-ietf-mpls-lsp-ping-registry-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-registry/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

It's not at all clear to me why this document is going for Standards
Track or why it updates 4379 and 6424, nor does the ballot nor shepherd
writeup explain. It's creating a registry, which doesn't change the
protocol in either of those documents. Seems to me fine that it be
Informational, and that it doesn't update anything.

2.2, 2.3, 2.4:

OLD
   The registration policies [RFC5226] for this registry are:

      0-250    Standards Action
    251-254    Experimental
        255    Standards Action
NEW
   The registration policies [RFC5226] for this registry is Standards
   Action.

The registration policy for the entire registry is "Standards Action".
Within the registry itself, the values 251-254 should be marked
Experimental (which they are) and 255 should be marked Reserved (which it
is), but that doesn't change the registration policy.

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 4 Mar 2015 11:52:12 -0000

Hi Pete,

Is that a windmill?
Let me fetch your horse, Master.

> Informational, and that it doesn't update anything.

I can't say I am bothered by Standards Track or Informational.
I believe the thinking is that in order to modify a "standards action" registry, it is necessary to conform to the requirements of "standards action".
I see no evidence for that belief other than that is how our grandfathers always did it.
OTOH, I don't actually see a big disadvantage to using Standards Track especially given the other abuses we commit daily.

Wrt Update:
It seems to me that this document "fixes" something in 4379 and 6424. Sure, it doesn't fix the any protocol details, but it does update what they say. As much as anything, this is about metadata and cross links. Fix *that* and we don't need Updates.

Erm, well, I think "Experimental Use" is a 5226 allocation policy.
But I agree with you that once allocations have been made (or reserved, or whatever) then it doesn't make much sense to talk about the allocation policy that applied.

That said, if the IANA is content with this text, I would prefer just to hang on to it.

A

---

From: Pete Resnick <[email-masked]>
Date: Wed, 4 Mar 2015 09:55:34 -0600

> Let me fetch your horse, Master.

"Finally, from so little sleeping and so much reading, his brain dried 
up and he went completely out of his mind." -- Cervantes 
<https://books.google.com/books?id=_A62JbwvXeYC&pg=PA27#v=onepage&q&f=false>

> I can't say I am bothered by Standards Track or Informational.

I think I was more bothered by the question not being answered in the 
shepherd writeup (that's a poke, Ross ;-) ) than the result. You will 
note that this is not something I was inclined to DISCUSS.

> I see no evidence for that belief other than that is how our grandfathers always did it.

Yep.

> OTOH, I don't actually see a big disadvantage to using Standards Track especially given the other abuses we commit daily.

"Doctor, it hurts when I do this."

> It seems to me that this document "fixes" something in 4379 and 6424. Sure, it doesn't fix the any protocol details, but it does update what they say. As much as anything, this is about metadata an…

Yep. Tools makes rules.

So, totally understood. Windmill tilted at. We can move on.

> Erm, well, I think "Experimental Use" is a 5226 allocation policy.

Allocation policies are per registry, not per registry entry. They 
indicate how things get into the registry.

> That said, if the IANA is content with this text, I would prefer just to hang on to it.

Luckily for us, IANA is content with all sorts of things.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 4 Mar 2015 16:21:30 -0000

> Allocation policies are per registry, not per registry entry.

Are they now?
So when a registry is broken into ranges of Standards Action, and FCFS, and
Experimental Use, and Private Use, would you say this has broken 5226 or created
multiple registries?

For example (at random)
http://www.iana.org/assignments/rsvp-parameters/rsvp-parameters.xhtml#rsvp-param
eters-4

> They indicate
> how things get into the registry.

That they most surely do.

> But I agree with you that once allocations have been made (or reserved,
> or whatever) then it doesn't make much sense to talk about the allocation 
> policy that applied.
>

That's why they get the big bucks.

A

---

From: Barry Leiba <[email-masked]>
Date: Wed, 4 Mar 2015 17:54:09 +0100

> Experimental Use, and Private Use, would you say this has broken 5226 or created

I think that's not the same.  In this case, you don't have a range
that's allocated using the "Experimental" policy.  You have a range
that's already assigned to experimental use.

On the other hand, I'll point out to Pete that "Experimental Use" and
"Private Use" in 5226 aren't really registration policies anyway.
They're listed with policies, but are written as *usage* policies, not
*registration* policies.  There's also a separate "Experimental" usage
label (see Section 4).  Maybe when I actually get to dealing with the
comments on 5226bis (I've been putting it off) I'll address this.

In any case, I agree with Adrian that there's no issue here, either
way you slice it.

Barry