Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 24 Jul 2015 05:26:04 +0000

Hi all,

Please note that CONTINUE in SPRING is:

1. A DP-agnostic primitive

2. *Implemented* as SWAP instruction with MPLS DP.

So claiming equivalence of CONTINUE and NO-SWAP seems to be inaccurate IMO.

As for global labels (in SDN, MPLS-TP or any other technology) - this definitely looks to me like a very bad idea for networks comprised of devices that support different label ranges. From my experience these scenarios have been encountered in real MPLS-TP deployments  and resulted in eventually dropping the "simple" solution as live networks have been extended with new NEs supporting a more narrow label space than the original ones.

Adding a new forwarding primitive to MPLS architecture (yet another argument on this thread) immediately raises the question:

Is support of the new primitive mandatory?

If it is not (and this is clearly the case for NO-SWAP), then why should we bother? Occam's rasor cuts this off IMHO.

My personal bottom line: this is a strictly NO GO proposal.

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked];
Subject:Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

The point is that new control plane is already defined. In fact we already have two :)

As I mentioned in my first mail to the list the concept of NO_SWAP/CONTINUE is common to both H-SDN and SEGMENT ROUTING architectures.

Ref: https://goo.gl/3oxRbl

Thx,
R.

On Thu, Jul 23, 2015 at 11:16 PM, Shahram Davari  <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

So instead of calling it no-swap probably you should call it global label or so, and then define new control plane for it. But seems the data-pane behavior does not change and existing hardware can support this global label.  So maybe you just need new control plane.

Thx
Shahram

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Robert Raszuk
Sent: Thursday, July 23, 2015 2:12 PM
To: Shahram Davari
Cc: Eric C Rosen; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Hi Shahram,

Labels which are non of a local significance can be distributed by flooding protocols extensions (ISIS, OSPF) or by direct p2p sessions (BGP 3107, sessions from the controller, XMPP etc ...)

The important part is that the actual forwarding is computed recursively or set at the controller.

AFAIK I have not seen any proposal where LDP would play any role in such distribution.

Regards,
R.

On Thu, Jul 23, 2015 at 11:07 PM, Shahram Davari <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert,

How are these labels distributed? Via LDP or via SDN controller?

Thanks
Shahram

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Robert Raszuk
Sent: Thursday, July 23, 2015 12:58 PM
To: Eric C Rosen
Cc: Shahram Davari; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

​Hi Eric,​

​​
If you notice that the incoming label needs to be 'replaced' by an outgoing label of the same value, you could just make the rewrite string shorter, so it won't overwrite the top label on the stack.  This seems to be what the draft suggests, but it could be done as an optimization for the particular case where the incoming and outgoing labels have the same value.

​This is precisely ​the crux where your statement fails.

You use term "incoming label" and "outgoing lable" ... well in the new architectures there is no such things.

It is a "global label" or "path label" with adjacency information.

So to support legacy hardware new control plane has to make up from single label now two (identical) labels to pass it to data plane. Now also data plane must be smart to check that and program its state per your suggestion.

Why would we do that other then due to worry about legacy chipsets feared to be non compliant to new RFC ?

Many thx,
R.

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 24 Jul 2015 07:49:18 +0000

Hi all,

Before considering the possible MPLS forwarding optimization for global labels (a.k.a., domain-wide labels), should we firstly legalize the usage of global labels within the MPLS community? BTW, I believe global labels would be very useful and neccessary in some use cases, such as anycast segment.

Best regards,

Xiaohu

________________________________
发件人: mpls [[email-masked]] 代表 Alexander Vainshtein [[email-masked]]
发送时间: 2015年7月24日 13:26
收件人: Robert Raszuk; Shahram Davari
抄送: [email-masked]
主题: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Hi all,

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked];

Thx,
R.

Thx
Shahram

Hi Shahram,

Regards,
R.

Thanks
Shahram

​Hi Eric,​

​​

Many thx,
R.

---

From: Andrew Qu <[email-masked]>
Date: Fri, 24 Jul 2015 08:06:45 +0000

Hi Sasha,

My comments in lines…

From: mpls [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: Friday, July 24, 2015 7:26 AM
To: Robert Raszuk; Shahram Davari
Cc: [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Hi all,

[Andrew]  You are contradicting with 1) and 2).

With “CONTINUE” defined in SR draft,  for NEW ASIC to be designed,

Why should I still use “SWAP” to achieve it? Considering that I might

Have good saving in precious on-board memory for the ASIC ?

You can suggest that using SWAP, however you said CONTINUE is DP-agnostic, then

If I do it different, I am still standard compliant. RIGHT?

Again,  that is exactly my point,  SWAP is NOT the same as “NO_SWAP”.  Once you put

The wording out there,  it WILL have different impact.

Thanks,

Andrew

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked]<mailto:[email-masked]>;

Thx,
R.

Thx
Shahram

Hi Shahram,

Regards,
R.

Thanks
Shahram

​Hi Eric,​

​​

Many thx,
R.

---

From: Andrew Qu <[email-masked]>
Date: Fri, 24 Jul 2015 08:15:59 +0000

As for the voting,  I feel this draft has informational value.  It’s go for me.

Thanks,

Andrew

Hi all,

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked]<mailto:[email-masked]>;

Thx,
R.

Thx
Shahram

Hi Shahram,

Regards,
R.

Thanks
Shahram

​Hi Eric,​

​​

Many thx,
R.

---

From: Lizhenbin <[email-masked]>
Date: Fri, 24 Jul 2015 08:40:05 +0000

Hi all,

I think the concept is one hand, the implementation is another hand. I would like to clarify more about it.

1. Now all of us debates if there is NO_SWAP. I want to ask one question: Should there be SWAP? In fact, according to implementation, the SWAP can be seen as POP a label, then PUSH a label.

If so, POP and PUSH is enough. Why is there SWAP.

2. For the NO_SWAP, as the introduction of H-SDN and Segment Routing, at least in concept, there should introduce one new label operation. Regarding the implementation you can use SWAP same label, or POP one label and PUSH the same label if you like. There is also the possible way introduced in the draft-fang-mpls-label-forwarding-no-swap.

In addition I would like to propose the suggestion that a totally new term for the NO_SWAP label operation should be introduced such as CONTINUE, GO, DIRECTGO, etc. Why must we make it related with the existing the label operations?

Best Regards,

Zhenbin(Robin)

________________________________
发件人: mpls [[email-masked]] 代表 Andrew Qu [[email-masked]]
发送时间: 2015年7月24日 16:06
收件人: Alexander Vainshtein; Robert Raszuk; Shahram Davari
抄送: [email-masked]
主题: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Hi Sasha,

My comments in lines…

Hi all,

Thanks,

Andrew

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked]<mailto:[email-masked]>;

Thx,
R.

Thx
Shahram

Hi Shahram,

Regards,
R.

Thanks
Shahram

​Hi Eric,​

​​

Many thx,
R.

************* Email Confidentiality Notice ********************
The information contained in this e-mail message (including any
attachments) may be confidential, proprietary, privileged, or otherwise
exempt from disclosure under applicable laws. It is intended to be
conveyed only to the designated recipient(s). Any use, dissemination,
distribution, printing, retaining or copying of this e-mail (including its
attachments) by unintended recipient(s) is strictly prohibited and may
be unlawful. If you are not an intended recipient of this e-mail, or believe
that you have received this e-mail in error, please notify the sender
immediately (by replying to this e-mail), delete any and all copies of
this e-mail (including any attachments) from your system, and do not
disclose the content of this e-mail to any other person. Thank you!

---

From: Andrew Qu <[email-masked]>
Date: Fri, 24 Jul 2015 09:21:54 +0000

Agreed!   From networking point of view,  no_swap and swap is simply different fundamentally.  We should address that.

Thanks,

Andrew

From: Lizhenbin [mailto:[email-masked]]
Sent: Friday, July 24, 2015 10:40 AM
To: [email-masked]; Andrew Qu; Alexander Vainshtein; Shahram Davari; Robert Raszuk
Subject: 答复: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Hi all,

Best Regards,

Zhenbin(Robin)

抄送: [email-masked]<mailto:[email-masked]>

My comments in lines…

Cc: [email-masked]<mailto:[email-masked]>

Hi all,

Thanks,

Andrew

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked]<mailto:[email-masked]>;

Thx,
R.

Thx
Shahram

Hi Shahram,

Regards,
R.

Thanks
Shahram

​Hi Eric,​

​​

Many thx,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 24 Jul 2015 11:30:03 +0200

Another way to look at this is that SWAP requires awarness of peer's labels
either by flooding, by p2p protocol like LDP or via learning to controller
and pushing it back in p2mp fashion.

NO_SWAP does not have such dependency. It can be educated about just
endpoint label mapping from controller and actual forwarding and adj
creation will be local based on the vanilla IGP SPF.

To me this is fundamental difference.

Cheers,
R.

On Fri, Jul 24, 2015 at 11:21 AM, Andrew Qu <[email-masked]> wrote:

>  Agreed!   From networking point of view,  no_swap and swap is simply
> different fundamentally.  We should address that.
>
>
>
> Thanks,
>
>
>
> Andrew
>
>
>
>
>
> *From:* Lizhenbin [mailto:[email-masked]]
> *Sent:* Friday, July 24, 2015 10:40 AM
> *To:* [email-masked]; Andrew Qu; Alexander Vainshtein; Shahram Davari;
> Robert Raszuk
> *Subject:* 答复: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much
> does it really save?
>
>
>
> Hi all,
>
> 1. Now all of us debates if there is NO_SWAP. I want to ask one question:
> Should there be SWAP? In fact, according to implementation, the SWAP can be
> seen as POP a label, then PUSH a label.
>
> 2. For the NO_SWAP, as the introduction of H-SDN and Segment Routing, at
> least in concept, there should introduce one new label operation. Regarding
> the implementation you can use SWAP same label, or POP one label and PUSH
> the same label if you like. There is also the possible way introduced in
> the draft-fang-mpls-label-forwarding-no-swap.
>
>
>
> In addition I would like to propose the suggestion that a totally new term
> for the NO_SWAP label operation should be introduced such as CONTINUE, GO,
> DIRECTGO, etc. Why must we make it related with the existing the label
> operations?
>
>
>
>
>
> Best Regards,
>
> Zhenbin(Robin)
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>  ------------------------------
>
> *发件人**:* mpls [[email-masked]] 代表 Andrew Qu [[email-masked]
> ]
> *发送时间**:* 2015年7月24日 16:06
> *收件人**:* Alexander Vainshtein; Robert Raszuk; Shahram Davari
> *抄送**:* [email-masked]
> *主题**:* Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much
> does it really save?
>
> Hi Sasha,
>
>
>
> My comments in lines…
>
>
>
>
>
>
>
> *From:* mpls [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Alexander Vainshtein
> *Sent:* Friday, July 24, 2015 7:26 AM
> *To:* Robert Raszuk; Shahram Davari
> *Cc:* [email-masked]
>
> *Subject:* Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much
> does it really save?
>
>
>
> Hi all,
>
> As for global labels (in SDN, MPLS-TP or any other technology) - this
> definitely looks to me like a very bad idea for networks comprised of
> devices that support different label ranges. From my experience these
> scenarios have been encountered in real MPLS-TP deployments  and resulted
> in eventually dropping the "simple" solution as live networks have been
> extended with new NEs supporting a more narrow label space than the
> original ones.
>
>
>
> Adding a new forwarding primitive to MPLS architecture (yet another
> argument on this thread) immediately raises the question:
>
>
>
> If it is not (and this is clearly the case for NO-SWAP), then why should
> we bother? Occam's rasor cuts this off IMHO.
>
>
>
> *From: *Robert Raszuk
> *Date: *24/07/2015 00:22
> *To: *Shahram Davari;
> *Cc: [email-masked];
> *Subject:*Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much
> does it really save?
>
>
>
> As I mentioned in my first mail to the list the concept of
> NO_SWAP/CONTINUE is common to both H-SDN and SEGMENT ROUTING architectures.
>
>
>
> On Thu, Jul 23, 2015 at 11:16 PM, Shahram Davari  <[email-masked]>
> wrote:
>
> Robert,
>
>
>
> So instead of calling it no-swap probably you should call it global label
> or so, and then define new control plane for it. But seems the data-pane
> behavior does not change and existing hardware can support this global
> label.  So maybe you just need new control plane.
>
>
>
> Thx
> Shahram
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Robert
> Raszuk
> *Sent:* Thursday, July 23, 2015 2:12 PM
> *To:* Shahram Davari
> *Cc:* Eric C Rosen; [email-masked]; [email-masked]
>
>
> *Subject:* Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much
> does it really save?
>
>
>
>
>
> Hi Shahram,
>
>
>
> Labels which are non of a local significance can be distributed by
> flooding protocols extensions (ISIS, OSPF) or by direct p2p sessions (BGP
> 3107, sessions from the controller, XMPP etc ...)
>
>
>
> On Thu, Jul 23, 2015 at 11:07 PM, Shahram Davari <[email-masked]>
> wrote:
>
> Hi Robert,
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Robert
> Raszuk
> *Sent:* Thursday, July 23, 2015 12:58 PM
> *To:* Eric C Rosen
> *Cc:* Shahram Davari; [email-masked]; [email-masked]
> *Subject:* Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much
> does it really save?
>
>
>
> ​Hi Eric,​
>
>
>
>  ​​
>
> If you notice that the incoming label needs to be 'replaced' by an
> outgoing label of the same value, you could just make the rewrite string
> shorter, so it won't overwrite the top label on the stack.  This seems to
> be what the draft suggests, but it could be done as an optimization for the
> particular case where the incoming and outgoing labels have the same value.
>
>
>
> So to support legacy hardware new control plane has to make up from single
> label now two (identical) labels to pass it to data plane. Now also data
> plane must be smart to check that and program its state per your
> suggestion.
>
>
>

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 24 Jul 2015 15:10:59 +0000

From: mpls [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Friday, July 24, 2015 2:30 AM
To: Andrew Qu
Cc: [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Another way to look at this is that SWAP requires awarness of peer's labels either by flooding, by p2p protocol like LDP or via learning to controller and pushing it back in p2mp fashion.

NO_SWAP does not have such dependency. It can be educated about just endpoint label mapping from controller and actual forwarding and adj creation will be local based on the vanilla IGP SPF.

[Uma]: Absolutely. And the need for NO_SWAP/CONTINUE kind of semantic was never needed earlier in 3031.
FWIW, It’s good  to define  a single term for this rather than per application (SR/HSDN etc..).

Cheers,
R.

On Fri, Jul 24, 2015 at 11:21 AM, Andrew Qu <[email-masked]<mailto:[email-masked]>> wrote:
Agreed!   From networking point of view,  no_swap and swap is simply different fundamentally.  We should address that.

Thanks,

Andrew

From: Lizhenbin [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, July 24, 2015 10:40 AM
To: [email-masked]<mailto:[email-masked]>; Andrew Qu; Alexander Vainshtein; Shahram Davari; Robert Raszuk
Subject: 答复: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Hi all,

Best Regards,

Zhenbin(Robin)

发件人: mpls [[email-masked]<mailto:[email-masked]>] 代表 Andrew Qu [[email-masked]<mailto:[email-masked]>]

My comments in lines…

Hi all,

Thanks,

Andrew

My 2c.

Thumb typed on my LG,
Sasha

------ Original message ------
From: Robert Raszuk
Date: 24/07/2015 00:22
To: Shahram Davari;
Cc: [email-masked]<mailto:[email-masked]>;

Thx,
R.

Thx
Shahram

Hi Shahram,

Regards,
R.

Thanks
Shahram

​Hi Eric,​

​​

Many thx,
R.

---

From: Eric C Rosen <[email-masked]>
Date: Fri, 24 Jul 2015 11:53:29 -0400

On 7/24/2015 4:40 AM, Lizhenbin wrote:
> In fact, according to implementation, the SWAP can be seen as POP a
> label, then PUSH a label.

Certainly the architecture could have been written this way.  But it 
wasn't ;-)  It was written in such a way as to emphasize the difference 
between operations that change the size of the label stack and 
operations that do not.

These concepts do not necessarily show up at all in the forwarding 
logic.  All the forwarding plane has to know is what the rewrite string 
is, where to put it, and how to adjust any TTL and/or checksum fields 
that might be in it.

---

From: Loa Andersson <[email-masked]>
Date: Sat, 25 Jul 2015 10:00:16 +0200

Folks,

> between operations that change the size of the label stack and

In addition the intention of a pop (in most cases) is to make the next
label in the stack available to take decisions on, a swap does not do
this.

/Loa
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 27 Jul 2015 15:30:16 +0100

On 24/07/2015 09:06, Andrew Qu wrote:
>
> Hi Sasha,
>
> My comments in lines…
>
> *From:*mpls [mailto:[email-masked]] *On Behalf Of *Alexander 
> Vainshtein
> *Subject:* Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how 
> much does it really save?
>
> Hi all,
>
What Sasha says is correct
> Why should I still use “SWAP” to achieve it?
>
.. because you need to be backwards compatible with
the deployed equipment and deployed networks.

If that is not a requirement in your world, then I suggest
that you get a new ethertype and call it MPLS2

- Stewart

---

From: Andrew Qu <[email-masked]>
Date: Mon, 27 Jul 2015 18:56:07 +0000

Hi Stewart,

From: Stewart Bryant [mailto:[email-masked]]
Sent: Monday, July 27, 2015 4:30 PM
To: Andrew Qu; Alexander Vainshtein; Robert Raszuk; Shahram Davari
Cc: [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

My comments in lines...

Hi all,

[Andrew]  You are contradicting with 1) and 2).
What Sasha says is correct
[Andrew]  I don't think so,  points are listed below.

With "CONTINUE" defined in SR draft,  for NEW ASIC to be designed,

Why should I still use "SWAP" to achieve it?
.. because you need to be backwards compatible with
the deployed equipment and deployed networks.

[Andrew] "backwards compatible" is right consideration, hence I don't object
                to mention 2) as an option, so people read such RFC will be clear about
how to support that feature using existing device.  but "NO_SWAP" is another option
to support such primitive called "CONTINUE", to be REALLY "DP-agnostic", they you must
exhaust all options to also mention "NO_SWAP" simply from being logically consistent
"agnostic", let alone there are technical benefits to mention.

Adding "NO_SWAP" for new/future generation DEVICE does NOT break backward capability.

Rule number 1 says "DP-agnostic", but at the same time you purposely leave one option out but
Insists one more two options, then it is contradicting, simply from logic point of view.

[Andrew] You mis-understood my points,  I am fully aware of backward compatibility requirement by asking
adding NO_SWAP primitive.
                Please think again if I need MPLS2 or not,  I don't think so.

Andrew

- Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 28 Jul 2015 12:03:22 +0100

> Adding “NO_SWAP” for new/future generation DEVICE does NOT break 
> backward capability.
>
Andrew

Existing devices should be assumed to have non-aligned label spaces.
(there is much empirical evidence to support this position)

So if you have a no-swap only device between two existing devices
you cannot be sure that you can build an LSP.

A backwards compatible device would therefore need to support swap.

Once you support swap then no-swap become an optimization.

- Stewart

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 28 Jul 2015 13:11:18 +0200

Stewart,

That is not quite correct.

I can have context label directing my packets to a completely new label
space on both old and new devices.

Therefor mutually disjoined non aligned label space is not sufficient
reason to enforce swap action on all LSRs.

Besides while you can call it as optimization what is the problem in
defining it ?

Cheers,
R.
On Jul 28, 2015 1:03 PM, "Stewart Bryant" <[email-masked]> wrote:

> Adding “NO_SWAP” for new/future generation DEVICE does NOT break backward
>> capability.
>>
>>  Andrew
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 28 Jul 2015 07:49:38 -0400

Stewart has it right:

> that you get a new ethertype and call it MPLS2

This is enough of a deviation from the millions of devices in the installed
base that you can just get a new Ethertype and optimize to your heart's
content. You're going to need new ASICs anyway, may as well go all the way.
This also removes the need to do any sort of peer capability negotiation
for backwards compatibility, and gives you the freedom to produce devices
that ONLY support MPLS2 if you so desire, to have a less expensive and
optimized data center solution. I would support standardization in this
case.

Cheers,
Andy

---

From: Andrew Qu <[email-masked]>
Date: Tue, 28 Jul 2015 14:35:28 +0000

Hi Andy,

Let’s drop this.  No one intend to break anything.  Any talk in this direction is trash talk, hence let’s avoid it.

Thanks,

Andrew

From: Andrew G. Malis [mailto:[email-masked]]
Sent: Tuesday, July 28, 2015 4:50 AM
To: Stewart Bryant
Cc: Andrew Qu; Alexander Vainshtein; Robert Raszuk; Shahram Davari; [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Stewart has it right:

On Mon, Jul 27, 2015 at 10:30 AM, Stewart Bryant <[email-masked]<mailto:[email-masked]>> wrote:
If that is not a requirement in your world, then I suggest
that you get a new ethertype and call it MPLS2

This is enough of a deviation from the millions of devices in the installed base that you can just get a new Ethertype and optimize to your heart's content. You're going to need new ASICs anyway, may as well go all the way. This also removes the need to do any sort of peer capability negotiation for backwards compatibility, and gives you the freedom to produce devices that ONLY support MPLS2 if you so desire, to have a less expensive and optimized data center solution. I would support standardization in this case.

Cheers,
Andy

---

From: Andrew Qu <[email-masked]>
Date: Tue, 28 Jul 2015 14:57:34 +0000

Hi Stewart,

Agreed that SWAP must be kept because MPLS fundamentals can't be broken.
And I agreed that _if_ there is NO such global label space idea,  no-swap is
optimization of swap as well. 

However I don't agree no-swap become an optimization in terms of network
Behavior when global label idea become a needed thing.

When global Label introduced, then no_swap is the conceptually right thing for the transition [even
Local implementation can use swap to achieve, again, per previous conversation,
the popular wisdom, which I agreed as well,  is that this is local implementation, we should
not get involved, so we must define no-swap as the new primitive at RFC level]

So the question really boils down to that do we need global label?

I believe that is the key thing here.  May be we can put swap/no-swap aside for the moment.

Thanks,

Andrew

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Tuesday, July 28, 2015 4:03 AM
To: Andrew Qu; Alexander Vainshtein; Robert Raszuk; Shahram Davari
Cc: [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Andrew

So if you have a no-swap only device between two existing devices you cannot be sure that you can build an LSP.

- Stewart

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 28 Jul 2015 14:58:28 +0000

It does remind me of the discussion around T-MPLS. After couple years we’ve managed to shape it into MPLS-TP and, I hope, learned a thing or two. So, may be another profile of MPLS is due this time?

                Regards,
                                Greg

From: mpls [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Tuesday, July 28, 2015 4:50 AM
To: Stewart Bryant
Cc: [email-masked]; Robert Raszuk
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Stewart has it right:

Cheers,
Andy

---

From: Shahram Davari <[email-masked]>
Date: Tue, 28 Jul 2015 16:40:21 +0000

Andrew

Continue operation in segment routing and in HSDN is not global label. Global label means every router knows how to forward a global label. What is the application for a global label and how does each router know how to forward it?

Regards,
Shahram

> On Jul 28, 2015, at 7:58 AM, Andrew Qu <[email-masked]> wrote:
> 
> Hi Stewart,
>

---

From: Andrew Qu <[email-masked]>
Date: Tue, 28 Jul 2015 17:55:37 +0000

Hi Shahram,

This is a question that must be answered,  but could you please hold the question for now?

I just want to have one issue clarified before moving to another.

Do we agree that _IF_ global label becomes necessary,  no-swap as primitive is necessary?

Understood that _IF_ will be next topic to follow.  

Thanks,

Andrew

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]] 
Sent: Tuesday, July 28, 2015 9:40 AM
To: Andrew Qu
Cc: [email-masked]; Alexander Vainshtein; Robert Raszuk; [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Andrew

Regards,
Shahram

> And I agreed that _if_ there is NO such global label space idea,  
> no-swap is optimization of swap as well.
> 
> However I don't agree no-swap become an optimization in terms of 
> network Behavior when global label idea become a needed thing.
> 
> 
> When global Label introduced, then no_swap is the conceptually right 
> thing for the transition [even Local implementation can use swap to 
> achieve, again, per previous conversation, the popular wisdom, which I 
> agreed as well,  is that this is local implementation, we should not 
> get involved, so we must define no-swap as the new primitive at RFC 
> level]
> 
> 
> ************* Email Confidentiality Notice ******************** The 
> information contained in this e-mail message (including any
> attachments) may be confidential, proprietary, privileged, or 
> otherwise exempt from disclosure under applicable laws. It is intended 
> to be conveyed only to the designated recipient(s). Any use, 
> dissemination, distribution, printing, retaining or copying of this 
> e-mail (including its
> be unlawful. If you are not an intended recipient of this e-mail, or 
> believe that you have received this e-mail in error, please notify the 
> sender immediately (by replying to this e-mail), delete any and all 
> copies of this e-mail (including any attachments) from your system, 
> and do not disclose the content of this e-mail to any other person. Thank you!
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 28 Jul 2015 19:36:22 +0100

Andrew,

> Do we agree that _IF_ global label becomes necessary,  no-swap as primitive is

No, not really.
A new primitive may be useful to describe what goes on in such a world, but it
is not necessary because we can already describe such a world.

But, underlying this is the question: what are these primitives? They are not
things you see on the wire; they are descriptions of what goes on inside a
router/switch. They don't need to be defined for standardisation.

The place that all of this might be useful is on an interface that is used to
program a device. If that is useful then go for it - write the data model or
interface spec for it. But I don't believe this has anything to do with 3031.

> Understood that _IF_ will be next topic to follow.

Appreciate separating the two questions although maybe you have the order wrong
:-)

Obviously, Stewart's words of warning about integrating with legacy devices
doing downstream label allocation must be considered. but that is a network
design issue.

Adrian

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 29 Jul 2015 03:06:45 +0000

> I believe that is the key thing here.  May be we can put swap/no-swap aside for

Concur.

Best regards,
Xiaohu

> attachments) may be confidential, proprietary, privileged, or otherwise exempt
> from disclosure under applicable laws. It is intended to be conveyed only to the
> designated recipient(s). Any use, dissemination, distribution, printing, retaining
> or copying of this e-mail (including its
> attachments) by unintended recipient(s) is strictly prohibited and may be
> unlawful. If you are not an intended recipient of this e-mail, or believe that you
> have received this e-mail in error, please notify the sender immediately (by
> replying to this e-mail), delete any and all copies of this e-mail (including any
> attachments) from your system, and do not disclose the content of this e-mail to
> any other person. Thank you!
>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 29 Jul 2015 13:52:31 +0100

> Do we agree that _IF_ global label becomes necessary,  no-swap as primitive is necessary?
No, the primitive is not *needed*.

Stewart
> .

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Andrew Qu <[email-masked]>
Date: Thu, 30 Jul 2015 01:22:29 +0000

Alright, not convincingly, I will hold it to myself for now.

Thanks

Andrew

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Wednesday, July 29, 2015 5:53 AM
To: Andrew Qu; Shahram Davari
Cc: Alexander Vainshtein; Robert Raszuk; [email-masked]
Subject: Re: [mpls] draft-fang-mpls-label-forwarding-no-swap - how much does it really save?

Stewart
>> achieve, again, per previous conversation, the popular wisdom, which 
>> I agreed as well,  is that this is local implementation, we should 
>> otherwise exempt from disclosure under applicable laws. It is 
>> intended to be conveyed only to the designated recipient(s). Any use, 
>> attachments) by unintended recipient(s) is strictly prohibited and 
>> may be unlawful. If you are not an intended recipient of this e-mail, 
>> or believe that you have received this e-mail in error, please notify 
>> the sender immediately (by replying to this e-mail), delete any and 
>> all copies of this e-mail (including any attachments) from your 
>> system, and do not disclose the content of this e-mail to any other person. Thank you!
>>