Subject: Re: [mpls] [Technical Errata Reported] RFC6428 (3629)

From: Loa Andersson <[email-masked]>
Date: Wed, 15 Jul 2015 08:56:07 +0200

Folks,

The errata seems correct, but I'd like the authors to nod also :),
John, George and/or Dave.

/Loa

On 2013-05-21 16:13, RFC Errata System wrote:
> The following errata report has been submitted for RFC6428,
> "Proactive Connectivity Verification, Continuity Check, and Remote Defect Indication for the MPLS Transport Profile".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6428&eid=3629
>
> --------------------------------------
> Type: Technical
> Reported by: Alan Davey <[email-masked]>
>
> Section: 3.5.3
>
> Original Text
> -------------
> The length is the length of the following data: the Global_ID, Node Identifier, and Attachment Circuit ID (AC_ID) are as per [9].
>
>
> Corrected Text
> --------------
> The length is the length of the data following the length field.  The Global_ID, Node Identifier, and Attachment Circuit ID (AC_ID) are as per [9].
>
>
> Notes
> -----
>
>
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6428 (draft-ietf-mpls-tp-cc-cv-rdi-06)
> --------------------------------------
> Title               : Proactive Connectivity Verification, Continuity Check, and Remote Defect Indication for the MPLS Transport Profile
> Publication Date    : November 2011
> Author(s)           : D. Allan, Ed., G. Swallow Ed., J. Drake Ed.
> Category            : PROPOSED STANDARD
> Source              : Multiprotocol Label Switching
> Area                : Routing
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Loa Andersson <[email-masked]>
Date: Wed, 15 Jul 2015 08:57:40 +0200

Folks,

Sorry - forget this, wrong errata :(!

/Loa

On 2015-07-15 08:56, Loa Andersson wrote:
>> "Proactive Connectivity Verification, Continuity Check, and Remote
>> Defect Indication for the MPLS Transport Profile".
>>
>> The length is the length of the following data: the Global_ID, Node
>> Identifier, and Attachment Circuit ID (AC_ID) are as per [9].
>>
>>
>> Corrected Text
>> --------------
>> The length is the length of the data following the length field.  The
>> Global_ID, Node Identifier, and Attachment Circuit ID (AC_ID) are as
>> per [9].
>>
>>
>> Notes
>> -----
>>
>>
>> Instructions:
>> -------------
>> Title               : Proactive Connectivity Verification, Continuity
>> Check, and Remote Defect Indication for the MPLS Transport Profile
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 15 Jul 2015 11:05:58 +0100

Actually we had better find out what people have implemented.

I agree that the change looks to reflect the intent, but you could
actually implement the text as written, since we have a length
then some fixed field and then a length.

- Stewart

On 15/07/2015 07:56, Loa Andersson wrote:
> .

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: David Allan I <[email-masked]>
Date: Wed, 15 Jul 2015 15:52:59 +0000

The problem in the original text is the enumeration of fields and references in the TLV encompassed by the length is split over two sentences. So the proposed errata does make it clearer and would be better than simply munging the two sentences together....

So I'm good with it

Cheers
D

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Tuesday, July 14, 2015 11:56 PM
To: RFC Errata System; David Allan I; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Technical Errata Reported] RFC6428 (3629)

Folks,

The errata seems correct, but I'd like the authors to nod also :), John, George and/or Dave.

/Loa

On 2013-05-21 16:13, RFC Errata System wrote:
> The following errata report has been submitted for RFC6428, "Proactive 
> Connectivity Verification, Continuity Check, and Remote Defect Indication for the MPLS Transport Profile".
>
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party (IESG) can log in to 
> change the status and edit the report, if necessary.
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 16 Jul 2015 11:52:24 +0100

... but what have people implemented?

- Stewart

---

From: David Allan I <[email-masked]>
Date: Thu, 16 Jul 2015 13:52:23 +0000

Point taken. 

Dave

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Thursday, July 16, 2015 3:52 AM
To: David Allan I; Loa Andersson; RFC Errata System; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Technical Errata Reported] RFC6428 (3629)

- Stewart

On 15/07/2015 16:52, David Allan I wrote:
> To: RFC Errata System; David Allan I; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]

---

From: Loa Andersson <[email-masked]>
Date: Thu, 16 Jul 2015 19:04:11 +0200

Folks,

I might have made a mistake that causes a mix up of two errata.

We have a new erratum RFC6428 (4415) sent by Greg. This errata is
active, and we need to respond to it.

We also have an old erratum RFC6428 (3629), this was verified back in
2013. If we want to reopen this we will need a new errata.

What happened was that when I got the new errata I did go back and check
the earlier.

When I intended to respond to the new errata (4415), I responded to the
mail reporting errata (3629). I think all mails have been on the working
group mailing list.

It seems to that some of the comments are on the verified (3629) and
some are on (4415).

Can those of you that participated in the discussion so far verify that
your comments are intended for errata (4415).

/Loa
with the fool's cap on

---

From: Alice Russo <[email-masked]>
Date: Fri, 17 Jul 2015 12:49:42 -0700

> 2013. If we want to reopen this we will need a new errata.

Actually, rather than report a new one, we suggest correcting the existing erratum. To do this, simply send a request to the RFC Editor that the existing one be reopened. Then, it can be edited as needed by the verifying party (in this case, an AD).

Thank you.
RFC Editor/ar

---

From: Loa Andersson <[email-masked]>
Date: Sun, 19 Jul 2015 11:34:08 +0200

Alice,

Yes that is the right procedure for RFC6428 (3629).

I will lean a bit on Dave and Stewart to see if we need to reopen
it. Let us close loops during the IETF week.

In the mean time errata for RFC6428 (4415) my take is that it is correct
and can be verified.

/Loa

---

From: David Allan I <[email-masked]>
Date: Wed, 22 Jul 2015 16:03:57 +0000

Hi MPLSers:

We'd like to "re-close off" this old errata.

Our assumption is the majority if not all should have divined the desired interpretation (TLV length applies to the whole TLV), but we'd like to verify this. So please advise if you have an implementation that corresponds or differs from the corrected text. You can email me privately if you wish to spare the list, and I'll summarize the results.

Thanks
Dave