Subject: [mpls] MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

From: <[email-masked]>
Date: Tue, 14 Jul 2015 16:02:50 +0200

Hello,

I have been selected as reviewer of http://tools.ietf.org/html/draft-mirsky-mpls-bfd-directed-03.

I think the draft is coherent, technically sound and operational useful. It extents the explicit path capability for the backward direction of _bidirectional_ forwarding detection (BFD). The document is ready for WG adoption.

Some comments:

Section 1.1.1, Terminology:
I am not sure, whether the term _MPLS_ is really required in this section.

Section 3.1, "Case of MPLS Data Plane": Structure of sub-TLV specification.
The whole section describes, that three sub-TLV are specified for usage: "Static", "RSVP-TE" and "Segment Routing". For "Static" and "RSVP-TE", the draft refers to the according RFC (that's fine). But the structure of this section contains only a subsection for "Segment routing" and the reference to the other sub-TLV is part of this subsection. I propose to add two additional subsections "Static" (3.1.x) and "RSVP-TE" (3.1.x) with the references and remove it from the subsection "Segment Routing" to be more coherent.

Section 3.1.2: "Segment Routing Tunnel Sub-TLV >
The section specifies the encoding of the SR tunnel Sub-TLV with the encoding of the label stack elements. I think it makes sense to describe the usage of this information in the draft ("copy this information to the label stack"). Is the remote PE (initiator) allowed to add additional segments bases on his local information or is the encoded label stack strict?

Section 3.3:
This section confused me. Maybe it should be considered to be rewritten (or explained specifically to me).
Who is the _initiator_ in this case for the BFD reverse path scenario?

Section 3.4: "Return Codes"
The paragraph repeats the description text of the return code 2 times.  The section specifies, that the egress LSR _MAY_ send back the return code. In section 3.1.1, last paragraph, the behavior is specified, that the egress LSR may set up the BFD session or not, but in both cases, it sends back the return code (are the MAYs are concatenated in the case, when the BFD session is set up - see also comment from Nobo?). This implies, that the egress LSR _MUST_ send the return code, when the reverse path is not known.

Section 4 "Use case scenario":
The "value N" and "value M" are confusing, because it uses the same vocabulary as the nodes in the network example (capital letter). It could be called "foobar" if it is not for interest.

Regards.

Thomas

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 23 Jul 2015 09:22:14 +0000

Hi Thomas,
many thanks for thorough review and thoughtful and most helpful comments and suggestions. Please find my answers in-line and tagged GIM>>.

                Regards,
                                Greg

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 14, 2015 4:03 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Gregory Mirsky; Jeff Tantsura; [email-masked]; [email-masked]
Subject: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Hello,

Some comments:

GIM>> Agree

GIM>> Will extract references to Static and RSVP-TE and format into subsections.

GIM>> This is very interesting angle. We thought that it is strict but I think that if egress node instructed to make stack more explicit it MAY do so. In other words, egress SHOULD NOT exclude any LSE from the stack but MAY only add. Would you agree with this interpretation?

Section 3.3:

GIM>> The term "initiator" is inherited from LSP Ping for Segment Routing. I'll discuss with authors and either map to another, clearer term or provide explanation of roles and scenario.

GIM>> Yes, Nobo as well pointed to duplicate use of MAY in one sentence. Idea was that use of LSP Echo Reply is optional, hence the first MAY. And use of Return Code is proposed as optional - thus the second MAY. If the generic idea sound, will re-word. If normative language should be different - open for suggestion.

GIM>> Agree, will update in the next version.

Regards.

Thomas

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 24 Jul 2015 07:51:18 +0000

Hi Thomas,
would greatly appreciate if you kindly review proposed changes to address your comments. I've attached diff and MS copy of what may be next version.

                Regards,
                                Greg

Hello,

Some comments:

Section 3.3:

Regards.

Thomas

---

From: <[email-masked]>
Date: Wed, 29 Jul 2015 09:21:00 +0200

Hi Greg,

I am fine with the changes.

Thomas

Von: Gregory Mirsky [mailto:[email-masked]]
Gesendet: Freitag, 24. Juli 2015 09:51
An: Beckhaus, Thomas; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Jeff Tantsura; [email-masked]; [email-masked]
Betreff: RE: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Hi Thomas,

                Regards,
                                Greg

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, July 14, 2015 4:03 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Gregory Mirsky; Jeff Tantsura; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: MPLS-RT review of draft-mirsky-mpls-bfd-directed-03

Hello,

Some comments:

Section 3.3:

Regards.

Thomas