Subject: Re: [mpls] New Version Notification for draft-xu-sfc-using-mpls-spring-04.txt

From: Xuxiaohu <[email-masked]>
Date: Wed, 28 Oct 2015 04:07:30 +0000

Hi SFC co-chairs,

I haven't received any response from you yet. Would you please tell us your thoughts on the new version of this draft. Thanks a lot.

Best regards,
Xiaohu (on behalf of all co-authors)

> -----Original Message-----
> From: Xuxiaohu
> Sent: Wednesday, September 09, 2015 5:45 PM
> To: [email-masked]'; [email-masked]
> Cc: [email-masked]'; [email-masked]
> Subject: FW: New Version Notification for draft-xu-sfc-using-mpls-spring-04.txt
> 
> Hi all,
> 
> Service chaining is an important function for all type of networks including those
> using the source routing paradigm as specified by the SPRING working group.
> This draft is especially focused on the SPRING/MPLS network scenario.
> 
> When we posted the early versions (-00 to -02), the feedback from the SFC
> working group chairs was that the solution required changes to the MPLS
> architecture. We discussed this among the authors and posted a new version
> (-03) that does not require any change to the MPLS Architecture anymore.
> Version -04 merely corrects some typos.
> 
> Now we would like to ask the SFC chairs and WGs if the draft can now be
> considered for adoption by the SFC working group.
> 
> Best regards,
> Xiaohu
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Wednesday, September 09, 2015 5:23 PM
> > To: Lizhenbin; Luis M. Contreras; Xuxiaohu; Himanshu C. Shah;
> > Xuxiaohu; Himanshu Shah; Luis M. Contreras; Lizhenbin
> > Subject: New Version Notification for
> > draft-xu-sfc-using-mpls-spring-04.txt
> >
> >
> > A new version of I-D, draft-xu-sfc-using-mpls-spring-04.txt
> > has been successfully submitted by Xiaohu Xu and posted to the IETF
> repository.
> >
> > Name:		draft-xu-sfc-using-mpls-spring
> > Revision:	04
> > Title:		Service Function Chaining Using MPLS-SPRING
> > Document date:	2015-09-09
> > Group:		Individual Submission
> > Pages:		7
> > URL:
> > https://www.ietf.org/internet-drafts/draft-xu-sfc-using-mpls-spring-04
> > .txt
> > Status:
> > https://datatracker.ietf.org/doc/draft-xu-sfc-using-mpls-spring/
> > Htmlized:       https://tools.ietf.org/html/draft-xu-sfc-using-mpls-spring-04
> > Diff:
> > https://www.ietf.org/rfcdiff?url2=draft-xu-sfc-using-mpls-spring-04
> >
> > Abstract:
> >    Source Packet Routing in Networking (SPRING) WG specifies a special
> >    source routing mechanism.  Such source routing mechanism can be
> >    leveraged to realize the service path layer functionality of the
> >    service function chaining (i.e, steering traffic through a particular
> >    service function path) by encoding the service function path or the
> >    service function chain information as the explicit path information.
> >    This document describes how to leverage the MPLS-based source routing
> >    mechanism as developed by the SPRING WG to realize the service path
> >    layer functionality of the service function chaining.
> >
> >
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat

---

From: Thomas Narten <[email-masked]>
Date: Wed, 28 Oct 2015 12:21:35 -0400

Hi Xiaohu.

See below.

> I haven't received any response from you yet. Would you please tell us your
> thoughts on the new version of this draft. Thanks a lot.

> Best regards, Xiaohu (on behalf of all co-authors)
> 
> > -----Original Message----- From: Xuxiaohu Sent: Wednesday, September 09,
> > 2015 5:45 PM To: [email-masked]'; [email-masked] Cc:
> > [email-masked]'; [email-masked] Subject: FW: New Version
> > Notification for draft-xu-sfc-using-mpls-spring-04.txt
> > 
> > Hi all,
> > 
> > Service chaining is an important function for all type of networks including
> > those using the source routing paradigm as specified by the SPRING working
> > group.  This draft is especially focused on the SPRING/MPLS network
> > scenario.

> > Version -04 merely corrects some typos.

Good that the document is now consistent with the MPLS
architecture. 

That said, this document is not really core to SFC. E.g., we are
focused on being transport independent. This document is
MPLS-specific.

The key question is how relevant and important it is to the work of
this WG. Our read of the mailing list discussions over recent months
is that there isn't strong interest in this work.

Given the weak interest and lack  of clear importance to the WG core
deliverables, we do not see justification for taking this on as a WG
document.

Thomas & Jim

> > 
> > Best regards, Xiaohu
> > 
> > > -----Original Message----- From: [email-masked]
> > > [mailto:[email-masked]] Sent: Wednesday, September 09, 2015 5:23
> > > PM To: Lizhenbin; Luis M. Contreras; Xuxiaohu; Himanshu C. Shah; Xuxiaohu;
> > > Himanshu Shah; Luis M. Contreras; Lizhenbin Subject: New Version
> > > Notification for draft-xu-sfc-using-mpls-spring-04.txt
> > >
> > >
> > > A new version of I-D, draft-xu-sfc-using-mpls-spring-04.txt has been
> > > successfully submitted by Xiaohu Xu and posted to the IETF
> > repository.
> > >
> > > Name: draft-xu-sfc-using-mpls-spring Revision: 04 Title: Service Function
> > > Chaining Using MPLS-SPRING Document date: 2015-09-09 Group: Individual
> > > Submission Pages: 7 URL:
> > > .txt Status:
> > > https://datatracker.ietf.org/doc/draft-xu-sfc-using-mpls-spring/ Htmlized:
> > > https://tools.ietf.org/html/draft-xu-sfc-using-mpls-spring-04 Diff:

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 29 Oct 2015 01:40:38 +0000

Hi Thomas,

> From: Thomas Narten [mailto:[email-masked]]
> Sent: Thursday, October 29, 2015 12:22 AM
> To: Xuxiaohu
> Cc: [email-masked]'; [email-masked]; [email-masked]';
> [email-masked]
> Subject: Re: New Version Notification for draft-xu-sfc-using-mpls-spring-04.txt
> 
> Hi Xiaohu.
> 
> See below.
> 
> > I haven't received any response from you yet. Would you please tell us
> > your thoughts on the new version of this draft. Thanks a lot.
> 
> > > Service chaining is an important function for all type of networks
> > > including those using the source routing paradigm as specified by
> > > the SPRING working group.  This draft is especially focused on the
> > > SPRING/MPLS network scenario.
> 
> > > When we posted the early versions (-00 to -02), the feedback from
> > > the SFC working group chairs was that the solution required changes
> > > to the MPLS architecture. We discussed this among the authors and
> > > posted a new version
> Good that the document is now consistent with the MPLS architecture.
> 
> That said, this document is not really core to SFC. E.g., we are focused on being
> transport independent. This document is MPLS-specific.

In this draft, the SFC encapsulation is implemented in the form of an MPLS label stack (equivalent to NSH). Such SFC encapsulation could be transported over any transport networks such as IPv4, IPv6, MPLS networks. In a words, the SFC-encapsulation approach described in this draft is fully transport-independent indeed.

> The key question is how relevant and important it is to the work of this WG. Our
> read of the mailing list discussions over recent months is that there isn't strong
> interest in this work.

By encoding the SFP info by an MPLS label stack (i.e., implementing the SFC encapsulation in the form of an MPLS label stack), SFF devices could be easily implemented on existing MPLS devices without any change to their data planes. As a result, there is no need to introduce a totally new SFC encapsulation scheme and accordingly there is no need to introduce a totally new forwarding paradigm (e.g., NSH-based forwarding paradigm) especially when considering implementing SFFs on hardware platforms due to performance demands.  

According to the following statement quoted from the current SFC charter:

"... The WG will examine existing identifier schemes,
  if there is a need for such identifiers in the context of the Generic SFC
  encapsulation, before defining any new identifier scheme.
..."

It seems that this MPLS-SPRING-based SFC encapsulation scheme should be relevant to the SFC WG. At least, it could be investigated as a light-weight SFC encapsulation approach (from the aspect of reducing and even avoiding any impact on the data plane).

Best regards,
Xiaohu

> deliverables, we do not see justification for taking this on as a WG document.
> 
> Thomas & Jim
> 
> 
> > > Now we would like to ask the SFC chairs and WGs if the draft can now
> > > be considered for adoption by the SFC working group.
> 
> 
> 
> > >
> > > Best regards, Xiaohu
> > >
> > > > [mailto:[email-masked]] Sent: Wednesday, September 09,
> > > > 2015 5:23 PM To: Lizhenbin; Luis M. Contreras; Xuxiaohu; Himanshu
> > > > C. Shah; Xuxiaohu; Himanshu Shah; Luis M. Contreras; Lizhenbin
> > > > A new version of I-D, draft-xu-sfc-using-mpls-spring-04.txt has
> > > > been successfully submitted by Xiaohu Xu and posted to the IETF
> > > repository.
> > > >
> > > > Name: draft-xu-sfc-using-mpls-spring Revision: 04 Title: Service
> > > > Function Chaining Using MPLS-SPRING Document date: 2015-09-09
> > > > Group: Individual Submission Pages: 7 URL:

---

From: Thomas Narten <[email-masked]>
Date: Fri, 30 Oct 2015 16:33:06 -0400

> It seems that this MPLS-SPRING-based SFC encapsulation scheme should be
> relevant to the SFC WG. At least, it could be investigated as a light-weight
> SFC encapsulation approach (from the aspect of reducing and even avoiding any
> impact on the data plane).

The charter also says:

   3. Generic SFC Encapsulation: This document will describe a single 
      service-level data plane encapsulation format that:

I want to emphasize the term "a single ... encapsulation format" It
has been my understanding that the intention of this WG from the
beginning was to produce one encapsulation, not multiple ones.

I think it has been clear for some time already that the WG has
selected the NSH document as its desired approach.

Are you suggesting that the WG take on this document as an additional
encapsulation for SFC? I do not think that is consistent with the
intent of the charter. Also, my read of the overall list discussion
with respect to this document is that the WG has not shown a strong
interest in this document nor indicated a compelling need for it.

If the WG disagrees with this assessment, I expect folk would speak
up.

Thomas