Subject: Re: [mpls] Kathleen Moriarty's No Objection on draft-ietf-mpls-self-ping-05: (with COMMENT)

From: Ronald Bonica <[email-masked]>
Date: Fri, 16 Oct 2015 16:01:51 +0000

Hi Kathleen,

Thanks for the thoughtful review. Response inline.

                                    Ron

> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> I see that the Security Considerations section says,
>   "operators SHOULD
>    filter LSP Self-ping packets at network ingress points"
> 
> I think it would be helpful to have the draft explicitly state the scope for this
> new function - within a single operator's network is my assumption.  If that
> assumption is not correct, I may come back with more questions.
> 
[RPB] 

Good catch. The statement that you quote, above, reflects the mental model that I had in my head when I wrote it. That is:

- MPLS-SIGNALING-DOMAIN == OPERATORS-NETWORK-DOMAIN

While this is generally true, it may not be 100% of the time. We can fix the problem by editing the text as follows:

OLD>
operators SHOULD  filter LSP Self-ping packets at network ingress points"
<OLD
NEW>
operators SHOLD filter LSP Self-ping packets at the edges of the MPLS signaling domain.
<NEW

> There was also a suggestion made int he SecDir review that you may want to
> consider:
> https://mailarchive.ietf.org/arch/search/?email_list=secdir
> 
> 
[RPB] 
Good idea. I will add a sentence to the text.

                                          Ron

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 16 Oct 2015 13:10:24 -0500

Thank you, Ron!

Sent from my iPhone

> On Oct 16, 2015, at 11:01 AM, Ronald Bonica <[email-masked]> wrote:
> 
> Hi Kathleen,
>