Subject: [mpls] [Technical Errata Reported] RFC3107 (4500)

From: RFC Errata System <[email-masked]>
Date: Tue, 13 Oct 2015 15:19:20 -0700 (PDT)

The following errata report has been submitted for RFC3107,
"Carrying Label Information in BGP-4".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3107&eid=4500

--------------------------------------
Type: Technical
Reported by: Alexander Okonnikov <[email-masked]>

Section: 5

Original Text
-------------
   A BGP speaker that is capable of handling multiple routes to a
   destination (as described above) should use the Capabilities Optional
   Parameter, as defined in [BGP-CAP], to inform its peers about this
   capability.  The value of this capability is 4.

Corrected Text
--------------
   A BGP speaker that is capable of handling multiple routes to a
   destination (as described above) should use the Capabilities Optional
   Parameter, as defined in [BGP-CAP], to inform its peers about this
   capability.  This capability is advertised using the Capability Code
   4 and Capability Length 0.

Notes
-----
To remove confusion what word value means - Capability Value or value of Capability Code.
Also, format of multiple routes capability is not described, so length = 0 is assumed.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3107 (draft-ietf-mpls-bgp4-mpls-04)
--------------------------------------
Title               : Carrying Label Information in BGP-4
Publication Date    : May 2001
Author(s)           : Y. Rekhter, E. Rosen
Category            : PROPOSED STANDARD
Source              : Multiprotocol Label Switching
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Eric C Rosen <[email-masked]>
Date: Fri, 16 Oct 2015 16:17:55 -0400

I suspect that this capability code has never actually been used, in 
which case it might be best to avoid doing anything that might be 
interpreted as encouraging its use.

On 10/13/2015 6:19 PM, RFC Errata System wrote:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Alexander Okonnikov <[email-masked]>
Date: Fri, 16 Oct 2015 23:44:48 +0300

Understand.

Thank you.