Subject: Re: [mpls] Seeking WG and chairs feedback on LDP/mLDP Yang doc split [Re: A quick update on LDP/mLDP Yang model (draft-ietf-mpls-ldp-mldp-yang)]

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Fri, 11 Nov 2016 06:05:36 +0000

Hello Tarek,

Refer to the topic of the conversation related to LDP/mLDP Yang doc split, we (the authors) would like to confirm with you the following  two items before proceeding.
Please confirm/ack back as the Document Shepherd:

 1. Are you okay with the proposal of split of document and YANG module between LDP and mLDP ?
 2. We plan to split current WG doc (draft-ietf-mpls-ldp-mldp-yang) into two new WG documents - one for LDP (draft-ietf-mpls-ldp-yang) and other for mLDP (draft-ietf-mpls-mldp-yang).  Please confirm back.

Rgds.
-
Kamran
(on behalf of authors)

From: Syed Kamran Raza <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 11, 2016 at 2:07 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] Seeking WG and chairs feedback on LDP/mLDP Yang doc split [Re: A quick update on LDP/mLDP Yang model (draft-ietf-mpls-ldp-mldp-yang)]

Hello MPLS WG and WG chairs,

[Refer to our email two weeks ago]

Keeping in view some of the MPLS-RT review comments and the current size of the join document (draft-ietf-mpls-ldp-mldp-yang), we, the authors, are thinking of splitting the LDP/mLDP Yang model into two separate documents - one for LDP and other for mLDP - and would like to get WG and chairs feedback on this.

Please comment/advise accordingly.
Rgds.
-
Kamran
(on behalf of authors)

From: Syed Kamran Raza <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 27, 2016 at 1:14 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] A quick update on LDP/mLDP Yang model (draft-ietf-mpls-ldp-mldp-yang)

Hello MPLS WG and WG chairs,

This email is to give a quick update on the current work being done on  the IETF LDP/mLDP Yang draft (draft-ietf-mpls-ldp-mldp-yang-00).

  *   Multi-vendor team is meeting twice a month to progress on the model:
     *   Cisco, Juniper, Huawei, Ciena, Ericsson, Nokia
  *   The current focus of the team is to:
     *   address remaining MPLS-RT comments
     *   divide the model into "base" and "extended" features
     *   general cleanup
  *   We plan to submit a next revision before next IETF.
  *   We also want to get feedback from WG/chairs on whether it makes sense to divide this large document (which is already > 115 pages) into two separate documents - one covering LDP Yang and other mLDP yang.
     *   We will still keep mLDP model dependent on LDP.
     *   Please advise.

Rgds.
-
Kamran
(on behalf of authors)

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Fri, 11 Nov 2016 13:58:37 +0000

Hi Kamran/authors,

Yes, as document shepherd, I am OK proceeding with the two actions below.

Regards,
Tarek

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Friday, November 11, 2016 at 1:05 AM
To: Tarek Saad <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [mpls] Seeking WG and chairs feedback on LDP/mLDP Yang doc split [Re: A quick update on LDP/mLDP Yang model (draft-ietf-mpls-ldp-mldp-yang)]

Hello Tarek,

 1. Are you okay with the proposal of split of document and YANG module between LDP and mLDP ?
 2. We plan to split current WG doc (draft-ietf-mpls-ldp-mldp-yang) into two new WG documents – one for LDP (draft-ietf-mpls-ldp-yang) and other for mLDP (draft-ietf-mpls-mldp-yang).  Please confirm back.

Rgds.
—
Kamran
(on behalf of authors)

Keeping in view some of the MPLS-RT review comments and the current size of the join document (draft-ietf-mpls-ldp-mldp-yang), we, the authors, are thinking of splitting the LDP/mLDP Yang model into two separate documents – one for LDP and other for mLDP - and would like to get WG and chairs feedback on this.

—
Kamran
(on behalf of authors)

     *   address remaining MPLS-RT comments
     *   divide the model into “base” and “extended” features
     *   general cleanup

  *   We plan to submit a next revision before next IETF.
  *   We also want to get feedback from WG/chairs on whether it makes sense to divide this large document (which is already > 115 pages) into two separate documents – one covering LDP Yang and other mLDP yang.

—
Kamran
(on behalf of authors)