Subject: [mpls] New version: draft-ietf-mpls-sfc-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 13 Oct 2018 17:09:13 +0100

Hi,

The update here is just to fix an email address and a reference.

>From my point of view this work is done with just one open question for the
WG...

Currently we use an extended special purpose label to identify that SFC labels
follow. The question is: is this work sufficiently mainstream to use a regular
special purpose label?

Thoughts?

Thanks,
Adrian
> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: 13 October 2018 17:05
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-mpls-sfc-03.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> This draft is a work item of the Multiprotocol Label Switching WG of the IETF.
> 
>         Title           : An MPLS-Based Forwarding Plane for Service Function
Chaining
>         Authors         : Adrian Farrel
>                           Stewart Bryant
>                           John Drake
> 	Filename        : draft-ietf-mpls-sfc-03.txt
> 	Pages           : 28
> 	Date            : 2018-10-13
> 
> Abstract:
>    Service Function Chaining (SFC) is the process of directing packets
>    through a network so that they can be acted on by an ordered set of
>    abstract service functions before being delivered to the intended
>    destination.  An architecture for SFC is defined in RFC7665.
> 
>    The Network Service Header (NSH) can be inserted into packets to
>    steer them along a specific path to realize a Service Function Chain.
> 
>    Multiprotocol Label Switching (MPLS) is a widely deployed forwarding
>    technology that uses labels placed in a packet in a label stack to
>    identify the forwarding actions to be taken at each hop through a
>    network.  Actions may include swapping or popping the labels as well,
>    as using the labels to determine the next hop for forwarding the
>    packet.  Labels may also be used to establish the context under which
>    the packet is forwarded.
> 
>    This document describes how Service Function Chaining can be achieved
>    in an MPLS network by means of a logical representation of the NSH in
>    an MPLS label stack.  It does not deprecate or replace the NSH, but
>    acknowledges that there may be a need for an interim deployment of
>    SFC functionality in brownfield networks.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-mpls-sfc/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-mpls-sfc-03
> https://datatracker.ietf.org/doc/html/draft-ietf-mpls-sfc-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-sfc-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Loa Andersson <[email-masked]>
Date: Sun, 14 Oct 2018 12:28:43 +0800

Adrian, Authors, working group,

Speaking as someone that has to manage the rather scarce pool of
"regular" special purpose labels.

If there is no compelling reason to use the "regular" special purpose
labels, I'd say that we stay with the extended special purpose label.

/Loa

On 2018-10-14 00:09, Adrian Farrel wrote:
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 17 Oct 2018 12:24:04 +0100

Thanks Loa,

Not hearing any raised voices on this, we probably leave the text as it is (with an extended special purpose label).

What's next, chairs? Are we good for WG last call?

Thanks,
Adrian

> From: Loa Andersson [mailto:[email-masked]]
> Sent: 14 October 2018 05:29
> To: [email-masked]; [email-masked]
> Subject: Re: [mpls] New version: draft-ietf-mpls-sfc-03.txt
>

---

From: Loa Andersson <[email-masked]>
Date: Wed, 17 Oct 2018 21:34:36 +0800

Adrian, authors,

Yes I'd say you are OK to start the wglc process.

Normally that involves:
- sheperd review (updates as necessary)
- IPR poll
- wglc (updates as mecessary)

I normally start the IPR poll as soon as I'm convinced that we
will do the wglc on the current version (maybe +1)

/Loa

--