Subject: Re: [mpls] MPLS-RT review of draft-malis-mpls-sfc-encapsulation

From: "Hejia (Jia)" <[email-masked]>
Date: Thu, 11 Oct 2018 09:31:01 +0000

Hi,

I have reviewed draft-malis-mpls-sfc-encapsulation-02. The draft introduces a SFF label in the MPLS label stack, which is used to transport SFC packets with the NSH over an MPLS infrastructure. In summary, I think the draft is useful and ready to be considered for WG adoption.

I have found one comment and some nits, which can be resolved either before or after WG adoption.

Comments:

As indicated by the first sentence of Section 2.1, it is to describe the steps of constructing label stack to "send an SFC packet with the NSF (typo? NSH?)". However, the first step that follows describes the special cases and uses OAM as an example using GAL/G-ACh where no NSH is applied if I understand correctly. It looks inconsistent somehow. Since there are already separate sections for OAM and ECMP considerations. Can I suggest leaving Section 2 to describe only the general SFF label processing and leave the special cases to OAM and ECMP sections respectively? And if possible, a figure to show the structure of label stack (e.g. the general case, the OAM case, the ECMP case) will be more direct and absolutely clear :-)

Nits:

Section 2, s/by having the receiving advertise .../by having the receiving node advertise ...

Section 2.1, s/When one SFF wishes to send an SFC packet with the NSF to another SFF.../When one SFF wishes to send an SFC packet with the NSH to another SFF...

B.R.

Jia

-----邮件原件-----
发件人: Loa Andersson [mailto:[email-masked]]
发送时间: 2018年9月26日 20:34
收件人: Sam Aldrin <[email-masked]>; Hejia (Jia) <[email-masked]>; Bocci, Matthew (Nokia - GB) <[email-masked]>; Yimin Shen <[email-masked]>
抄送: [email-masked]; [email-masked]
主题: MPLS-RT review of draft-malis-mpls-sfc-encapsulation

Sam, Jia, Matthew and Yimin,

You have been selected as MPLS-RT reviewers for draft-malis-mpls-sfc- encapsulation.

Note to authors: You have been CC'd on this email so that you can know that this review is going on. However, please do not review your own document.

Reviews should comment on whether the document is coherent, is it useful (ie, is it likely to be actually useful in operational networks), and is the document technically sound?

We are interested in knowing whether the document is ready to be considered for WG adoption (ie, it doesn't have to be perfect at this point, but should be a good start). Please remember that it often is easier to progress the document when it has become a working group document. All comments in the MPLS-RT review needs to be addressed, but please think carefully about whether a comment is gating the adoption or could just as easily be addressed after the adoption.

Reviews should be sent to the document authors, WG co-chairs and WG secretary, and CC'd to the MPLS WG email list. If necessary, comments may be sent privately to only the WG chairs.

If you have technical comments you should try to be explicit about what needs to be resolved before adopting it as a working group document, and what can wait until the document is a working group document and the working group has the revision control.

Are you able to review this draft by October 11, 2018? Please respond whether you are available to do the review in a timely fashion.

Thanks, Loa

(as MPLS WG co-chair)

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>

Senior MPLS Expert

Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 11 Oct 2018 09:56:19 -0400

Jia,

Thanks for your review. I personally prefer keeping section 2 as it is, so
that a reader doesn't have to looking through the document for all of the
cases, as someone not particularly interested (for example) in OAM may not
read the section on OAM considerations. Of course, once this is a WG
document, if the WG prefers a restructuring, we can do that.

Your suggestion to illustrate the label stack is a good one, and something
we can pursue once it's a WG draft.

Thanks again,
Andy

On Thu, Oct 11, 2018 at 5:31 AM Hejia (Jia) <[email-masked]> wrote:

> Hi,
>
>
>
> I have reviewed draft-malis-mpls-sfc-encapsulation-02. The draft
> introduces a SFF label in the MPLS label stack, which is used to transport
> SFC packets with the NSH over an MPLS infrastructure. In summary, I think
> the draft is useful and ready to be considered for WG adoption.
>
> As indicated by the first sentence of Section 2.1, it is to describe the
> steps of constructing label stack to "send an SFC packet with the NSF
> (typo? NSH?)". However, the first step that follows describes the special
> cases and uses OAM as an example using GAL/G-ACh where no NSH is applied if
> I understand correctly. It looks inconsistent somehow. Since there are
> already separate sections for OAM and ECMP considerations. Can I suggest
> leaving Section 2 to describe only the general SFF label processing and
> leave the special cases to OAM and ECMP sections respectively? And if
> possible, a figure to show the structure of label stack (e.g. the general
> case, the OAM case, the ECMP case) will be more direct and absolutely clear
> :-)
>
>
>
> Nits:
>
> Section 2.1, s/When one SFF wishes to send an SFC packet with the NSF to
> another SFF.../When one SFF wishes to send an SFC packet with the NSH to
> another SFF...
>
>
>
>
>
> B.R.
>
> Jia
>
>
>
> -----邮件原件-----
> 收件人: Sam Aldrin <[email-masked]>; Hejia (Jia) <[email-masked]>;
> Bocci, Matthew (Nokia - GB) <[email-masked]>; Yimin Shen <
> [email-masked]>
> Note to authors: You have been CC'd on this email so that you can know
> that this review is going on. However, please do not review your own
> document.
>
>
>
> Reviews should comment on whether the document is coherent, is it useful
> (ie, is it likely to be actually useful in operational networks), and is
> the document technically sound?
>
>
>
> We are interested in knowing whether the document is ready to be
> considered for WG adoption (ie, it doesn't have to be perfect at this
> point, but should be a good start). Please remember that it often is easier
> to progress the document when it has become a working group document. All
> comments in the MPLS-RT review needs to be addressed, but please think
> carefully about whether a comment is gating the adoption or could just as
> easily be addressed after the adoption.
>
>
>
> Reviews should be sent to the document authors, WG co-chairs and WG
> secretary, and CC'd to the MPLS WG email list. If necessary, comments may
> be sent privately to only the WG chairs.
>
>
>
> If you have technical comments you should try to be explicit about what
> needs to be resolved before adopting it as a working group document, and
> what can wait until the document is a working group document and the
> working group has the revision control.
>
>
>
> Are you able to review this draft by October 11, 2018? Please respond
> whether you are available to do the review in a timely fashion.
>
>
>
>
>
> Thanks, Loa
>
> (as MPLS WG co-chair)
>
> --
>
>
>
>
>
> Loa Andersson                        email: [email-masked]
>
> Senior MPLS Expert
>